Jump to content
Sign in to follow this  
scorpio33

Authorize.net

Recommended Posts

The transaction goes to Authorize.net, the payment goes through and I and the buyer get an email receipt, however, the order does not record on OS Commerce. I am also not getting any e-mail from the store saying that an order was placed.

 

Can anyone tell me how to fix this?

Share this post


Link to post
Share on other sites

The install was done for me. I will have to find out the ver. of A.Net that was used.

However below is a copy of how my Response/Receipt URLs are set up. I am not sure if that is what you are asking for.

 

The install is called: Authorize.net Secured Credit Card Processing

 

Sorry for being a novice to this.

 

--------------------------------------------------------------------------------

 

The Payment Gateway verifies the URL specified in the post string against the URLs in this list. If the URL provided does not match one of the values on this list, the transaction will be rejected. If no URL is provided, the Default URL value will be used.

 

 

URL Add URL

(Click Edit to define a default URL value.) Default Receipt URL Edit

(Click Edit to define a default URL value.) Default Relay Response URL Edit

 

 

what version of authorizenet are you using and what are your authorizenet return url settings?

Share this post


Link to post
Share on other sites

I am using SIM.

The install was done for me. I will have to find out the ver. of A.Net that was used.

However below is a copy of how my Response/Receipt URLs are set up. I am not sure if that is what you are asking for.

 

The install is called: Authorize.net Secured Credit Card Processing

 

Sorry for being a novice to this.

 

--------------------------------------------------------------------------------

 

The Payment Gateway verifies the URL specified in the post string against the URLs in this list. If the URL provided does not match one of the values on this list, the transaction will be rejected. If no URL is provided, the Default URL value will be used.

 

 

URL  Add URL

(Click Edit to define a default URL value.)  Default Receipt URL Edit 

(Click Edit to define a default URL value.)  Default Relay Response URL Edit

Share this post


Link to post
Share on other sites

if you dont get answers, then reword the questions, stating EVERYTHING you have done to try to find the answer. did you check your server log files to see what is being sent? did you check with authorizenet to make sure they are sending things back?

do you have a valid transaction id #?

numerous things you can do to let others know you are trying other than saying no one can help.


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

I can complete a transaction. I also get e-mail from Authorize.net confirming the transaction. I just don't see the name of the item that the customer purchased in OS.

On the Authorize.net payment form there is also no item description.

if you dont get answers, then reword the questions, stating EVERYTHING you have done to try to find the answer. did you check your server log files to see what is being sent?  did you check with authorizenet to make sure they are sending things back?

do you have a valid transaction id #?

numerous things you can do to let others know you are trying other than saying no one can help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×