Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

Hi,

 

By tracing every step of the process, I found out that the error occurs because I'm purchasing a gift voucher. During the discount calculation, the gift-voucher part of the code notices that I have a gift voucher in my cart, but then messes up and APPLIES the gift voucher to the purchase's total price [subtotal plus shipping] (see get_order_total in ot_coupon). Subtotal is price of gift voucher [ie. 25$] - value of voucher [$25] = 0, + shipping, minus 10%. So it IS taking the 10% off of the total, as it should; it just somehow thinks that the total is 0 plus the shipping! This is also why, if you turn 'calculate shipping' off, the discount doesn't appear at all: the discount code takes cart value [$25] - gift voucher [$25] = 0, plus nothing because shipping isnt calculated... so then the coupon's discount total is zero and the program supresses it's output.

 

I might have mised something, but the (cart) scenario seems to be when you ONLY have products equal to the value of the gift voucher/s in the cart, as it seems to be, from the description above ??

 

Can't you just check if the sub-total is equal to the (total) value of all gift vouchers (i.e. just in case you are using mutiple ones), the add the shipping amount, but _don't_ apply the gift voucher ?

 

Peter

Share this post


Link to post
Share on other sites

Hi,

 

Need help - installed a fresh oscommerce, with this addon, http://shop.e-hobbies.co.nz - but all my prices have gone to zero - anyone able to help please?

 

Usually a currency problem. Go into admin, and make sure that you have at least one currency set as default

 

Delete your install path, or rename it.

 

Peter

Share this post


Link to post
Share on other sites

The last 5-or-so posts in the contribution page are all updates or fixes, some to previous updates and fixed. Can someone post a single updated version, with all known fixes and updates incorporated?

Share this post


Link to post
Share on other sites
To anyone wanting to make the payment screen a little more easy to understand (at least in my humble opinion):  this is how my payment screen now looks: payment screencap  And yes I do know that I neglected to customize the stupid redeem button to look like the rest...  putting that off in case I decide to change the button look again...

 

 

I just installed the code you posted and I love the idea of this. But there are a few issues that I am concerned with.

 

1) If you DO have a voucher balance from a Gift Certificate or Credit Voucher, it shows up just fine.

 

BUT, if the Gift Certificate balance is more than the total order amount, it displays the order total and NOT the order subtotal when you have it setup in the admin to NOT include tax or shipping. Screen shot: http://www.cardhost.com/CCGV-1.jpg

 

ALSO, even though it displays the order total to be included from your voucher balance, in the end, it will only include the order subtotal as seen in this screen shot: http://www.cardhost.com/CCGV-3.jpg

 

As you can see, on the Checkout Payment screen, it should display the order subtotal and NOT the order total to be added in as part of your payment from your voucher balance. I hope this makes since???

 

 

2) If you have NO Gift Certificate or Credit Voucher balance, it displays $0.00 and nothing else. This should not display anything at all if you do not have any Gift Certificates or have a $0.00 Credit Voucher balance. Screen shot: http://www.cardhost.com/CCGV-2.jpg

 

Any input on this???


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

It wouldbe nice to have gift certificats that are issues on a per person basis and welcomes the user,.. "Hi Larry welcome to the store"

 

Also it would be nice to have certs onyl good for one particular item or just for shipping.

 

 

It is a great add on though!

 

Keiran Mullen

Share this post


Link to post
Share on other sites

Hello, i have successfully installed the gift module with corrections, but now it skips the checkout_shipping.php and goes directly to checkout_payment.php, and when i do the confirmation, it goes back to checkout_payment.php

 

Can anybody help me? :'(

Share this post


Link to post
Share on other sites
It wouldbe nice to have gift certificats that are issues on a per person basis and welcomes the user,.. "Hi Larry welcome  to the store"

 

Also it would be nice to have certs onyl good for one particular item or just for shipping.

It is a great add on though!

 

Keiran Mullen

 

 

Actually, it does both of these. Look in your Admin...


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Not as far as I can tell sorry!

 

If you find a way to do this easily (also a heavily modified store) let me know !

Anna

 

I'm thinking you might be able to do that with the product attributes. Maybe make it so that buying 1 item = say, 1.00

2 = 2.00

3 = 3.00

4 = 3.00

 

or maybe just adding the atribute

 

4 = 3.00 so that ppl will buy just 1 (and update the quantity in the shopping cart if they want 2 or whatever) or 4 items = 3.00.

 

I hope that makes sense. I've very tired and have been poring over most of these 100+ pages in this thread...


--Sanguinarius

 

If you're reading this, I'm probably pulling my hair out. ;>

 

*waiting for osCommerce 3.0 alpha 6* (I'm after the coupons.)

Share this post


Link to post
Share on other sites
LOOPING DILEMA

 

- clicking "continiue" will take the user to the third step i.e. "Order Confirmation" BUT the problem on this page is that the price shown on the page does not include VAT and the sub-total and total exclude VAT whereas the shopping cart box displays the correct amount

- when the user clicks "confirm order" button instead of goind to the last stage to finalize the payement process we are TAKEN BACK TO STEP 2 i.e PAYMENT DETAILS

- this loop is never ending (!) and checkout never happens!

 

I am having this happen. Has anybody else had this happen, and if so, what did you do to fix this? I think it is not the sort order; I have tried that to no avail. I think it is something in the code perhaps? Please help if you can. If you need me to post any information, just let me know what I need to post and I will.

 

Thank you in advance.


--Sanguinarius

 

If you're reading this, I'm probably pulling my hair out. ;>

 

*waiting for osCommerce 3.0 alpha 6* (I'm after the coupons.)

Share this post


Link to post
Share on other sites

Never mind the above. I reuploaded the original checkout_shipping.php file for gv mod.

 

NOW, I'm having a problem with the coupon I'm trying to set:

 

My info on the Discount Coupons page:

 

Coupon Name  Coupon Amount  Coupon Code  Action

Welcome Coupon  Free Shipping    welc1 

Displaying 1 to 1 (of 1 coupons)    Page 1 of 1

Insert

 

[4] welc1

Coupon Name ::  Welcome Coupon

Coupon Amount ::  $10.00

Start Date ::  04/07/2005

End Date ::  04/07/2006

Uses per Coupon ::  0

Uses per Customer ::  1

Valid Product List ::  NONE

Valid Categories List ::  NONE

Date Created ::  04/07/2005

Date Modified ::  04/07/2005

 

Now, I do NOT want the $10.00 coupon amount to be $10.00 but 10% and I keep setting it as such:

 

I click on edit. Brings me to the edit page.

 

Coupon amount: 10.0000

 

Coupon minimum order: 5.0000

 

SO, I enter 10% (for the 5th time) and click Preview. Which takes me to the page that says:

 

Discount Coupons 

2005-04-07

Coupon Name  Welcome Coupon

Coupon Name 

Coupon Name 

Coupon Description  10% off your purchase over $5.00. A thank you for registering with Dreamland Gallery.

Coupon Description 

Coupon Description 

Coupon Amount  10%

Coupon Minimum Order  5.0000

Free Shipping  Free Shipping

Coupon Code  welc1

Uses per Coupon  0

Uses per Customer  1

Valid Product List 

Valid Categories List 

Start Date  04/07/2005

End Date  04/07/2006

 

So far so good. :) So I click Confirm.

 

Takes me back to the Coupons page which says:

 

Coupon Name  Coupon Amount  Coupon Code  Action

Welcome Coupon  Free Shipping    welc1 

Displaying 1 to 1 (of 1 coupons)    Page 1 of 1

Insert

 

[4] welc1

Coupon Name ::  Welcome Coupon

Coupon Amount ::  $10.00

Start Date ::  04/07/2005

End Date ::  04/07/2006

Uses per Coupon ::  0

Uses per Customer ::  1

Valid Product List ::  NONE

Valid Categories List ::  NONE

Date Created ::  04/07/2005

Date Modified ::  04/07/2005

 

As you can see, it's not 10% but $10.00. Why won't it stay a percent?! What am I doing wrong/do I need to change, edit, or whatever I need to do?


--Sanguinarius

 

If you're reading this, I'm probably pulling my hair out. ;>

 

*waiting for osCommerce 3.0 alpha 6* (I'm after the coupons.)

Share this post


Link to post
Share on other sites
Hello, i have successfully installed the gift module with corrections, but now it skips the checkout_shipping.php and goes directly to checkout_payment.php, and when i do the confirmation, it goes back to checkout_payment.php

 

Can anybody help me?  :'(

 

similar problem here.

 

But I aware that this only will happen when I first create a test account and only buy the Gift Vouchers with no other items on my test store. It skipped the checkout_shipping.php, what's more, when I click the link to the chechout_shipping.php at the bottom nav links on the check out stage, it also redirect to the checkout_payment.php.

 

And the second time I tried use different items in the shopping cart to make check out, I realized that when I add other items in the shopping cart, everthing become fine -- even if I remove the other items except the Gift Voucher.

 

The weird thing is the third time: After I did what in the second time, I create a third new test account and only buy the Gift Voucher, and this time it can straight went to the paypal site instead went back to checkout_payment.php after I did the confirmation. But the checkout_shipping.php was still skipped.

 

Can anyone else also have this problem?

 

 

Other things I found about this contir:

 

After I set the Welcome Message Gift Voucher and Discount Coupon in the admin, when I create a new account, the new account's shopping cart is empty. What's wring with it? And also I want to ask is can I set any number in the Welcome Gift Voucher Amount?

 

Last, I can't found where to manage the "Queue Purchases" in the admin, since the installation doc says "Now when the customer purchases a Gift Voucher it will be logged in a queue. The customer will not be able to use the Gift Voucher until you use the admin option to release it from the queue" .

 

Hope someone can give me some advise.

Share this post


Link to post
Share on other sites
To anyone wanting to make the payment screen a little more easy to understand (at least in my humble opinion):  this is how my payment screen now looks: payment screencap  And yes I do know that I neglected to customize the stupid redeem button to look like the rest...  putting that off in case I decide to change the button look again...

 

 

I just installed the code you posted and I love the idea of this. But there are a few issues that I am concerned with.

 

1) If you DO have a voucher balance from a Gift Certificate or Credit Voucher, it shows up just fine.

 

BUT, if the Gift Certificate balance is more than the total order amount, it displays the order total and NOT the order subtotal when you have it setup in the admin to NOT include tax or shipping. Screen shot: http://www.cardhost.com/CCGV-1.jpg

 

ALSO, even though it displays the order total to be included from your voucher balance, in the end, it will only include the order subtotal as seen in this screen shot: http://www.cardhost.com/CCGV-3.jpg

 

As you can see, on the Checkout Payment screen, it should display the order subtotal and NOT the order total to be added in as part of your payment from your voucher balance. I hope this makes since???

2) If you have NO Gift Certificate or Credit Voucher balance, it displays $0.00 and nothing else. This should not display anything at all if you do not have any Gift Certificates or have a $0.00 Credit Voucher balance. Screen shot: http://www.cardhost.com/CCGV-2.jpg

 

Any input on this???


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
I just installed the code you posted and I love the idea of this. But there are a few issues that I am concerned with.

 

1) If you DO have a voucher balance from a Gift Certificate or Credit Voucher, it shows up just fine.

 

BUT, if the Gift Certificate balance is more than the total order amount, it displays the order total and NOT the order subtotal when you have it setup in the admin to NOT include tax or shipping. Screen shot: http://www.cardhost.com/CCGV-1.jpg

 

ALSO, even though it displays the order total to be included from your voucher balance, in the end, it will only include the order subtotal as seen in this screen shot: http://www.cardhost.com/CCGV-3.jpg

 

As you can see, on the Checkout Payment screen, it should display the order subtotal and NOT the order total to be added in as part of your payment from your voucher balance. I hope this makes since???

2) If you have NO Gift Certificate or Credit Voucher balance, it displays $0.00 and nothing else. This should not display anything at all if you do not have any Gift Certificates or have a $0.00 Credit Voucher balance.  Screen shot: http://www.cardhost.com/CCGV-2.jpg

 

Any input on this???

 

Am I seeing double? Anyways, I know the problem with the first two problems, as they are from the same problem.(thats a lot of problems in one sentence) When I calculate the amount that shows "$23.23 from gift voucher account" that number is very simply calculated, I just figure out which is less, the voucher amount or the total, and display that amount. I was not taking into account that some vouchers might not be taken off of the whole amount. I'll work on fixing this today, and hopefully post the solution some time tonight or tomorow.

 

About the 0.00 displaying: oops I must have put the $ amount outside of the if statement that checks whether or not the customer has a gift voucher amount... I thought I tested this already but I guess not. This will be an easy fix, just move the if statement... I'll post the exact solution later too. On a side note, I wish Texas had that low of a sales tax... (ours is around 8%) Although we have no state income tax so I guess it equals out...

 

NerioDavid: I'm not sure exactly what your first problem was, but I know part of it: when there is only a gift voucher in your shopping cart, you do not need to ship it so it skips the shipping page.

 

You should be able to set any number for the welcome gift voucher amount.

 

To get to the gift voucher que click on "Vouchers/Coupons" in admin, then under it click on "Gift voucher queue"

Edited by jonyo

Share this post


Link to post
Share on other sites

Well the fix might take a little while longer, I somehow messed things up last night... now I have to go and figure out what I did to the stupid thing. (javascript is broke, logic is broke when there is only one payment type...)

Share this post


Link to post
Share on other sites

Big Fixes for the "easier to understand" update that I posted on page 102:

NOTE:These are BUG FIXES to a previously posted update. It is NOT an update by itself. Once I work out ALL the bugs (with the help from everyone else to find them) I will re-post a bug-free version of the instructions.

 

1. Javascript fix: in catalog/checkout_payment.php: Find all occurences of forms[0] and replace with checkout_payment

This fixes a bug where if you have a form defined before the payment form, the javascript breaks.

 

2. $0 displayed when there is no voucher amount: either do the fix for #3

OR in catalog/checkout_payment.php: find the line

if ($temp>0){

change to

if ($gv_result['amount']>0){

 

3. To display the right amount, for instance if you set it in admin to not include tax or shipping in the amount, do this:

 

in catalog/includes/modules/order_total/ot_gv.php :

after this function:

    function process() {
     global $order, $currencies, $cot_gv;
//      if ($_SESSION['cot_gv']) {  // old code Strider
      if (tep_session_is_registered('cot_gv')) {
       $order_total = $this->get_order_total();
       $od_amount = $this->calculate_credit($order_total);
       if ($this->calculate_tax != "None") {
         $tod_amount = $this->calculate_tax_deduction($order_total, $od_amount, $this->calculate_tax);
         $od_amount = $this->calculate_credit($order_total);
       }
       $this->deduction = $od_amount;
//        if (($this->calculate_tax == "Credit Note") && (DISPLAY_PRICE_WITH_TAX != 'true')) {
//          $od_amount -= $tod_amount;
//          $order->info['total'] -= $tod_amount;
//        }
       $order->info['total'] = $order->info['total'] - $od_amount;
       if ($od_amount > 0) {
         $this->output[] = array('title' => $this->title . ':',
                          'text' => '<b>' . $currencies->format($od_amount) . '</b>',
                          'value' => $od_amount);
       }
     }
   }

add

function mod_process() {
//this is a moded process function so that we can see the
//amount that can be applied to the account
     global $order, $currencies, $cot_gv;
       $order_total = $this->get_order_total();
       $od_amount = $this->calculate_credit($order_total);
       if ($this->calculate_tax != "None") {
         $tod_amount = $this->calculate_tax_deduction($order_total, $od_amount, $this->calculate_tax);
         $od_amount = $this->calculate_credit($order_total);
       }
       $this->deduction = $od_amount;
       //$order->info['total'] = $order->info['total'] - $od_amount;
       if ($od_amount > 0) {
         $this->output[] = array('title' => $this->title . ':',
                          'text' => '<b>' . $currencies->format($od_amount) . '</b>',
                          'value' => $od_amount);
       }
   }

 

in catalog/checkout_payment.php find this code (this is code from the update)

if (MODULE_ORDER_TOTAL_INSTALLED)
 $temp=$order_total_modules->process();
  $gv_query = tep_db_query("select amount from " . TABLE_COUPON_GV_CUSTOMER . " where customer_id = '" . $customer_id . "'");
  $gv_result = tep_db_fetch_array($gv_query);
//$temp=$order_total_modules->process();
$temp=$temp[count($temp)-1];
$temp=$temp['value'];
if ($gv_result['amount']>=$temp){ $coversAll=true;

Replace it with

if (MODULE_ORDER_TOTAL_INSTALLED)
 $temp=$order_total_modules->process();
  $testing= $GLOBALS['ot_gv']->mod_process();
  $testing=$GLOBALS['ot_gv']->output[0];
if ($testing['value']>=$temp){ $coversAll=true;

same file, find (from updated material)

    if (tep_session_is_registered('customer_id')) {

if ($temp>0){
echo ' <tr><td width="10">' .  tep_draw_separator('pixel_trans.gif', '10', '1') .'</td><td colspan=2><table border="0" cellpadding="2" cellspacing="0" width="100%"><tr class="moduleRow" onmouseover="rowOverEffect(this)" onclick="clearRadeos()" onmouseout="rowOutEffect(this)" >' . "\n" .
                             '   <td width="10">' .  tep_draw_separator('pixel_trans.gif', '10', '1') .'</td><td class="main"><b>';
if ($gv_result['amount']>$temp) echo $currencies->format($temp).' ';
else echo $currencies->format($gv_result['amount']).' ';
echo $order_total_modules->sub_credit_selection();
  }
}

Replace it with

  if (tep_session_is_registered('customer_id')) {  
 if ($gv_result['amount']>0){
  echo ' <tr><td width="10">' .  tep_draw_separator('pixel_trans.gif', '10', '1') .'</td><td colspan=2><table border="0" cellpadding="2" cellspacing="0" width="100%"><tr class="moduleRow" onmouseover="rowOverEffect(this)" onclick="clearRadeos()" onmouseout="rowOutEffect(this)" >' . "\n" .
                             '   <td width="10">' .  tep_draw_separator('pixel_trans.gif', '10', '1') .'</td><td class="main"><b>';
  echo $testing['text'].' ';//var_dump ( $testing);
  echo $order_total_modules->sub_credit_selection();
  }
}

Thanks to PopTheTop for finding bug 2 and 3 :)

 

from now on, any posts I make concerning this update I will have "easier to understand" at the top, so to see all the bugfixes or updated instructions do a thread search for "easier to understand" update

Edited by jonyo

Share this post


Link to post
Share on other sites

OOPS! I found a bug in my bug fix... Follow these instead!!! Do NOT use the message above! If a moderator is feeling very nice, could you delete the previous post so people don't do it instead of this one?

 

Use these modified bug fixes:

 

 

Big Fixes for the "easier to understand" update that I posted on page 102:

NOTE:These are BUG FIXES to a previously posted update. It is NOT an update by itself. Once I work out ALL the bugs (with the help from everyone else to find them) I will re-post a bug-free version of the instructions.

 

1. Javascript fix: in catalog/checkout_payment.php: Find all occurences of forms[0] and replace with checkout_payment

This fixes a bug where if you have a form defined before the payment form, the javascript breaks.

 

2. $0 displayed when there is no voucher amount: either do the fix for #3

OR in catalog/checkout_payment.php: find the line

if ($temp>0){

change to

if ($gv_result['amount']>0){

 

3. To display the right amount, for instance if you set it in admin to not include tax or shipping in the amount, do this:

 

in catalog/includes/modules/order_total/ot_gv.php :

after this function:

    function process() {
     global $order, $currencies, $cot_gv;
//      if ($_SESSION['cot_gv']) {  // old code Strider
      if (tep_session_is_registered('cot_gv')) {
       $order_total = $this->get_order_total();
       $od_amount = $this->calculate_credit($order_total);
       if ($this->calculate_tax != "None") {
         $tod_amount = $this->calculate_tax_deduction($order_total, $od_amount, $this->calculate_tax);
         $od_amount = $this->calculate_credit($order_total);
       }
       $this->deduction = $od_amount;
//        if (($this->calculate_tax == "Credit Note") && (DISPLAY_PRICE_WITH_TAX != 'true')) {
//          $od_amount -= $tod_amount;
//          $order->info['total'] -= $tod_amount;
//        }
       $order->info['total'] = $order->info['total'] - $od_amount;
       if ($od_amount > 0) {
         $this->output[] = array('title' => $this->title . ':',
                          'text' => '<b>' . $currencies->format($od_amount) . '</b>',
                          'value' => $od_amount);
       }
     }
   }

add

function mod_process() {
     global $currencies;
       $my_order_total = $this->get_order_total();
       $my_od_amount = $this->calculate_credit($my_order_total);
       if ($this->calculate_tax != "None") {
         $tod_amount = $this->calculate_tax_deduction($my_order_total, $od_amount, $this->calculate_tax);
         $my_od_amount = $this->calculate_credit($my_order_total);
       }
       //$this->deduction = $od_amount;
       //$order->info['total'] = $order->info['total'] - $od_amount;
       if ($my_od_amount > 0) {
         $this->my_output[] = array('title' => $this->title . ':',
                          'text' => '<b>' . $currencies->format($od_amount) . '</b>',
                          'value' => $od_amount);
       }
   }

 

in catalog/checkout_payment.php find this code (this is code from the update)

if (MODULE_ORDER_TOTAL_INSTALLED)
 $temp=$order_total_modules->process();
  $gv_query = tep_db_query("select amount from " . TABLE_COUPON_GV_CUSTOMER . " where customer_id = '" . $customer_id . "'");
  $gv_result = tep_db_fetch_array($gv_query);
//$temp=$order_total_modules->process();
$temp=$temp[count($temp)-1];
$temp=$temp['value'];
if ($gv_result['amount']>=$temp){ $coversAll=true;

Replace it with

if (MODULE_ORDER_TOTAL_INSTALLED)
 $temp=$order_total_modules->process();
  $testing= $GLOBALS['ot_gv']->mod_process();
  $testing=$GLOBALS['ot_gv']->my_output[0];
if ($testing['value']>=$temp){ $coversAll=true;

same file, find (from updated material)

    if (tep_session_is_registered('customer_id')) {

if ($temp>0){
echo ' <tr><td width="10">' .  tep_draw_separator('pixel_trans.gif', '10', '1') .'</td><td colspan=2><table border="0" cellpadding="2" cellspacing="0" width="100%"><tr class="moduleRow" onmouseover="rowOverEffect(this)" onclick="clearRadeos()" onmouseout="rowOutEffect(this)" >' . "\n" .
                             '   <td width="10">' .  tep_draw_separator('pixel_trans.gif', '10', '1') .'</td><td class="main"><b>';
if ($gv_result['amount']>$temp) echo $currencies->format($temp).' ';
else echo $currencies->format($gv_result['amount']).' ';
echo $order_total_modules->sub_credit_selection();
  }
}

Replace it with

  if (tep_session_is_registered('customer_id')) {  
 if ($gv_result['amount']>0){
  echo ' <tr><td width="10">' .  tep_draw_separator('pixel_trans.gif', '10', '1') .'</td><td colspan=2><table border="0" cellpadding="2" cellspacing="0" width="100%"><tr class="moduleRow" onmouseover="rowOverEffect(this)" onclick="clearRadeos()" onmouseout="rowOutEffect(this)" >' . "\n" .
                             '   <td width="10">' .  tep_draw_separator('pixel_trans.gif', '10', '1') .'</td><td class="main"><b>';
  echo $testing['text'].' ';//var_dump ( $testing);
  echo $order_total_modules->sub_credit_selection();
  }
}

Thanks to PopTheTop for finding bug 2 and 3 :)

 

from now on, any posts I make concerning this update I will have "easier to understand" at the top, so to see all the bugfixes or updated instructions do a thread search for "easier to understand" update

 

Sorry for the messup, let me know if I messed up anything else...

 

What I changed was I changed the output[] to my_output[] so it would not mess with the order total module variables, and I commented out the line that updates the total. Does this make sense?

Share this post


Link to post
Share on other sites

Heyo Jonyo, :)

 

is there a way, that you post a new zip into Contribs ?

 

With a install readme, so i can check all, over the old changes in my php files.

Many work to do, i think, but i need to have the CCGV running fine :)

 

Regards

Hobbes

 

P.S.

The fix you have post above... most i don?t have into my php files.

Dunno why, but my store is heavy modified ;)

Edited by Hobbes_TheReal

Share this post


Link to post
Share on other sites

Hi all, I posted in a different topic, but I will try here. I installed the latest full version of CCGV into my OSC M2.2 store. It doesn't show up in the checkout page though. I re-installed it twice now and I can't get it to work. All I want is a discount coupon (or promo code) that will give free shipping.

 

Any suggestions?

 

Thank you in advance,

Shawn

Share this post


Link to post
Share on other sites
Hi all, I posted in a different topic, but I will try here. I installed the latest full version of CCGV into my OSC M2.2 store. It doesn't show up in the checkout page though. I re-installed it twice now and I can't get it to work. All I want is a discount coupon (or promo code) that will give free shipping.

 

Any suggestions?

 

Thank you in advance,

Shawn

 

Did you go into the admin section>modules>order totals and click install for "discount coupons" "and gift vouchers". I just installed this contribution and I forgot to do that, works fine now.

Share this post


Link to post
Share on other sites
OOPS!  I found a bug in my bug fix...  Follow these instead!!!  Do NOT use the message above!  If a moderator is feeling very nice, could you delete the previous post so people don't do it instead of this one? 

 

Use these modified bug fixes:

Big Fixes for the "easier to understand" update that I posted on page 102:

NOTE:These are BUG FIXES to a previously posted update.  It is NOT an update by itself.  Once I work out ALL the bugs (with the help from everyone else to find them) I will re-post a bug-free version of the instructions.

 

 

 

Hey, after installing the fixes you posted above, NOTHING shows up at all in the checkout_payment screen. Meaning, all shows up fine EXCEPT for the voucher balance option in the payment options box.

 

I tried it with an account that has a gift voucher balance from a gift certificate, an account that has a new user credit voucher balance, and an account that has no voucher balance at all, still nothing is getting displayed.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

Also, the java script for the payment option radials only disables the top one in the list. If I do not pick one, it displays an error that I have not chosen a payment option.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Also, the java script for the payment option radials only disables the top one in the list. If I do not pick one, it displays an error that I have not chosen a payment option.

 

 

Sorry, I was wrong, this is what is happening...

 

The java script for the payment option radials disables all the radial buttons in the list when you click on the check box to use your credit balance. It does not matter if you had chosen a paymant option or not. When you click on CONTINUE, it states an error that I have not chosen a payment option.

 

No matter what I do, I can not use the credit balance because I can not click on any payment buttons.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

Heyo all, :)

 

is it possible, when there is comming a new version, to make

the Gift ammount, welcome gift etc. visible for user in his

account page as CCGV Ammount ?

 

atm a user only know his ammount from email, but is not

seeing in his account page in shop.

 

Regards

Hobbes

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×