Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

Have you tried the fix presented in this post?

 

Appears to work for me - haven't fully tested it (too busy reading 88 pages of this thread) :)

 

Thanks for the info!

 

I applied the fix and it appears to work, but I need to test a bit more. Unfortunately I had to add these patches to the live store, but so far, so good.

Share this post


Link to post
Share on other sites
spherica: If you will look at the rest of the readme it will tell you exactly which files to modify. The modifications in the files are all setup where it as

//ICW ADDED FOR CREDIT CLASS SYSTEM added to the side of a single line insert or has a begin and end statement. To install it by hand takes a good four hours for most people. Have some strong coffee and a bottle of champagne at the ready.

 

 

I have successfully loaded it up, no problem that I see on my test site.

 

I will doing to the a active site, at some point today. Took less then 3 hours to install.

 

I took the advice, and went and bought Beyond Compare.......funny, I've been doing this sort of stuff for a few years, and never heard of it. duh on me I guess.

 

I don't drink coffee or champagne.... any other suggestions that are without caffeen or alcohol :D

 

Thanks for the help all.

Edited by spherica

Share this post


Link to post
Share on other sites

KieranMullen: I tried this out on 3 different versions of mysql and it worked fine after I made restrict_to_p roducts be restrict_to_products ... that might have just been a problem with the transformation of the text in the forum though....

 

select coupon_id, coupon_code, coupon_amount, coupon_type, coupon_start_date,coupon_expire_date,uses_per_user,uses_per_coupon,restrict_to_p
roducts, restrict_to_categories, date_created,date_modified from coupons where coupon_active='Y' and coupon_type != 'G' limit -20, 20

 

spherica: great glad to hear it works for you... well you might go for a long run and let the endorphins kick in ...

 

 

sargenle: try changing

if ($order->content_type == 'virtual') {

 

to

 

 if (($order->content_type == 'virtual') || ($order->content_type == 'virtual_weight') ) {


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites
sargenle: try changing

if ($order->content_type == 'virtual') {

 

to

 

 if (($order->content_type == 'virtual') || ($order->content_type == 'virtual_weight') ) {

 

That was the fix I needed.

 

Thank you very much : )

 

Lee

Share this post


Link to post
Share on other sites

I've sifted through I don't know how many pages, and can't see any indication of my problem.

 

I go in and buy a Gift Certificate (weight 0 , Model GIFT25 ) and download enabled.

 

I get to the checkout, go through the process (2check out, paypal, linkpointconnect) after that, Iget forwarded back to the checkout_payment, and noything goes to the admin orders, but it does sit in the process of the merchant account.

 

However, if I try and buy something else, it works fine.

 

If I combined, and buy a product AND a Gift Cert. I get the same thing in forwarding back to the checkout_payment.php

 

did I miss something??

Share this post


Link to post
Share on other sites

See this post 1760 for my original reply in this forum.

 

I have since added the contrib "Downloads Controller", and have sucessfully solved at least one of my hurdles, in getting the CCGV contrib to work. That is, because this contrib "Downloads Controller", adds a "free shipping" module when installed.

 

Now, when I try to check out when purchasing a GV, shipping is not charged. But I still get redirected back to the payment information page when confirming the order (see above mentioned post again).

 

When purchasing a GV and another product, I still get charged for shipping for the GV (problem), as well as the other product (not a problem). The "free shipping" module does not come into play.

 

Again, when confirming the order, I get redirected back to the payment information page.

 

I have read all 90 pages of this forum twice. I have tried the solutions mentioned in this forum, for effect. All the params are set correctly (reasonably sure on both these statements).

 

Are there any other new thoughts?

Share this post


Link to post
Share on other sites
ahhhhh, another beyond comparer!  yes, it works so well i put it into my store!  and also windows grep has proven invaluable, to search for whatever text you want to find in any directory.  i work with over 50 web sites and it has been a life saver.  actually both have been.  now i just have to search for the code changes for bypassing submission of a cc if the voucher amount is higher than the balance due.

Ok, i have downloaded Beyond Compare becuase i have heard so many of you recommend it.

 

I just wanted to make sure i use it correctly.

 

When I open checkout_confirmation.php (as it applies to this contribution) i see all the pink lines on the right that are not on the left. Do I just add them to the left, save the file and then up load it again? It seems pretty basic, but one thing i have learned from this oscomm stuff is if it seems easy i am doing it wrong! :blush: :P

 

As a matter of interest.... I just want to add in a coupon code - no discount vouchers or gift vouchers or anything fancy... just something that they can put in code COUP1 (for example) and it will take 10% off their total... Do i have to download and install all of these mods (as stated above)?

 

1. 26 Jun 2004 - ccgv 510c

2. 11 Jul 2004 - Credit Class & Gift Voucher

3. 4 Sep 2004 - CCGV bug fix

4. 18 Nov 2004 - Class creates a TAX problem

 

Just the first mod has over 99 files to edit or add. That seems so excessive! :blink:

 

I really wish someone would clean up that mod it is a real mess! :0)

Thanks for any replies

Angi

Share this post


Link to post
Share on other sites

I need some assistance. Myu coupons have gone haywire!! When I click on order total in admin panel all I see is one single line that says discoutn code and nothing else! Does anyone know why?? The coupons do not work all the time seems to be hit and miss I am at a total lose as to why this has happend and my site is up and runniung. I would appreciate any help. Thanks!

Share this post


Link to post
Share on other sites

I'm having difficulties too.

 

Hopefully a simple fix tho.

 

When in 'Coupon Admin', I insert a new coupon, and set the end date. When I preview/insert that coupon, the start date defaults to todays date, and the end date defaults back exactly a year from the start date.

 

Is there a minimum duration for coupons of 1 year?

Share this post


Link to post
Share on other sites

hello guys , i just installed version ccgv-510c_TC. Everything works fine , but after customer uses their gift voucher, it stays their ( and they can use it again and again ), i am not sure what did i do wrong..

 

any help is greatly apprecaited

 

thankyou

Share this post


Link to post
Share on other sites

I am having problems with the interaction of CCGV and my transaction processing gateway (trustcommerce). When a customer uses a DISCOUNT Code everything appears to work correctly (invoice, emails, etc).

 

However, the customer is charged the entire amount (no discount) on their CC. (luckily I am only pre-authing so I can charge the correct amount when I post-auth).

 

I am missing a config option or somthing to make this charge the correct amount to the CC?

 

-Neil


---------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites
I have a version of this contib installed.

 

 

2) When I try to send a $10 gift voucher, the amount received by the customer is $0.00. The amount in the gv Queue is $0.00

 

Thanks!

 

I didn't see anybody answer this - but just to verify, don't put in the "$" sign into the amount field, or you'll always get $0.00. Just put in the number. (I know I had that problem the first few times I tested it and was baffled.) :P

 

Jacob

Share this post


Link to post
Share on other sites

This is an update to my last post. It looks like someone else was having this same problem (see post #396). But I am not sure where to put the single line of code referenced in the fix. Anyone else willing to look at post #396?

 

My main question is where (I am assuming that the file to be edited is includes/modules/payment/trustcommerce.pgp) in the file after the process_button() function that line should go. I tried adding it as:

 

// !Functions to execute before finishing the form
// Store all the relevant order information into hidden fields for the
// before_process() function to use
   function process_button() {
    global $HTTP_POST_VARS, $order; //ADDED BY NEIL FOR CCGV FIX
     $process_button_string = tep_draw_hidden_field('cc', $this->cc_card_number) .
                              tep_draw_hidden_field('exp', $this->cc_expiry_month . substr($this->cc_expiry_year, -2));

     if (MODULE_PAYMENT_TRUSTCOMMERCE_CVV == 'True') {
       $process_button_string .= tep_draw_hidden_field('cvv', $HTTP_POST_VARS['trustcommerce_cc_cvv']);
     }

     return $process_button_string;
   }

 

but that did not seem to work.

 

Any thoughts?

Neil


---------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

I have futzed and futzed with this.

 

What is going on between the process_button() function and before_process() function?

 

If I put debug prints in the payment code I can see that $order->['total'] is correct at the beginning of the process_button() function BUT if I put the same print statement in the before_process() function I get the total WITHOUT the discount.

 

Please help on this one - could this be a OSC config issue and not a trustcommerce.php issue?

 

-Neil

 

 

This is an update to my last post. It looks like someone else was having this same problem (see post #396). But I am not sure where to put the single line of code referenced in the fix. Anyone else willing to look at post #396?

 

My main question is where (I am assuming that the file to be edited is includes/modules/payment/trustcommerce.pgp) in the file after the process_button() function that line should go. I tried adding it as:

 

// !Functions to execute before finishing the form
// Store all the relevant order information into hidden fields for the
// before_process() function to use
? ?function process_button() {
? ? global $HTTP_POST_VARS, $order; //ADDED BY NEIL FOR CCGV FIX
? ? ?$process_button_string = tep_draw_hidden_field('cc', $this->cc_card_number) .
? ? ? ? ? ? ? ? ? ? ? ? ? ? ? tep_draw_hidden_field('exp', $this->cc_expiry_month . substr($this->cc_expiry_year, -2));

? ? ?if (MODULE_PAYMENT_TRUSTCOMMERCE_CVV == 'True') {
? ? ? ?$process_button_string .= tep_draw_hidden_field('cvv', $HTTP_POST_VARS['trustcommerce_cc_cvv']);
? ? ?}

? ? ?return $process_button_string;
? ?}

 

but that did not seem to work.

 

Any thoughts?

Neil


---------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

nserdinsky: What is your sort order?


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Here is a list of problems I have incountered with the mod, any help is appreciated.

 

When purchasing a Gift Certificate, after process order, you are directed back to the payment page, order is not getting put into database for shipping process.

 

When using the "Welcome" Coupon that is sent out with the Welcome email apon creating an account, the code sent does the same thing, after you clikc porcess, you are directed back to the payment.

 

When using the Admin fuction to create coupons that you manual send out, while it does says

(demonstration)

sub total 100.00

coupon -10.00

Total 100.00

But when you are sent to the merchant it does charge $90 also in the verification emails that are sent out, and are in the same format, Total is 100 - 10

 

Thanks for the help in advance.

Edited by spherica

Share this post


Link to post
Share on other sites

This is what I have right now:

 

Discount Coupons 9

Giftwrap 3

Gift Vouchers 740

Low Order Fee

Shipping 2

Sub-Total 1

Tax 4

Total 900

 

I thought giftwrap may have been the problem so I tried removing it completely but had the same results.

 

I have the discounts setup to not apply against tax or shipping.

 

All the totals work correctly within OSC, but just not with the payment gateway.

 

Thanks!

Neil

?

 

 

nserdinsky: What is your sort order?


---------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites
Hi all, just wondering if any users of this contrib, using in conjuction with a qty discount, have run into the "double-discount" issue described in the post below:

 

How 2 exclude vouchers from quantity discount calc, Voucher getting "double discount"...

 

I am using the Customer Discount mod and would like to have the option to exclude Gift Vouchers from any type of discount as well. A $5.00 Gift Voucher ends up being a $4.25 Gift Voucher with the 15% Customer Discount.

 

Is this possible to exclude the purchase of Gift Vouchers from special discounts?

Share this post


Link to post
Share on other sites

I haven't played with Customer Discount mod, but gift vouchers are not discounted with discount coupons.


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Does anyone have ideas? Perhaps something in my config?

-Neil

 

This is what I have right now:

 

Discount Coupons 9

Giftwrap 3

Gift Vouchers 740

Low Order Fee

Shipping 2

Sub-Total 1

Tax 4

Total 900

 

I thought giftwrap may have been the problem so I tried removing it completely but had the same results.

 

I have the discounts setup to not apply against tax or shipping.

 

All the totals work correctly within OSC, but just not with the payment gateway.

 

Thanks!

Neil

?


---------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites
I am using the Customer Discount mod and would like to have the option to exclude Gift Vouchers from any type of discount as well. A $5.00 Gift Voucher ends up being a $4.25 Gift Voucher with the 15% Customer Discount.

 

Is this possible to exclude the purchase of Gift Vouchers from special discounts?

 

 

GOOD NEWS: After more testing I realize that the actual value of the GV is credited, so the credit would only be $4.25 - no double discount. :thumbsup:

 

BAD NEWS: Can be confusing for customers when they think they are buying $5 in GV, when actually it's only 4.25. Maybe I'll just make a 4 gift vouchers that = $1 for each discount level (although this will most likely look very unprofessional).

 

You see, the way way Customer Discounts work is the price is discounted in the store, not at the checkout.

 

I'll live with it for now I guess :D

Share this post


Link to post
Share on other sites

I am having problems with version ccgv-510c_TC .When a customer uses a DISCOUNT Code everything appears to work correctly ( emails, invoices ).

 

However, the Discount stays in their shopping cart and they can use it again ang again

 

any help is greatly appreciated

 

thankyou

Share this post


Link to post
Share on other sites
See this post  1760 for my original reply in this forum.

 

I have since added the contrib "Downloads Controller", and have sucessfully solved at least one of my hurdles, in getting the CCGV contrib to work. That is, because this contrib "Downloads Controller", adds a "free shipping" module when installed.

 

Now, when I try to check out when purchasing a GV, shipping is not charged. But I still get redirected back to the payment information page when confirming the order (see above mentioned post again).

 

When purchasing a GV and another product, I still get charged for shipping for the GV (problem), as well as the other product (not a problem). The "free shipping" module does not come into play.

 

Again, when confirming the order, I get redirected back to the payment information page.

 

I have read all 90 pages of this forum twice. I have tried the solutions mentioned in this forum, for effect. All the params are set correctly (reasonably sure on both these statements).

 

Are there any other new thoughts?

Share this post


Link to post
Share on other sites
I am still having Gift Voucher checkout issue. During the checkout process, the user is still being redirected from the Confirmation page back to the Payment page. I loaded the latest CCGV_5_11 but the user still cannot complete the checkout process unless a real asset is in the shopping cart along with the virtual asset. Was this issue ever resolved?

Share this post


Link to post
Share on other sites

I followed the instructions word for word and imported teh sql file to the database but I get this error dbsurplu_p_os1 is the database name.

 

1146 - Table 'dbsurplu_p_os1.coupons' doesn't exist

 

select count(*) as total from coupons where coupon_active='Y' and coupon_type != 'G'

 

[TEP STOP]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×