Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

I have just installed CCGV. Discount coupons work fine when I leave the "valid product list" field blank. When a customer checks out, the "Voucher/Coupon" box appears in the payment screen.

 

As soon as I enter one or more product ID's in the "Valid Product List" field, though, the "Voucher/Coupon" box fails to appear, even when one of the listed products is the only item in the cart.

 

Have I missed something? How do I get a discount coupon to work with a specific list of product id's?

 

Thanks!

 

Doug

 

P.S., I mistakenly posted in this in the wrong place the other day. Sorry!

Share this post


Link to post
Share on other sites
I have just installed CCGV. Discount coupons work fine when I leave the "valid product list" field blank. When a customer checks out, the "Voucher/Coupon" box appears in the payment screen.

 

As soon as I enter one or more product ID's in the "Valid Product List" field, though, the "Voucher/Coupon" box fails to appear, even when one of the listed products is the only item in the cart.

I found a work-around, at least. I created a discount coupon that works for all products. Then I created one that works only for a selected list of products. Now the field for entering coupons and vouchers is present in the payment section AND it only deducts discounts from products on the selected list.

 

Doug

Share this post


Link to post
Share on other sites

My discount coupons now seem to work in every way but one: the discounts from a %-based coupon are calculated incorrectly. I can't figure out what calculation they ARE based on, but here's a sample.

 

The discount coupon is set up to deduct 10% from the products in a valid products list. Here's what it deducts, instead (in the order in which the order total modules appear):

  • 2 items in cart, ($19.95 & $29.95) subtotal: $49.90
  • discount coupon: $1.18
  • shipping: $5.85
  • tax: $2.50

  • 3 items in cart (same two plus one more; all are on the 'valid products list', ($19.95 & $29.95 & $39.95) subtotal: $89.85
  • discount coupon: $1.77
  • shipping: $5.85
  • tax: $4.49

I'm using CCGV 510c, MS 2.2, PHP 4.3.4, mySQL 3.23.56, on Redhat Linux 9.0.

 

Any clues how to fix this?

 

Doug

Share this post


Link to post
Share on other sites

Hi there! I've been debugging my 510c install that I thought was working perfectly, but isn't. Fixed a couple of problems on my own. Now I have two that seem somewhat common:

 

1) Purchased gift vouchers are not showing up to send to people in the cart box even after status is "delivered". There is no clear way to send a gift certificate to anyone. Something's broken and I can't tell what.

 

2) Was it ever answered how to exclude shipping from a gift certificate? The code seems to be there, but it's not working. I couldn't find any answers in the pages I browsed through here.

 

Thanks much!

Susan Midlarsky

http://www.aspiring-arts.com

Share this post


Link to post
Share on other sites

Hallo,

 

i have a significant problem, i installed the 'Credit Class & Gift Voucher' - contribute. If i have a Customer with a special discount and he buys a Gift Voucher, then the price for the Gift Voucher is less discount. I don't want that.

 

Cause, at the one hand the value of the gift voucher is only the price less discount if the customer encash the voucher, that's terrible and on the other hand, could the customer buy the voucher cheaper, then he get double discount - at first of the voucher and second on the article he buys with the voucher.

 

Thats the reasen, why i want exclude vouchers from discount.

 

Could Anybody help me!!!

 

Thanks

Share this post


Link to post
Share on other sites
2) Was it ever answered how to exclude shipping from a gift certificate? The code seems to be there, but it's not working. I couldn't find any answers in the pages I browsed through here.

 

Thanks much!

Susan Midlarsky

Hi Susan.... what I did was to enable the 'download' in the admin config section. Then you set the gift voucher weight to zero...... it worked for me.... :)

Share this post


Link to post
Share on other sites

Hi,

 

In the email that is sent from either admin or a customer, the redeem url leads to gv_redeem and it says that the gv is redeemed, but when I log in the amount is not being applied to the account. If I try to make a purchase, I can enter the code in the redeem box and then it is acutally redeemed and everything is fine.

 

Anyone have this problem? I've searched in the forums using all the keywords I could think of with nothing poping up :(

 

 

Thanks for any help

 

Tim

Share this post


Link to post
Share on other sites

A couple things: I figured out why gift certificates weren't showing up - I forgot to send them in the queue (*blush*). Then they work fine.

 

EXCEPT --

 

1) If you email a voucher to someone, you have to include four zeroes, or the amount shows up as 0.00. So for example, the amount has to be 10.0000, not 10.00. This seems to be a bug.

 

2) It's fine if someone clicks on a link, and it says the certificate is redeemed. But there seems to be no account checking. Thus if someone redeems it and doesn't create an account on the same machine right away, they could lose the value, right? And there is no warning about this, is there? I guess I should put something about this is in the automated email, eh?

 

Thanks,

Susan

Share this post


Link to post
Share on other sites
2) Was it ever answered how to exclude shipping from a gift certificate? The code seems to be there, but it's not working. I couldn't find any answers in the pages I browsed through here.

 

Thanks much!

Susan Midlarsky

Hi Susan.... what I did was to enable the 'download' in the admin config section. Then you set the gift voucher weight to zero...... it worked for me.... :)

 

I have a similar problem. I've enabled downloads and set the gv weights to 0 and when I purchase the gv alone it doesn't include shipping, but if I purchase together with another item it charges shipping on both items.

 

I'm using table rate shipping method.

 

 

Anyone have this problem that got it fixed and can help me out? ;)

 

 

Thanks,

 

Tim

Share this post


Link to post
Share on other sites
:ptrinephi: actually I think it might be a problem with the mysql version you are using. I just tried the sql queries you presented in the 4.1.2 and it played ok .. I just found a note "The initial release of MySQL 4.1.3 for Windows accidentally was not compiled with support for the Spatial Extensions " that you might want to consider. but since you are running b it might not be that ....

 

carfever: sorry I could not understand what you are saying.

ditto... B)

Share this post


Link to post
Share on other sites
I have a new store that I recently installed 5.10c on.  All seems to be working correctly, but when I attempt to redeam a coupon or a voucher, the total is not updated with the discounted amount.  Any ideas on what I need to check to find out what I did wrong?

 

-Jeff DeVerter

jeff@texascoffee.biz

"Freshest coffee on the net"

i think you need to sort the order of your "total" in modules.

i have this prob too...

 

I'm in Admin in modules... but CCGV-510c isnt' listed here.

 

I see the voucher amount in cart and I can send voucher to someone... but it doesn't subtract from order total. no check boxes, etc.

 

ack

Share this post


Link to post
Share on other sites

omg... never mind... der

 

i installed both and was wondering other people's sort orders.

 

ok... so here's a test run...

 

ORDER:

1 x MNEMIC - AUDIO INJECTED SOUL $14.93

2 x Remix '2004' logo T-shirt

- Color: Obsidian Black

- Size: Adult Large $35.98

1 x INKYA - Women's Knit Spaghetti Strap Tank $12.99

1 x 8 Pointed Star Pendant $12.10

1 x 14" B&W Quad Monitor System with 4 Infrared Cameras $411.19

 

Total: $487.19

Gift Vouchers: $20.00

Sub-Total: $487.19 <<<< shouldn't this deduct the Gift Voucher??? and be $467.19???

 

My sort order:

Discount Coupons 1

Gift Vouchers 10

Low Order Fee

Shipping 2

Sub-Total 0

Tax 3

Total 4

Edited by remixstore

Share this post


Link to post
Share on other sites

Yeah, I'm seeing that problem too (not deducting gift vouchers from total). Has anyone tried using a dummy credit card (not real processing) to see if the correct amount gets charged?

Share this post


Link to post
Share on other sites

i have tried a dummy card.

 

it charges the full amount.

 

I am going to try swapping the order yet again and give it a whirl.

 

I did check the box tho to use voucher and it didn't seem to work.

Share this post


Link to post
Share on other sites

For anyone having problems getting percentages to work or getting the discount coupons to actually be applied to an order in the coupon admin remove free shipping - when I had free shipping set to on I couldnt use % at all and the coupon was not applied to the order total even tho the entry for coupon appeared just below the shopping cart box. As soon as I removed free shipping for the coupon it works spot on now!

 

Hope this helps someone!

 

Jase

Share this post


Link to post
Share on other sites

Hello all. I have installed the ccgv-510c files. All appears to work fine with one exception:

 

When I enable both the Voucher and Coupons, only one field works in the Checkout Payment page, and it is always the second field that is listed.

 

For instance, if Discount Coupons appears above Gift Vouchers in the sort order, then only the field for Gift Vouchers will work. And it works for both Voucher and Coupon codes. The Discount Coupon field with its Redeem button will not work.

 

If I switch the sort order, then the Discount Coupon field will work for both and the Gift Vouchers field will not.

 

Thanks for any ideas.

Share this post


Link to post
Share on other sites

I am having a problem with one of these that I've installed. The shipping is not showing up in the checkout confirmation. In the admin in modules, order total there is no option for shipping. What did I miss?

I've installed this before and it worked fine......

I've reuploaded files and it still doesn't work....

Share this post


Link to post
Share on other sites
In the email that is sent from either admin or a customer, the redeem url leads to gv_redeem and it says that the gv is redeemed, but when I log in the amount is not being applied to the account.  If I try to make a purchase, I can enter the code in the redeem box and then it is acutally redeemed and everything is fine.

 

Anyone have this problem?  I've searched in the forums using all the keywords I could think of  with nothing poping up :(

 

 

Thanks for any help

 

Tim

Does anyone use Linda's Loginbox 5.5 that needed a fix for this contrib? It seems to me that when I use it to log in after going to the redeem url it is starting a new session and loses the fact that I was redeeming a voucher.

 

So, I end up in a continuous loop of redirect, login, blah, redirect, login, blah.

 

 

Thanks

 

Tim

Share this post


Link to post
Share on other sites

I installed the contribution and have been using it for a while. However, I noticed something odd today and don't know when it got introduced.

 

In the configuration for "MY STORE", in the middle frame (under DISPLAY PRICES WITH TAX), I notice I have 2 entries each:

 

Welcome Gift Voucher Amount 0

Welcome Gift Voucher Amount 0

Welcome Discount Coupon Code

Welcome Discount Coupon Code

 

Since they are in order 1,1,2,2 instead of 1,2,1,2, I think perhaps they are either sorted or in the database twice?

 

If I had copied the code in a second time, I would think they would be in the order 1,2,1,2.

 

Anyway, where can I look for this error.

 

The URL appears to be /admin/configuration.php?gID=1&selected_box=gv_admin

 

but I didn't see anything obvious in admin/configuration.php

 

If it makes any difference, I also am using Admin with Levels.

Share this post


Link to post
Share on other sites

The discount module calculates the amount to be discounted from the final selling price -- this includes discounts already given in the specials. Is there anyway we can have the discount be based on the original price prior to the discounts given for "specials"?

 

Thanks.

Share this post


Link to post
Share on other sites

The discount module calculates the amount to be discounted from the final selling price -- this includes discounts already given in the specials. Is there anyway we can have the discount be based on the original price prior to the discounts given for "specials"?

 

Thanks.

Share this post


Link to post
Share on other sites
For anyone having problems getting percentages to work or getting the discount coupons to actually be applied to an order in the coupon admin remove free shipping ... As soon as I removed free shipping for the coupon it works spot on now!

 

Jase, thanks for suggesting this... but at least in my case, it doesn't help, as free shipping was never turned on anyway. Still wanting the voucher amount to be applied to total, but it isn't.

 

Thanks,

Susan

Share this post


Link to post
Share on other sites

Hello, after installing the Credit Class & Gift Voucher Contribution I have found a problem in the admin side, inwhich the link in the left column is trying to point to this:

 

http://www.mysite.com/catalog/admin/FILENA...ed_box=gv_admin

 

I gathered there was a bit missing from the filename.php file or something so I tried accessing this URL:

http://www.mysite.com/catalog/admin/coupon...ed_box=gv_admin

 

It loaded a page, but there was an error here too. This was the error:

1146 - Table 'mysite_com_-_shop.TABLE_COUPONS' doesn't exist

 

select count(*) as total from TABLE_COUPONS where coupon_active='Y' and coupon_type != 'G'

 

[TEP STOP]

 

Does anyone know how this can be fixed please?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×