Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

i have given up on the multiple redemption field attempt. really too much work to get it going. anyways, thanks for the help u have provided.

 

btw, i found that when i set the coupons to specific products it worked, but not when set to categories. is this a bug of the older version(5.06) that i am using? will this be resolved once i upgrade to the latest?

 

pls advice.

 

thanks in advance.

Share this post


Link to post
Share on other sites

i have given up on the multiple redemption field attempt. really too much work to get it going. anyways, thanks for the help u have provided.

 

btw, i found that when i set the coupons to specific products it worked, but not when set to categories. is this a bug of the older version(5.06) that i am using? will this be resolved once i upgrade to the latest?

 

pls advice.

 

thanks in advance.

Share this post


Link to post
Share on other sites

Hello, I installed the version 5.10c. I'm not possible the sent away coupons are to be redeemed. At least it is booked nothing. Property my Sort order already as adjusted as here indicated in the forum. On the whole side is no one for the topic of coupons indicates. But an error message does not come also...

 

Please help me!

Share this post


Link to post
Share on other sites

I could use any help on this one...

 

I installed the ccgv 5.10b, and all semed to go fine until I attempted to add an item to the cart, which then gives me the following error in the Shopping Cart infobox:

 

Fatal error: Call to undefined function: get_products() in /***/***/***/***/catalog/includes/boxes/shopping_cart.php on line 31

 

When I click to view my shopping cart contents, I get the following error:

 

Fatal error: Call to undefined function: get_products() in /***/***/***/***/catalog/shopping_cart.php on line 77

 

I do have a number of other contributions installed, and all had tested as working properly before I attempted the ccgv install.

 

After double checking my install, and looking over the code of the two error message files, I believe they are fine and that my error is in some other fiile...

 

Any ideas?

Share this post


Link to post
Share on other sites

I just loaded this on a clean load test site and I get the following message in the shopping cart window on every screen.

 

"dvecatalog.TABLE_COUPON_GV_CUSTOMER' doesn't exist"

 

I can see that the table does exist in the database so I don't know what I'm doing wrong.

 

Thanks for any help,

 

Don

Share this post


Link to post
Share on other sites

haro!

 

I've just added this script and i simply love it! :D

 

however, I've encountered some problems and i hope you guys can help.

 

1. How to show the total amount payable after discount? Currently, it just shows the amount being discounted, but did not show the final amount payable as well.

 

2. In the automated mail generated after checkout, the price of the items as shown in the mail is $0.00 for all items, although the Subtotal, Total as well as the Discount amount still shows.

 

Thats all for now, and i erally must compliment the people behind this wonderful script! :) Thanks for helping. :)


You live, you learn. :)

Share this post


Link to post
Share on other sites

I have a new store that I recently installed 5.10c on. All seems to be working correctly, but when I attempt to redeam a coupon or a voucher, the total is not updated with the discounted amount. Any ideas on what I need to check to find out what I did wrong?

 

-Jeff DeVerter

jeff@texascoffee.biz

"Freshest coffee on the net"

Share this post


Link to post
Share on other sites
I have a new store that I recently installed 5.10c on. All seems to be working correctly, but when I attempt to redeam a coupon or a voucher, the total is not updated with the discounted amount. Any ideas on what I need to check to find out what I did wrong?

 

-Jeff DeVerter

jeff@texascoffee.biz

"Freshest coffee on the net"

i think you need to sort the order of your "total" in modules.


You live, you learn. :)

Share this post


Link to post
Share on other sites
haro!

 

I've just added this script and i simply love it! :D

 

however, I've encountered some problems and i hope you guys can help.

 

1. How to show the total amount payable after discount? Currently, it just shows the amount being discounted, but did not show the final amount payable as well.

 

2. In the automated mail generated after checkout, the price of the items as shown in the mail is $0.00 for all items, although the Subtotal, Total as well as the Discount amount still shows.

 

Thats all for now, and i erally must compliment the people behind this wonderful script! :) Thanks for helping. :)

I've solved point 1. yay! :)

 

But i still need help on point 2. no matter what i do, it still shows $0.00. and it appears $0.00 in order_confirmation too! the prices for each item is $0.00, although the subtotal and total amount are correct. pls help! TIA. :D


You live, you learn. :)

Share this post


Link to post
Share on other sites
I have a new store that I recently installed 5.10c on.  All seems to be working correctly, but when I attempt to redeam a coupon or a voucher, the total is not updated with the discounted amount.  Any ideas on what I need to check to find out what I did wrong?

 

-Jeff DeVerter

jeff@texascoffee.biz

"Freshest coffee on the net"

i think you need to sort the order of your "total" in modules.

What should the order be (where should the discounts/vouchers be in the list?)

Share this post


Link to post
Share on other sites
I have a new store that I recently installed 5.10c on.? All seems to be working correctly, but when I attempt to redeam a coupon or a voucher, the total is not updated with the discounted amount.? Any ideas on what I need to check to find out what I did wrong?

 

-Jeff DeVerter

jeff@texascoffee.biz

"Freshest coffee on the net"

i think you need to sort the order of your "total" in modules.

What should the order be (where should the discounts/vouchers be in the list?)

read through the thread. there're answers in there. :)


You live, you learn. :)

Share this post


Link to post
Share on other sites

Anyone Have A Perfectly Working Correctly Calculating Script For CCGV?

 

It seems as if there have been many things to alter the script to make fixes to bugs, but there are so many differnt things its hard to figure out everything...

 

Can someone post a perfectly working code here?

 

Thanks,

Steve

Share this post


Link to post
Share on other sites

Hi everyone!

 

Was just wondering if anyone is able to tell me how to correct the issue where:

 

a voucher which gives a percentage discount AND has free shipping enabled does not calculate the percentage discount! and only gives the customer free shipping.

 

Thanks for all your help!

 

Edwin.

Share this post


Link to post
Share on other sites
Hi everyone!

 

Was just wondering if anyone is able to tell me how to correct the issue where:

 

a voucher which gives a percentage discount AND has free shipping enabled does not calculate the percentage discount! and only gives the customer free shipping.

 

Thanks for all your help!

 

Edwin.

Hi Edwin,

 

If I am not wrong, you can not mix percentage discount and free shipping, at least not for the discount coupon part. You have to choose between precentage discount or free shipping NOT both.

 

I think free shipping has higher precedence then precentage discount, that explains why you only get free shipping.

 

/Fred

Share this post


Link to post
Share on other sites

Good Day! A big thank you to strider! I just installed this and from the admin side everything looks great!! But when I go to view the catalog all I get is a blank page. :unsure: Any ideas which file I messed up or perhaps I forgot to load one? Thanks so much!

Share this post


Link to post
Share on other sites

"In the bottom level directory (The same one this document is in) you will find a file ending with .sql. This contains the database definitions for tables that are required by the contribution. These definitions need to be added to the Database that you use for your osCommerce catalog. How you achieve this depends on your installation. The easiest method is to use phpMyAdmin to upload and add the .sql file."

 

After unzipping the zip file, I cannot find this .sql file

 

any ideas where I can find it?

 

Thanks!

Share this post


Link to post
Share on other sites
Hi everyone!

 

Was just wondering if anyone is able to tell me how to correct the issue where:

 

a voucher which gives a percentage discount AND has free shipping enabled does not calculate the percentage discount! and only gives the customer free shipping.

 

Thanks for all your help!

 

Edwin.

Hi Edwin,

 

If I am not wrong, you can not mix percentage discount and free shipping, at least not for the discount coupon part. You have to choose between precentage discount or free shipping NOT both.

 

I think free shipping has higher precedence then precentage discount, that explains why you only get free shipping.

 

/Fred

Thanks Fred! That answers my questions!

Share this post


Link to post
Share on other sites

During chekout process, there is a fatal error at checkout_confirmation.php:

 

Fatal error: Cannot redeclare class order_total in /home/digitals/public_html/catalog/includes/classes/order_total.php on line 13

 

I don't know where it goes wrong...

 

Besides, i wonder where will gv_send.php and gv_redeem.php be shown in the web? Do i have to add them as a link in a new infobox?

 

Can anyone help me?

Thanks in advance!!

;)

Share this post


Link to post
Share on other sites

Besides, what does the following error mean?

 

 

1062 - Duplicate entry '11' for key 1

 

insert into coupons_description (coupon_name, coupon_description, coupon_id, language_id) values ('Trial2', '', '11', '4')

 

[TEP STOP]

Share this post


Link to post
Share on other sites

Second try.

 

I just installed all the code for the third time and I'm still getting the same error. I'm putting this up on a test site to see if I can get it to work before trying to install it on a working site that has been modified a lot. So this morning I started with a fresh install of the oscommerce-2.2ms2 code and then copied ccgv-510c on top of it.

 

I made the required changes to the files and installed the SQL file. I get the following error on every screen that shows the shopping cart.

 

1146 - Table 'dvellio_dvecatalog.table_coupon_gv_customer' doesn't exist

 

select amount from table_coupon_gv_customer where customer_id = '2'

 

When I go to the database I can see the table and everything looks OK to me.

 

Database dvellio_dvecatalog - Table coupon_gv_customer running on localhost

 

Can someone help me understand what I'm missing?

 

Thanks in advance.

 

Don

Share this post


Link to post
Share on other sites

Looking for a solution to this error also. I have the Authorize.net mod and STS installed, I've looked at all the files, imported the the gv sql file, check my mysql dp and the table exists, ran the query for below manually and it retuned just fine.

 

So, Where do I look to correc this behavior. Also, I'm getting a link problem with the admin interface for the bottom box link:

 

1146 - Table 'otatraining.TABLE_COUPON_GV_CUSTOMER' doesn't exist

 

select amount from TABLE_COUPON_GV_CUSTOMER where customer_id = '6'

 

[TEP STOP]

Share this post


Link to post
Share on other sites

Ok, solved this by READING the instructions.

 

There are several files that MUST be edited by HAND, See Below:

 

24) catalog/includes/languages/english.php (EDIT)

Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_LANGUAGES . 'add_ccgvdc_english.php'); // ICW CREDIT CLASS Gift Voucher Addittion

 

25) catalog/includes/languages/german.php (EDIT)

Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_LANGUAGES . 'add_ccgvdc_german.php'); // ICW CREDIT CLASS Gift Voucher Addittion

 

26) catalog/includes/languages/espanol.php (EDIT)

Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_LANGUAGES . 'add_ccgvdc_espanol.php'); // ICW CREDIT CLASS Gift Voucher Addittion

 

60) catalog/includes/application_top.php (EDIT)

Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_INCLUDES . 'add_ccgvdc_application_top.php'); // ICW CREDIT CLASS Gift Voucher Addittion

 

70) admin/includes/application_top.php (EDIT)

Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_INCLUDES . 'add_ccgvdc_application_top.php'); // ICW CREDIT CLASS Gift Voucher Addittion

 

 

71) admin/includes/column_left.php (EDIT)

Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_BOXES . 'gv_admin.php'); // ICW CREDIT CLASS Gift Voucher Addittion

 

 

76) admin/includes/languages/english.php (EDIT)

Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_LANGUAGES . 'add_ccgvdc_english.php'); // ICW CREDIT CLASS Gift Voucher Addittion

 

77) admin/includes/languages/german.php (EDIT)

Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_LANGUAGES . 'add_ccgvdc_german.php'); // ICW CREDIT CLASS Gift Voucher Addittion

 

78) admin/includes/languages/espanol.php (EDIT)

Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_LANGUAGES . 'add_ccgvdc_espanol.php'); // ICW CREDIT CLASS Gift Voucher Addittion

 

 

This is what happens when you try and implement mods at 3am in the morning. :unsure:

Share this post


Link to post
Share on other sites

I have installed the Credit Class & Gift Voucher contribution into OSC 2.2 MS2 (with Japanese Language Pack MS1) and have tested the discount coupons (not gift vouchers yet).

 

Things are looking pretty good, but I have one issue that I believe is a conflict with another installed contribution, Actual Attribute Price v 1.2.2 (http://www.oscommerce.com/community/contributions,1716).

 

Product prices which have attribute-specific pricing are not being calculated accurately for the cart. I tried adding (via copy/paste) the Actual Attribute Price code to the CCGV-modified catalog/shopping_cart.php file, but that didn't help.

 

Is this a known issue - hopefully with a user-friendly solution?

 

I have a second question:

 

Is CCGV compatible with the QTpro v3.0 - Quantity Tracking Professional Contribution (http://www.oscommerce.com/community/contributions,888)?

 

I am thinking of uninstalling Actual Attribute Price and replacing it with QTpro 3, but, in either case, I want to keep CCGV contribution installed.

 

If someone can get back to me asap, that would be fantastic, as I'm kinda in a time crunch on this.

 

Thank you VERY much!

 

Macisle

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×