Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

Hello everyone, first there has been some posts from people saying things were not being subtracted from the final total. What I did to solve that problem was make Total sort order 800.

 

 

 

Now I am still having a problem, one that I keep getting with every single version of the contribution and that is orders not being listed in admin>customers>orders

 

Has anyone figured out this problem yet?

Share this post


Link to post
Share on other sites

Hi Strider,

 

I would like to thank you for answering me or trying to help.. I'm not too sure what you mean about the database and this modules thing supposed to be in there.. Wasn't that already in the sql file that I uploaded from the contribution? and in the configure file.. What line is supposed to be in there that you are suggesting is not? And I assume you mean in /admin/includes/configure.php correct?

 

I may need for you to be a little more explicit if that's alright with you.. Mainly because I don't want to misinterpret anything you're trying to help me by.. And then make even a bigger mistake.. I just want the darn thing to work .. lol

 

Thanks again Strider

 

Christine


If it ain't broke, don't fix it! :)

Share this post


Link to post
Share on other sites

Still waiting.. but posting again to keep this thread alive and kicking.. lol

 

Thanks..

 

Christine


If it ain't broke, don't fix it! :)

Share this post


Link to post
Share on other sites

Andrew,

I have just been playing around with my orders to see if there was a problem and I think it might prove beneficial if you listed your total after your gift voucher yet your gift voucher after everything else.

It would be like this in modules->order total

Discount Coupons 4

Gift Vouchers 5

Low Order Fee

Shipping 2

Sub-Total 1

Tax 3

Total 6

 

Now I don't have the low order fee but this does two things one shows the customer the correct total and two it places it in the order information in the admin correctly.

Notice the simple logic of the order. Just like you would like it to be when your checking out.


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Redsonya,

You need to make sure the values were installed in the database. You can do that with phpmyadmin or another mysql manager. It has nothing I don't believe to do with the admin/includes/configure.php.

After making sure it has been placed in there then you need to go through the instructions again and make sure you modified the files that needed modifying and replaced or modified the other ones and placed the new ones in the proper place.

It is hard for this old brain to remember but I don't think it is a straight copy over. There are some edits you have have to do in the application_top files and I believe that is all.

But...if you just want to see it work. Take a new copy of 2.2 ms2 and a virgin copy of the database, copy in all the files in the gvdc contrib, do the sql thing and edit the application_top.php files (yes there are two of them). Open up the admin file, go to modules->order_total install the gift vouchers install the discount coupon if you like and your all set to go .. pretty easy eh

Adjust values as you require them.


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites
# phpMyAdmin MySQL-Dump

# version 2.3.1

# http://www.phpmyadmin.net/ (download page)

#

# Host: localhost

# Generation Time: May 02, 2003 at 03:49 AM

# Server version: 3.23.52

# PHP Version: 4.2.3

# Database : `new_cc_gv`

# --------------------------------------------------------

 

#

# Table structure for table `coupon_email_track`

#

 

CREATE TABLE coupon_email_track (

 unique_id int(11) NOT NULL auto_increment,

 coupon_id int(11) NOT NULL default '0',

 customer_id_sent int(11) NOT NULL default '0',

 sent_firstname varchar(32) default NULL,

 sent_lastname varchar(32) default NULL,

 emailed_to varchar(32) default NULL,

 date_sent datetime NOT NULL default '0000-00-00 00:00:00',

 PRIMARY KEY  (unique_id)

) TYPE=MyISAM;

# --------------------------------------------------------

 

#

# Table structure for table `coupon_gv_customer`

#

 

CREATE TABLE coupon_gv_customer (

 customer_id int(5) NOT NULL default '0',

 amount decimal(8,4) NOT NULL default '0.0000',

 PRIMARY KEY  (customer_id),

 KEY customer_id (customer_id)

) TYPE=MyISAM;

# --------------------------------------------------------

 

#

# Table structure for table `coupon_gv_queue`

#

 

CREATE TABLE coupon_gv_queue (

 unique_id int(5) NOT NULL auto_increment,

 customer_id int(5) NOT NULL default '0',

 order_id int(5) NOT NULL default '0',

 amount decimal(8,4) NOT NULL default '0.0000',

 date_created datetime NOT NULL default '0000-00-00 00:00:00',

 ipaddr varchar(32) NOT NULL default '',

 release_flag char(1) NOT NULL default 'N',

 PRIMARY KEY  (unique_id),

 KEY uid (unique_id,customer_id,order_id)

) TYPE=MyISAM;

# --------------------------------------------------------

 

#

# Table structure for table `coupon_redeem_track`

#

 

CREATE TABLE coupon_redeem_track (

 unique_id int(11) NOT NULL auto_increment,

 coupon_id int(11) NOT NULL default '0',

 customer_id int(11) NOT NULL default '0',

 redeem_date datetime NOT NULL default '0000-00-00 00:00:00',

 redeem_ip varchar(32) NOT NULL default '',

 order_id int(11) NOT NULL default '0',

 PRIMARY KEY  (unique_id)

) TYPE=MyISAM;

# --------------------------------------------------------

 

#

# Table structure for table `coupons`

#

 

CREATE TABLE coupons (

 coupon_id int(11) NOT NULL auto_increment,

 coupon_type char(1) NOT NULL default 'F',

 coupon_code varchar(32) NOT NULL default '',

 coupon_amount decimal(8,4) NOT NULL default '0.0000',

 coupon_minimum_order decimal(8,4) NOT NULL default '0.0000',

 coupon_start_date datetime NOT NULL default '0000-00-00 00:00:00',

 coupon_expire_date datetime NOT NULL default '0000-00-00 00:00:00',

 uses_per_coupon int(5) NOT NULL default '1',

 uses_per_user int(5) NOT NULL default '0',

 restrict_to_products varchar(255) default NULL,

 restrict_to_categories varchar(255) default NULL,

 restrict_to_customers text,

 coupon_active char(1) NOT NULL default 'Y',

 date_created datetime NOT NULL default '0000-00-00 00:00:00',

 date_modified datetime NOT NULL default '0000-00-00 00:00:00',

 PRIMARY KEY  (coupon_id)

) TYPE=MyISAM;

# --------------------------------------------------------

 

#

# Table structure for table `coupons_description`

#

 

CREATE TABLE coupons_description (

 coupon_id int(11) NOT NULL default '0',

 language_id int(11) NOT NULL default '0',

 coupon_name varchar(32) NOT NULL default '',

 coupon_description text,

 KEY coupon_id (coupon_id)

) TYPE=MyISAM;

 

This is the structure that I uploaded into my phpmyadmin,, and it installed.. But you can tell me if something is missing.. As opposed to the Discount Coupon that's supposed to be in my order totals mod via the shopping carts admin.. I figure we can start here since this may be source of the problem.. I'm not sure.. Thank you again Strider.. :)

 

Christine


If it ain't broke, don't fix it! :)

Share this post


Link to post
Share on other sites

no no no no no

not structures .. values .. in your configuration table for module order totals

 

there is an html file called install in the contrib. If you read that and follow the instructions .. I don't think you will have any problems. I think it is written fairly well and seems to be self explanatory


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

You know what? I'm still not getting it! I read the instructions vividly! And for some reason.. It's still difficult! Why is that? And should not be! A simple instruction as to what is wrong right now instead of guessing games would be great right about now.. And now I'm getting frustrated because I'm not getting straight answers. First you say phpmyadmin and etc.. in your previous posts.. And when I go in there and respond to even trying to understand what you mean. You get all huffy with me.. So no.. For some reason.. Either my contribution is corrupt and something is dammm missing.. Or something is wrong with my database.. And no.. I don't have any more spare space to install another cart.. My webhosting won't go for that I don't think.. They're already given me this space to use to upgrade my store as of now.. And I've got about 6 other contributions running.. And guess what? I had no problems with them.. Just this one! And I shouldn't be!

 

So , if you would please tell me what needs to be put where.. IN PLAIN ENGLISH! I can be on my way and stop humilating myself here on this forum.. Thanks!

 

Christine


If it ain't broke, don't fix it! :)

Share this post


Link to post
Share on other sites

Oh, and further more! I did step by step what that HTML Install file said.. And still no dammm Discount Coupon showing up in my order totals.. Just Gift Voucher.. And I will say it again! I followed those instructions to the T.. And it all should be working like a charm.. And instead.. I'm not seeing any Discount Coupon option in my Order Totals.. In Modules via the ADMIN OF THE CART! DO YOU UNDERSTAND THAT? I THINK THIS IS WRITTEN FAIRLY WELL AND SEEMS TO BE SELF EXPLANATORY.. WOuldn't you say?

 

Geez.. some nice people we have here in this community.. Just know how to make others feel so welcome.. Weeeeeeeeeee


If it ain't broke, don't fix it! :)

Share this post


Link to post
Share on other sites

*smiles* .. aren't there


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

You know.. I'm beginning to think that some people in here do not take this too very serious.. Some of us have business's to run and places to be and things to do.. Other than get told we're idiots in so many words.. :(

 

Well anyway, I went over the entire HTML install file yet again, and then re-uploaded every single file in the contribution again! And still no Discount Coupon showing up in my Order Totals in Modules via the cart.. So Im thinking something is missing.. Maybe because I did a fresh install of this contribution and not an upgrade.. I don't know.. But something is not right.. I really don't know what's wrong.. I didn't leave anything out.. Nothing.. :cry:

 

Oh well.. Just probably gonna have to uninstall the whole thing and do with out.. What a waste of time.. Geez.. I wish Ian was around to help out.. At least he wouldn't insult anyone or mock them.. But would help out till it worked..

 

Extremely sad now

 

Christine


If it ain't broke, don't fix it! :)

Share this post


Link to post
Share on other sites

Christine,

 

It sounds like you are at your wits end :evil:

 

First, I would check to see that you actually uploaded the file ot_coupon.php to the catalog/includes/modules/order_total directory.

 

If it is there and you cant see it from the admin>>Modules>>order total section, chances are you made a mistake somewhere in the installation process.

 

This mod is complicated, so there are many chances to make mistakes.

 

As an aside, I think you misread the reply by strider. I didnt catch anything other than emphasis off the post that sent you spinning :) I dont think anyone thinks you are an idiot, heck we hardly know you :wink:

Share this post


Link to post
Share on other sites

Msasek,

 

Thank you so very much.. the strangest thing is happening with my WS_FTP Pro.. It says that I uploaded files.. But the fact of the matter is.. It didn't upload.. And get this.. It's the only file that wasn't uploaded.. All the rest seem to be there. Including the other file that was in that directory.. And that's the ot_gv.php file.. It was there too uploaded.. Just not the ot_coupon.php.. And now I personally uploaded it all by it's self.. And WellA! It's working.. I knew it had to be something simple.. But couldn't figure out what.. lol

 

As far as my outburst earlier.. I'm very sorry.. It's just gets frustrating when you're just not on the same page as the person you're asking help from.. It gets upsetting.. And makes you feel helpless.. Hard to explain.. But I'm sure you can understand my deliemma here.. lol :)

 

Anyways,, thank you very much again.. Now I can go ahead and create these gift vouchers in my catalog and begin some testing etc.. weeeeeee thank you , thank you again! :D

 

Christine


If it ain't broke, don't fix it! :)

Share this post


Link to post
Share on other sites

ws_ftp pro is a little buggy.

 

when you are uploading files, watch the log box for RED text. if you see red text scroll by, it means it did not upload. For me, the first file i try to upload does this. after the first time, it doesn't do this again (per each connection).

Share this post


Link to post
Share on other sites

I've read this thread thorughly and still can't get the gift voucher to deduct from the order total. I am using V5.03 (i don't have MS2).

 

Order Total Modeules is set to (all defaults):

Discount 9

Gift Vouchers 740

Shipping 799

Sub-Total 299

Tax 499

Total 9999

Members Dsicount 720

 

I send myself a voucher.

I click on the redeem link (which by the way, the page comes up blank and then if you refresh it says the GV has been redeemed (which it has) - but still need to figure out why the page is coming up blank)

The GV shows up in the shopping cart as being redeemed

But as you go thru checkout and get to the confirmation page, it does not get deducted from the total.

 

I've changed the $session in ot_gv to $_Session and no help.

 

Please help - this is driving me nuts.

Share this post


Link to post
Share on other sites

Hi all,

 

I have installed this contribution into MS2 and I get this error on the bottom of all my pages now. How do I go about fixing it???

 

Warning: (null)() [ref.outcontrol]: output handler 'ob_gzhandler' cannot be used twice in Unknown on line 0

 

Also, where do I find the voucher code to send to the customer once they have paid?

 

Thanks

Kevin


Kevin Rosenthal

Share this post


Link to post
Share on other sites

k guya,, need some help

i went through the install,, but trashed it all,,

can someone explain what i am to do where the files were folded into one?

i altered the one that was the same,, and added the one that was folded in,,,

it gave me error in the checkout confirm... so i trashed it and waiting to start over if someone can guide me through that,,

thanks in advance,,

Tom


no bugs in my stuff,,, just random features ;)

Share this post


Link to post
Share on other sites

well lets see where do we begin....

mystic 'ob_gzhandler' has to do with the gzip compressions in admin->configuration->gzip compression you might want to put this false.

 

jeana why do you have your sort values so high? I am just curious. Have you tried setting your sort orders to what came out of the box? There was another bug between the 5.03 and 5.04 release dealing with the 5.03 code. The voucher stuff to send the voucher is in the admin panels

 

 

you can just copy the create_account.php straight into itself I think unless you have other mods installed into it. I think if I remember correctly, that if you startoff with a fresh ms2.2.2 release you can copy gv_dc over it and then modify the application_top files. Don't hold me to this the aluminum in my brain sometimes causes me to forget things. and then change the session thingie majiggy


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites
well lets see where do we begin....

mystic 'ob_gzhandler' has to do with the gzip compressions in admin->configuration->gzip compression you might want to put this false.

 

Thanks! That fixed the problem. Now if you can tell me where I find the section to send the gift voucher code to the customer I will be all set.

 

Thanks,

Mystic


Kevin Rosenthal

Share this post


Link to post
Share on other sites

the voucher stuff to send the voucher is in

admin->vouchers/coupons->vouchers->mail gift voucher ..

you also need to deal with the q

and you know how those pesky q's are you always have to place a u behind them


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites
the voucher stuff to send the voucher is in

admin->vouchers/coupons->vouchers->mail gift voucher ..

you also need to deal with the q

and you know how those pesky q's are you always have to place a u behind them

 

This is not in my admin. Did I miss updating a file and if so, which one??

 

Thanks again! :D :lol:

 

Mystic


Kevin Rosenthal

Share this post


Link to post
Share on other sites

You should have added some stuff to the admin side also in application_top and also in left_column.php


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

You should have added some stuff to the admin side also in application_top and also in left_column.php

the instructions are pretty well laid out in the install.html file.


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

strider

the install html is not real clear for me anyway,, on what to do in the files that were ,,, as it says,, deprecated, and folded,,

not really sure how to treat those two files,, i tried my changing the ones that matched in name,, and i got an error in checkout confirm ..

so i trashed it and waiting to see if anyone can explain how that is meant to be handled there..

thanks

Tom


no bugs in my stuff,,, just random features ;)

Share this post


Link to post
Share on other sites

create account process has been deprecated and was folded into create account.

if you look at the example of create_account.php it shows you where the code was changed and taken from create_account_process.

in create account it is somewhere around line 248

in create account process it is taken from about line 321

it has to do with sending a gv or dc to a new customer signup

if your running a stock 2.2 ms2 you don't have the create account process anymore. that is why it was folded into create account


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×