Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

I have a question about the way the order_totals table is filled it.

 

Why are the values positive?

 

Shouldn't they be negative?

 

I found this when working with the order_edit contribution.

 

Tom


Thomas A. Moulton, W2VY

osCommerce core developer

Support the developers!

http://www.oscommerce.com/about/team

Share this post


Link to post
Share on other sites

mjm: in short no

 

Zdub: I don't think that is the way it is shown in the install doc of 5.10b

 

BoulderDash: hmmm... the bug report basically rectifies the order in which you do things. as such you don't call the gateway til you did the process to get the correct values....

 

aceclimber: hmmm... I suppose you could do a javascript to run a function on the server to update the databases then sql the correct tables to process the order totals so you could show the subtotals that you put in .. or you could put a link to the gv_redeem and let them redeem the coupon before they get to the checkout_payment page but then they still haven't ticked the box yet so we don't know if they are going to use the gv amount or not .. hmmm... besides all that it is pretty simple don't you think?

 

darfsnuzal: do you have authorize_direct in your checkout_process file?

 

sexyshopping: 1) the . isn't suppose to be there. 2) your sort order isn't correct please read the install doc

 

marymoran: no it isn't possible in this release but I am thinking about putting it in the next release but that probably won't be til 2.2.3 comes out whenever that is...

 

w2vy: nope the values are suppose to be what they are. I did find a lot of wierd things going on in the order edit mod though ... like massive rewrite


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Hi,

 

I installed this contribution on a clean install.

 

I'm testing it now but I dont know whats supposed to happend next?

 

After I purchase a gift voucher and it get released from "Gift Voucher Queue"

 

I see this email:

 

You recently purchased a Gift Voucher from our online store.

For security reasons this was not made immediately available to you.

However this amount has now been released. You can now visit our store

and send the value via email to someone else

 

but now I log in and dont know what else I'm supposed to do?

 

thanks,

jr

Share this post


Link to post
Share on other sites

Does anybody know a way to make the voucher balance or any of the other related information for an individual appear in the header? My cart is in the header but I can't seem to make the code work to show my balance below it. Any help or ideas would be appreaceated.

Share this post


Link to post
Share on other sites
darfsnuzal: do you have authorize_direct in your checkout_process file?

Thanks for the response Strider! No, there is no authorize_direct in my checkout_process file.

 

Thanks for your help!

Share this post


Link to post
Share on other sites

Hi,

 

I'm using (what I think) are the latest versions of OSC and the CCGV. But I seem to have a problem I can't find a solution for. When I create a voucher to give free shipping, the calculation that get's passed to Paypal is the total subtract the shipping, which wouldn't be such a big deal if the cost of the item was higher than the shipping. In this case, a negative dollar amount is being passed to Paypal, which won't work! Is there a way to control how the free shipoing voucher is calculated?

 

Any further clarification, just ask. Thanks for any help.

Share this post


Link to post
Share on other sites

Hi,

I've got some issues :wacko: ... (well not me but me shop rather) :P

 

I have installed everything, and it is in working order...

Problems:

1) In my admin panel, there are two boxes on the left side that say "Vouchers/Coupons" -They both open when i click on one, and act as one...

-The don't cause any problems but it is kinda annoying... How can i fix this?

2) I can't delete inactive coupons... I change the top status to inactive coupons, click on one of the coupons to select it, and then try to delete it, but the screen goes back to active coupons and when i click confirm nothing happens

3) Percentages are messed up... When ever i want to give a percentage off in a coupon, it always displays it as $ off...

- In the "Gift Voucher's Sent" area, it has all the gift vouchers I have sent, then it has the coupons that have been used... One of them is for 10% off, but it shows $10.00

 

Thanks so much for any help!

 

O ya, and do you know how to take off the model number below the name of the product?

"$10 Gift Certificate

[GIFT10]"

how do i get rid of gift 10 w/o taking it out of the model number?

Edited by mijman2

Share this post


Link to post
Share on other sites

I have the credit calss & gift voucher module and it's working great to the best of my knowledge! I have encountered one small problem. If someone purchases a gift voucher from my store and that's the only thing that they purchase, they are still billed shipping charges when they check out. They shouldn't be billed shipping charges at all because it's getting emailed to them. How do I fix it so there is no shipping charges added for gv orders?

Share this post


Link to post
Share on other sites

Hi,

I was wondering if someone has seen this problem before...

 

I have a problem after a gift voucher is created... the checkout_payment page now shows 2 input boxes in the "Credits Available" section, 1 for gift voucher, the other for coupon. but the 1st input box (for gift voucher) does not work.... in addition, if i input the gift voucher code in the coupon box... it works...

 

I checked the html... both input boxes for gift and coupon are named the same thing... so why is the first box not working??

 

does anyone else have this problem?

 

thanks in advance

Share this post


Link to post
Share on other sites

I have one more problem. The emails that are sent out when a gift voucher is purchased or emailed to another person are supposed to contain a link back to the site. The link is there, but it's not linked as in you can't click on it and get to the site. How do I fix this and where?

Share this post


Link to post
Share on other sites

Clarification for my original problem:

I have the credit calss & gift voucher module and it's working great to the best of my knowledge! I have encountered one small problem. If someone purchases a gift voucher from my store and that's the only thing that they purchase, they are still billed shipping charges when they check out. They shouldn't be billed shipping charges at all because it's getting emailed to them. How do I fix it so there is no shipping charges added for gv orders?

 

I am using table shipping based on price and NOT weight. I don't know the weight of my 1000+ products, so weight is not really an option for me to use. I have set the weight on the gv to 0 and a couple of products to 1 just to see what would happen based on other posts here. I turned downloads to true. What happens is that when I purchase only a gv, no shipping shows up (perfect!). But if I purchase a regular item with a gv, shipping is charged based on the total value of both items (not so perfect!).

 

Strider had made a post somewhere around pg 83 about adding a line of code to the table.php file in includes/modules/shipping but this didn't work either, in fact it didn't do anything that I can tell. After reading all of the pages of this forum line I havn't seen any answers. What can I do to make it so shipping is not calculated on gvs and still use my price based table shipping?

Share this post


Link to post
Share on other sites
Hi,

I was wondering if someone has seen this problem before...

 

I have a problem after a gift voucher is created... the checkout_payment page now shows 2 input boxes in the "Credits Available" section, 1 for gift voucher, the other for coupon. but the 1st input box (for gift voucher) does not work.... in addition, if i input the gift voucher code in the coupon box... it works...

 

I checked the html... both input boxes for gift and coupon are named the same thing... so why is the first box not working??

 

does anyone else have this problem?

 

thanks in advance

never mind... it looks like the coupon module i have in my creloaded 6 version, has some updates which look even newer than version 5.10b but the ot_gv.php is really old at version 1.2... :o

 

it looks like the code is really different... i will look through all 96 files of 5.10b now... :blink: to update differences....

Share this post


Link to post
Share on other sites

ok. that's not it... creloaded has some what up to date files...

 

Help! somebody! this gift voucher is driving me nuts...

my guess is that 2 input/value pairs of the same name, but different values are passed to checkout_confirmation.php page

but the code can only read from the second pair...

i changed the "post" to "get" and confirmed that the code is, indeed, passing 2 pairs of the same name.

 

No one else has this problem??

Share this post


Link to post
Share on other sites

I've been looking through the forum on this and can't find any help...

 

I have osCommerce 2.2 up and running and the latest version of the CCGV contribution. I've also made the necessary fix to checkout_process.php as noted many times in this post.

 

However, when a free shipping coupon is used and passed to PayPal I get an odd result - the grand total is right (well it was out by $0.01, actually) but the total and amount for shipping is wrong. PayPal quoted a figure for shipping although it should have balanced to $0.00, and the grand total had a figure that made up the difference.

 

Is there any solution to fixing this? I'd appreciate any help - appart from this one problem the mod works just great!

Share this post


Link to post
Share on other sites
I have one more problem. The emails that are sent out when a gift voucher is purchased or emailed to another person are supposed to contain a link back to the site. The link is there, but it's not linked as in you can't click on it and get to the site. How do I fix this and where?

Someone else mentioned this problem along page 78, haven't come across the solution yet ... getting a little sick of reading this thread actually. hehe Might want to check back from there on though to see if anyone replied.

Share this post


Link to post
Share on other sites
Hi,

I was wondering if someone has seen this problem before...

 

I have a problem after a gift voucher is created... the checkout_payment page now shows 2 input boxes in the "Credits Available" section, 1 for gift voucher, the other for coupon. but the 1st input box (for gift voucher) does not work.... in addition, if i input the gift voucher code in the coupon box... it works...

 

I checked the html... both input boxes for gift and coupon are named the same thing... so why is the first box not working??

 

does anyone else have this problem?

 

thanks in advance

2 boxes named the same thing? heh I wouldn't recommend that. If they are compatible, would simply use 1 box for both. if they are not, would rename one. What kind of error do you get btw? Nothing happen, page crash, runs with error?

Share this post


Link to post
Share on other sites

I just installed this contribution - excellent job to those of you who worked so hard on it.

 

The problem I'm having is that the coupon doesn't actually subtract from the total amount. It shows:

----------------------------

Sub-Total: $11.50

Shipping Total (Shipping Rate): $4.50

Total: $16.00

Discount Coupons:GR5: -$5.50

----------------------------

 

So as you can see the discount amount isn't coming off the total.

 

Am I missing a file or some code, or is this the way that it's designed? Shouldn't the coupon be subtracted from the total?

 

Thanks - Paul

Share this post


Link to post
Share on other sites

Thats what happens to me... It show for a total order of 30 dollars, then below it, there is however much the coupon was off... in this case 3 dollars...

 

it bugs me!

Share this post


Link to post
Share on other sites

I finally figured this out - it was just a matter of setting the sort order of the various values in admin --> modules --> order total. This sets the order in which the calculation is executed (the contribution documentation actually says this). I set mine to

 

subtotal - 1

shipping - 2

tax - 3

gift vouchers - 9

discount coupons - 740

total - 900

 

HTH!

Paul

Share this post


Link to post
Share on other sites
Hi,

I was wondering if someone has seen this problem before...

 

I have a problem after a gift voucher is created... the checkout_payment page now shows 2 input boxes in the "Credits Available" section, 1 for gift voucher, the other for coupon. but the 1st input box (for gift voucher) does not work.... in addition, if i input the gift voucher code in the coupon box... it works... 

 

I checked the html... both input boxes for gift and coupon are named the same thing... so why is the first box not working??

 

does anyone else have this problem?

 

thanks in advance

2 boxes named the same thing? heh I wouldn't recommend that. If they are compatible, would simply use 1 box for both. if they are not, would rename one. What kind of error do you get btw? Nothing happen, page crash, runs with error?

i thought 2 boxes WAS the default behavior... how else can a customer enter both a gift code and a coupon?

or did you mean that there should be 2 boxes with different names?

do you have a working site i can check?

 

thanks,

Share this post


Link to post
Share on other sites

hi steve,

thanks for letting me hit your site. yes, i see that... there's must be something wrong with the contribution code i have... i will have to look at it...

 

so how does a customer use both a gift certificate and a coupon? hit back button after redeeming gift voucher?? kinda weird...

Share this post


Link to post
Share on other sites

I am figuring out how to add text to say this... If you have both, then enter the GV first, because it only adds the GV and does not progress you through the checkout proccess like a coupon does...

Share this post


Link to post
Share on other sites

Hello,

 

I read this entire thread in order to solve my problem but I was not able to fix it.

 

Ok here it is:

 

I have also (like many other people) problems with the calculation in the order-total area.

 

In the checkout-confirmation it shows:

 

Result:

 

sub-total: 10,00 (CORRECT)

discount: -5,00EUR (CORRECT)

Tax: 0,33EUR (CORRECT)

total: 4,67EUR (WRONG! Must be: 5,00 )

 

The sub-total consists out of taxable good (7%) and it is showing the amonut including the 7% (set in the main configuration of osCommerce)

 

I use the discount coupon with the setting: Recalculate Tax as a credit note with the tax class of 7%.

 

My sort order of the order-total-modules is set to (as said in the ccgv manual):

 

sub-total --> 1

shipping --> 2

gift voucher --> 9

discount coupon --> 740

tax --> 800

total --> 900

 

The total shows actually the net-amount. Which is wrong.

 

Has anyone an idea how I can get it work the way I need it?

 

Thanks a lot !!

 

Ron

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×