Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

If your running MS2 i would asume theres a error in you contribution installation somewhere.

 

Order Total Modules in mine shows:

Include Shipping

true

 

Include Tax

true

 

I have GV showing up fine in my cart.

 

I would recheck the installation or back up all my files and replace the ones on the server with the contribution ones to see where my problem is.

Share this post


Link to post
Share on other sites

in previous posts there was brought to light an error about having to choose a payment method even if you had enough in the gift voucher. there have been a couple of us working on this fix and I think this is it.. you might want to play with it please because there is no way I could test something as good as you guys test things ..

 

The problem is in catalog/includes/modules/order_total/ot_gv.php

the code that is there is

 

function pre_confirmation_check($order_total) {

if ($SESSION['cot_gv']) {

$gv_payment_amount = $this->calculate_credit($order_total);

}

return $gv_payment_amount;

}

 

and the code that should be there is

 

function pre_confirmation_check($order_total) {

if ($_SESSION['cot_gv']) {

$gv_payment_amount = $this->calculate_credit($order_total);

}

return $gv_payment_amount;

}

 

let's try that and see if it works... oh I almost forgot .. lol .. one sec ...

we also need to change

 

if ($order->info['total'] - $total_deductions <= 0 ) {

$credit_covers = true;

}

 

to

 

if (($order_total - $total_deductions) <= 0 ) {

$credit_covers = true;

}

 

on line 207 in the function pre_confirmation_check within

catalog/includes/classes/order_total.php

and that should do it.... I think .. please play and tell me what you come up with


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Have this new issue where if you purchase just one GV on checkout you have to select shipping charges.

 

The GV product's weight is set to 0.

Maybe if i make one base voucher with some attributes it just might work.

Share this post


Link to post
Share on other sites

yes I noticed that also Illicious ... but even more so I noticed that the other fix I thought worked doesn't quite do it yet.. in fact if you buy an item more expensive than the amount of your gv it let's it through with the second part to that fix am working on it now .. should have something soon I should think ..


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Ok whats wrong with me. In Order Total Modules/Shipping:

 

Allow Free Shipping

false

 

Then set to true.

 

Now it works.

 

As for that that other price GV thing.

 

If you purchase say a item of $25 and GV is $20 then it lets you use the GV?

 

I thought it was ok like that. If you wish to choose a product over the GV amount then you should be able to and be able to cover the difference.

Share this post


Link to post
Share on other sites

ok

if your download enabled which is in

admin->configuration->download

is not set to true then it doesn't recognize virtual ie gift vouchers as being no shipping. if this is set to true it does work.

the fix for the other is just the first fix ie add a _ to the $SESSION variable or $_SESSION in the ot_gv.php in the pre_confirmation_check function. ot_gv is in includes/modules/order_total.

 

so it looks like this

 

function pre_confirmation_check($order_total) {

if ($_SESSION['cot_gv']) {

$gv_payment_amount = $this->calculate_credit($order_total);

}

return $gv_payment_amount;

}

 

 

sorry about the earlier wrong post .. posted before I had any sleep

I think that has it guys any problems please tell me .. I would love to put this puppy to bed for a few days


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

This is the issue I was having regarding downloads must be activated in order for GV to skip the shipping page.

 

Illicious: I am probably not being clear on my second issue. The gift vouchers balance do not show up in my shopping cart side box (if I have a gift voucher balance in my account, not a new gift voucher for purchase) , UNLESS I have another product in the shopping cart.

 

If I log into my account, and I know I have a balance of $20.00 (from gift vouchers previouslt purchased), it will not show up as a GV balance, nor will the links to send to a friend show up, unless I have some other item in my shopping cart.

 

I would like the balance to always show in the shopping cart side box if I am logged in, regardless of whether or not I have anything else in my cart.

 

I hope that makes more sense.

Share this post


Link to post
Share on other sites

I managed to figure it out. I just moved the ICW code out of the 'if' statement, immediately after the closing } and it now displays the GV link and balance all the time when you are logged in, regardless of the items in the cart.

 

Most likely I just added this in the wrong place?

 

Thanks! Just typing out the explanation gave me the idea on what to change. This is really a nice mod, thanks for the work!

Share this post


Link to post
Share on other sites

Ok, implemented your fix. Workes about %90. Here's what I'm facing now:

 

BEFORE:

When a customer attempted to use the checkbox for applying their GC to their oder, they were required to enter a CC number (if they skipped over that area, then the resulting page would show an error w/ CC# in red).

 

AFTER

When a customer checks the checkbox for applying the GC to their order total AND skips the CC form fields, their credit is applied and no error appears... UNTIL they reach the confirmation page. The following error appears:

 

There has been an error processing your credit card. Please try again.

 

This error appears after checkout_confirmation.php

 

So... we're almost there! Just a different place for the error.

Share this post


Link to post
Share on other sites

Ok, I think I understand why the error is appearing: it might be because of the authorize.net problem:

 

If you pass $0 to authorize.net then authorize.net will freak out on you and kill your first-born (in this case, killing of a first-born is equivalent to not processing an order: they both carry the same crushing feeling on my end).

 

So.... in order for the fix to work for me (crap! I've just made this so customized that no-one else will probably need the fix), I need to disable the passthru to authorize.net should the order total <= 0.

 

Any idea where I can find that?

Share this post


Link to post
Share on other sites

good I take it then that everything is working ok. hope every one enjoys it and if anyone sees ian they should thank him ....

 

thanks ian


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Hey,

 

I got a few errors after having installed this wonderfull contribution. It seems like a few functions should be added somewhere. Can anyone help med with this??

 

Fatal error: Call to undefined function: tep_draw_date_selector() in /home/horzeno/public_html/admin/coupon_admin.php on line 709

 

 

Fatal error: Call to undefined function: create_coupon_code() in /home/horzeno/public_html/admin/gv_mail.php on line 42

 

 

Thanx in advance!!

Arne

Share this post


Link to post
Share on other sites

read the instructions and add the lines in the appropriate files ie the

add_ccgvdc_application_top.php require in application_top


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Great contribution, it works on one of the stores I manage.

 

I have just tryied installing this contrib on a recent snapshot from 7/10 (almost ms2) and it does not work.

 

Here is what is going on: I have followed every step in the instructions and uploaded ALL the new and modified files.

I have created a new coupon of 10% no free shipping for the month of august. with the code test1. When I go through the checkout process I type the coupon code but I cannot see it deducting or atking any effect on the total amounts at the checkout_confirmation page.

 

I have tried the 740 thing and nothing. What to do? by the way, I need only the coupon part to work for now.

 

thanks.

Share this post


Link to post
Share on other sites

Still having that authorize.net issue.

 

Any idea where I can find the code to keep from passing $0 to authorize.net?

 

It seems that it's OK to not enter a CC if the checkbox is selected for using a GC. However, authorize.net still receives information when the order is processed (sending the user back to the cc insert form).

 

Any ideas?

 

PS: Here's a little bonus:

Any idea on how to add my own select list (dropdown) of shipping options? I'd like to customize my own options and rates, using my own text.

 

The closest thing I could find was the "Zones," unfortunatly I can only see how to add one zone.

Share this post


Link to post
Share on other sites

ronpeled....

I can't tell you where to go .. I just blew up my box.. lol .. but under modules order_totals there is a discount coupon and gift voucher entry ...

install them

if they are installed uninstall and install them again

the 740 'thing' is for the gift voucher should not have anything to do with your discount coupon

also test1 isn't the name of the coupon except to the admin .. in the gift voucher modules down at the lower left of the left column in admin there is a thing for discount coupons it gives you a number .. that is the number you use on the discount coupon

 

chadedge .. I am not for sure off the top of my head .. is it processing the order if you do not select the type of payment if you have enough in the voucher? .. it shouldn't even go to the payment module if you don't choose one.... for a test try installing the check moneyorder payment module and see if it still goes to verisign.


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Strider,

I cannot get it to work. reinstalled everything and tryied a bunch of stuff. Simply it does not want to work.

 

let me give you some more details:

I am using authorizenet.com payment module. and the flat rate shipping with free shipping over 50$.

 

where should I start looking?

Share this post


Link to post
Share on other sites

what version did you download to play with


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

I downloaded the latest one. 5.05 although the documentation says: 5.04

 

and I also downloaded the language fix.

Share this post


Link to post
Share on other sites

I don't know how 5.05 works .. just out of curiosity try the 5.04 and see if that plays

make the change in ot_gv with the $Session to $_Session

I think that is really the only fix needed ..

and ojulah it's fixed


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

I have done it and it still does not work.

yes the $_session is there.

 

what to do?

where is the input field for the coupon code entry is displayed? under which function or file?

Share this post


Link to post
Share on other sites

Strider,

here is the status: od_amount is always zero!

 

I have the coupon order total module installed.

the order is:

 

Discount Coupons 2

Gift Vouchers

Low Order Fee

Shipping 3

Sub-Total 1

Tax 4

Total 5

 

let me know,[/img]

Share this post


Link to post
Share on other sites

Rronpeled,

Are these the two lines you are talking about?

 

if ($HTTP_POST_VARS[$post_var]) $_SESSION[$post_var] = $HTTP_POST_VARS[$post_var];

 

// if (!tep_session_is_registered($post_var)) tep_session_register($post_var);


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×