Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

The TickBox to use the Gift Vaucher Balances should appear just at the same page you would submit the payment information.

 

its simply mean you miss something at installation. and i fyou go through the install file again you will eventually get it but I am sorry I cant help further but you will get tips if you read through this forum from page 17 to this page :rolleyes:

Share this post


Link to post
Share on other sites

admin31: it appears you have a version of osc and the version of the gvcc that you installed is not compatible. If you had to pay them I would ask for my money back because they should never have left you in such a bad state.

 

Jack_mcs: You might want to do a diff of your checkout_payment.php as compared to what you are running. Or you might look at your sort order. Gv needs to be 760 and dc needs to be 740


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Strider, it's very possible that my current version of OSC is older than that requred by GVCC. My hosting company (who are doing this at no charge, so I am certainly in no position to get upset :-) will probably be willing to upgrade me to OSC 2.2ms2. Are there any gotchas...will upgrading blow away all the products in the catalog?

Share this post


Link to post
Share on other sites

admin31 .. depends on the version they are running. If it is a stock release then no probably not. You might want to make sure they are running a php > 4.2


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites
Jack_mcs: You might want to do a diff of your checkout_payment.php as compared to what you are running. Or you might look at your sort order. Gv needs to be 760 and dc needs to be 740

Great, that was it and seemed to clear up a lot of my problems. I've ran many tests and everything seems to be working fine now. There are a few questions I still have about the checkout procedure though.

 

Let's say I have a GV balance, order an item and procede to checkout. If I click on Redeem without choosing check/money order or credit card as payment, I get an email with something like:

Sub-Total: $6.29

Per Item (Best Way): $7.08

Total: $13.37

Gift Vouchers: $13.37

 

It's a minor question but I'm wondering if there is a way to show balance due = 0? This would make it clear to the customer that they don't owe anything.

 

Now, given the same scenario as above except this time I also check a payment method (check/money order or credit card). In the case of check, I receive an email saying my order won't be shipped until payment is made even though there is nothing owing. The amount due is shown as above.

 

If I try checking payment by credit card and redeem a GV, it won't let me process the order. After pressing confirm order, I get a message highlighted in red stating "There has been an error processing your credit card. Please try again."

 

Is there a way around this last one? Or is it not a problem to be concerned with. I understand this isn't checking either of these boxes is causing the problem but customers being what they are...

Share this post


Link to post
Share on other sites

put your total sort order=900 or as your highest sort order


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites
put your total sort order=900 or as your highest sort order

I changed the total sort order and it took care of the check/money order problem. But the problem with ordering by credit card and using a GV is still there. Any ideas on how to fix (change) that?

 

Jack

Share this post


Link to post
Share on other sites

I am curious about the email link that is generated from the "mail GV" function. When I use the pulldown for a customer, the link is incorrect

 

 

 

If I input the customer's email directly, the link is correct

 

 

Note the = sign and the ? which are both wrong in the first option.

 

I am curious as to why the link is generated differently depending on how the voucher is sent, and I just need to know the correct coding and for exactly what file. I am a php newbie, but after my second install have managed to get the GV up and running properly (except this minor error). Thanks in advance for taking the time to answer.

 

Great mod!

Share this post


Link to post
Share on other sites

smoovvox: part of the reason is that you have search engine safe url's set to true


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

I'm having the same problem as Jack.

 

let's say the customer has 88.00 in his GV account. and his total order is 46.98.

osc has the autoselect feature it will autoselect the cc or whatever is in the first postion. and will not let you deselect the payment method.

so, if you click on the redeem buttom allworks fine until you click on the confirm buttom. it will hit the payment gatway and kickback an error. due to no cc info was entererd and because it's passing a value of 0.

how do you skip the payment gateway if the customer has more funds in his GV then what the total order value is?.

now if the auto select feature was off then the customer would not have to select any payment method except the redeem button...

any ideas?...

 

TIA


<span style='font-family:Courier'>If you can't fix it Perl it!!!...</span>

******************************

Share this post


Link to post
Share on other sites

Hi,

ok, iv installed the latest version 5.06 and, now im not quite sure what im doing wrong, because, all the code is correct but when i go through checkout and the redemtion code is entered, and i hit redeem nothing happens. why is it like this, is it a must that i have the shopping cart infobox, because i dont use that box on my store, is there some other way of doing it. Also when someone gets sent a voucher or coupon and it says to click on the link, i go to the link, and it says that it has been redeemed, but i dont get how this would work, cause there is nothing in the shopping cart to say like -$20 or something, and i dont use the shopping cart infobox.

 

What should i do??

 

thanks

 

kristofor


Don't die with the music in you!!!

 

Failure is just another boundary to sucess!!! But that doesn't mean your getting somewhere...

Share this post


Link to post
Share on other sites

Kristofor: Well as far as where it tells you if and how much of the gift voucher you have it is in that box. Not knowing how your sites designed is hard to suggest something on that. On the matter of the error when you click on the link I have just heard about this in the last couple of weeks and am looking into it.

 

 

well to jack and jello... I guess I should tell you my car doesn't work, can you fix it. I know it has gas, it's a porsche


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites
well to jack and jello... I guess I should tell you my car doesn't work, can you fix it. I know it has gas, it's a porsche

 

I don't get your point here. I'm not sure if you are trying to say the problem was not explained enough or that you know there is a problem but don't have a solution. If you mean the former, I've read back through my, and Jellos', posts, and it seems fairly well explained. However, assuming it wasn't, let me try again.

 

Buy a GV for $10 so that your account has a balance. Now buy something in the shop so that the total will come up to less than $10. When you check out, select credit card as the payment type and also check the box to redeem the coupon. The process fails. The site I am working on is HERE if you want to see for yourself. The site is not live so charges won't actually happen. To make it easier, I have set up a test account. Log in as email = test@yahoo.com and password = passme.

 

If you meant the latter, then that's fine. It is an excellent contribution and I wouldn't think that this particular situation, at least in my case, would come up that often. It was just something I noticed, and since I had already made several mistakes, I thought I should ask in case I was doing something else wrong.

 

Oh, and BTW, everyone knows that if a porsche doesn't work and it has gas then you have to reboot the computer to start the game over. ;)

 

Jack

Share this post


Link to post
Share on other sites

what is the admin password Jack. And my point was you can't fix my porsche unless you can tell what the problem is can you. Or should I tell you to reboot *smiles*


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites
what is the admin password Jack. And my point was you can't fix my porsche unless you can tell what the problem is can you. Or should I tell you to reboot *smiles*

Please forgive my ignorance on the subject but I am relatively new to working with OSC so I am not sure what you mean. Are you asking for my password to my host? Is that something I should be making public?

 

And, no, I wouldn't expect you to be able to fix it. But you are the one that knows what he is doing here, not me. I gave you all the information I knew to give and will gladly supply you with any additional information. All that is needed is for you to tell me what you need.

 

Jack

Share this post


Link to post
Share on other sites

OK,

 

I thought I had it all working, but I guess I don't.

 

I have everything in this order:

 

Sub-Total 1

Shipping 2

Discount Coupons 3

Gift Vouchers 4

Tax 5

Total 6

 

I tried all sorts of options in the Discount Coupon options, and I still get the same result:

 

 

Sub-Total: $209.89

Free Shipping : $0.00

Discount Coupons:CC3439: -$49.97

Tax 15%: $31.48

Total: $191.41

 

/\ Tax & Total SHOULD be - $23.99 & $183.91 :unsure:

 

Now WHY is it that my taxes are being calculated on the subtotal, and not the total after the discount coupons?

 

This makes no sence. I've read through this entire topic forum, and changed that tod_amount thing from tax to total, then I changed it back and changed that none to None, and still no go. I know I have the order correct, as you can see from the top, what is the problem then?

 

Please help, thanks!!! :D :D

Share this post


Link to post
Share on other sites

Nitro: how are your order totals configurations setup

 

Jack: I don't care for your host's passwords. But you didn't seem to get my meaning when I told you my porsche would not start and I only gave you one item of information.... I am beginning to think a mind reader would be better at answering you.. because I don't have the information needed to make a suggestion and to tell you the truth I am tired of typing


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Order totals? You mean the sort?

 

Or what?

 

If you're talking about the discount coupon (which applies in this case) this is what I have currently:

 

Include shipping - true

include tax - true

re-calculate tax -standard

tax class - (the same as my products)

 

 

I've tried many multiple types of combinations, even without recalculate tax, I even went exactly to what you have in the "forum_instructions.txt" file, and it still doesn't recalculate properly.

 

I'll tell you what I have in the cart:

 

1 vest

10 calendars

 

The calendar coupons (or whatever) gives the customer 33.3333% off the product. It works perfectly when you order >just< calendars

 

I even tried it with just ONE calendar, it still calculates it wrong:

 

Sub-Total: $14.99

Free Shipping$0.00

Discount Coupons:CC232: -$5.00

Tax (15%): $2.25

Total: $12.24

 

 

Sooooo.... :\ I'm lost.

Share this post


Link to post
Share on other sites

Nitro: So I gather from your last statement you are using multiple coupons with certain types of products for each coupon?


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

I have two coupons, only one of which will be used at any given time.

 

1 coupon is for 20% off everything, for employees only, and the other is just for customers, which is 33.3333% off >just< the calendar.

Share this post


Link to post
Share on other sites
well to jack and jello... I guess I should tell you my car doesn't work, can you fix it. I know it has gas, it's a porsche

Well......

Why do you have to be such a dick about it!!!

I read EVERY post and saw some mention to it and some half ass posted code but it did not fix the problem. I did not post some smart ass remark about you so whay do you have to post a smart ass remark to us?...

not to mention this is NOT the first post that YOU have been so rude about it...

and was my question directed to you?... I think not is was an open question.


<span style='font-family:Courier'>If you can't fix it Perl it!!!...</span>

******************************

Share this post


Link to post
Share on other sites
applelinks it's your sort order .. you can find the answer in previous posts probably

Jason

 

Thanks for all your help. It was the sore order

 

Joe


----------------------------

Long Island, New York

Share this post


Link to post
Share on other sites

Hi

 

Quick question

 

I have added a coupon to only be used once. Once the coupon is redeemed should it then be listed as an inactive coupon?

 

This is the info of the redeemed coupon. Eventhough it has been redeemed it is still shoing up as active?

 

 

 

oupon Name?::? exo3

Coupon Amount?::? $29.85

Start Date?::? 12/04/2003

End Date?::? 01/04/2004

Uses per Coupon?::? 1

Uses per Customer?::? 1

Valid Product List?::? View

Valid Categories List?::? NONE

Date Created?::? 12/04/2003

Date Modified?::? 12/04/2003


----------------------------

Long Island, New York

Share this post


Link to post
Share on other sites
Jack: I don't care for your host's passwords. But you didn't seem to get my meaning when I told you my porsche would not start and I only gave you one item of information.... I am beginning to think a mind reader would be better at answering you.. because I don't have the information needed to make a suggestion and to tell you the truth I am tired of typing

Fair enough. I misunderstood what you said. Perhaps it is a language barrier (I'm assuming you are not from the US) but when someone makes such a statement as you did about the porsche, it is an attempt at sarcasm. It would probably have been better if you would have just come out and said you did not know how to fix it. As I mentioned earlier, I'm just asking the question because I saw what I thought was a problem. I thought that was the purpose of these forums. However, after reading back through my posts it is obvious that something about them have bothered you right from the beginning. No idea why. It certainly wasn't intentional on my part. But it is obvious your stess level has increased because of it. So, I agree, let's let the matter drop.

Share this post


Link to post
Share on other sites

Nitro: put your sort order like this

Sub-Total 1

Shipping 2

Tax 5

Discount Coupons 740

Gift Vouchers 760

Total 900

 

Applelinks: I am not for sure. The way it works is that the coupon should be able to be used only once but it is still considered active until admin deactivates it. I forget but I will look at the code in the next day or so. There is a reason for the madness but I my brain is so small I can't always remember everything. If I remember you were using this for the product a company was giving away and you were trying to generate 500 in bulk or something. How did you solve the coupon generation? BTW you can also make it for that single product if that is your desire, if not it will be for the whole catalog.

 

jello: *chuckles*


(my knowledge is so small you would think that an ant was a genius in comparison)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×