Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

I've just installed CCGV5.18 plus the various fixes since and its all working fine except...

 

if a gift voucher covers the total amount of the purchase, it is going through to paypal IPN with a £0 balance. This gives a paypal error "please enter an amount greater than zero" and the transaction can't be completed.

 

IE.

Product = £15

Voucher = $15

Total amount payable = £0

 

In this scenario, I'd like to skip paypal and just complete the transaction.

 

Don't know if I've missed something but can anyone help? I'm hoping someone has come up against this before and found a fix! Thank you in advance for any help you might be able to give :)

Share this post


Link to post
Share on other sites

install this contribution http://www.oscommerce.com/community/contri...,free+downloads

 

change name of it to say free

 

then in paypal.php or paypal_ipn.php find this

// class methods

function update_status() {

global $order;

 

and add this directly after it

// disable the module if free products

if ($this->enabled == true) {

global $cart;

if ($cart->show_total() == 0.00) {

$this->enabled = false;

}

}

 

what above will do is to disable payment module if its 0.00 and that contribution is only active if amount is 0.00 when they click on continue the order will be updated

Share this post


Link to post
Share on other sites

Howdy,

I'm having some problems with CCGV(5.19). I can get the checkout_payment.php page to process and apply coupons/vouchers and I can get it to process credit cards BUT I can't get it to do both at the same time. Basically if I modify checkout_payment.php and checkout_confirmation.php to process the coupons/vouchers then when you enter a credit card and click continue it just goes back to the checkout_payment.php page and never to checkout_confirmation.php. HOWEVER, and don't ask me how I figured this out, if I ftp an older version of checkout_confirmation.php up after I've redeemed a coupon then click continue I can go to checkout_confirmation.php BUT if I then go to place another order it won't redeem coupons/vouchers. Any idea what I might have messed up? I'm using the Authorize.net AIM module and also have Points and Rewards installed.

 

Thanks for any help.

Share this post


Link to post
Share on other sites

Now i have just try'id to install this modul on another site. and i got the same result. when i try to check out. and it link to the checkout_payment.php page, then i only gonna get a blank white page. Can i really be the only one with this problem.

There have to be something i have done wrong or missed.

Share this post


Link to post
Share on other sites
Now i have just try'id to install this modul on another site. and i got the same result. when i try to check out. and it link to the checkout_payment.php page, then i only gonna get a blank white page. Can i really be the only one with this problem.

There have to be something i have done wrong or missed.

 

note: if you ever get blank pages turn php error reporting all on

 

<?

error_reporting(E_ALL);

?>

 

you will then receive any error message

 

hope that helps

Share this post


Link to post
Share on other sites
note: if you ever get blank pages turn php error reporting all on

 

<?

error_reporting(E_ALL);

?>

 

you will then receive any error message

 

hope that helps

 

Hi

No errors message shows :-(

 

I only think that the problem is on the checkout_payment.php becouse that is the page there is blank.

if i take checkout_payment.php from my Backup files I still get the same blank page. :-(

 

So maybe the error is on another page.

 

but it is wierd that i have the same problem on 2 different websites. so it is me there is missing something.

 

Best Regards

Kent Larsen

Share this post


Link to post
Share on other sites
note: if you ever get blank pages turn php error reporting all on

 

<?

error_reporting(E_ALL);

?>

 

you will then receive any error message

 

hope that helps

 

Hi

No errors message shows :-(

 

I only think that the problem is on the checkout_payment.php becouse that is the page there is blank.

if i take checkout_payment.php from my Backup files I still get the same blank page. :-(

 

So maybe the error is on another page.

 

but it is wierd that i have the same problem on 2 different websites. so it is me there is missing something.

 

Best Regards

Kent Larsen

Share this post


Link to post
Share on other sites
note: if you ever get blank pages turn php error reporting all on

 

<?

error_reporting(E_ALL);

?>

 

you will then receive any error message

 

hope that helps

 

Hi

No errors message shows :-(

 

I only think that the problem is on the checkout_payment.php becouse that is the page there is blank.

if i take checkout_payment.php from my Backup files I still get the same blank page. :-(

 

So maybe the error is on another page.

 

but it is wierd that i have the same problem on 2 different websites. so it is me there is missing something.

 

Best Regards

Kent Larsen

Edited by Party

Share this post


Link to post
Share on other sites
Hi

No errors message shows :-(

 

I only think that the problem is on the checkout_payment.php becouse that is the page there is blank.

if i take checkout_payment.php from my Backup files I still get the same blank page. :-(

 

So maybe the error is on another page.

 

but it is wierd that i have the same problem on 2 different websites. so it is me there is missing something.

 

Best Regards

Kent Larsen

Are you using ssl


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Are you using ssl

 

Hi Thx for replying

 

In the admin it says: You are not protected by a secure SSL connection.

 

Thx

Share this post


Link to post
Share on other sites
Hi Thx for replying

 

In the admin it says: You are not protected by a secure SSL connection.

 

Thx

What is the url of the blank page?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
I have just send you a PM

Thanks.

In the meantime, look at page 211 pjnet Sep 29 2006, 11:07 PM Post #4206


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Thanks.

In the meantime, look at page 211 pjnet Sep 29 2006, 11:07 PM Post #4206

 

Hi again

 

I have try'id this with out any luck:-(

 

Best regards

Kent Larsen

Share this post


Link to post
Share on other sites

I got everything working now except that I don't have a check box on the payment page to use gift certificate funds for payment. Is this something that I missed? I'm looking for it but if someone can confirm that this is something that I missed/messed up as opposed to a bug it would be helpful.

 

Thanks,

Tim

Share this post


Link to post
Share on other sites
I got everything working now except that I don't have a check box on the payment page to use gift certificate funds for payment. Is this something that I missed? I'm looking for it but if someone can confirm that this is something that I missed/messed up as opposed to a bug it would be helpful.

 

Thanks,

Tim

Could be either.

 

One problem that I had was in a file that was changed by CCGV, but it was not the CCGV mod itself (I just can't remember which file).

 

So, if your edits are correct, compare the rest of the file with the latest version of OSC.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Has anyone ran into a problem with v5.19 going from the payment screen to the confirmation screen and getting kicked out to the login again?


When you have eliminated the impossible, whatever remains, however improbable, must be the truth.

-Sherlock Holmes

Share this post


Link to post
Share on other sites

Has anyone ran into a problem with v5.19 going from the payment screen to the confirmation screen and getting kicked out to the login again? :huh:


When you have eliminated the impossible, whatever remains, however improbable, must be the truth.

-Sherlock Holmes

Share this post


Link to post
Share on other sites

Has anyone ran into a problem with v5.19 going from the payment screen to the confirmation screen and getting kicked out to the login again? :huh:


When you have eliminated the impossible, whatever remains, however improbable, must be the truth.

-Sherlock Holmes

Share this post


Link to post
Share on other sites
Hi again

 

I have try'id this with out any luck:-(

 

Best regards

Kent Larsen

 

Hi.

 

I have have the same problem as you, have you find a soulution yet?

 

/David

Share this post


Link to post
Share on other sites

How does a user purchase a gift voucher???

 

I have installed the CCGV5.19 version and it all seems to work fine (after some effort!!!) However I cant seem to figure out how a customer can purchase a gift voucher?

 

Have I missed the obviouse? have I not enables something PLEASE HELP???

Share this post


Link to post
Share on other sites

Ok I figured it out HOW A CUSTOMER CAN BUY A GIFT VOUCHER and wow, I got through the entire instalation and then got stuck on this I STILL think its not obvious, so here is the answer:

 

hadezee post says:

 

Create a new product, however you want to do that. Make it worth what you want. Make sure to make the Product Model start with GIFT. That being say, GIFT_25, GIFT25, GIFT_pleasemakethiswork, etc.

 

What you then need to do is go to the admin >> Vouchers/coupons >> Gift voucher Queue and release the voucher

 

It worked for me GOOD LUCK ALL :)

Share this post


Link to post
Share on other sites

Re: the total is not calculated correctly

 

Hello,

 

I have read this entire thread and could not find answers to this problem. I have installed this contribution correctly and have tried various sort orders for the Order Total but it seems that it cannot correctly calculate the order totals. I am using the Canadian Tax contribution but when a flat rate shipping is setup, it messes up the totals.

 

Here is what I get when I try to check out:

 

Item Price: $99.50

Discount Coupons: 15% discount: -$14.93

Sub-Total: $99.50

GST ( 6% ): $5.97

PST ( 7.5% ): $7.91

Flat Rate for Zone 1 (Best Way): $10.00

Total: $109.10

 

Now here are two issues: 1. The taxes are calculated on the original amount not the discounted price and 2. The final total is incorrect with or without taxes being calculated on original or discounted price

 

What we SHOULD ideally get is the following:

1. Taxes are calculated based on Original Price

Item Price: $99.50

Discount Coupons: 15% : -$14.93

Sub-Total: $84.58 <<<< needs to show correct subtotal

GST ( 6% ): $5.97 <<<< even if you leave the taxes as is the final total is incorrect

PST ( 7.5% ): $7.91

Flat Rate for Zone 1 (Best Way): $10.00

Total: $108.46 <<<<< Adding the above figures should equal 108.45 NOT 109.10

 

2.Taxes are calculated on Discounted price

Item Price: $99.50

Discount Coupons: 15% : -$14.93

Sub-Total: $84.58

GST ( 6% ): $5.07

PST ( 7.5% ): $6.72 <<<< PST = 7.5% of the total of GST + subtotal

Flat Rate for Zone 1 (Best Way): $10.00

Total: $106.37

 

In either case, the total is much different from what the osc currently calculates. Any help would be much appreciated.

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×