Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

Nop still nothing.

 

I remember someone saying that they had to installed another contribution to make this one work

 

I will try to find it

 

and if anyone can send me to that post i will be thankful

 

Thanks


at the end of the day the code will be good

Share this post


Link to post
Share on other sites
I just enabled SSL. Without SSL everything works fine. When SSL is enabled, coupons do not work anymore. When I try to redeem a coupon I am taken back to the home page.

 

Any ideas?

You should check that your https server is specified correctly.

 

Check the forums.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Nop still nothing.

 

I remember someone saying that they had to installed another contribution to make this one work

 

I will try to find it

 

and if anyone can send me to that post i will be thankful

 

Thanks

No that is not correct. Recheck your ccgv installation.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

I am. I just re-Installed CCGV 5.15a2 and I over rote all my files and all I get is a white page that when I look at the sorce code it shows

 

 

 

 

 

-----------------------------------------------------------------------------------------------

 

 

 

 

 

 

 

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

<html dir="LTR" lang="en">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

<title>Welcome in your Cool Bug Stuff shop</title>

<base href="http://coolbugstuff.com/catalog/">

<link rel="stylesheet" type="text/css" href="stylesheet.css">

<script language="javascript"><!--

var selected;

var submitter = null;

function submitFunction() {

submitter = 1;

}

function selectRowEffect(object, buttonSelect) {

 

// #################### Begin Added CGV JONYO ######################

if (!document.checkout_payment.payment[0].disabled){

// #################### End Added CGV JONYO ######################

if (!selected) {

 

if (document.getElementById) {

selected = document.getElementById('defaultSelected');

} else {

selected = document.all['defaultSelected'];

}

}

 

if (selected) selected.className = 'moduleRow';

object.className = 'moduleRowSelected';

selected = object;

 

// one button is not an array

if (document.checkout_payment.payment[0]) {

document.checkout_payment.payment[buttonSelect].checked=true;

} else {

document.checkout_payment.payment.checked=true;

}

// #################### Begin Added CGV JONYO ######################

}

// #################### End Added CGV JONYO ######################

}

 

function rowOverEffect(object) {

 

if (object.className == 'moduleRow') object.className = 'moduleRowOver';

}

 

function rowOutEffect(object) {

if (object.className == 'moduleRowOver') object.className = 'moduleRow';

}

 

 

<br />

<b>Fatal error</b>: Call to a member function on a non-object in <b>/home/content/c/o/o/coolbug/html/catalog/checkout_payment.php</b> on line <b>174</b><br />


at the end of the day the code will be good

Share this post


Link to post
Share on other sites
I am. I just re-Installed CCGV 5.15a2 and I over rote all my files and all I get is a white page that when I look at the sorce code it shows

-----------------------------------------------------------------------------------------------

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

<html dir="LTR" lang="en">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

<title>Welcome in your Cool Bug Stuff shop</title>

<base href="http://coolbugstuff.com/catalog/">

<link rel="stylesheet" type="text/css" href="stylesheet.css">

<script language="javascript"><!--

var selected;

var submitter = null;

function submitFunction() {

submitter = 1;

}

function selectRowEffect(object, buttonSelect) {

 

// #################### Begin Added CGV JONYO ######################

if (!document.checkout_payment.payment[0].disabled){

// #################### End Added CGV JONYO ######################

if (!selected) {

 

if (document.getElementById) {

selected = document.getElementById('defaultSelected');

} else {

selected = document.all['defaultSelected'];

}

}

 

if (selected) selected.className = 'moduleRow';

object.className = 'moduleRowSelected';

selected = object;

 

// one button is not an array

if (document.checkout_payment.payment[0]) {

document.checkout_payment.payment[buttonSelect].checked=true;

} else {

document.checkout_payment.payment.checked=true;

}

// #################### Begin Added CGV JONYO ######################

}

// #################### End Added CGV JONYO ######################

}

 

function rowOverEffect(object) {

 

if (object.className == 'moduleRow') object.className = 'moduleRowOver';

}

 

function rowOutEffect(object) {

if (object.className == 'moduleRowOver') object.className = 'moduleRow';

}

<br />

<b>Fatal error</b>: Call to a member function on a non-object in <b>/home/content/c/o/o/coolbug/html/catalog/checkout_payment.php</b> on line <b>174</b><br />

We have discussed thie befor. You need to enable coupons and vouchers in admin.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Ok Lets see

I log in to my admin area and I go to "Vouchers/Coupons" on the Left Nav then what do i do?

 

or how do i enable coupons and vouchers?


at the end of the day the code will be good

Share this post


Link to post
Share on other sites
Ok Lets see

I log in to my admin area and I go to "Vouchers/Coupons" on the Left Nav then what do i do?

 

or how do i enable coupons and vouchers?

Well I can't give you step by step instructions because I do not remember.

 

Look in payment modules, configuration, order total.

 

Vouchers/Coupons enables you to create coupons (as per the install instuctions).


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Under Payment Mod I have

 

Modules										   Sort Order								  

Authorize.net											0	 
Credit Card											0	 
Credit Class Error									 99	--- This is the new one  
Cash on Delivery		 
iPayment		 
Check/Money Order		 
NOCHEX		 
PayPal		 
PayPal (Credit Card / Debit)		 
2CheckOut		 
PSiGate		 
SECPay

 

 

and Under Credit Class Error

 

I have Sort order of display


at the end of the day the code will be good

Share this post


Link to post
Share on other sites
Under Payment Mod I have

 

Modules										   Sort Order								  

Authorize.net											0	 
Credit Card											0	 
Credit Class Error									 99	--- This is the new one  
Cash on Delivery		 
iPayment		 
Check/Money Order		 
NOCHEX		 
PayPal		 
PayPal (Credit Card / Debit)		 
2CheckOut		 
PSiGate		 
SECPay

and Under Credit Class Error

 

I have Sort order of display

Well, I do not know waht you have done. I do not have credit class error as a payment option. I have Gift Vouchers as a payment option.

 

Perhaps you need a simpler contrib to install?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Well, I do not know waht you have done. I do not have credit class error as a payment option. I have Gift Vouchers as a payment option.

 

Perhaps you need a simpler contrib to install?

 

 

I will look for that in the contrib


at the end of the day the code will be good

Share this post


Link to post
Share on other sites

for some rason I cant find the Payment Mod "Gift Vouchers as a payment option"

 

do you know in what packet it is at?

 

 

Thanks 4 all the help


at the end of the day the code will be good

Share this post


Link to post
Share on other sites
for some rason I cant find the Payment Mod "Gift Vouchers as a payment option"

 

do you know in what packet it is at?

Thanks 4 all the help

Gift Vouchers should show up, not credit class error.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Serious problem with CCGV.

 

I want to sell gift vouchers using the IPN and without queing but every time I test I get the same thing: I only need to go as far as checkout_confirmation and the Voucher Balance appears in the Shopping Cart Box - no need to part with any money; I've got my voucher without going any further.

 

Which is the most bug-free version to install? The CCGV5.16.zip from 8 Feb 2006 uncompresses to CCGV1.51a. I've been adding the subsequent fixes and testing on a test server, on a clean install of oscommerce-2.2ms2-051113 every time. Latterly, I haven't been bothering with the fixes because I don't think they have any effect on this issue (please correct me if I'm wrong)!

 

The site will be selling music downloads and the idea was to use Gift Vouchers to allow customers to buy credits worth several downloads so that the 20p Paypal transaction charge applies only once. Queing the voucher is not really an option because, for this site, the vouchers wouldn't be an extra; they'd be an intergral part of every sale so, basically, no voucher scheme - no site.

Share this post


Link to post
Share on other sites

is the

 

includes/modules/payment/ccerr.php

 

file that i need for the git card?


at the end of the day the code will be good

Share this post


Link to post
Share on other sites

HELP!!

 

I have been trying to launch my site, but I cannot get the coupon for free shipping reflect the correct order total in my payment module.

 

After some research in my Authorize.net payment module I figured out that its getting the order total from the variable $order->info['total']. It seems that this variable is not updated with the correct order total.

 

Any help is appreciated on isolating this issue.

 

I'm using the Credit Class & Gift Voucher dated 24 Feb 2006.

 

Thanks

Edited by nkapasi

Share this post


Link to post
Share on other sites

I have successfully installed CCGV without any major problems. HOWEVER, I am having a very strange problem that I cannot for the life of me figure out.

 

On the checkout_payment.php page, upon entering a Gift Voucher that is either valid or invalid, i should get an error saying "Invalid Gift Voucher Code" in a red box error message box. I get the red error box, but no text is in it! However, in the URL, It says: /checkout_payment.php?payment_error=ot_gv&error=Invalid+Gift+Voucher+Code

 

Why doesn't this error display in the error box for me?

 

This happens when I enter a valid coupon code as well....

 

Has anyone had this problem?

 

I have searched through this massive fourm and have yet to find the someone with the same problem.

 

I would appreciate any help at all.

 

Thanks.

Share this post


Link to post
Share on other sites

Hi everybody, I installed a Credit Class & Gift Voucher http://www.oscommerce.com/community/contri...3/search,coupon

 

In a fresh oscommerce (to test a module)...and its working FINE and GREAT, the problem was when I installed in a REAL STORE!!!

 

I buyed a template in Monster template and worked great, but when I installed a Credit Class & Gift Voucher (CCGV516)...appear a error..when I try to create a new ACCOUNT the error is:

 

Fatal error: Cannot redeclare tep_show_category() (previously declared in /home/adsoma/public_html/bijoul_cp/includes/header.php:207) in /home/adsoma/public_html/bijoul_cp/includes/boxes/categories.php on line 13

 

Sorry I don?t know about PHP I am a simple mortal....please HELP ME!!

 

Thanks for your time and patience....because my english no it?s good!!

 

Adrian Soltero

Edited by adsoma

Share this post


Link to post
Share on other sites
Currently, the coupon code is set up such that it is applied after taxes and shipping charges. How do I set it such that the coupon code will be applied only to the selling price (before taxes and shipping)?

 

Thanks!

 

 

go to your Admin then in Module/order_total

 

once there... click edit and give htem order numbers

 

 

ex:

Subtotal 1

Discount 2

tax 3

Share this post


Link to post
Share on other sites

ok... am done installing ccgv 5.16

 

I seem to have succeeded in installing everything properly... it's in the functionning of it that I must be doing something wrong. I did try to search here but can't find that anyone has had the situation...

 

I am adding a Discount Coupon... and I am restricting it to one category... I have category A and B... so I want it applied to A only... which is also working. It's starts going wrong when I have a product with options. As soon as there are one or more options/attributes to a product... the shopping cart sees it as not being part of the category I picked. The coupon works if set directly on a specific product.

 

 

Any help would be appreciated.

Share this post


Link to post
Share on other sites

Is it just me or is the manual installation instructions for CCGV5.16 filled with errors. I have spotted 2 and i am not even 20% of the way through the installation. It is really putting me off and i am sure it will put off alot of other users as well.

 

I will post a new set of installation instructions once i am finished, if i decide to finish. If i miss an error or two and it balls up my site them i cant really fix the instructions can I.

 

Please post any errors with the current instructions here and i will include it when i make a fresh copy. But all credit goes to the guy that made the original, errors or no errors, i have found it very useful so far and he obviously put days of effort into creating the whole thing.


Menou and unome

Share this post


Link to post
Share on other sites
I am getting an error after installing this Contribution. Can anyone help me ?

 

Here is the error: Fatal error: Call to undefined function: clear_posts() in /home/u2/bry21317/html/osc/checkout_payment.php on line 89

 

Thanks,

Bryan

 

I was getting this error after following the rtf installation instructions word for word... i think this...

 

--------------------

10) catalog/includes/classes/order_total.php

 

Right Above:

the last ?> at end of file

--------------------

 

should be

 

--------------------

10) catalog/includes/classes/order_total.php

 

Right Above:

the last

}

?>

at end of file

--------------------

otherwise those functions dont get included into the class, instead they just chill out in the file... i post this here in the hopes that it helps someone else...

 

 

i also think this line

 

----------------------------

----------------------------------------------------------------------------------------

Right Below:

<?php

$radio_buttons++;

}

?>

----------------------------------------------------------------------------------------

should be

 

----------------------------------------------------------------------------------------

Right Below:

<?php

$radio_buttons++;

}

-----------------------------------------------------------

Share this post


Link to post
Share on other sites

Hey man,

thanks, i have nearly finished correcting the instructions and will post them soon. Thanks for the response and that error has already been corrected as well. Though you answered the wrong thing that guy asked. Instead his problem was caused by faulty instructions at step 2.

 

Remove whatever step 2 told you to do and replace it with step 2 of the new instructions i will post in a few moments. I remember that there was a big typo at step 2(checkout_payments.php) which has now been corrected.

Nick


Menou and unome

Share this post


Link to post
Share on other sites
I have successfully installed CCGV without any major problems. HOWEVER, I am having a very strange problem that I cannot for the life of me figure out.

 

On the checkout_payment.php page, upon entering a Gift Voucher that is either valid or invalid, i should get an error saying "Invalid Gift Voucher Code" in a red box error message box. I get the red error box, but no text is in it! However, in the URL, It says: /checkout_payment.php?payment_error=ot_gv&error=Invalid+Gift+Voucher+Code

 

Why doesn't this error display in the error box for me?

 

This happens when I enter a valid coupon code as well....

 

Has anyone had this problem?

 

I have searched through this massive fourm and have yet to find the someone with the same problem.

 

I would appreciate any help at all.

 

Thanks.

 

I am getting this error as well. Does anyone have any ideas.

 

Thanks

Share this post


Link to post
Share on other sites

I've installed CCGV 5.16a onto a new OSC package. The install has since had other Contribs installed, but CCGV was installed early on in the process, so was a basic drop files on type installation.

 

I've checked many other threads for this - and tried all proposed solutions (redo SQL etc), but...

 

I cannot get admin->configuration->Welcome Gift Voucher Amount, and admin->configuration->Welcome Discount Coupon Code to be visible to me.

 

The Contrib is installed correctly, I've checked. I've Re-done the SQL (deleting the old parts first). I've made sure I've created a Voucher (which is apparently what triggers the above Configuration options to appear), and still Nothing!

 

The Gift Voucher text is showing in the Welcome emails, but with no Actual voucher number etc listed - which seems odd. Either vouchers are On, or they are Not, I would think?

 

There must be something simple I'm not doing that is making Configuration not see these options, but I don't know what - anyone been in a similar situation etc?

Share this post


Link to post
Share on other sites

Using v. 5.15a2

 

I currently have the following problem:

When I have an item that costs less than what the gift voucher is worth and I redeem the voucher, it automatically defaults to the paypal payment system (all the payment systems are greyed out and the user can't choose any). Ideally, the user should be able to choose a method of payment. However, because the payment will be $0.00 anyways, I'm not so sure that the payment should even be forwarded to a payment processor. Has anyone had this problem before and/or a way to fix it?

 

Thanks!

Andrew

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×