Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

Guest

Sorry, fixed it...

 

In the fix to the contrib part 4 (I think!!) says:

 

In /catalog/includes/modules/order_total/ot_gv.php

 

Find this code:

 

$order->info['total'] = $order->info['total'] - $od_amount;

 

add these two lines above it:

 

$order->info['total'] = tep_round($order->info['total'],2);

$od_amount = tep_round($od_amount,2);

$order->info['total'] = $order->info['total'] - $od_amount;

 

I had $order->info['total'] = $order->info['total'] - $od_amount; in twice thus it was taking off ?50 then another ?50.

 

Cheers

 

W

 

If I just apply a voucher I get this (as an example)

 

Sub-Total: ?49.95

Flat Rate (Best Way): ?5.00

Gift Vouchers (-) : ?50.00

Total: ?-45.05

 

Cheers

 

W

Share this post


Link to post
Share on other sites
It is assumed that you have a PayPal contrib installed and working before this contrib is installed, not the other way around.

 

If you installed the DevOSC paypal contrib (I have version 3.1.5), get it working before getting CCGV working (I have CCGV 5.51a2-parts1 2) with it. Any questions regarding PayPal should be placed in the correct thread.

 

In one of the earlier versions of CCGV, there were instructions about installing the PayPal IPN. From memory, it referred to the ext folder as the one to use (but I may be wrong, and usually am).

 

====================================

I still can't get the discount price be forwarded to Paypal!

I got every thing working before I installed CCGV.

 

I am having the same problem:

1) When the customer checks out and it forwards to paypal, the discount is not there. The customer will end up paying the original amount without the coupon discount.

I am currently using version 5.16 of CCG.

And this is the same problem as Arrowhead123 is having part 1.

Not solved yet, can you help, please.

Share this post


Link to post
Share on other sites
OK then...I am using Linkpoint. I have installed this contribution (v 5.16) and I get all the way thru checkout except after I enter a credit card number and click continue, the page comes up with an error referring to my linkpoinconnect.php file. This should be my checkout_confirmation.php page. And shouldn't the discount show up before then or does it come up after I pay and then show the subtotal, shipping, etc.?

 

Also, I ran the SQL but I don't have this in my admin>modules>order total. I think there should be the Discount Coupons that I'm supposed to install but it's not there.

 

I have been able to create a voucher and I emailed it to myself hoping to use it at checkout but as mentioned above, I get an error page.

 

Any suggestions would be fantastic! Thanks!

 

Ok so I fixed my linkpoint problem but I still don' t have the option to "turn on" the Gift Vouchers part in the admin>modules>order total....It's just not there. I tried running the query again but it just said it was already installed. What am I doing wrong? :blink:

Share this post


Link to post
Share on other sites
Guest
Ok so I fixed my linkpoint problem but I still don' t have the option to "turn on" the Gift Vouchers part in the admin>modules>order total....It's just not there. I tried running the query again but it just said it was already installed. What am I doing wrong? :blink:

I really have no idea.

 

Did you edit the admin\includes\column_left.php file by adding the lines below?

 

 

// Start ICW CREDIT CLASS Gift Voucher Addition

require(DIR_WS_BOXES . 'gv_admin.php');

// End ICW CREDIT CLASS Gift Voucher Addition

Share this post


Link to post
Share on other sites
I really have no idea.

 

Did you edit the admin\includes\column_left.php file by adding the lines below?

// Start ICW CREDIT CLASS Gift Voucher Addition

require(DIR_WS_BOXES . 'gv_admin.php');

// End ICW CREDIT CLASS Gift Voucher Addition

 

Yep - it's in there.

Share this post


Link to post
Share on other sites
Yep - it's in there.

Wait a minute - I have heavily modified my site. If I have changed the look of it, would that have an effect on the column_left. php? I thought that this voucher box where a customer would imput the code would be right around where you enter the credit card info. I am completely confused at this point. Also, would that have an effect of being able to turn it on in the admin section?

Share this post


Link to post
Share on other sites
Guest
Yep - it's in there.

If all of the files are in the correct location and all of the edits have been done correctly, it should look like this in Order Total Modules

 

Modules Sort Order Action

Discount Coupons 4

Gift Vouchers 5

Low Order Fee

Shipping 2

Sub-Total 1

Tax 7

Total 9

Module Directory: /hsphere/local/home/coopco/coopco.com.au//catalog/includes/modules/order_total/

 

and at the left in Admin

 

Configuration

 

Catalog

 

Modules

 

Customers

 

FAQ System

 

Vouchers/Coupons <------------------------- You should see this

 

Locations / Taxes

 

Localization

 

Reports

 

Tools

Share this post


Link to post
Share on other sites
Guest
Wait a minute - I have heavily modified my site. If I have changed the look of it, would that have an effect on the column_left. php? I thought that this voucher box where a customer would imput the code would be right around where you enter the credit card info. I am completely confused at this point. Also, would that have an effect of being able to turn it on in the admin section?

 

Oh, I thought that you were talking about the Admin side. You must turn it on in Admin.

 

I now think that you may be referring to the payment information page where you have the dreaded Redeem Button?

Share this post


Link to post
Share on other sites

Anybody in here got CCGV going will the full easy checkout?

I had CCGV going until I eliminated the first checkout page - can't get my new order totals to update anymore. :(

Share this post


Link to post
Share on other sites
Oh, I thought that you were talking about the Admin side. You must turn it on in Admin.

 

I now think that you may be referring to the payment information page where you have the dreaded Redeem Button?

 

I'm sorry I am not conveying exactly what I'm not seeing:

 

I am talking about both. I do not have anything for this contribution in my admin>modules>order total. (I do have the Coupon/Voucher at the left side of admin.)

 

And I also don't have anything at the payment information for the redeem button. (And you scare me when you say "dreaded"!! :)

 

Sorry about the confusion.

Share this post


Link to post
Share on other sites
Guest
I'm sorry I am not conveying exactly what I'm not seeing:

 

I am talking about both. I do not have anything for this contribution in my admin>modules>order total. (I do have the Coupon/Voucher at the left side of admin.)

 

And I also don't have anything at the payment information for the redeem button. (And you scare me when you say "dreaded"!! :)

 

Sorry about the confusion.

 

In catalog\includes\modules\order_total\ you shpild have

ot_coupon.php

ot_gv.php

ot_loworderfee.php

ot_shipping.php

ot_subtotal.php

ot_tax.php

ot_total.php

 

In catalog\includes\languages\english\modules\order_total\ there should be different files but with the same name.

 

If any are missing, check that you have uploaded all of the required new files as well as the edited files.

 

The Redeem Button was dreaded for me because of the proiblems that I had getting to look goo.

Share this post


Link to post
Share on other sites
In catalog\includes\modules\order_total\ you shpild have

ot_coupon.php

ot_gv.php

ot_loworderfee.php

ot_shipping.php

ot_subtotal.php

ot_tax.php

ot_total.php

 

In catalog\includes\languages\english\modules\order_total\ there should be different files but with the same name.

 

If any are missing, check that you have uploaded all of the required new files as well as the edited files.

 

The Redeem Button was dreaded for me because of the proiblems that I had getting to look goo.

 

Thank you Coopco!!! You rock! I can't believe it was such a simple mistake!! So now I turned it on in admin and did a test checkout and the redeem button is there - so awesome!! However, the discount was for 10%. So for 29.00 that should be $2.90 and it said that at the top of the page but in the order total (subtotal, discount, shipping, total) the discount applied was actually $3.99. What the???

Share this post


Link to post
Share on other sites
Guest
Thank you Coopco!!! You rock! I can't believe it was such a simple mistake!! So now I turned it on in admin and did a test checkout and the redeem button is there - so awesome!! However, the discount was for 10%. So for 29.00 that should be $2.90 and it said that at the top of the page but in the order total (subtotal, discount, shipping, total) the discount applied was actually $3.99. What the???

Check that you are not applying the discount to shipping.

Share this post


Link to post
Share on other sites
Guest

Hi Guys, I've been following this thread for a while now trying to pluck up enough courage to bite the bullet and give it a go!

 

I've installed 'CCGV v5.16', 'coupon admin rollup 3' and 'bunch of fixes v1.1' in that order as has been recommended. The store looks OK but when I try to go to Admin, I get this error:

 

Fatal error: Cannot re-assign $this in /home/xxxxxx/public_html/shop/admin/includes/classes/upload.php on line 31

 

As far as I'm aware, 'Upload.php' wasn't even a file to be altered was it?

 

Any help anyone?!

Share this post


Link to post
Share on other sites
Guest
Hi Guys, I've been following this thread for a while now trying to pluck up enough courage to bite the bullet and give it a go!

 

I've installed 'CCGV v5.16', 'coupon admin rollup 3' and 'bunch of fixes v1.1' in that order as has been recommended. The store looks OK but when I try to go to Admin, I get this error:

 

Fatal error: Cannot re-assign $this in /home/xxxxxx/public_html/shop/admin/includes/classes/upload.php on line 31

 

As far as I'm aware, 'Upload.php' wasn't even a file to be altered was it?

 

Any help anyone?!

OSC update 051112 made an update in this area of admin/includes/classes/upload.php

Share this post


Link to post
Share on other sites
Guest

Hi Moon

 

Did you resolve this. I have the same problem in that Coupon Redemption is the only thing that shows (plus a pink empty box below it).

 

Cheers

 

W

 

Hey all...

My checkout payment page does not show the "Congratulations you have redemed message."

Everything works fine, the coupons pass, it's just a problem of the customer not getting this message for confirmation. The only thing it displays is the words "Coupon Redemption". I have used the checkout_payment.php from the contribution. Any ideas on what might be wrong?

 

Always greatful,

Moon

Share this post


Link to post
Share on other sites
Guest
OSC update 051112 made an update in this area of admin/includes/classes/upload.php

 

Is that something I need to be doing then? Is there an update to Osc that I need to apply?

 

Thanks

Share this post


Link to post
Share on other sites
Guest

OK, got that but now I've got:

 

Fatal error: Cannot redeclare tep_set_coupon_status() (previously declared in /home/xxxxxx/public_html/shop/admin/includes/functions/general.php:721) in /home/xxxxxx/public_html/shop/admin/includes/add_ccgvdc_application_top.php on line 108

 

:blush:

Share this post


Link to post
Share on other sites
Guest
Is that something I need to be doing then? Is there an update to Osc that I need to apply?

 

Thanks

Er, yes, but if you did not do the update, then I do not know what would be causing your problem. CCGV did not alter that file. Maybe check the file and post what is around that area of the file.

 

The OSC Update info can be found here http://www.oscommerce.com/ext/update-20051113.html

Share this post


Link to post
Share on other sites
Guest
OK, got that but now I've got:

 

Fatal error: Cannot redeclare tep_set_coupon_status() (previously declared in /home/xxxxxx/public_html/shop/admin/includes/functions/general.php:721) in /home/xxxxxx/public_html/shop/admin/includes/add_ccgvdc_application_top.php on line 108

 

:blush:

 

Just remove the CCGV mod from the general file ie admin/includes/functions/general.php The same function appears in both files.

Share this post


Link to post
Share on other sites
Guest
Just remove the CCGV mod from the general file ie admin/includes/functions/general.php The same function appears in both files.

 

Thanks very much Coopco. I also found I needed to apply another fix in the update.

Share this post


Link to post
Share on other sites
Guest

AARRGGHH!! Seemed like everything was going OK!

 

I have setup a coupon but when I get to 'checkout_payment.php' I get a blank screen!

 

:blush:

Share this post


Link to post
Share on other sites
Guest
AARRGGHH!! Seemed like everything was going OK!

 

I have setup a coupon but when I get to 'checkout_payment.php' I get a blank screen!

 

:blush:

If you can post your (in IE6) view then source, we may find where the problem lies (around the last line). It is 2:30 am in Melbourne, so I will look at it tomorrow.

Share this post


Link to post
Share on other sites
Guest
If you can post your (in IE6) view then source, we may find where the problem lies (around the last line). It is 2:30 am in Melbourne, so I will look at it tomorrow.

 

Thanks very much Coopco

 

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html dir="LTR" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>CraftyCarrot.com</title>
<base href="http://craftycarrot.info/shop/">
<link rel="stylesheet" type="text/css" href="stylesheet.css">

<script language="JavaScript">
<!--

function SymError()
{
 return true;
}

window.onerror = SymError;

var SymRealWinOpen = window.open;

function SymWinOpen(url, name, attributes)
{
 return (new Object());
}

window.open = SymWinOpen;

//-->
</script>

<script language="javascript"><!--
var selected;
var submitter = null;
function submitFunction() {
  submitter = 1;
  }
function selectRowEffect(object, buttonSelect) {

 // #################### Begin Added CGV JONYO ######################
 if (!document.checkout_payment.payment[0].disabled){
 // #################### End Added CGV JONYO ######################
if (!selected) {

if (document.getElementById) {
  selected = document.getElementById('defaultSelected');
} else {
  selected = document.all['defaultSelected'];
}
 }

 if (selected) selected.className = 'moduleRow';
 object.className = 'moduleRowSelected';
 selected = object;

// one button is not an array
 if (document.checkout_payment.payment[0]) {
document.checkout_payment.payment[buttonSelect].checked=true;
 } else {
document.checkout_payment.payment.checked=true;
 }
// #################### Begin Added CGV JONYO ######################
 }
// #################### End Added CGV JONYO ######################
}

function rowOverEffect(object) {
 if (object.className == 'moduleRow') object.className = 'moduleRowOver';
}

function rowOutEffect(object) {
 if (object.className == 'moduleRowOver') object.className = 'moduleRow';
}


<font color="#000000"><b>1146 - Table 'craftyca_osc1.TABLE_COUPONS' doesn't exist<br><br>select coupon_code from TABLE_COUPONS where coupon_id=''<br><br><small><font color="#ff0000">[TEP STOP]</font></small><br><br></b></font>
<script language="JavaScript">
<!--
var SymRealOnLoad;
var SymRealOnUnload;

function SymOnUnload()
{
 window.open = SymWinOpen;
 if(SymRealOnUnload != null)
 SymRealOnUnload();
}

function SymOnLoad()
{
 if(SymRealOnLoad != null)
 SymRealOnLoad();
 window.open = SymRealWinOpen;
 SymRealOnUnload = window.onunload;
 window.onunload = SymOnUnload;
}

SymRealOnLoad = window.onload;
window.onload = SymOnLoad;

//-->
</script>

Share this post


Link to post
Share on other sites
Guest

Hi CraftCarrot

 

Your code has some javscript that mine does not have.

 

<script language="JavaScript">

<!--

 

function SymError()

{

return true;

}

 

window.onerror = SymError;

 

var SymRealWinOpen = window.open;

 

function SymWinOpen(url, name, attributes)

{

return (new Object());

}

 

window.open = SymWinOpen;

 

//-->

</script>

 

I could not find this in my files, so maybe you have a contrib installed that I don't have.

 

The next part that differs is after where indicated

// #################### End Added CGV JONYO ######################

}

 

function rowOverEffect(object) {

if (object.className == 'moduleRow') object.className = 'moduleRowOver';

}

 

function rowOutEffect(object) {

if (object.className == 'moduleRowOver') object.className = 'moduleRow';

} <----------------------- this is the last line that is the same

 

 

// temp1 =

// temp2 = 19

// gvresult = 100.0000

 

function clearRadeos(){

document.checkout_payment.cot_gv.checked=!document.checkout_payment.cot_gv.checked;

for (counter = 0; counter < document.checkout_payment.payment.length; counter++)

 

Where you have

<font color="#000000"><b>1146 - Table 'craftyca_osc1.TABLE_COUPONS' doesn't exist<br><br>select coupon_code from TABLE_COUPONS where coupon_id=''<br><br><small><font color="#ff0000">[TEP STOP]</font></small><br><br></b></font>

 

The above seems to indicate that your TABLE_COUPONS does not exist, so maybe it is an error in setting up the coupons (either editing or other error). I do not know what error code 1146 actually means.

 

Finally, you have a line that says

<base href="http://craftycarrot.info/shop/">

The payments page should be SSL secured ie it should be https not http

 

Sorry, that I have not been able to help. If you send me an e-mail, I can send my CCGV files for you to compare with yours.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×