Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

Hmm, not sure if I'm on the right path here, but I'd say in your admin section, revise the "products that qualify" box to a "products that don't qualify" box, then change the underlying SQL statement to do something like "check off all products (or set to 1 or whatever) EXCEPT the products submitted in the "products that don't qualify box". It seems the easiest way to me, as it won't really require any modification outside the admin module. Sorry I don't know where theSQL query is but it will be in the admin somewhere.

 

Hope this helps, but sorry I can't be clearer... just no friggin time ya know?

 

Thanks for your thoughts. I will look into it further.

 

I am now thinking I would want an extra box for excluded items, that would run alongside the restricted items or categories.

Share this post


Link to post
Share on other sites
Post #3703 lists what version / fixes I used. and a couple pointers to boot, but I'd personally test the crap out of it before going live.

 

Thank you. Maybe I should just go with CCGV version 5.16 from 8 Feb 2005 and the updates after that?

 

Not sure what you mean with "CCGV1.51a"?

Share this post


Link to post
Share on other sites

Oh, I forgot an important thing. Are there any known big issues with CCGV at this point? If that is the case, I'd rather wait for next version that going through CCGV once again..

Share this post


Link to post
Share on other sites

Below is a quote from the information page on how to redeem Gift Vouchers. It says there should be a box that will apear if you have money in you gift voucher account and that you need to click that box to apply the money to the purchase.

 

Can someone post a picture of this box and maybe tell me what file the box is supposed to be called from. In other words what page should be displaying this box?

 

Buying with Gift Vouchers.

If you have funds in your Gift Voucher Account, you can use those funds to purchase other items in our store. At the checkout stage, an extra box will appear. Clicking this box will apply those funds in your Gift Voucher Account. Please note, you will still have to select another payment method if there is not enough in your Gift Voucher Account to cover the cost of your purchase. If you have more funds in your Gift Voucher Account than the total cost of your purchase the balance will be left in you Gift Voucher Account for the future.


Modules installed:

http://forums.oscommerce.com/index.php?showtopic=57259 - Options attributes

- wysiwyg editor

- cats on main page

- policies and terms

Share this post


Link to post
Share on other sites
Below is a quote from the information page on how to redeem Gift Vouchers. It says there should be a box that will apear if you have money in you gift voucher account and that you need to click that box to apply the money to the purchase.

 

Can someone post a picture of this box and maybe tell me what file the box is supposed to be called from. In other words what page should be displaying this box?

 

For me, the GV payment option shows up as payment option checkbox inside the coupon redeem box. (just below the redeem code input form box) This will show itself either above or below your payment entry box, depending on where you inserted the redeem code in your file.

Share this post


Link to post
Share on other sites
For me, the GV payment option shows up as payment option checkbox inside the coupon redeem box. (just below the redeem code input form box) This will show itself either above or below your payment entry box, depending on where you inserted the redeem code in your file.

 

 

so yours actually shows a little box that you can check to use that as a method of payment?

 

mine doesn't.

 

Elaine


"There are only 10 types of people in this world: those who understand binary, and those who don't. "

Share this post


Link to post
Share on other sites
so yours actually shows a little box that you can check to use that as a method of payment?

 

mine doesn't.

 

Elaine

 

 

Ah Crap. Sorry, I'm wrong.. it shows up in payment box. :blush:

Share this post


Link to post
Share on other sites

_belly,

 

Can you do me a big favor and post the part of the code that is generating that box. It is hard for me to troubleshoot it since I don't even know what I am looking for. Even a screenshot of the box might help.

 

I certainly don't have a box apearing anywhere during checkout.


Modules installed:

http://forums.oscommerce.com/index.php?showtopic=57259 - Options attributes

- wysiwyg editor

- cats on main page

- policies and terms

Share this post


Link to post
Share on other sites

Well I am happy to say that I finally got this contrib to work and tested it a couple of ways. Thanks to _bellys post awhile back. I installed it just like he said

 

CCGV5.16_1.51a

admin_rollup3

CCGV5.16_fixes_v1.1

 

works like a charm (well so far)

 

I didnt install any of the paypal ipn module stuff and I got regular paypal to work just fine. Showing the total, shipping total, and final total.

 

I just wanted to say thanks to _belly :thumbsup:


Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites
Well I am happy to say that I finally got this contrib to work and tested it a couple of ways. Thanks to _bellys post awhile back. I installed it just like he said

 

CCGV5.16_1.51a

admin_rollup3

CCGV5.16_fixes_v1.1

 

works like a charm (well so far)

 

I didnt install any of the paypal ipn module stuff and I got regular paypal to work just fine. Showing the total, shipping total, and final total.

 

I just wanted to say thanks to _belly :thumbsup:

 

Alright :)

 

BTW Squintz, I'm workin on it.

Share this post


Link to post
Share on other sites
_belly,

 

Can you do me a big favor and post the part of the code that is generating that box. It is hard for me to troubleshoot it since I don't even know what I am looking for. Even a screenshot of the box might help.

 

I certainly don't have a box apearing anywhere during checkout.

 

David, that part of the code is around Line 522:

 // #################### Begin Added CGV JONYO ######################

if (tep_session_is_registered('customer_id')) {
if ($gv_result['amount']>0){
 echo ' <tr><td width="10">' .  tep_draw_separator('pixel_trans.gif', '10', '1') .'</td><td colspan=2>' . "\n" .
							  ' <table border="0" cellpadding="2" cellspacing="0" width="100%"><tr class="moduleRow" onmouseover="rowOverEffect(this)" onclick="clearRadeos()" onmouseout="rowOutEffect(this)" >' . "\n" .
						 '   <td width="10">' .  tep_draw_separator('pixel_trans.gif', '10', '1') .'</td><td class="main">' . $gv_result['text'];

 echo $order_total_modules->sub_credit_selection();
 }
}


// #################### End Added CGV JONYO ######################

 

I believe the line "echo $order_total_module->sub_credit_selection();" calls catalog/includes/modules/ot_gv.php. Hope this helps.

 

Here is a screenshot:

 

Screenshot

 

Michael

Share this post


Link to post
Share on other sites

I have CCGV 5.16 installed and working pretty good, but I am still testing it. I ran into a problem after the install and have no idea where to look for the problem.

 

After entering a redeem code, wheather it is valid or not, the red "error" box that is supposed to show a message is there but no text in it. I have tried to redeem coupons that were valid but not for the purchase I was making and still no text in the red box.

 

Thanks for any ideas.

 

Sean

Share this post


Link to post
Share on other sites

Need to ask again; are there any known big issues with CCGV at this point (except with paypal that I'm not going to use)? If that is the case, I'd rather wait for next version that going through CCGV once again.. I need to remove 5.14 and install 5.16.

 

I believe I should go from CCGV 5.16 (8 Feb 2006) and look at all fixes uploaded since then?

 

I really want to use SEO, but that is not possible right now?

Edited by Fredrik.r

Share this post


Link to post
Share on other sites

_belly

 

Thanks for that code. I ended up having to remove and reinstall the Credit Card Error CCERROR module in order to get the box to show up. Now that the box is showing I have another problem. When I click the box it apears that it should clear all the payment methods but it is not doing this. When I click continue the money is not being deducted from my account.

 

Any ideas guys?


Modules installed:

http://forums.oscommerce.com/index.php?showtopic=57259 - Options attributes

- wysiwyg editor

- cats on main page

- policies and terms

Share this post


Link to post
Share on other sites

Okay, I was able to get the voucher to almost work correctly. I had to clear all the items out of my cart and re-add them. Then when I checked out the money was deducted from the total. However, It was not deducted from the voucher account total like it should have been so the same $100 voucher I just used was still available for use again according to the account total.

 

THATS NOT GOOD :)

 

Should this mod work with all payment types or only paypal? I used the Check/Money order to test it and will probably be using something like Paypal and Authorize.net for actuall transactions.

 

Anyone have any insight?


Modules installed:

http://forums.oscommerce.com/index.php?showtopic=57259 - Options attributes

- wysiwyg editor

- cats on main page

- policies and terms

Share this post


Link to post
Share on other sites

_belly/ Darren & anyone else:

 

I have installed CCGV and seem to have it working, I will only be using the coupon feature, and not the gift voucher--- so i'm not having any of the problems that people run into when trying to get the gift voucher working.

 

My question, is kind of advanced (I think) as it is about how CCGV works.. what I need to know is how/when/ where CCGV holds its coupon discounts. Reason being is i'm trying to create an rule to over ride another contribution, easy discount, if the CCGV coupon value is larger... for example it would be somthing like this:

 

if (______________ > $easy_discount->discounts['WEB']['amount'])
$easy_discount->clear('WEB');
}

 

The '__________' has to be something in regards to the coupon discount, maybe somting like....

$coupon->['x']

... but that not it. If you or anyone has an idea it would be of great help.

 

Thanks in advance,

 

Nate

Share this post


Link to post
Share on other sites

Nate,

 

As a quick thought, I'd look at the point where it is doing the order total update once a coupon is redeemed. As far as I can tell, this is done at the start of the checkout confirmation page.. the coupon amount is determined somewhere in there and applied to the order. After this, the "error" message.. something like "coupon successfully applied" is set, then it kicks you back to the payment page with an updated order total..

 

I wish I could help out more but I'm just too pressed for time this week.

 

Regards,

Darren

Share this post


Link to post
Share on other sites
Need to ask again; are there any known big issues with CCGV at this point (except with paypal that I'm not going to use)? If that is the case, I'd rather wait for next version that going through CCGV once again.. I need to remove 5.14 and install 5.16.

 

I believe I should go from CCGV 5.16 (8 Feb 2006) and look at all fixes uploaded since then?

 

I really want to use SEO, but that is not possible right now?

 

Fredrick, I'd be hesitant to to install CCGV on a working shop. I've got mine installed on a test shop, along with the easy checkout mod and a CSS conversion that I've still yet to complete. To me a large part of the problem is the lack of clarity about the mod (as with many others). I would be much happier if there was a psuedocode layout about what this mod does, and where it happens, rather than trying to "reverse engineer" it for troubleshooting. It seems we are getting a better understanding in time, but don't expect this mod to work for you straight out of the box, and even if it seems to, you would be well advised to test it thoroughly. I have an earlier post recommending an installation path that worked well for me, but to say I had no issues arising from the installation would be a misnomer. In fact, I've yet to really test it out, as I'm working on some other modifications at the time. Once I test it for production, hopefully next week, I expect issues to arise and will attempt to post any fixes that I can figure out.

 

All the best,

Darren

Share this post


Link to post
Share on other sites
_belly

 

Thanks for that code. I ended up having to remove and reinstall the Credit Card Error CCERROR module in order to get the box to show up. Now that the box is showing I have another problem. When I click the box it apears that it should clear all the payment methods but it is not doing this. When I click continue the money is not being deducted from my account.

 

Any ideas guys?

 

David, not sure here, but I don't think the Gift Certificate SHOULD clear the other payment boxes, as I believe it is treated as an "added on" payment option. If it was intended as an exclusive option, it should be in the form of another radio button, and in such case, clear the other payment options. For instance, if the total is 100.00 and you want to use a $50 gift certificate, payment from CCard, Paypal or whatever is still required.

 

Now what I'm NOT sure about is if the Gift Certificate meets or exceeds the payment amount - what will happen if a user has CCard info filled out? On the checkout confirmation page I'd EXPECT the payment method (other than the Gift Certificate) to be invalidated - but I'm not sure what will happen as I haven't tested it out.

Share this post


Link to post
Share on other sites
Can anyone tell me where in the code, the payment method is written to the Orders table?

 

Michael

 

checkout_process.php -- starts at line 79 for me:

 

 

 $sql_data_array = array('customers_id' => $customer_id,
					  'customers_name' => $order->customer['firstname'] . ' ' . $order->customer['lastname'],
					  'customers_company' => $order->customer['company'],
					  'customers_street_address' => $order->customer['street_address'],
					  'customers_suburb' => $order->customer['suburb'],
					  'customers_city' => $order->customer['city'],
					  'customers_postcode' => $order->customer['postcode'],
					  'customers_state' => $order->customer['state'],
					  'customers_country' => $order->customer['country']['title'],
					  'customers_telephone' => $order->customer['telephone'],
					  'customers_email_address' => $order->customer['email_address'],
					  'customers_address_format_id' => $order->customer['format_id'],
					  'delivery_name' => $order->delivery['firstname'] . ' ' . $order->delivery['lastname'],
					  'delivery_company' => $order->delivery['company'],
					  'delivery_street_address' => $order->delivery['street_address'],
					  'delivery_suburb' => $order->delivery['suburb'],
					  'delivery_city' => $order->delivery['city'],
					  'delivery_postcode' => $order->delivery['postcode'],
					  'delivery_state' => $order->delivery['state'],
					  'delivery_country' => $order->delivery['country']['title'],
					  'delivery_address_format_id' => $order->delivery['format_id'],
					  'billing_name' => $order->billing['firstname'] . ' ' . $order->billing['lastname'],
					  'billing_company' => $order->billing['company'],
					  'billing_street_address' => $order->billing['street_address'],
					  'billing_suburb' => $order->billing['suburb'],
					  'billing_city' => $order->billing['city'],
					  'billing_postcode' => $order->billing['postcode'],
					  'billing_state' => $order->billing['state'],
					  'billing_country' => $order->billing['country']['title'],
					  'billing_address_format_id' => $order->billing['format_id'],
	  here>>>   'payment_method' => $order->info['payment_method'],
					  'cc_type' => $order->info['cc_type'],
					  'cc_owner' => $order->info['cc_owner'],
					  'cc_number' => $order->info['cc_number'],
					  'cc_expires' => $order->info['cc_expires'],
					  'date_purchased' => 'now()',
					  'orders_status' => DEFAULT_ORDERS_STATUS_ID,
				// the following field has been moved from orders to order_status_history
				// 'comments' => $order->info['comments'],
					  'currency' => $order->info['currency'],
					  'currency_value' => $order->info['currency_value']);

 tep_db_perform(TABLE_ORDERS, $sql_data_array);
$insert_id = tep_db_insert_id();

 

I found this in 30 seconds - you can too:

1. download ultraedit http://www.ultraedit.com

2. install

3. Search > "find in files", enter "order" in the search box, browse and point the search start to your local copy of the website (root folder), make sure "search subdirectories" is checked and "match case" isn't, and away you go. :thumbsup:

Edited by _belly

Share this post


Link to post
Share on other sites
OK, it appears that the coupon is redeeming OK in the end, but when you click on Redeem or Continue on the checkout_payment.php page, it takes you back to the login page. If you click the back button, the coupon is shown in the shopping cart and you can continue with your purchase.

It's just this redirect to the login page - can anyone point me in the right direction to fix this? Thanks!

I'm having the same problem; click "Redeem" and I'm redirected to the login page. Click back and the coupon has been entered. It appears to be an interaction with Ultimate SEO that's causing the problem, if I turn SEO off the Redeem button works correctly. I've found several posts of this redirect problem but no solutions. Anyone know of a possible fix?

Share this post


Link to post
Share on other sites
Sean,

 

Are you using SEO URL? if so this will cause a similar problem....

Yes I am using ultimate SEO URLs, but I currently have it turned off.

 

Sean

Share this post


Link to post
Share on other sites
Yes I am using ultimate SEO URLs, but I currently have it turned off.

 

Sean

 

You can turn SEO URLs back on, but make sure that in:

 

Admin --> SEO URLs --> Set 'Configure Output W3C valid URLs (parameter string)?' to False

 

This should fix the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×