Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

Doesn't anyone else get a pop up window when they click the redeem button that says they haven't entered enough digits in the credit card field?

 

What's the fix?

Share this post


Link to post
Share on other sites

Well I had no offers to help with my problems so I guess I am going to remove this contribution and wait for someone to actually take a grip of this contribution and repair it from the bottom up instead of everyone chipping in and trying to help with their piece of "sticky plaster" which is good but makes it impossible to keep up with.

 

It is a shame because what I have seen of it - it has the makings of a classic contribution that is a really worthwhile addition :(

 

John

Share this post


Link to post
Share on other sites

I installed this Mod and during the process one of the steps was to replace the existing paypal mod. And Add the paypal IPN mod. Now when i go into the admin to configure the pay pal mod it looks like the images below. Any idea why all the extra textboxes are showing up?

 

Also, it seems like the language definitions are missing from includes/language/english.php for the checkout page. Its a simple fix but I am wondering what those variables are supposed to say by default. Such as the TEXT_ENTER_GV_CODE and all the others that have been asked about a million time. I have read through the last few post and have not seen the answer.

 

And lastly can anyone tell me the difference between the PayPal and the PayPal IPN module are. Are they both needed to run the GV mod? Do I need to setup anything extra with my paypal account. It looks like IPN is simply a way to transmit data to paypal.

 

paypalmod1.gif

paypalmod2.gif

paypalmod3.gif


Modules installed:

http://forums.oscommerce.com/index.php?showtopic=57259 - Options attributes

- wysiwyg editor

- cats on main page

- policies and terms

Share this post


Link to post
Share on other sites

PLease ignore the post above. I realizes THIS is the thread! LOL!!

 

-----------

 

Hi,

 

I just installed this module on my oscommerce store and seem to have a problem.

 

I ran a test purchase of a gift certificate. The purchase seems to have gone through fine.

 

But, the link that is supposed to say 'Send Gift Voucher' is not appearing in the shopping cart box like it says in the FAQ.

 

Also, the Gift Voucher does not appear in the Gift Voucher Queue.

 

As stated in the readme file, I started the Model Number with GIFT - in this case GIFT25.

 

If you go to my site HERE you can see that the link does not appear.

 

I followed the very basic instruction for installation. Is there something else I should have done?

 

Thanks!

 

Mark

Edited by jazzmark

Share this post


Link to post
Share on other sites
I also just noticed that the coupon redemption field is not showing in the checkout. :(

 

Argh! Please help.

 

did you install / enable Discount Coupons and/or Gift Vouchers in the admin section?

admin: modules > Order Total ....

Share this post


Link to post
Share on other sites

D'oh!!!

 

Well, that solved the coupon code redemption issue.

 

Still don't have a Send Gift Voucher Link though.

Share this post


Link to post
Share on other sites
so you're pretty much having the same issue. WAs the gift voucher amount more than the total of your order?

 

it was less - this is not the problem

Share this post


Link to post
Share on other sites
can some one inform me what each bit of code added to checkout process.php does with all code added my sales go through checkout confirmation and success and then just goes straight to the default home page not paypal? with them all removed it goes through to paypal no problem. But with this done of course i can use gift vouchers as payment no problem but it doesn't deduct from the total of gift vouchers i have in my account.

 

 

Still need an explanation of code added to checkout process php. need to know what each bit does.

Share this post


Link to post
Share on other sites

Hey _belly

 

I did this same thing right before you posted:

 

So I changed the code so that (Y) now precedes (X)

 

For some reason I had this code in there twice:

 

// load the before_process function from the payment modules
$payment_modules->before_process();

 

I deleted the one above the

 

// Make sure the /catalog/includes/class/order.php is included
// and $order object is created before this!!!
if(MODULE_PAYMENT_AUTHORIZENET_STATUS) {
	include(DIR_WS_MODULES . 'authorizenet_direct.php');

 

and everything seems to be working fine for me now. So this must be the solution if both of us did it and it worked.

Share this post


Link to post
Share on other sites
Also, it seems like the language definitions are missing from includes/language/english.php for the checkout page. Its a simple fix but I am wondering what those variables are supposed to say by default. Such as the TEXT_ENTER_GV_CODE and all the others that have been asked about a million time. I have read through the last few post and have not seen the answer.

 

 

your language is going to be in the following files:

 

includes/languages/english/checkout_shipping.php

includes/languages/english/checkout_payment.php

includes/languages/english/checkout_confirmation.php

Share this post


Link to post
Share on other sites
your language is going to be in the following files:

 

includes/languages/english/checkout_shipping.php

includes/languages/english/checkout_payment.php

includes/languages/english/checkout_confirmation.php

 

Sethman - glad to hear you got it running too :)

 

BTW, I found the "TEXT_ENTER_GV_CODE" (and others) in:

catalog/includes/languages/english/modules/order_total/ot_gv.php

and its not included unless you enable/install the Gift Voucher module in admin section.

Share this post


Link to post
Share on other sites

Has anyone gotten this to work properly?

 

I really would love to add a gift certificate section to my store, but it is modified and live so I really dont want to bring it down for too long.

 

I downloaded the last 5 or 6 fixes on the contrib section and I am trying to fix all the bugs before I upload it.

 

Just looking for some feedback, thats all.

 

Dave

Share this post


Link to post
Share on other sites
Hi!

I am having the same problem as jazzmark is, the exact same problem with GV, it doesn't show in the shopping cart box, doesn't show in payment options when I buy something either.

 

Can you help?

 

thanks,

 

 

Elaine

 

I don't really have this completely configured, though I'll try and get you to the point I'm at.

First of all, read post #3703:

Make sure you have adminrollup3 and CCGV5.16_fixes_v1.1

completed.

Make sure you have installed/enabled both coupon vouchers and Gift Certificates in the admin section as well as enabling downloads in the admin > configuration > download section.

 

To get Gift certificates to show up as a purchase option, add the gift certificate(s) as a new product(s) in the

admin > catalog section. Make sure you name the gift certificate starting with "GIFT" and be sure to set the

product weight to 0 for shipping purposes. The contribution download will have gift certificate images you can use when doing this. If all goes properly, this should now show up as a purchase, though I am unsure

as of yet how to, for example:

have customerA buy one for customerB and email this gift certificate to customerB. I just haven't had

the time to search around and figure it out completely.

Share this post


Link to post
Share on other sites

Ok I installed it and looks like it is working at the moment.

 

I need to fix the download part and I am not using any paypal modules just the regular paypal

 

I am getting these lines and need to remove them.

 

MODULE_PAYMENT_PAYPAL_CC_TEXT

MODULE_PAYMENT_PAYPAL_CC_DESCRIPTION MODULE_PAYMENT_PAYPAL_CC_URL_TEXT

 

Can someone assist me?

Share this post


Link to post
Share on other sites
Ok I installed it and looks like it is working at the moment.

 

I need to fix the download part and I am not using any paypal modules just the regular paypal

 

I am getting these lines and need to remove them.

 

MODULE_PAYMENT_PAYPAL_CC_TEXT

MODULE_PAYMENT_PAYPAL_CC_DESCRIPTION MODULE_PAYMENT_PAYPAL_CC_URL_TEXT

 

Can someone assist me?

 

Hey Dave,

 

All the TEXT_WHATEVERS are going to be in their respective language file. Those will probably be in one of the following:

 

catalog/includes/languages/

Share this post


Link to post
Share on other sites

I cant find them anywhere in those language files. I must be missing something.

 

I have a more serious issue to attend to

 

When I use the paypal checkout I get this error upon order confirmation

 

Warning: before_process(includes/modules/payment/paypal/classes/osC/osC.class.php): failed to open stream: No such file or directory in **/catalog/includes/modules/payment/paypal.php on line 141

 

Warning: before_process(): Failed opening 'includes/modules/payment/paypal/classes/osC/osC.class.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in **/catalog/includes/modules/payment/paypal.php on line 141

 

Fatal error: Undefined class name 'paypal_osc' in **/catalog/includes/modules/payment/paypal.php on line 142

Share this post


Link to post
Share on other sites

I have this issue as well.

 

Everything lines up with my fixed width site except the payment option screen.

 

I cant seem to get it to stay a fixed width it gets blown out the right side.

 

Any suggestions?

rightside.jpg

Thanks,

 

Dave

Share this post


Link to post
Share on other sites
Fatal error: Undefined class name 'paypal_osc' in **/catalog/includes/modules/payment/paypal.php on line 142

 

I am also seeing the same error:

 

PHP Fatal error: Undefined class name 'paypal_osc' in /var/www/html/smarterior/includes/modules/payment/paypal.php on line 142, referer: https://www.smarterior.com/checkout_confirmation.php

 

Anyone have any ideas? I am guessing there is simply a class missing from the /includes/classes/ folder. It is hard to tell because the PayPal.php being distributed is not commented very well.


Modules installed:

http://forums.oscommerce.com/index.php?showtopic=57259 - Options attributes

- wysiwyg editor

- cats on main page

- policies and terms

Share this post


Link to post
Share on other sites

I am thinking that the issue lies in here somewhere.

 

function before_process() {

if(!class_exists('PayPal_osC')) include_once(DIR_WS_MODULES . 'payment/paypal/classes/osC/osC.class.php');

if (PayPal_osC::check_order_status()) {

tep_redirect(tep_href_link(FILENAME_SHOPPING_CART, '', 'SSL'));

} else {

include(DIR_WS_MODULES . 'payment/paypal/catalog/checkout_process.inc.php');

}

exit;

}

 

I am noticing a few classes that do not exist in my build such as 'payment/paypal/classes/osC/osC.class.php' and 'payment/paypal/catalog/checkout_process.inc.php'

 

Line 142 is if(!class_exists('PayPal_osC')) include_once (DIR_WS_MODULES . 'payment/paypal/classes/osC/osC.class.php');

 

I am going to play around and see if i can get the error to go away but I would really like to know if this is an isolated case or if more than two people are seeing this. I may be looking at the wrong file and be getting mis lead by the php error.


Modules installed:

http://forums.oscommerce.com/index.php?showtopic=57259 - Options attributes

- wysiwyg editor

- cats on main page

- policies and terms

Share this post


Link to post
Share on other sites

I am having an issue where I always get the error "You did not enter a redeem code" whenever I go to the checkout page. Even when I have a valide coupon and the value is subtracted, I still get this error. Does anyone have any idea what may be going on here?

 

Thanks.

Share this post


Link to post
Share on other sites

One more problem I am having for the records. I enabled a flat rate shipping charge and I dont see it showing up in the checkout_payment.php page. I have this:

 

$192.95

Sub-Total: $192.95

Discount Coupons:test: -$1.00

Maryland TAX 5.0%: $9.60

Total: $201.55

 

And I want to have this

 

$192.95

Sub-Total: $192.95

Discount Coupons:test: -$1.00

Maryland TAX 5.0%: $9.60

Shipping: $6.90

Total: $208.45

 

But for some reason Shipping is not showing up. Can anyone help with this?


Modules installed:

http://forums.oscommerce.com/index.php?showtopic=57259 - Options attributes

- wysiwyg editor

- cats on main page

- policies and terms

Share this post


Link to post
Share on other sites
One more problem I am having for the records. I enabled a flat rate shipping charge and I dont see it showing up in the checkout_payment.php page. I have this:

 

$192.95

Sub-Total: $192.95

Discount Coupons:test: -$1.00

Maryland TAX 5.0%: $9.60

Total: $201.55

 

And I want to have this

 

$192.95

Sub-Total: $192.95

Discount Coupons:test: -$1.00

Maryland TAX 5.0%: $9.60

Shipping: $6.90

Total: $208.45

 

But for some reason Shipping is not showing up. Can anyone help with this?

 

Have you successfully enabled flat rate shipping without this mod anywhere? When I first tried setting up a table, I had the same problem and found out there was a bug... hmm what the heck was it... oh ya..

I based mine on price and it won't work if the table starts with a zero dollar price. And of course the obvious,

make sure its installed and enabled, etc. and I'm not sure, but tare weight seems to cause problems for quite a few folk, so if nothing else works try enabling/disabling that module as well.

 

Also, squintz, take a good look into this thread... there were a lot of paypal issues addressed (at least it seemed so) quite a few pages back... like about 3 or 400 posts ago. Good luck

Edited by _belly

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×