Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

If anyone knows when molafish will be ready to release the pulled-together update I'd really really like to know... I'm also wondering how it's so hard to get this thing to work, though my php skills are rudimentary at best...

 

If anyone knows, it's molafish. Ask him.

 

I totally agree on this,

publishing distributions this way must be stopped. It is an insult to the open source community. This hasn't been tested very well (if at all) before publishing in the first place. Going trhough the forum I can't imagine anyone having this contrib working fully. Now community members like Shane Jackson are cleaning up the mess. This contrib is a waste of community effort.....

But I still hope it'll work out one day, I like the idea of this contrib for my shop.........

 

Hubert

 

You are right. The contrib as it stands currently is an abysmal mess. All the more reason to stop by and help test!

 

This happened because we didn't have anyone take charge of the contribution and guide development and bug fixing. This will get better, I promise.

 

Update on my progress:

 

I have a working copy installed on a server. I am going through now and fixing known bugs. Every time I do I find three more. After I've done my testing I will post it.

 

Stay tuned.

Share this post


Link to post
Share on other sites

I had someone convert the rar file to a zip file for me, and I put both parts together into one zip file that I submitted for others who can't open a rar file. Once it's approved, it should be available in the contribution list. I didn't do anything to the mod other than to put it into zip format.


Tara Lang

Share this post


Link to post
Share on other sites

One thing that has been bothering me about this contribution has been the error text in the URL when redeeming a valid coupon or gift voucher. The other thing is the fact that the error coding is also used for successful redemption of coupons and gift vouchers resulting in a success message placed into a red error box on Checkout Payment.

 

I have resolved these two issues. I have added code to resolve the URL redemption text and I have reworked a section of checkout_payment.php so that the Message Stack Class is now used for both errors and successes. The Message Stack Class utilizes a warning icon (yellow triangle with exclamation point) for coupon and voucher errors in the default red/pink message box and a success icon (yellow light bulb exclamation) for coupon and voucher successes in a green message box. The Message Stack Class colors are easily changed at the end of the stylesheet.css.

 

This is an example of a coupon error using the Message Stack Class:

 

010.jpg

 

This is an example of the error shown in the URL:

 

https://<your_web_site>/catalog/checkout_payment.php?payment_error=ot_coupon&error=Invalid+Coupon+Code&osCsid=c601066506eacc4e208d7c9dda181450

 

 

This is an example of a coupon success using the Message Stack Class:

 

011.jpg

 

This is an example of the success shown in the URL:

 

https://<your_web_site>/catalog/checkout_payment.php?redemption_successful=ot_coupon&success=Congratulations%2C+you+have+redeemed+%243.30.&osCsid=c601066506eacc4e208d7c9dda181450

 

 

Here are the code changes:

 

In /catalog/checkout_payment.php find this code:

 

<?php
 if (isset($HTTP_GET_VARS['payment_error']) && is_object(${$HTTP_GET_VARS['payment_error']}) && ($error = ${$HTTP_GET_VARS['payment_error']}->get_error())) {
?>
  <tr>
	<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
	  <tr>
		<td class="main"><b><?php echo tep_output_string_protected($error['title']); ?></b></td>
	  </tr>
	</table></td>
  </tr>
  <tr>
	<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBoxNotice">
	  <tr class="infoBoxNoticeContents">
		<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
		  <tr>
			<td><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
			<td class="main" width="100%" valign="top"><?php echo tep_output_string_protected($error['error']); ?></td>
			<td><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
		  </tr>
		</table></td>
	  </tr>
	</table></td>
  </tr>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
<?php
 }
?>

 

 

 

Replace it with this code:

 

<!-- BEGIN >>> CCVG v5.15 - Custom Modification - Display Success & Error messages using Message Stack Class -->
<?php
 if (isset($HTTP_GET_VARS['payment_error']) && is_object(${$HTTP_GET_VARS['payment_error']}) && ($error = ${$HTTP_GET_VARS['payment_error']}->get_error())) {
?>
  <tr>
	<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
	  <tr>
		<td class="main"><b><?php echo tep_output_string_protected($error['title']); ?></b></td>
	  </tr>
	</table></td>
  </tr>
  <tr>
	<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
	<td class="main" width="100%" valign="top">
<?php
 $messageStack = new messageStack();
 $messageStack->add('general', $error['error'], 'warning');
 if ($messageStack->size('general') > 0) echo $messageStack->output('general');
?>
	</td> 
	<td class="main" width="100%" valign="top"></td>
	</table></td>
  </tr>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
<?php
} elseif (isset($HTTP_GET_VARS['redemption_successful']) && is_object(${$HTTP_GET_VARS['redemption_successful']}) && ($success = ${$HTTP_GET_VARS['redemption_successful']}->get_success()))  {
?>
  <tr>
	<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
	  <tr>
		<td class="main"><b><?php echo tep_output_string_protected($success['title']); ?></b></td>
	  </tr>
	</table></td>
  </tr>
  <tr>
	<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
	<td class="main" width="100%" valign="top">
<?php
 $messageStack = new messageStack();
 $messageStack->add('general', $success['success'], 'success');
 if ($messageStack->size('general') > 0) echo $messageStack->output('general');
?>
	</td>
	<td class="main" width="100%" valign="top"></td>
  </tr>
  </table></td>
<tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
<?php
 }
?>
<!-- END <<< CCVG v5.15 - Custom Modification - Display Success & Error messages using Message Stack Class -->

 

 

In /catalog/includes/modules/order_total/ot_coupon.php find this code:

 

		if ( strlen($cc_id)>0 && $coupon_amount==0 ) {
	  $err_msg = ERROR_REDEEMED_AMOUNT.ERROR_REDEEMED_AMOUNT_ZERO;
	} else {
	  $err_msg = ERROR_REDEEMED_AMOUNT.$coupon_amount_out;
	}
	tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'payment_error='.$this->code.'&error=' . urlencode($err_msg), 'SSL'));

 

Replace it with this code:

 

		// BEGIN >>> CCVG v5.15 - Custom Modification - Display Success Message and URL text, Use Function get_success
	if ( strlen($cc_id)>0 && $coupon_amount==0 ) {
	  $msg = ERROR_REDEEMED_AMOUNT.ERROR_REDEEMED_AMOUNT_ZERO;
	} else {
	  $msg = ERROR_REDEEMED_AMOUNT.$coupon_amount_out;
	}
	tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'redemption_successful='.$this->code.'&success=' . urlencode($msg), 'SSL'));
	//tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'payment_error='.$this->code.'&error=' . urlencode($err_msg), 'SSL'));
	// END <<< CCVG v5.15 - Custom Modification - Display Success Message and URL text, Use Function get_success

 

In /catalog/includes/modules/order_total/ot_coupon.php AND in /catalog/modules/order_total/ot_gv.php find this code:

 

	return $error;
 }

 

Replace it with this code:

 

	return $error;
 }

 // BEGIN >>> CCVG v5.15 - Custom Modification - Provide Success Messages
 // show module successes on checkout_payment page
 function get_success() {
global $HTTP_GET_VARS;
$success = array('title' => MODULE_ORDER_TOTAL_COUPON_TEXT_ERROR,
'success' => stripslashes(urldecode($HTTP_GET_VARS['success'])));
return $success;
 }
 // END <<< CCVG v5.15 - Custom Modification - Provide Success Messages

 

In /catalog/modules/order_total/ot_gv.php find this code:

 

tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'payment_error='.$this->code.'&error=' . urlencode(ERROR_REDEEMED_AMOUNT. $currencies->format($gv_amount)), 'SSL'));

 

Replace it with this code:

 

		  // BEGIN >>> CCVG v5.15 - Custom Modification - Display Success Message and URL text, Use Function get_success
	  tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'redemption_successful='.$this->code.'&success=' . urlencode(ERROR_REDEEMED_AMOUNT. $currencies->format($gv_amount)), 'SSL'));
	  // END <<< CCVG v5.15 - Custom Modification - Display Success Message and URL text, Use Function get_success
   }

 

 

If you decide to make this change, please post your results so we can all benefit and maybe it will make it into Ian's upcoming stable re-package contribution.

 

Joe

Share this post


Link to post
Share on other sites
in the Update 5.13a that Rigadin contributed, he added the following code to the includes\modules\order_total\ot_coupon.php file:

tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'payment_error='.$this->code.'&error=' . urlencode(ERROR_REDEEMED_AMOUNT), 'SSL')); // Added in v5.13a by Rigadin

 

Not sure why a successful redeem is being redirect to the payment_error function. Anyone have any suggestions?

 

He felt it was easier to code the communication to the user about the coupons and gift vouchers during the checkout process by using the error reporting process.

 

I don't like this, and it should be changed. It also causes problems with special characters (such as umlauts in german) being displayed because all html chars are stripped out as a security precaution as they are parsed from the html query.

 

With that being said, it can be put on the backburner. Primadude in the meantime has modified the stack so that the customer is not scared by a red warning which says Congratulations!

Share this post


Link to post
Share on other sites
Hey, I'm using 5.13a and whenever I add a percentage in the amount field... like 50% and it looks fine in preview, but when I submit it, it changes to $50.00 instead of a percentage.

 

How do I correct this?

Cartel,

 

This happens when you have selected the Free Shipping checkbox. Percent seems to work only when Free Shipping is deselected. Not if this was by design or not.

 

Joe

 

Right now the documentation (next to the free checking checkbox on the admin page) says: "The coupon gives free shipping on an order. Note. This overrides the coupon_amount figure but respects the minimum order value."

 

The "overrides" part is by design. Really, the amount should not be recorded if free checking is checked. If that checks conceptually with everyone, I'll change that in the admin tool.

 

It seems that the free shipping coupon is not working as expected anyway. If you do enter a dollar amount or percentage with free shipping checked, the percentage is changed to a dollar amount and that dollar amount is ADDED to whatever the shipping cost is to derive the order discount.

 

Example: shipping costs 5 dollars. If a coupon is applied which has free checking checked and has 2.5 in the amount field, the discount showing on checkout_confirmation.php is $7.50.

 

I have to rethink how checkout_confirmation should show the free shipping. The fixed sort order complicates things a little.

 

Obviously, this should not happen. It should deduct 5.00. I'll post the fix here.

Share this post


Link to post
Share on other sites

In my last post, where I said "free checking" I meant "free shipping."

 

Does the ability to edit your own post expire after a set amount of time?

Share this post


Link to post
Share on other sites

I've been using CCGV for a while and it's great!

 

But now I want to restrict it to a range of products, but I don't know what cpaths are Coiuld someone give me an example.

 

BTW, I am using search engine freindly URLs is that makes any difference.

 

Thanks

Share this post


Link to post
Share on other sites
Leslie, yes I noticed that quirk when you edit a coupon, it puts in some default values that you need to reset if you re-save the coupon...

 

Joe

 

Obviously, this should not happen. It should deduct 5.00. I'll post the fix here.

 

I've done a lot of fix work to admin/coupon_admin.php tonight.

 

I'm going to put it up on the contrib page.

 

Here's the highlights:

  • Fixed coupon_admin from overwriting dates and customer uses fields to defaults when editing or displaying an error. (default uses per customer is 1 and default date range is now() to now() + 1 year).
  • removed non-working length check of coupon_name field in coupon_admin, fixed other possibly non-working checks. (instead of fixing the check, I made the name optional. It was desirable for me to have the option to display just the coupon code to the customer).
  • fixed problem where free shipping coupons deduct an additional amount (if the amount was specified on the coupon_admin page) above the shipping cost. During coupon creation now, the amount will be zeroed out if free shipping is checked. (You will need to edit all of your previous coupons which have both an amount and free shipping checked for this to take effect).
  • fixed missing or hard coded language text used on coupon_admin page for errors and buttons.
  • changed Coupon Name help text to reflect the unrequired nature of that field. (Your contrib probably still displays nothing if the name field is blank for a language - I have changed all instances of that to display the coupon code instead in my unpublished contrib. Until I put up the full contrib, just continue to enter the coupon name field to avoid this).

All these changes are made only to one file: admin/coupon_admin.php. Except for the missing language text item, which will require you to add these 6 lines to your admin/includes/languages/[language]/coupon_admin.php file:

 

define('ERROR_NO_COUPON_AMOUNT', 'Error: No coupon amount has been entered. Either enter an amount or select free shipping.');
define('ERROR_COUPON_EXISTS', 'Error: A coupon with the same coupon code already exists.');
define('COUPON_BUTTON_EMAIL_VOUCHER', 'Email Voucher');
define('COUPON_BUTTON_EDIT_VOUCHER', 'Edit Voucher');
define('COUPON_BUTTON_DELETE_VOUCHER', 'Delete Voucher');
define('COUPON_BUTTON_VOUCHER_REPORT', 'Voucher Report');

Share this post


Link to post
Share on other sites

I have installed 5.14 and checked all files in the contributions are until 10 august 2005. I would be very thankful if someone can assist me which fixes and version I should use when updating? I'm about to use this contrib on several stores, and now Is the time to get this work properly. Any help is appreciated! Thank you!

Share this post


Link to post
Share on other sites
I have installed 5.14 and checked all files in the contributions are until 10 august 2005. I would be very thankful if someone can assist me which fixes and version I should use when updating? I'm about to use this contrib on several stores, and now Is the time to get this work properly. Any help is appreciated! Thank you!

 

My recomindation is to WAIT!! A new release is in the works. It has a ton of fixes and it will save you more time to wait then to try and fix all the problems manualy.

Share this post


Link to post
Share on other sites

Has anyone had or got the same problem i'm getting in the coupon_admin.php this part doesn't load up on page what is the problem? does anyone know?

 

 

<td align="left" class="main"><?php echo COUPON_STARTDATE; ?></td>

<td align="left"><?php echo tep_draw_date_selector('coupon_startdate', mktime(0,0,0, $coupon_startdate[1], $coupon_startdate[2], $coupon_startdate[0], 0)); ?></td>

<td align="left" class="main"><?php echo COUPON_STARTDATE_HELP; ?></td>

</tr>

<tr>

<td align="left" class="main"><?php echo COUPON_FINISHDATE; ?></td>

<td align="left"><?php echo tep_draw_date_selector('coupon_finishdate', mktime(0,0,0, $coupon_finishdate[1], $coupon_finishdate[2], $coupon_finishdate[0], 0)); ?></td>

<td align="left" class="main"><?php echo COUPON_FINISHDATE_HELP; ?></td>

</tr>

<tr>

<td align="left"><?php echo tep_image_submit('button_preview.gif',IMAGE_PREVIEW); ?></td>

<td align="left"><?php echo '  <a href="' . tep_href_link('coupon_admin.php', ''); ?>"><?php echo tep_image_button('button_cancel.gif', IMAGE_CANCEL); ?></a>

</td>

</tr>

</td></table></form>

</tr>

 

</table></td>

Share this post


Link to post
Share on other sites

also with this contribution installed it skips the shipping page and jumps straight into the payment page on all orders placed? why is this? plus i usually have COD as an option for payment this has disappeared from choices why this?

 

can i get this sorted? so that i have shipping page back and cod is left as an option.

 

 

can anyone help.

Share this post


Link to post
Share on other sites
My recomindation is to WAIT!! A new release is in the works. It has a ton of fixes and it will save you more time to wait then to try and fix all the problems manualy.

 

Thank you! I'll do that.

Share this post


Link to post
Share on other sites

Hello every body,

I've installed the lates version of CCGV.

It works fine before some time say a month ago..After installing points and reward contrib (1.5), now I'm facing problem on checkout_payment.php..

Whenever a customer comes to this page he/she can't see the redeem your code section.

then I try to figure out the problem and find something strange. After passing the checkout_payment.php and when u r on checkout_confirmation page after clicking edit payment come back to checkout_payment.php and hurray u get your ccgv code here... :huh:

 

can anybody help me out?? its urgent

 

Thanx in advance

KERUL

Share this post


Link to post
Share on other sites

I installed CCGV about a week ago, and ran into a number of issues. I've since hammered most of them out, but now am faced with the following. The first one, is during the checkout I get the following text:

 

Congratulations, you have redeemed <span class=currency_symbol>$</span>1.00<span class=currency_symbol></span> on orders greater than <span class=currency_symbol>$</span>1.00<span class=currency_symbol></span>

 

My question, which file(s) can I edit to get rid of the <span class>, etc; so I'm getting just text?

 

Also. during the checkout process after I enter the coupon code the first time, I get a message to the effect of 'reduction not available, see restrictions', but after entering again, it goes through. Any ideas on this?

 

Thanks ...

 

Ron

Share this post


Link to post
Share on other sites

Hi Guys,

 

Please help, i have below 2 problems after i install CCVG5.15a2(follow instruction, just copy into new, clean fresh copies of oscommerce-2.2ms2-051113),

 

1.) in admin:"Payment Modules" page

 

Warning: main(/home/theshop/domains/theshop.com.my/public_html/ctg/includes/languages/english/modules/payment/paypal_ipn.php): failed to open stream: No such file or directory in /home/theshop/domains/theshop.com.my/public_html/ctg/admin/modules.php on line 128

 

Warning: main(/home/theshop/domains/theshop.com.my/public_html/ctg/includes/languages/english/modules/payment/paypal_ipn.php): failed to open stream: No such file or directory in /home/theshop/domains/theshop.com.my/public_html/ctg/admin/modules.php on line 128

 

Warning: main(): Failed opening '/home/theshop/domains/theshop.com.my/public_html/ctg/includes/languages/english/modules/payment/paypal_ipn.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/theshop/domains/theshop.com.my/public_html/ctg/admin/modules.php on line 128

 

2.) in catalog: "Delivery Information" page

 

once i click on continue button, the link page is blank and nothing show up.

 

why? Please help :(

 

Thanks

Edited by brucelim

Share this post


Link to post
Share on other sites

Hi All,

 

I've been hunting for a solution to this problem for a few days now and I hope someone here can help me. I installed CCGV 5.15 and PayPal WPP. I've been tweaking my site with various smaller contributions but at some point a weird problem has cropped up that I can't seem to fix.

 

My redemption messages have all dissapeared! The red box shows, the title above the box shows, but the actual message isn't appearing. Any ideas on where to look? Since the box and the title are showing up and the coupon is shown as applied in the cart infobox it seems like it's 95% working, just the message is missing!

 

Any ideas on where to start? I diffed several files from backups but I can't seem to find the issue. I also checked the permissions on the lang files but no dice.

 

Any help would be most appreciated.

 

Thanks,

 

Karim

Share this post


Link to post
Share on other sites
Hi All,

 

I've been hunting for a solution to this problem for a few days now and I hope someone here can help me. I installed CCGV 5.15 and PayPal WPP. I've been tweaking my site with various smaller contributions but at some point a weird problem has cropped up that I can't seem to fix.

 

My redemption messages have all dissapeared! The red box shows, the title above the box shows, but the actual message isn't appearing. Any ideas on where to look? Since the box and the title are showing up and the coupon is shown as applied in the cart infobox it seems like it's 95% working, just the message is missing!

 

Any ideas on where to start? I diffed several files from backups but I can't seem to find the issue. I also checked the permissions on the lang files but no dice.

 

Any help would be most appreciated.

 

Thanks,

 

Karim

 

I realize that I'm replying to my own post, but I figured I'd add an extra bit of info that I just found. I know that this may not be the right place but here goes.

 

It appears that my URL encoding seems to have gotten all fudged up somehow (perhaps during Ultimate SEO URL's install?). The CCGV modules are functioning correctly but the url string being passed back to checkout _payment is placing the wrong query string delimiter between the payment_error and error keys.

 

checkout_payment.php?payment_error=ot_coupon&error=This+coupon+is+not+available+yet

 

Rather than:

 

checkout_payment.php?payment_error=ot_coupon&error=This+coupon+is+not+available+yet

 

Note the extra "amp;" in there.

 

Any ideas on how to fix this? I believe that the urlencode function is a PHP core function no? Maybe I'm encoding the string twice somewhere?

 

Any help from the guru's would be greatly appreciated.

 

Karim

Share this post


Link to post
Share on other sites
Has anyone had or got the same problem i'm getting in the coupon_admin.php this part doesn't load up on page what is the problem? does anyone know?

<td align="left" class="main"><?php echo COUPON_STARTDATE; ?></td>

<td align="left"><?php echo tep_draw_date_selector('coupon_startdate', mktime(0,0,0, $coupon_startdate[1], $coupon_startdate[2], $coupon_startdate[0], 0)); ?></td>

<td align="left" class="main"><?php echo COUPON_STARTDATE_HELP; ?></td>

</tr>

<tr>

<td align="left" class="main"><?php echo COUPON_FINISHDATE; ?></td>

<td align="left"><?php echo tep_draw_date_selector('coupon_finishdate', mktime(0,0,0, $coupon_finishdate[1], $coupon_finishdate[2], $coupon_finishdate[0], 0)); ?></td>

<td align="left" class="main"><?php echo COUPON_FINISHDATE_HELP; ?></td>

</tr>

<tr>

<td align="left"><?php echo tep_image_submit('button_preview.gif',IMAGE_PREVIEW); ?></td>

<td align="left"><?php echo '  <a href="' . tep_href_link('coupon_admin.php', ''); ?>"><?php echo tep_image_button('button_cancel.gif', IMAGE_CANCEL); ?></a>

</td>

</tr>

</td></table></form>

</tr>

 

</table></td>

 

 

Any ideas anyone ? still got this problem

Share this post


Link to post
Share on other sites
also with this contribution installed it skips the shipping page and jumps straight into the payment page on all orders placed? why is this? plus i usually have COD as an option for payment this has disappeared from choices why this?

 

can i get this sorted? so that i have shipping page back and cod is left as an option.

can anyone help.

 

 

Still need help on this one. Any ideas?

Share this post


Link to post
Share on other sites

Hi Guys,

 

Please help, i have below 2 problems after i install CCVG5.15a2(follow instruction, just copy into new, clean fresh copies of oscommerce-2.2ms2-051113),

 

1.) in admin:"Payment Modules" page

 

Warning: main(/home/theshop/domains/theshop.com.my/public_html/ctg/includes/languages/english/modules/payment/paypal_ipn.php): failed to open stream: No such file or directory in /home/theshop/domains/theshop.com.my/public_html/ctg/admin/modules.php on line 128

 

Warning: main(/home/theshop/domains/theshop.com.my/public_html/ctg/includes/languages/english/modules/payment/paypal_ipn.php): failed to open stream: No such file or directory in /home/theshop/domains/theshop.com.my/public_html/ctg/admin/modules.php on line 128

 

Warning: main(): Failed opening '/home/theshop/domains/theshop.com.my/public_html/ctg/includes/languages/english/modules/payment/paypal_ipn.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/theshop/domains/theshop.com.my/public_html/ctg/admin/modules.php on line 128

 

 

2.) in catalog: "Delivery Information" page

 

once i click on continue button, the link page is blank and nothing show up.

 

why? what should i do? Please help

 

Thanks

Share this post


Link to post
Share on other sites

Hi everybody,

 

Finally I found the problem but didn't get any solution.. it was due to installaiton of fast easy checkout contrib..

 

I lost my gift voucher code..

 

Its very urgent plz help me out if anybody knows about this..

 

Regards,

KERUL

Share this post


Link to post
Share on other sites
Hi Guys,

 

Please help, i have below 2 problems after i install CCVG5.15a2(follow instruction, just copy into new, clean fresh copies of oscommerce-2.2ms2-051113),

 

1.) in admin:"Payment Modules" page

 

Warning: main(/home/theshop/domains/theshop.com.my/public_html/ctg/includes/languages/english/modules/payment/paypal_ipn.php): failed to open stream: No such file or directory in /home/theshop/domains/theshop.com.my/public_html/ctg/admin/modules.php on line 128

 

Warning: main(/home/theshop/domains/theshop.com.my/public_html/ctg/includes/languages/english/modules/payment/paypal_ipn.php): failed to open stream: No such file or directory in /home/theshop/domains/theshop.com.my/public_html/ctg/admin/modules.php on line 128

 

Warning: main(): Failed opening '/home/theshop/domains/theshop.com.my/public_html/ctg/includes/languages/english/modules/payment/paypal_ipn.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/theshop/domains/theshop.com.my/public_html/ctg/admin/modules.php on line 128

2.) in catalog: "Delivery Information" page

 

once i click on continue button, the link page is blank and nothing show up.

 

why? what should i do? Please help

 

Thanks

 

I had found way to fix 1st problem refer http://www.oscommerce.com/community/contributions,282 :lol:, but 2nd problem still cant fix it anyone can share the idea to help me fix it pls.. Pls help.. :( Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×