Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

Just a quick note to say that i've added a file to the ccgv contribution which adds a categories/products treeview popup to the coupon_admin.php page.

 

This allows you to select the valid categories/products for your coupon by selecting the relevant checkboxes. When you close the popup the values are automatically passed back to the coupon_admin.php page.

 

 

This modification is VERY cool and VERY easy to implement. 2 simple steps!

 

Tested on Internet explorer and firefox browsers!

 

I recommend that you try it, it's easy to remove if you don't like it!

 

SEE screen_shot.jpg in the zip file and you'll understand what it does!

 

http://www.oscommerce.com/community/contributions,282


Light, in the absence of eyes, illuminates nothing.

Share this post


Link to post
Share on other sites
Sanguinarius

Try using the general.php file from Rigadin's Full package 5.13 of 22 Apr 2005 ... Just overwrite the one you have unless you have modified it for other modules. Hope this helps.

 

maddie

 

I downloaded that package and there was no general.php to be found in there. I sorted the files alphabetically, and still could not find it present. I doubled checked that it was the correct file that I downloaded, too. *frustrated look*

 

In fact, there isn't an /includes/functions/ folder present...


--Sanguinarius

 

If you're reading this, I'm probably pulling my hair out. ;>

 

*waiting for osCommerce 3.0 alpha 6* (I'm after the coupons.)

Share this post


Link to post
Share on other sites
Just a quick note to say that i've added a file to the ccgv contribution which adds a categories/products treeview popup to the coupon_admin.php page.

 

Tested on Internet explorer and firefox browsers!

http://www.oscommerce.com/community/contributions,282

 

It doesn't work at all for me, neither in Internet Explorer 6, Firefox 1.0.6 or Opera 8.

The popup loads, but the tree doesn't "unfold".. it just displays "catalog", and nothing else.

 

And no, i haven't made any modifications that should affect this :huh:

 

-vebbe

Share this post


Link to post
Share on other sites

This is a real painfull problem we currently have, we sell a good deal of clothing, and we currently can't have discounts for spesific categories.. why? because when someone buys clothing that has attributes (size, color etc) CCGV won't discount that merchandise. It is weird as heck.. it DOES discount the merchandise if a general store-wide discount-code is used, but NOT when a categori-spesific code is used.

 

Has anyone experienced this before, or have any tips?

We're getting kinda desperate here..

 

sincerely

-vebbe

Share this post


Link to post
Share on other sites
This is a real painfull problem we currently have, we sell a good deal of clothing, and we currently can't have discounts for spesific categories.. why? because when someone buys clothing that has attributes (size, color etc) CCGV won't discount that merchandise. It is weird as heck.. it DOES discount the merchandise if a general store-wide discount-code is used, but NOT when a categori-spesific code is used.

 

Has anyone experienced this before, or have any tips?

We're getting kinda desperate here..

 

sincerely

-vebbe

 

Man i feel dumb now for not reading back a few pages. I appologize to everyone, i managed to fix it by reading this post .

 

Again, sorry for spamming :blush:

Share this post


Link to post
Share on other sites
I downloaded that package and there was no general.php to be found in there. I sorted the files alphabetically, and still could not find it present.  I doubled checked that it was the correct file that I downloaded, too.  *frustrated look*

 

In fact, there isn't an /includes/functions/ folder present...

 

You are right *duh* I am so bad :'( sorry ... if you have not made any modifications to the general.php file use one from the osc download.

 

Maddie

Share this post


Link to post
Share on other sites

I've looked through this thread.....for more then 4 hours and I cannot find the answer to a heavily asked question.....If someone does find the answer, PLEASE just put the link to the answer in a reply! do not just shrug these questions off! Others might come across them and use this post as a breadcrumb of sorts.....

 

anyways, here is the problem

 

after installing the contrib, I get no fatal errors really......the problem is when I create a 10% discount the discounted total does not pass to PayPal WPP setup (both express and direct pay).

 

Also, the little shopping cart box only says "Coupon: more info".......

 

Another problem, is when I redeem the code, and then logoff the account, it does not save into the account...however I can re-redeem it......

 

but thats an even BIGGER problem :)....I can re-redeem a code that only is set to 1 use as many times as I want (in different sessions). Even after a test purchase is complete I can redeem the same code!

 

please, I hope someone can help me with this......it so frustrating looking through this forum.....I'have had better luck using google to find answers IN THIS FORUM instead of the built in search engine..

Share this post


Link to post
Share on other sites

i did the same too and it works however, did you notice by doing so, the discount doubles for products that have more than one attribute?

 

it's still better than 1% but it may give some other product double the discount.

 

for that category that i used, all the products have more than one attribute so i used half the discount. during the checkout it would doble it...

 

it's a bandaid but it may not work for other categories next time.

 

someone know how to get the discount right???

 

Man i feel dumb now for not reading back a few pages. I appologize to everyone, i managed to fix it by reading this post .

 

Again, sorry for spamming  :blush:

Share this post


Link to post
Share on other sites
i did the same too and it works however, did you notice by doing so, the discount doubles for products that have more than one attribute?

 

it's still better than 1% but it may give some other product double the discount.

 

for that category that i used, all the products have more than one attribute so i used half the discount. during the checkout it would doble it...

 

it's a bandaid but it may not work for other categories next time.

 

someone know how to get the discount right???

 

I'm almost sorry to say that it doesn't double the discount with me (well i'm not sorry about it - just trying to be sympatethic :-" )

 

But have you made any changes to your attribute sets that might affect this ? I certainly have (highly modified store), but as i said, the discount works 100% on products with more than one attribute here. I checked and tested it over and over until i was 100% sure when i read your post ;)

Share this post


Link to post
Share on other sites
I'm almost sorry to say that it doesn't double the discount with me (well i'm not sorry about it - just trying to be sympatethic  :-" )

 

But have you made any changes to your attribute sets that might affect this ? I certainly have (highly modified store), but as i said, the discount works 100% on products with more than one attribute here. I checked and tested it over and over until i was 100% sure when i read your post  ;)

 

attributes would be like a color option and a size option for the same product. if there are two options, the discount doubles. if the product only had one option, discount works.

 

i'll look into the changes i did which were the same as you. there shouldn't be any differnce in the calculation though. hm...

 

thanks.

Share this post


Link to post
Share on other sites

I have been searching for the past 3 hours for the answer to my qesution, but no one seems to be having the same issue. First, the payment information page has no place even referencing the gv. Secondly, if you hit the continue button on that page, you get this error...

Fatal error: Cannot redeclare class order_total in /home/leisuret/public_html/osCommerce/catalog/includes/classes/order_total.php on line 13

Can someone please help me? I really want to get this cont. going so I can introduce the RMA system. Thanks all!!


David

Share this post


Link to post
Share on other sites
I have been searching for the past 3 hours for the answer to my qesution, but no one seems to be having the same issue. First, the payment information page has no place even referencing the gv. Secondly, if you hit the continue button on that page, you get this error...

Fatal error: Cannot redeclare class order_total in /home/leisuret/public_html/osCommerce/catalog/includes/classes/order_total.php on line 13

Can someone please help me?  I really want to get this cont. going so I can introduce the RMA system.  Thanks all!!

 

Nevermind. I figured out what it was. However, I do have a problem with the admin->config->my store. It shows some things in english then others in french. Is anyone aware of a fix for this becuase I cannot read french! Thanks


David

Share this post


Link to post
Share on other sites

I recently added a patch file to simplify the install of CCGV 1.54. I got ahead of myself without properly testing it on modified stores. I apologise for that. I still bieleve it is somewhat easier than the copy and replace method for installing since you shouldnt have to edit any files manually on new installs of osCommerce. I would like feed back so I know if I should use it on other contributions and their updates. The manual install should always be an option since my patches dont work on modified stores. It is quite simple to create a patch. If the creator would like for me to keep making patches then PM me. :D I can easily direct you to one of the simple developer's tools I use or just do it myself.

Share this post


Link to post
Share on other sites
Nevermind.  I figured out what it was.  However, I do have a problem with the admin->config->my store.  It shows some things in english then others in french.  Is anyone aware of a fix for this becuase I cannot read french!  Thanks

 

I am also getting the French language in my admin - on /admin/configuration.php - Please translate! Thanks!

Share this post


Link to post
Share on other sites
When I posted the fix for the latest package, I misstyped the file path to check for the french fix here is the correct path sorry  :( 

 

The way I fixed it:

 

What I did was to use Rigadins download and opened the same file(s)

 

catalog/includes/modules/order_total/ot_coupon.php around line 556

catalog/includes/modules/order_total/ot_gv.php around line 321

 

and after this line of the following in those 2 files

 

function install() {

 

I copied the english from this file to the updated one that portion if the files.

Then I uploaded these files... but then you have to go into admin panel and remove the module and reinstall it by clicking on the green plus sign... then you should see it in english.  Hope you were able to follow that.

 

Update: I was told by Gyakutsuki who prodived an update 24 May 2005:

"Just a little update in ot_coupon payment. Now you can use free shipping with an amount. It does'nt work before"

 

He said this was this file was the only one altered. So using the previous versions files should fix it. A bit easeir then how I did it.... less room for error.

 

if anyone needs help you can IM meand as time permits as I am working on several projects right now.

 

Thanks for the suggestions, Maddie! Everything appears to be working, especially after the unistall-reinstall. There's still one problem I'm having in relation to the My Store page in Configuration. Here's what I'm getting at the bottom of the list...

 

...

Offrir un ch?que cadeau          0 

To offer a gift voucher            0 

To offer a gift voucher              0 

Offrir un ch?que cadeau          0 

Offrir un ch?que cadeau          0 

To offer a gift voucher              0 

To offer a gift voucher            0 

Offrir un coupon de r?duction   

To offer a discount coupon   

To offer a discount coupon   

Offrir un coupon de r?duction   

Offrir un coupon de r?duction   

To offer a discount coupon   

To offer a discount coupon   

To offer a gift voucher

...

 

I have poured over the code and SQL looking for something that is causing the duplication and the always-annoying French. I haven't seen anyone address this particular issue, but I bet I am not the only one to whom this is happening. If I've missed a piece of code or SQL, or even a previous post that addresses this, let me know. Thanks in advance!


David

Share this post


Link to post
Share on other sites
Nevermind.  I figured out what it was.  However, I do have a problem with the admin->config->my store.  It shows some things in english then others in french.  Is anyone aware of a fix for this becuase I cannot read french!  Thanks

 

May you tell us how you fixed it please?

 

I have the same problem.. i am looking the order_total.php file and the original one has less function than the "new one" :/

 

What should i do?

Share this post


Link to post
Share on other sites

I've just install the module, but have a slight bug - all vouchers, no matter what the value, always show up as being ?5 on the order confirmation page.

 

Can anyone point me in the right direction to solve this?

 

Thanks in advance

Share this post


Link to post
Share on other sites
Thanks for the suggestions, Maddie!  Everything appears to be working, especially after the unistall-reinstall.  There's still one problem I'm having in relation to the My Store page in Configuration.  Here's what I'm getting at the bottom of the list...

I have poured over the code and SQL looking for something that is causing the duplication and the always-annoying French.  I haven't seen anyone address this particular issue, but I bet I am not the only one to whom this is happening.  If I've missed a piece of code or SQL, or even a previous post that addresses this, let me know.  Thanks in advance!

 

 

That happens when you query the databse more then once. You can delete it via phpmyadmin. Bring up your data base and click on configuration on the left side.... then on the right click on Browse at the top and then go page by page until you come across the duplicate entries.. delete the ones you do not need. (Most likely on one of the last) Hop it helps

 

Maddie

Share this post


Link to post
Share on other sites
That happens when you query the databse more then once. You can delete it via phpmyadmin. Bring up your data base and click on configuration on the left side.... then on the right click on Browse at the top and then go page by page until you come across the duplicate entries.. delete the ones you do not need.  (Most likely on one of the last) Hop it helps

 

Maddie

 

Thanks again, Maddie!


David

Share this post


Link to post
Share on other sites

I'm looking for a contribution to offer discount coupons and it sounds like this is the right place. It also sounds like there is quite a bit of bugginess in the latest version. Can anyone recommend a version or other contribution that I can install fairly painlessly? I'm running MS2.2 with several add on mods. TIA!

Share this post


Link to post
Share on other sites

hnorfleet - i've just installed the v5.13 and so far I havn't found any bugs (although it's only just been installed and I may find some later on). As for how easy it is to install, then if you use something like beyond compare it's not too hard. I've got osc2.2 with quite a few mods and extra modules, with the beyond compare I just went through the files and added the lines of code where required. Took me about 1 1/2 hours

Share this post


Link to post
Share on other sites
Here's an example picture:

 

the pic is here :D

 

hi

 

that looks really nice, please forward details of how to do it

 

many thanks in advance


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×