Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

Shipping not showing.

 

Shipping method and cost are not showing up anywhere in the ordering process.

 

Does anyone know how to get the shipping method (Table Rate in my case) to reappear?

 

This is in addition to the above problems that I'm still having.

 

I'm playing with various sort orders and settings.

Share this post


Link to post
Share on other sites

Ripping this baby out completely and rolling my store back about a month!

 

Hopefully Table Rate shipping will return at checkout!

Share this post


Link to post
Share on other sites

No shipping only with no-weight products.

 

So far this is what I know. Because we were using table-rate shipping, we did not put a weight on any of our products.

 

Products with drop down options (color, size, etc.) were routed to the Delivery confirmation page, but Products without options with NO weight (Weight of 0) were bypassing the delivery confirmation page as "virtual items" which they were not.

 

Is there a setting that will allow for the gift cerifiates (weightless items) to continue to be virtual, but other no-weight items to draw from the table.php table weight settings?

 

Otherwise, it looks like we will just have to had "1 lb." to every product. I'll probably use the contribution 'easy populate' to do that.

 

Any suggestions? A setting that fixes this without adding weight?

Share this post


Link to post
Share on other sites

Invoice not showing GV/not clearing.

 

The osCommerce invoice does not show the Gift certificate amount and the Gift Voucher amount is not cleared.

 

However, the correct amount is deducted by the credit card processor (GeoTrust)

 

I have gotten this to react correctly once, but I changed the settings before I realised, and can't get it back to "working".

I think the answer is in the sort order, or a combination of sort order and Gift Voucher/Discount Coupon settings.

 

I have tried various sort orders, including the original ones in the 5.13 instructions.

My settings are consistent with the instructions.

 

I have tried clearing my Gift Voucher amount on my account (by sending it to someone) and applying a fresh code: Didn't help.

 

If you have any suggestions, even a hunch, please post!

Share this post


Link to post
Share on other sites

Whats up with the french in the admin area. Anyone know how to get rid of it. (i tried fixing the sql and other things that were suggested but not such luck.)

 

Leslie

Share this post


Link to post
Share on other sites
Whats up with the french in the admin area. Anyone know how to get rid of it. (i tried fixing the sql and other things that were suggested but not such luck.)

 

Leslie

 

Yes, I had that problem, and it is explain in this topic somewhere.

Basically the french is included in one of the php files in 5.13d and 5.13e.

I grabbed a file from an earlier version and I also deleted the french out of the mySQL database, and that fixed it.

But there is hard french written in the php files....one of the modules I think.

Share this post


Link to post
Share on other sites

When I posted the fix for the latest package, I misstyped the file path to check for the french fix here is the correct path sorry :(

 

The way I fixed it:

 

What I did was to use Rigadins download and opened the same file(s)

 

catalog/includes/modules/order_total/ot_coupon.php around line 556

catalog/includes/modules/order_total/ot_gv.php around line 321

 

and after this line of the following in those 2 files

 

function install() {

 

I copied the english from this file to the updated one that portion if the files.

Then I uploaded these files... but then you have to go into admin panel and remove the module and reinstall it by clicking on the green plus sign... then you should see it in english. Hope you were able to follow that.

 

Update: I was told by Gyakutsuki who prodived an update 24 May 2005:

"Just a little update in ot_coupon payment. Now you can use free shipping with an amount. It does'nt work before"

 

He said this was this file was the only one altered. So using the previous versions files should fix it. A bit easeir then how I did it.... less room for error.

 

if anyone needs help you can IM meand as time permits as I am working on several projects right now.

Share this post


Link to post
Share on other sites
The French of which you speak is located in the .sql file that is uploaded into the db. 

 

I don't know much about editing those files, but if your translations are correct, I will try it

 

Thanks

Collectables

 

Here is how you fix it.

1. Get the Rigadin's Full Package 5.13 dated, April 22, 2005.

2. Open the "catalog\includes\modules\order_total\ot_gv.php" file.

3. Copy the function and code for "function install (...)" (approx line# 321)

4. Replace the french "function install ()" lines on your web server file "catalog\includes\modules\order_total\ot_gv.php" with the ones copied from version 5.13.

 

There is also a SQL fix for the French Database config data.

1. Search for "CCGV v5.14 addon with French - English SQL fix" author aarondwyer dated 28 Jul 2005

2. Run the SQL query against your database or manually update the data with the appropriate cell information.

 

Hope this helps, deeman.

Share this post


Link to post
Share on other sites

Gift vouchers don't appear in queue nor are they directly available on purchase of a gift voucher.

 

I've installed CCGV 5.14 (so far without any problems) on a ms2 osco with some other contribs.

 

Installation was done manually and went smoothly, checked it and I don't seem to have omitted a change.

 

I've turned on the gift voucher queue but the voucher doesn't show up anywhere, not even as an email to the customer with a code.

When I turn off the GVqueue the voucher also isn't available directly to the customer.

 

When I create one in the admin everything works (including email).

E-mail works fine throughout the shop.

I've created 3 giftcertificates in the shop for purchase with GIFT5, GIFT10 and GIFT20 as described in the manual, buying is not the problem, only the (automatic) creation after the purchase doesn't seem to work.

 

I've seen the question before but did not find an answer to it.

 

:o Please can anybody help me on this? Or give me a clue as to where I need to look.

 

TIA :thumbsup:

Share this post


Link to post
Share on other sites

Never mind, I found the issue, not the product ID but the Model field needs to have GIFT for starters.

 

I'm a happy camper agian

Share this post


Link to post
Share on other sites

Hi @all!

 

I have installed CCGV 5.14 and nearly everything is working fine, except for the Error or Success Messages when i try to redeem a coupon. These Messages just won?t show up. I always get an empty red information box.

 

I figured out why: The Error-Messages are posted in the redirect link like this:

 

http://www.mydomain.tld/catalog/checkout_payment.php?payment_error=ot_gv&error=You+did+not+enter+a+redeem+code.

 

The Problem is that somehow a amp; is added after the & before error=....

 

In catalog/includes/modules/order_total/ot_gv.php (arround line 220) it says

if ($HTTP_POST_VARS['submit_redeem_x'] && !$HTTP_POST_VARS['gv_redeem_code']) tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'payment_error='.$this->code.'&error=' . urlencode(ERROR_NO_REDEEM_CODE), 'SSL'));

 

I tried to solve the problem by entering

if ($HTTP_POST_VARS['submit_redeem_x'] && !$HTTP_POST_VARS['gv_redeem_code']) tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'payment_error='.$this->code.'&error=' . urlencode(ERROR_NO_REDEEM_CODE), 'SSL'));

 

but this reproduces a double amp;

 

http://www.mydomain.tld/catalog/checkout_payment.php?payment_error=ot_gv&error=You+did+not+enter+a+redeem+code.

 

Anyone might have an Idea why there is an "amp;" added after the "&" and how to fix this? Or am I the only one having this problem?

 

 

Thanks in advance!

 

 

Max

Share this post


Link to post
Share on other sites

Why is coupon related items appearing under Configuration --> My Store ?

 

Isn't all this handled in the Voucher / Coupon area ??

 

To remove all the stuff that the french mod included, you have to go into sql directly.

 

If this is proper, what items are supposed to be there?

Share this post


Link to post
Share on other sites
Why is coupon related items appearing under Configuration --> My Store ?

 

Isn't all this handled in the Voucher / Coupon area ??

 

To remove all the stuff that the french mod included, you have to go into sql directly.

 

If this is proper, what items are supposed to be there?

 

 

I believe it is designed to have those appearing in Configuration>My Store area, separate from the other functions.

 

Roll back prior to 5.13d to get files that have english. Do a search in this topic for french or topics posted by MzBeanz because it has been talked about a lot.

Share this post


Link to post
Share on other sites
Why is coupon related items appearing under Configuration --> My Store ?

 

Isn't all this handled in the Voucher / Coupon area ??

 

If this is proper, what items are supposed to be there?

Works as designed, the two items are supposed to be more related to your shop than that they are actual vouchers/coupons.

They are just there to offer a voucher/coupon on creation of an account as an incentive.

 

If you want you can add a link to both items to the admin/includes/boxes/gv_admin.php to have them there.

I'm no wizz yet in the references in the Db to give you the link, maybe someone else can.. :-"

 

o:) If someone does, I'd rather have them there too :-"

Share this post


Link to post
Share on other sites

I downloaded the French fix + others for 5.14 posted by Shawkes in the contribution section. The zip file flyover text says it contains 11 files but when I open it, it has only 3. What's the deal here? Are there 8 missing files in the zip file, or is WinZip on crack?


--Sanguinarius

 

If you're reading this, I'm probably pulling my hair out. ;>

 

*waiting for osCommerce 3.0 alpha 6* (I'm after the coupons.)

Share this post


Link to post
Share on other sites

Okay, I've got this module installed and it works. I have only one problem with it.

 

I'm using Paypal IPN and I did everything in the paypal ipn fix contribution, but in my admin when I look at the orders that have been made it shows the orginal amount before the amount was redeemed. However, when I click for the details of the order, I see that the coupon was applied.

 

This isn't a big problem, but I just wondered if I could see the actual amount paid without clicking on the details.

 

Anything I can do?

Share this post


Link to post
Share on other sites

OK just to let you all know I was also haveing the issue with the checkbox not appearing to use the voucher account. I changed my sort order so that the voucher came after the coupon but the TOTAL is still last.

 

So on my confirmation screen I get something like:

 

Sub-Total: $179.00

AusPOST Parcel Post (This order qualifies for FREE shipping.):

GST 10%: $16.27

Gift Vouchers: $48.00

Total: $131.00


Dan

Share this post


Link to post
Share on other sites

Here's another example with an order surcharge i have on iveprepaid.com payments...

 

 

Sub-Total: $139.00

AusPOST Parcel Post (Delivery to 6062 (includes $1.05 insurance and $2.35 registered post) ): $9.79

GST 10%: $13.53

Gift Vouchers: $25.00

iveprepaid.com Surcharge (5%) : $6.19

Total: $129.98


Dan

Share this post


Link to post
Share on other sites

I also have:

 

define('DOWNLOAD_ENABLED','false');

 

 

The way I got around it is I have a product type for each product so just have another one (G), for Gift Certificate. The code which determined the cart type has been modified to pick this up and deal with it appropriately.


Dan

Share this post


Link to post
Share on other sites
Why is coupon related items appearing under Configuration --> My Store ?

 

Isn't all this handled in the Voucher / Coupon area ??

 

To remove all the stuff that the french mod included, you have to go into sql directly.

 

If this is proper, what items are supposed to be there?

 

Hi Tom,

Those, I suppose, are listed in the config file becasue that is where you set up your store variables. These two instances are designed to provide the store owner a way to make a gesture to new customers by sending them a coupon or voucher to be used against their first purchase in your store and incentive so to speak. Does this help explain it?

 

Maddie

Share this post


Link to post
Share on other sites
What do I need to do to make it solve the discount right?

 

Sub-Total: $20.00

Orange County Tax (6.50%): $1.30

USPS Shipping (First Class / Priority Mail): $5.00

Discount Coupons:JULY05IDP: -$7.50  This is suppose to be a 30% discount which with how it is figuring should be -$7.89

Total: $18.80

 

Sort Order is

Discount Coupons 760 

Gift Vouchers 740 

Points Redeemptions 2 

Shipping 4 

Sub-Total 1 

Tax 3 

Total 900

 

Just a note even when I have the sort order the way it should be it still figures the wrong way.

Please help.

Thanks,

Carol

 

it depends on how you have the coupons set up, not the sort order (for this particular problem). If you add it this way it comes out the way you want:

 

Sub-Total: $20.00

Orange County Tax (6.50%): $1.30

USPS Shipping (First Class / Priority Mail): $5.00

20.00+1.30+5.00=$26.30

Now take the 30% = $7.89

 

Right now you have it setup to figure it this way

 

$20.00 + $5.00= $25.00 -30% =$7.50

 

So my guess, if I understand the problem correctly, is the settings under admin/modules/order total/discount coupon total need tweeking.

 

It seems you want the shipping to be included in the calcualtions so check to see if:

 

Include Shipping set to true and Include Tax set to true

 

You can IM me if you need further assistance and I am on yahoo messenger

 

Maddie

Share this post


Link to post
Share on other sites

I had this same problem as mentioned below, and I removed the specified text and uploaded general.php and now I get:

 

Fatal error: Call to undefined function: tep_get_languages() in /home/sangui81/public_html/store/index.php on line 58

 

when I go to my store's home page.

 

...

 

I wish someone would come up with a complete install of this mod without all the bugs and errors, and WITH decent documentation for the version of the mod. You know, you coders should form a team and work on this mod at source forge. *begging* They have all kinds of things to keep track of various progresses, and to keep from doubling up, undoing other's work, etc. And then have 1 release of the current project, and many people will not be so very confused and frustrated, and bugs can be reported and worked on in an organized manner.

 

The code is repeated in both files - previously declared.  Delete the following out of your general.php and then you will find it wont repeat.  I think it has happened because so many people are working on the contribution and are doing a bit of doubling up.  You will find the same error happening in your admin as well.

 

// Create a Coupon Code. length may be between 1 and 16 Characters

// $salt needs some thought.

 

  function create_coupon_code($salt="secret", $length = SECURITY_CODE_LENGTH) {

    $ccid = md5(uniqid("","salt"));

    $ccid .= md5(uniqid("","salt"));

    $ccid .= md5(uniqid("","salt"));

    $ccid .= md5(uniqid("","salt"));

    srand((double)microtime()*1000000); // seed the random number generator

    $random_start = @rand(0, (128-$length));

    $good_result = 0;

    while ($good_result == 0) {

      $id1=substr($ccid, $random_start,$length);       

      $query = tep_db_query("select coupon_code from " . TABLE_COUPONS . " where coupon_code = '" . $id1 . "'");   

      if (tep_db_num_rows($query) == 0) $good_result = 1;

    }

    return $id1;

  }

////

// Update the Customers GV account

  function tep_gv_account_update($customer_id, $gv_id) {

    $customer_gv_query = tep_db_query("select amount from " . TABLE_COUPON_GV_CUSTOMER . " where customer_id = '" . $customer_id . "'");

    $coupon_gv_query = tep_db_query("select coupon_amount from " . TABLE_COUPONS . " where coupon_id = '" . $gv_id . "'");

    $coupon_gv = tep_db_fetch_array($coupon_gv_query);

    if (tep_db_num_rows($customer_gv_query) > 0) {

      $customer_gv = tep_db_fetch_array($customer_gv_query);

      $new_gv_amount = $customer_gv['amount'] + $coupon_gv['coupon_amount'];

  // new code bugfix

  $gv_query = tep_db_query("update " . TABLE_COUPON_GV_CUSTOMER . " set amount = '" . $new_gv_amount . "' where customer_id = '" . $customer_id . "'"); 

  // original code $gv_query = tep_db_query("update " . TABLE_COUPON_GV_CUSTOMER . " set amount = '" . $new_gv_amount . "'");

    } else {

      $gv_query = tep_db_query("insert into " . TABLE_COUPON_GV_CUSTOMER . " (customer_id, amount) values ('" . $customer_id . "', '" . $coupon_gv['coupon_amount'] . "')");

    }

  }

////

// Get tax rate from tax description

  function tep_get_tax_rate_from_desc($tax_desc) {

    $tax_query = tep_db_query("select tax_rate from " . TABLE_TAX_RATES . " where tax_description = '" . $tax_desc . "'");

    $tax = tep_db_fetch_array($tax_query);

    return $tax['tax_rate'];

  }

 

Just make sure you delete out the repeated code in the general.php only.

 

Hope this helps.


--Sanguinarius

 

If you're reading this, I'm probably pulling my hair out. ;>

 

*waiting for osCommerce 3.0 alpha 6* (I'm after the coupons.)

Share this post


Link to post
Share on other sites
I had this same problem as mentioned below, and I  removed the specified text and uploaded general.php and now I get:

when I go to my store's home page.

 

...

 

I wish someone would come up with a complete install of this mod without all the bugs and errors, and WITH decent documentation for the version of the mod.  You know, you coders should form a team and work on this mod at source forge.  *begging*  They have all kinds of things to keep track of various progresses, and to keep from doubling up, undoing other's work, etc.  And then have 1 release of the current project, and many people will not be so very confused and frustrated, and bugs can be reported and worked on in an organized manner.

 

Sanguinarius

Try using the general.php file from Rigadin's Full package 5.13 of 22 Apr 2005 ... Just overwrite the one you have unless you have modified it for other modules. Hope this helps.

 

maddie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×