Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

Hello there,

I wonder if somebody could help me. I've been searching this extensive forum but don't seem to be able to find a reply.

 

My gift vouchers working fine, I can purchase them using Cheque / Money order, they appear in a queue and I can redeem and use them. However if I try to use PayPal or Credit Card (using NetBanx), I'm being charged, I see vouchers on the invoice but they are not in the queue... Am I just being blind and overlooking some obvoius setting? All seems to be set properly, weight is 0, please, please help.

 

Alex


Absinthe Original Liquor Store

Share this post


Link to post
Share on other sites

Man, spent 2 hrs readin thread-still cant find an answer.

 

I am running this add on...its been working great in our store, but I know went to add some products to the product line (product ids 166,158,172) but when I checkout with THOSE specific items in cart, and enter the code, it doesnt give me a discount.

I tried also adding the categories that those items are in, still nothing. I tried adding spaced after the comma, nothing....

 

ANyone help me on this, because I have a code going for a CERTAIN brand, but people are getting the discount on OTHER stuff too, because this valid product list thing doesnt work.

 

thanks in advance!

Share this post


Link to post
Share on other sites

Any suggestions / comments on my first posted question??

Hi,

Hobzilla had posted a problem with coupon not getting properly discounted with restrict to products with attributes (the coupon was in percentage).

Even i faced the same problem and after much debugging int he file catalog/includes/modules/order_total/ot_coupon.php in the function calculate_credit()

I replaced the line

 

//Fred 2003-10-28, fix for the row above, otherwise the discount is calc based on price excl VAT! */

 

$pr_c = $this->product_price($pr_ids[$ii]);

 

with the following line

 

$pr_c = $this->product_price($order->products[$i]['id']);

 

Also in the same function below

I replaced the line

 

$pr_c = $this->product_price(tep_get_prid($order->products[$i]['id']));

 

(The function tep_get_prid was creating problem)

 

with the following line

 

$pr_c = $this->product_price($order->products[$i]['id']);

It is working fine now !!!

But i just need to know whether in doing this thing have i unknowingly allowed one more bug to creep in or is it ok ???

Maybe Strider,Fred ,Hobzilla or any other person could solve

Waiting for a reply desperately :(

 

 

Ok, hours later, I got it...I did what you did with those lines and now my products with attributes work!!! Did we ever find out if replacing those lines messes something else up?

Share this post


Link to post
Share on other sites
I'm having difficulties too.

 

Hopefully a simple fix tho.

 

When in 'Coupon Admin', I insert a new coupon, and set the end date. When I preview/insert that coupon, the start date defaults to todays date, and the end date defaults back exactly a year from the start date.

 

Is there a minimum duration for coupons of 1 year?

 

Anyone find a solution to the expire date problem, I am having same issue as above!

Share this post


Link to post
Share on other sites
If it makes you feel any better, I am having exactly the same problem.  Have played around many versions of the code but to no avail.  Have a feeling it's a conflict with another contrib.  Let me know if you sort it out.

 

-Christian

It makes me feel a load better. I am going nutts. I have these contributions installed -

-ship date

-CVV(which doesnt work now as gobals have been turned off on my server)

-EFT payment contribution

-Cash on Delivery module is active.

 

These are the only one's that I think affect the processing payment. Do you have any of the above installed? Are register globals on your server turned on or off? My site is quite modified - but can't see how the other mod's could affect the payment process.

 

Appreciate your reponse, it may help me work out why this is happening if anything.

 

Cheers, Cathy


Cath

Share this post


Link to post
Share on other sites

Hello,

 

I wonder if anybody could help me please, perhaps you've experienced similar problem? I don't really know what to do now...

 

I'm unable to purchase gift vouchers with Credit Card or PayPal.

I've tried 5 different settings and none of them work for Credit Cards but ALL work for Cheque / Money order! As soon as I purchase a voucher with money order, I can see it in a queue. The settings I've been trying are following:

 

Sub-total - Sort order = 1

Shipping - Sort order = 2

Tax - Sort order = 3

Gift Voucher - Sort order = 9

Discount Coupons - Sort Order =740

Total - Sort Order = 900

 

Sub-total - Sort order = 1

Shipping - Sort order = 2

Gift Voucher - Sort order = 740

Discount Coupons - Sort Order =760

Tax - Sort order = 800

Total - Sort Order = 900

 

Sub-total - Sort order = 1

Shipping - Sort order = 2

Gift Voucher - Sort order = 9

Discount Coupons - Sort Order =740

Tax - Sort order = 800

Total - Sort Order = 900

 

Sub-total - Sort order = 1

Shipping - Sort order = 2

Gift Voucher - Sort order = 760

Discount Coupons - Sort Order =740

Tax - Sort order = 800

Total - Sort Order = 900

 

Sub-total - Sort order = 1

Shipping - Sort order = 2

Gift Voucher - Sort order = 760

Discount Coupons - Sort Order =740

Tax - Sort order = 3

Total - Sort Order = 900

 

Weight is 0, download enabled, model GIFT-025.

 

If there is someone who could help me, I appreciate it.

 

Alex


Absinthe Original Liquor Store

Share this post


Link to post
Share on other sites

Hi all.

 

I know this has been asked before, but I didn't see an answer that worked for me so I am asking again.

 

On my checkout_payment.php the field to enter the coupon code is there, but the check box to use available credit does not show up. Which ofcourse makes it not work correctly on the checkout_confirmation.php page.

 

I know there can be a bunch of reasons why this may be and have tried everything I saw on this thread so I guess I have 2 questions.

 

1. does anyone have any new ideas?

2. which file(s) control that part of the checkout_payment.php where the text field with redeem button and the checkbox to use available credit?

 

Thanks in advance! :)


Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Share this post


Link to post
Share on other sites

CCGV & SkipJack/GeoTrust in test mode gives me a credit card error and can not fully process the order when I have the CCGV checkbox ticked to use the Gift Certificate balance as my payment.

 

Without ticking the 'use balance' box, the order processes.

 

Does the CCGV have any effect on the the "Orderstring" form naming?

GeoTrust needs it to be precisely named, and I'm wondering if ticking the box changes the orderstring naming, or submits an additional form name that GeoTrust doesn't understand.

 

If there are others using this credit card payment processor and also the CCGV contribution, please reply w/ thoughts.

 

Is there a general problem out there where ticking the 'use balance' box will give a 'credit card processing' error?

 

Thanks.

Share this post


Link to post
Share on other sites
Do you have the gift vouchers set up as actual products?

 

First are they installed? You have to make sure you go to the admin panel>modules>order total and install both gift vouchers and coupons and then check their settings by highlighting them and clicking edit. It is good idea to queue the vouchers to make sure you receive payment beofre releasing them.

 

Then you need to make a category for them like any other product. I have 'Gift Vouchers' as a category then I insert 'new product' and assign the value of the voucher in 'Products Price' (as per the install instructions) where the 'Products Model' you put the word GIFT in caps with whatever denominaiton you want it to be worth GIFT5 ..... GIFT10 .... GIFT15  etc. Also set the weight to 0

 

Then on the catalog page you will see a category to purchase the gift voucher where customers can add them to the cart like any other product in your store. Once you receive confirmation of the order you go to the admin panel and go to 'vouchers/coupons' and select Gift Voucher Queue and select confrim (if you queue the vouchers). hope this helps

 

Maddie

 

 

Maddie,

 

That helps a lot. I was missing the entire step of creating a product with 'GIFT#', zero weight, etc.

 

Thanks!

Share this post


Link to post
Share on other sites

I am having trouble with this contrib. There is no place for the customers to redeem their voucher or cupon code. I can set them up and they appear to function on the admin side and i can read about the gift vouchers in the FAQ, so most of this install worked. I searched through the admin controls just in case i missed something that would just turn it on. No luck so far!

 

I may be able to figure it out myself but i'm not sure of what page these options would appear.. If someone would let me know where to look for this, i will give it a shot and post the outcome, otherwise i will be posting the code! :D Thank you


James Tomasello

Share this post


Link to post
Share on other sites
I am having trouble with this contrib. There is no place for the customers to redeem their voucher or cupon code. I can set them up and they appear to function on the admin side and i can read about the gift vouchers in the FAQ, so most of this install worked. I searched through the admin controls just in case i missed something that would just turn it on. No luck so far!

 

I may be able to figure it out myself but i'm not sure of what page these options would appear.. If someone would let me know where to look for this, i will give it a shot and post the outcome, otherwise i will be posting the code! :D  Thank you

 

 

There are two ways they can redeem codes, but there is now "homepage redeem box" that comes with the script, although I've seen some people figure this out.

 

Coupon codes: You can email them a gift code with a redeem link. They can log into their account and also manually redeem the code during checkout.

 

As far as the vouchers, they need to be created first as a product. When someone purchases a voucher it will go into your admin queue, and then you confirm it. After you confirm it, it will be applied to their account. When the check out, they tick the checkbox to apply their credit to their order.

 

Read back a few pages and look for my (yodergraphics) question on creating a gift voucher product.

Share this post


Link to post
Share on other sites

OK!! So i downloaded the latest version for this contrib. and now i get this error:

 

Fatal error: Cannot redeclare create_coupon_code() (previously declared in /home/bcpframe/public_html/catalog/includes/functions/general.php:17) in /home/bcpframe/public_html/catalog/includes/add_ccgvdc_application_top.php on line 36

 

What is going on? this was supposed to fix things.


James Tomasello

Share this post


Link to post
Share on other sites
I installed the english version for Credit Class & Gift Voucher 5.13d

 

and French is appearing  where English should appear

in the Admin>Configuration>My Store area, under "Display prices with tax".

 

(Something changed from 5.13 to 5.13d possibly)

 

What file can I correct to make this French into English?

 

They text appearing wrong is below:

 

"Offrir un ch?que cadeau"

 

(Offer a check gift)

 

with help note

 

"Veuillez indiquer le montant du ch?que cadeau que vous voulez offrir ? un nouveau client.

Mettre 0 si vous ne voulez pas offrir de ch?que cadeau"

 

(Want to indicate the amount of the ch?que gift that you want to offer ? a new customer. Put 0 if you do not want to offer ch?que gift)

 

-------

Also:

 

"Offrir un coupon de r?duction"

 

(Offer a coupon reduction)

 

with help note

 

"Pour offrir un coupon de r?duction a un nouveau client veuillez entrer le code du coupon de r?duction.

Laisser vide si vous ne voulez pas offrir de coupon de r?duction"

 

(To offer a coupon of reduction has a new customer want to enter the code of the coupon of reduction. Leave empties if you do not want to offer coupon of reduction)

Thank you for your help!

 

 

 

The French of which you speak is located in the .sql file that is uploaded into the db.

 

I don't know much about editing those files, but if your translations are correct, I will try it

 

Thanks

Collectables

Share this post


Link to post
Share on other sites
Maddie,

 

That helps a lot. I was missing the entire step of creating a product with 'GIFT#', zero weight, etc.

 

Thanks!

You are m ost welcome! Glad I could help.

Maddie

Share this post


Link to post
Share on other sites
The French of which you speak is located in the .sql file that is uploaded into the db. 

 

I don't know much about editing those files, but if your translations are correct, I will try it

 

Thanks

Collectables

 

Easiest way to fix is by upload the language files from Rigadin 22 Apr 2005 version.

 

also for others having problems it really helps to read through the forums or do a search the answers are here. I know it is a lot to read... here is how I fixed several of the more asked about issues

 

I had installed 5.13d version and I had alot of these same problems.

I went back to Rigadin's full package 22 Apr 2005 - Full package 5.13 and it cleared them up.

 

Then I went back and installed the fixes/updates

 

- 18 May 2005 - Update 5.13a

- 24 May 2005 - CCGB V5.13b but only upload and overwrite this file catalog/includes/modules/order_total/ot_coupon.php or you will have french in the admin section.

The author of this update said all he modified was this file.

- 26 May 2005 - Order Total Module

- 29 May 2005 - Clickable link in Email Fix

 

I hope this helps.

Maddie

Share this post


Link to post
Share on other sites
CCGV & SkipJack/GeoTrust in test mode gives me a credit card error and can not fully process the order when I have the CCGV checkbox ticked to use the Gift Certificate balance as my payment.

 

Without ticking the 'use balance' box, the order processes.

 

Does the CCGV have any effect on the the "Orderstring" form naming?

GeoTrust needs it to be precisely named, and I'm wondering if ticking the box changes the orderstring naming, or submits an additional form name that GeoTrust doesn't understand.

 

If there are others using this credit card payment processor and also the CCGV contribution, please reply w/ thoughts.

 

Is there a general problem out there where ticking the 'use balance' box will give a 'credit card processing' error?

 

Thanks.

 

This is what I got from support. Can anyone verify that CCGV is designed to pass the developer serial number, and the entire transaction as a "Settled" transaction?

 

there are several things to look for when

attempting a credit and it does not process successfully. First, the

transaction must be in a 'settled' status in order to be credited.

Secondly, OSCommerce must pass the developer serial number with the

credit request. Check that there is a place for devserial in the OS

commerce module and add it if necessary.

Share this post


Link to post
Share on other sites
It makes me feel a load better.  I am going nutts.  I have these contributions installed -

-ship date

-CVV(which doesnt work now as gobals have been turned off on my server)

-EFT payment contribution

-Cash on Delivery module is active.

 

These are the only one's that I think affect the processing payment.  Do you have any of the above installed? Are register globals on your server turned on or off? My site is quite  modified - but can't see how the other mod's could affect the payment process.

 

Appreciate your reponse, it may help me work out why this is happening if anything.

 

Cheers, Cathy

 

It does seem that of the three people that I know that are having this problem - the common denominators are Cash on Delivery module on, and register_globals off. Does anyone else have/can recreate this setup to confirm if this is indeed a confilcting contrib?

 

I would myself, but am short of a testing server at the moment - d'oh!

 

Thanks in advance,

Christian

Share this post


Link to post
Share on other sites
Now here's the problem:

 

I put something in the shopping cart, proceed to checkout, click on the checkbox that says "to use the Gift Voucher balance" in checkout_payment and go to checkout_confirmation, and it's not reflected that the "use voucher" option has been selected. (the "(-)Gift Vouchers" line is missing)

 

I go back to checkout_payment, tick the checkbox again and proceed to checkout_confirmation, and now the voucher amount is reflected, and everything looks and acts correctly.

 

Finding it funny, I test by going back to checkout_payment, check the box again and proceed to checkout_confirmation, and behold, the option is not reflected again.

 

I test again by not checking the checkbox, then proceeding to checkout_confirmation, and find that now, even with the checkbox not selected, "use voucher amount" is reflected.

 

Upon further tests, the pattern is that "use voucher" is selected alternatively, Off then On, WHETHER OR NOT I CHECK the checkbox.

 

 

Here's betting you've got COD on and register_globals off...(see above post)

Share this post


Link to post
Share on other sites

More details on errors. Please advise.

 

This is related to my previous posts a few posts above.

 

Here's the symptoms:

 

If the Gift Certificate makes the entire sale amount to $0.00 (because the credit was greater than the item price), order will not process and I get a osCommerce generated "Credit Card error" messege.

 

If the total is a positive amount (anthing greater than $0.00), the order processes!

 

But, after that, more errors:

 

The Certificate balance does not clear/reset, as if it was not used.

The Cart does clear fine.

The e-mail invoice does not show the gift cert. applied.

But they were charged correctly, with the gift cert. amount applied.

 

Any suggestions?

 

I am running the CCGV 5.13e, no paypal fix, using Geotrust Skipjack as a payment processor.

Share this post


Link to post
Share on other sites

What do I need to do to make it solve the discount right?

 

Sub-Total: $20.00

Orange County Tax (6.50%): $1.30

USPS Shipping (First Class / Priority Mail): $5.00

Discount Coupons:JULY05IDP: -$7.50 This is suppose to be a 30% discount which with how it is figuring should be -$7.89

Total: $18.80

 

Sort Order is

Discount Coupons 760

Gift Vouchers 740

Points Redeemptions 2

Shipping 4

Sub-Total 1

Tax 3

Total 900

 

Just a note even when I have the sort order the way it should be it still figures the wrong way.

Please help.

Thanks,

Carol

Edited by rose3694

Share this post


Link to post
Share on other sites

hey im getting this error. i have fixed a lot of them for Gift Voucher but this one is really causing me headaches. i have the newest oscommerce and im using 5.14

 

Warning: main(includes/languages/english/FILENAME_GV_REDEEM): failed to open stream: No such file or directory in xxxxxxxxx/public_html/store/gv_redeem.php on line 56

 

Warning: main(includes/languages/english/FILENAME_GV_REDEEM): failed to open stream: No such file or directory in xxxxxxxxxxxxx/public_html/store/gv_redeem.php on line 56

 

Fatal error: main(): Failed opening required 'includes/languages/english/FILENAME_GV_REDEEM' (include_path='.:/usr/lib/php:/usr/local/lib/php') in xxxxxxxxxxxxxxxpublic_html/store/gv_redeem.php on line 56

 

 

anyhelp?

Share this post


Link to post
Share on other sites

ok here is what the line is pointing to (56)

 

require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_GV_REDEEM);

 

i even went back and replace the redeem files and someother stuff from 5.13d and the old faithful 5.13 by Rigadin but still the same error (on line 53) but the same exact deal.

 

i checked my includes, have all my defines, i just dont know what the deal is.

 

please help, i want so badly to see this crazy contribution work for the first time.

 

spanks

Share this post


Link to post
Share on other sites

before the edit, the discount for products with attributes gave a 1% discount for the few items i tried.

 

i changed the lines from below and the products with attributes work for coupon discounts.

 

however, if there are more than one attribute, the discount doubles. anyone have an idea how how to fix the double discount error? i'll be searching some more on this... but it somewhat works for now. :)

 

 

Hi,

Hobzilla had posted a problem with coupon not getting properly discounted with restrict to products with attributes (the coupon was in percentage).

Even i faced the same problem and after much debugging int he file catalog/includes/modules/order_total/ot_coupon.php in the function calculate_credit()

I replaced the line

 

//Fred 2003-10-28, fix for the row above, otherwise the discount is calc based on price excl VAT! */

 

$pr_c = $this->product_price($pr_ids[$ii]);

 

with the following line

 

$pr_c = $this->product_price($order->products[$i]['id']);

 

Also in the same function below

I replaced the line

 

$pr_c = $this->product_price(tep_get_prid($order->products[$i]['id']));

 

(The function tep_get_prid was creating problem)

 

with the following line

 

$pr_c = $this->product_price($order->products[$i]['id']);

It is working fine now !!!

But i just need to know whether in doing this thing have i unknowingly allowed one more bug to creep in or is it ok ???

Maybe Strider,Fred ,Hobzilla or any other person could solve

Waiting for a reply desperately :(

Ok, hours later, I got it...I did what you did with those lines and now my products with attributes work!!! Did we ever find out if replacing those lines messes something else up?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×