Jump to content
Strider

Credit Class/Gift Vouchers/Discount Coupons 5.10

Recommended Posts

I have the CCGV contribution up and running (everything seems to be running smooth) now my question is.. how do I add a gift voucher to my shopping cart and not get any shipping charge to it and then be automatically added to the users account?

 

Hope someone can help me.

 

Well you can always ship by weight and then just assign the voucher a weight of zero.

 

-Fractal

Share this post


Link to post
Share on other sites
I have the CCGV contribution up and running (everything seems to be running smooth) now my question is.. how do I add a gift voucher to my shopping cart and not get any shipping charge to it and then be automatically added to the users account?

 

Hope someone can help me.

 

Make sure that download to true in admin panel>download configuration> and then set teh gift voucher weight weight to 0- zero

Maddie

Share this post


Link to post
Share on other sites
Make sure that download to true in admin panel>download configuration> and then set teh gift voucher weight weight to 0- zero

Maddie

 

 

Since I already have all of my shipping done through price and not weight... is there any other way of specifying no shipping for 1 product only?

 

Also I can't seem to find a way to sell a gift voucher and for it to be automatically added to the persons account.

 

Thanks

Share this post


Link to post
Share on other sites

Wondering if anyone can help! I have used contribution and after debugging all the nasties that came with the latest compile - I have got it all working - except -

 

When one enters a coupon code - it says "congrats you have redeemed" on top - however it doesn't redeem. You have to enter it again and then it redeems. Redeem code has to be entered twice at checkout_payment stage for it to register. Then the coupon in the shopping cart box appears and you know its finally worked.

 

Would this have to do with my db settings/or admin settings on coupons. Any help would be greatly appreciated!!! I am really under the pump to make sure it works.

 

Cheers,


Cath

Share this post


Link to post
Share on other sites
Hi. I seem to be having a new problem after installing the gift voucher contrib.

Everything seems to be going ok. Send mail and setting up of the gift vouchers but if i set up a dummy account and send myself a test ?10 gift voucher, there is no way of using the voucher to purchase a product.

 

It says in the install manual that a box will appear but i do not appear to be seeing any boxes. which means that a customer wont be able to use their vouchers in the checkout procedure.

 

I would really appreciate any help.

 

Thanx

 

 

I am back again because this bugger of thing is doing silly things. So I can keep helping you, but no-one can help me :(

 

In your admin/modules/order_total in your admin panel, make sure you have you have your sort orders set to the followoing:

 

Discount Coupons 9

Gift Vouchers 740

Low Order Fee

Shipping 3

Sub-Total 1

Tax 2

 

Then you will see a little - thing come up in your coupon/gift voucher box on your payments_ which says'tick to use gift voucher balance amount' - you then tick it and it applies the gift voucher to the total. It's all bout the sort orders.

 

Can you let me know if your coupons are working. I am finding i have to enter the coupon code twice for it to register in the shopping cart box to the right. No-one seems to be able to help me - and I am seriously lacking in php knowledge to mess with _POST vars.

Cheers,


Cath

Share this post


Link to post
Share on other sites

I just did a fresh install of the oscommerce files and then added this contribution, I edited all files according to the instructions and get the following.

 

Fatal error: Cannot redeclare create_coupon_code() (previously declared in /home/virtual/site86/fst/var/www/html/oscommerce2/includes/functions/general.php:17) in /home/virtual/site86/fst/var/www/html/oscommerce2/includes/add_ccgvdc_application_top.php on line 36

Share this post


Link to post
Share on other sites
I just did a fresh install of the oscommerce files and then added this contribution, I edited all files according to the instructions and get the following.

 

Fatal error: Cannot redeclare create_coupon_code() (previously declared in /home/virtual/site86/fst/var/www/html/oscommerce2/includes/functions/general.php:17) in /home/virtual/site86/fst/var/www/html/oscommerce2/includes/add_ccgvdc_application_top.php on line 36

the code has being called twice , its an error in the latest upload.

just restore your oscommerce2/includes/functions/general.php


Remember - - - "STRESSED" spelled backwards "DESSERTS"

Share this post


Link to post
Share on other sites

Are you one of those people who is STILL having trouble making this contribution give you free shipping on GV purchases?? Or are you getting free shipping when GV are added to a physical product and not being charged the correct shipping for the physical product??

 

I have been struggling with this for weeks. I've done soooo many searches, and even tried paying for professional technical support. I've FINALLY figured it out. I've seen this question posted numerous times, but never saw a resolution posted. I also realized that it's only a problem for some people, not everyone.

 

So... here's the deal. If you are calculating shipping on PRICE, not on weight, you must have Downloads Enabled set to TRUE in Admin->Config->Download. Otherwise, it skips the proper shipping calculation! This also means ALL of your non Gift Voucher products MUST have a non-zero weight, even though you're calculating on price.

 

Also, if you happen to be using zone based shipping, there is another step. You must change this:

 

if (MODULE_SHIPPING_ZONES_MODE == 'price') {
$order_total = $cart->show_total();
} else {
$order_total = $shipping_weight;
}

 

 

to this:

 

if (MODULE_SHIPPING_ZONES_MODE == 'price') {
$order_total = $cart->show_total_virtual();
} else {
$order_total = $shipping_weight;
}

 

I really hope this helps someone! :D

Adrienne

Share this post


Link to post
Share on other sites

ok almost got everything owrking except it looks funny

Sub-Total: $29.95

United Parcel Service (1 x 1.76lbs) (Ground): $7.18

Total: $37.13

Discount Coupons:SAVE5: -$1.50

 

How do I get discount above total to it shows 35.XX instead if I proceed paypal it goes to the correct amount but on the checkout screen it is going to confuse peeople.

Share this post


Link to post
Share on other sites
ok almost got everything owrking except it looks funny

Sub-Total:  $29.95

United Parcel Service (1 x 1.76lbs) (Ground):  $7.18

Total:  $37.13

Discount Coupons:SAVE5:  -$1.50

 

How do I get discount above total to it shows 35.XX instead if I proceed paypal it goes to the correct amount but on the checkout screen it is going to confuse peeople.

 

"Total" should always have the highest sort order in admin->modules->order total. Search this forum for "sort order" for more details, it's been discussed a lot.

 

Adrienne

Share this post


Link to post
Share on other sites

Hi there,

Ok. Everything looks like it works all right HOWEVER, when I send a gift voucher by email to a customer, no matter what amount I make it for, it shows up on their email (and when they redeem it) as $0!!

How to fix that??

Share this post


Link to post
Share on other sites

I installed Credit Class/Gift Vouchers/Discount Coupons (Version 5.10).

 

Everything works great except when customers proceed to paypal payment, it doesnt show the discounted amount. It charges the item amount plus the shipping charge.

 

Example:

Item: 7.99

Shipping: 1.99

Discount: -0.80

Total: 9.19

 

When continue with paypal, it shows $9.98 instead of $9.19

 

Please help as customers are having difficult time and i cant find the solution.

 

Thanks in Advance

Share this post


Link to post
Share on other sites

Please help someone. I need this done as soon as possible. Paypal not picking up the discounted amount. which file needs to be edited?

 

Please answer someone.

 

Thanks

Share this post


Link to post
Share on other sites
Just a note to users of the latest version.

There are so many bugs that its hard to start with.

sometime people change the code to fit their need but hard to tell if it work fine with other users.

I pay alot of respact to  Ian C Wilson for all his hard work , looking at the original code i can tell that the contribution got cracked druing upgrades. so many tiny piecses of code that not in use .somebody have to clean up the mass and to start over with a cleaner code.(maybe I will do it but only after the official relese of osCommerce Version 2.2MS3 in  July or August).

The big issue is at the Product-Category restrictions apply.

Stores owners using this module should know that when you set a Product/Category restrictions the check is only for the first item in cart so if the customer have few items in cart and only one of those items is a valid products,

he/she will still be able to use the coupon to pay for the order.

DEEP-SILVER

 

 

Let us start a post with errors that require attention to fix this contribution. I have another issue to add: :blush: No restriction Product-Catagory and products with attributes will be discounted. If you restrict the Product-Catagory, then products with attributes does not get discounted.


2oldNslow

 

I am no expert, I am only trying to help.

Always, always back up.Use several browsers like IE,

Opera, Firefox and Netscape to view your work..

The free tools work great to do osCommerce changes,

PHP Designer 05/06, NoteTab Lite, SciTE, PSPad, XAMPP,

Filezilla, 1st Page, osCommerce is #1!

Share this post


Link to post
Share on other sites

I have read at least one person besides me that is experiencing this issue, please help if you can:

 

The problem is that, when using a discount coupon, the tax is being calculated BEFORE substracting the discount to the subtotal. It should be like:

 

(Sub-total - Discount) + Tax

 

with the tax amount calculated based on the subtotal AFTER substracting the discount.

 

I have tried playing with the options in Modules / Order Total / Discount Coupons (Re-calculate Tax and Include tax) but there is no change whatsoever in the calculations. Currently I have the sort order of the Order Total modules like this: Subtotal, Shipping, Discount Coupons, Tax, Total

 

Please help if anyone has been affected by this. Thanks in advance.

Share this post


Link to post
Share on other sites
Wondering if anyone can help!  I have used contribution and after debugging all the nasties that came with the latest compile - I have got it all working - except -

 

When one enters a coupon code - it says "congrats you have redeemed" on top - however it doesn't redeem.  You have to enter it again and then it redeems. Redeem code has to be entered twice at checkout_payment stage for it to register.  Then  the coupon in the shopping cart box appears and you know its finally worked.

 

Would this have to do with my db settings/or admin settings on coupons. Any help would be greatly appreciated!!!  I am really under the pump to make sure it works.

 

Cheers,

 

If it makes you feel any better, I am having exactly the same problem. Have played around many versions of the code but to no avail. Have a feeling it's a conflict with another contrib. Let me know if you sort it out.

 

-Christian

Share this post


Link to post
Share on other sites
If it makes you feel any better, I am having exactly the same problem.  Have played around many versions of the code but to no avail.  Have a feeling it's a conflict with another contrib.  Let me know if you sort it out.

 

-Christian

 

I'm having the same problem also. I have tried edited the catalog/languages/english/gv_redeem.php file to just say Congratulations. But it still says the same thing "Congratulations you have redeemed" I also look at the code in catalog/gv_redeem.php and couldn't figure out anything. The weird thing is it works perfectly when I mail a gift voucher to someome and they redeem it. I don't have any contributions installed except for this one.

Share this post


Link to post
Share on other sites

I am having trouble processing credit cards via authorizenet now that I have installed this contribution, it must have change my setting or something, I got a new key and replaced it and I am not sure what else might have changed, anyone have any ideas on what might be wrong. here is the error i get when trying to run a test card.

 

The server cannot connect to Authorize.net. Please check your cURL and server settings.

 

Thanks

Doug

Share this post


Link to post
Share on other sites

Accidentally posted this in the wrong place guess it goes here .

 

Hello,

 

I have CCGV installed everything works fine through the checkout process and deducts the amount from the order, but if I go into the order in the admin tool it adds that amount to the order instead of subtracting. This is also happening to the order process e-mails .

 

any help would be great

Share this post


Link to post
Share on other sites

Creating a virtual buyable product.

 

In other words, how do I create a virtual product that works with this newest ccgv.

 

Do I need to create a downloadable/Virtual product?

Then download an image with my Gift Voucher code?

 

Do I need a "Download Controller" contribution to have downloadable products?

 

When I go to create a product, I don't have an option to make the product virtual even though...

My Configuration>Download>Enable download is set to 'True'

 

The only function I can see with this ccgv contribution is the abilities to email them a code or have them receive one on account sign up.

 

But how does the customer purchase one themselves?

Share this post


Link to post
Share on other sites

After installing I am having problems connecting to authorize net, anyone know of a fix, please help. Here is the message I am getting,

 

The server cannot connect to Authorize.net. Please check your cURL and server settings.

 

I have made sure my curl settings is correct, and changed my key with authorize net and still no luck, my store is dead in the water until I can fix this, please help.

 

Doug

Share this post


Link to post
Share on other sites

While testing my v1.53d CCGV installation last month, I discovered some unusual behaviour.

 

I only intend to use Gift Vouchers. I registered an account, purchased a Gift Voucher, then used admin to release it from queue. Everything looks fine, I log in to the account and see that the Gift Vocuher amount has been credited.

 

**************************************************************

 

Now here's the problem:

 

I put something in the shopping cart, proceed to checkout, click on the checkbox that says "to use the Gift Voucher balance" in checkout_payment and go to checkout_confirmation, and it's not reflected that the "use voucher" option has been selected. (the "(-)Gift Vouchers" line is missing)

 

I go back to checkout_payment, tick the checkbox again and proceed to checkout_confirmation, and now the voucher amount is reflected, and everything looks and acts correctly.

 

Finding it funny, I test by going back to checkout_payment, check the box again and proceed to checkout_confirmation, and behold, the option is not reflected again.

 

I test again by not checking the checkbox, then proceeding to checkout_confirmation, and find that now, even with the checkbox not selected, "use voucher amount" is reflected.

 

Upon further tests, the pattern is that "use voucher" is selected alternatively, Off then On, WHETHER OR NOT I CHECK the checkbox.

 

**************************************************************

 

I know the problem above sounds complicated, and I'm not sure if anyone understands what I'm rambling at. Gone thru all 130 pages of this topic and no one else seems to have encountered this problem, so I'm not sure if anyone can help me. Rigadin makes a brief mention of this, but has offered no solution.

 

Just want to ask - for the more experienced people out there, which pages should I be troubleshooting, and what variables should I be monitoring? I have some (little) programming experience, but so far have not managed to solve this.

 

I've tried to force cot_gv to "true" upon the checkbox being selected, and this seems to work, but when I finish the checkout process, the <voucher amount used> is not deducted from the customer's <total voucher amount>.

 

Same problem when I use a $_POST['cot_gv'] instead of using tep_if_session_registered('cot_gv').

 

Hope someone can offer some suggestion on how I can solve this. I have been troubleshooting and testing for a solid 3 weeks to no avail.

Edited by silencer13

Share this post


Link to post
Share on other sites
Creating a virtual buyable product.

 

In other words, how do I create a virtual product that works with this newest ccgv.

 

Do I need to create a downloadable/Virtual product?

Then download an image with my Gift Voucher code?

 

Do I need a "Download Controller" contribution to have downloadable products?

 

When I go to create a product, I don't have an option to make the product virtual even though...

My Configuration>Download>Enable download is set to 'True'

 

The only function I can see with this ccgv contribution is the abilities to email them a code or have them receive one on account sign up.

 

But how does the customer purchase one themselves?

 

Do you have the gift vouchers set up as actual products?

 

First are they installed? You have to make sure you go to the admin panel>modules>order total and install both gift vouchers and coupons and then check their settings by highlighting them and clicking edit. It is good idea to queue the vouchers to make sure you receive payment beofre releasing them.

 

Then you need to make a category for them like any other product. I have 'Gift Vouchers' as a category then I insert 'new product' and assign the value of the voucher in 'Products Price' (as per the install instructions) where the 'Products Model' you put the word GIFT in caps with whatever denominaiton you want it to be worth GIFT5 ..... GIFT10 .... GIFT15 etc. Also set the weight to 0

 

Then on the catalog page you will see a category to purchase the gift voucher where customers can add them to the cart like any other product in your store. Once you receive confirmation of the order you go to the admin panel and go to 'vouchers/coupons' and select Gift Voucher Queue and select confrim (if you queue the vouchers). hope this helps

 

Maddie

Share this post


Link to post
Share on other sites
I'm having the same problem also. I have tried edited the catalog/languages/english/gv_redeem.php file to just say Congratulations. But it still says the same thing "Congratulations you have redeemed"? I also look at the code in catalog/gv_redeem.php and couldn't figure out anything. The weird thing is it works perfectly when I mail a gift voucher to someome and they redeem it. I don't have any contributions installed except for this one.

 

if you just want to change that line of text you need to edit this line

 

define('ERROR_REDEEMED_AMOUNT', 'Congratulations, you have redeemed ');

 

of this file:

 

catalog>inludes>languages>add_ccgvdc_english.php

 

hope that helps ya

 

Maddie

Edited by MzBeanz

Share this post


Link to post
Share on other sites
Since I already have all of my shipping done through price and not weight... is there any other way of specifying no shipping for 1 product only?

 

Also I can't seem to find a way to sell a gift voucher and for it to be automatically added to the persons account.

 

Thanks

 

Have you tired setting the Gift Vouchers Queue Purchases to false in the admin>order total>gift vouchers

 

I have not done this as I want to make sure I get paid before I release the $$ to their account so the purchase of a GV is placed in a queue for me to confirm payment and then release.

 

For the shipping issue, try setting 'Include Shipping' to false

 

Hope this helps

 

Maddie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×