Jump to content
Jack_mcs

Dynamic SiteMap

Recommended Posts

Im glad that worked. I haven't had time to look through the SEO code.

 

Jack

Share this post


Link to post
Share on other sites

strange that im the frist one to notice it , but even in the last version, i got all my line finishing if the catagory or text to display contains the ' character , like :

 

Carnet d

Nouvelle entr?e carnet d

 

should be :

 

Carnet d'adresse

Nouvelle entr?e carnet d'adresse

 

any way to fix that ?


MS2

Share this post


Link to post
Share on other sites

I noticed that but haven't had time to work on a fix for it. The apostrophe is causing the problem. I think I know how to fix it and will get to it eventually. There's no sutiable temporary fix for it that I can think of.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack,

Just finished bugging you about my problems with the Header Tags,

Thanks Again.

Installed the sitemap contrib. with no problems just a question.

Does it only go as far as listing the categories? Because none of the product pages are showing on the sitemap?

Share this post


Link to post
Share on other sites

Sitemaps don't generally list product pages. For that, you should add the All Products contribution (see my signature).

 

Jack

Share this post


Link to post
Share on other sites

Trying to find where this is being created

 

But not having much luck so far

 

Sitemap

 

Getting an extra couple of bullets and "pages" - called Card - that don't actually go anywhere

 

View source is just showing them up as text

 

Have nothing close to this as a filename in boxes or catalog

 

Would somebody like to push me in the obvious direction ?

 

Thanx

 

Tim

 

ps I am going to be so annoyed if has already been discussed in this forum - before I contemplate installing a contribution, i read the associated forum from front to back - at least this one is reasonably short :rolleyes:

Share this post


Link to post
Share on other sites

That is most likely caused by an infobox. Exclude all of the infoboxes by adding them to the code in includes/modules/dynamic_sitemap.php. Eventually you will find the one causing the problem.

 

Jack

Share this post


Link to post
Share on other sites

I really love this contrib now that I have it installed correctly. Even the little problems I had were easy to figure out after I checked my install. What I can't figure out is how to get rid of some of the right side pages. I've tried: strpos($file, 'my_order_history') !== FALSE ||

in the first section of includes/modules/dynamic_sitemap.php...

and I've tried: strpos($file, "my_order_history.php") !== FALSE ||

in the second section....am I missing something?

 

There's really very few on the right side list that I want there...just can't see what I'm missing

 

Thanks

Share this post


Link to post
Share on other sites

The first section you mention is for excluding infoboxes. The bottom section is for files. But it has tobe the actual file name. Do you have a file named my_order_history.php in your root? If not, you probably mean to use order_history.php. The named displayed in the sitemap is not always the name of the file.

 

Jack

Share this post


Link to post
Share on other sites
The first section you mention is for excluding infoboxes. The bottom section is for files. But it has tobe the actual file name. Do you have a file named my_order_history.php in your root? If not, you probably mean to use order_history.php. The named displayed in the sitemap is not always the name of the file.

 

Jack

 

Thanks for the info....now I have a better chance of getting this figured out.

Share this post


Link to post
Share on other sites
Jack,

 

I installed the contribution just now and, clicking in the Site Map entry in the Information Box, I get the following message

 

Warning: strpos(): Empty delimiter. in /home/paradin/public_html/includes/functions/dynamic_sitemap.php on line 35

 

repeated a large number of times, presumably once for every product (although I haven't counted), followed by the SiteMap page (with Column_right which has disappeared), followed by "Error! Unable to determine the page link".

 

If you try the following link, you'll se what I mean

 

my shop

 

Nick

 

Hi, Nick

 

I am impressed from your site it looks cool with site map

Can you please let me know step wise how can I add site map to my web page www.microglobe.co.uk

Thanking in advance for your help, and looking forward to hearing from you.

 

Habib

Share this post


Link to post
Share on other sites

I to am getting:

 

Error!

 

Unable to determine the page link!

 

 

  $info_box_contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_SHIPPING) . '">' . BOX_INFORMATION_SHIPPING . '</a><br>' .
									 '<a href="' . tep_href_link(FILENAME_PRIVACY) . '">' . BOX_INFORMATION_PRIVACY . '</a><br>' .
									 '<a href="' . tep_href_link(FILENAME_CONDITIONS) . '">' . BOX_INFORMATION_CONDITIONS . '</a><br>' .
									 '<a href="' . tep_href_link(FILENAME_GV_FAQ, '', 'NONSSL') . '">' . BOX_INFORMATION_GV . '</a><br>' .										
									 '<a href="' . tep_href_link(FILENAME_CONTACT_US) . '">' . BOX_INFORMATION_CONTACT . '</a><br>' .
									 '<a href="' . tep_href_link(FILENAME_DYNAMIC_SITEMAP) . '">' . BOX_INFORMATION_DYNAMIC_SITEMAP . '</a>');

 

The line causing the problem is:

'<a href="' . tep_href_link(FILENAME_GV_FAQ, '', 'NONSSL') . '">' . BOX_INFORMATION_GV . '</a><br>' .

 

Is I remove it the site map works.

 

However, I also get to information listings.

Share this post


Link to post
Share on other sites

I to am getting:

 

Error!

 

Unable to determine the page link!

 

 

  $info_box_contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_SHIPPING) . '">' . BOX_INFORMATION_SHIPPING . '</a><br>' .
									 '<a href="' . tep_href_link(FILENAME_PRIVACY) . '">' . BOX_INFORMATION_PRIVACY . '</a><br>' .
									 '<a href="' . tep_href_link(FILENAME_CONDITIONS) . '">' . BOX_INFORMATION_CONDITIONS . '</a><br>' .
									 '<a href="' . tep_href_link(FILENAME_GV_FAQ, '', 'NONSSL') . '">' . BOX_INFORMATION_GV . '</a><br>' .										
									 '<a href="' . tep_href_link(FILENAME_CONTACT_US) . '">' . BOX_INFORMATION_CONTACT . '</a><br>' .
									 '<a href="' . tep_href_link(FILENAME_DYNAMIC_SITEMAP) . '">' . BOX_INFORMATION_DYNAMIC_SITEMAP . '</a>');

 

The line causing the problem is:

'<a href="' . tep_href_link(FILENAME_GV_FAQ, '', 'NONSSL') . '">' . BOX_INFORMATION_GV . '</a><br>' .

 

Is I remove it the site map works.

 

However, I also get to information listings.

 

Thanks for the help. This is perfect!

Share this post


Link to post
Share on other sites

That is failing because Gift Vouchers store the filenames in a different file. Find this line in includes/add_ccgvdc_application_top.php

define('FILENAME_GV_FAQ', 'gv_faq.php');	  //moved here for dynamice sitemap

and move it to the includes/filenames.php file. If you ever update Gift Vouchers, this problem will return so I plan on adding a fix to Dynamic SiteMap but this will work for now.

 

Jack

Share this post


Link to post
Share on other sites

Sitemap is working well. There is a minor problem in that the Information Pages list is repeated 3 times. So Contact us, Privacy Policy, etc.. shows up 3 times on the sitemap page.

 

Any Ideas?

Share this post


Link to post
Share on other sites

Take a look in includes/boxes and make sure you don't have duplicates of information.php. Many times, a shop owner will rename one to information_oig.php when they are installing a change. If you do have such files, just delete them or move them to another location.

 

Jack

Share this post


Link to post
Share on other sites
Take a look in includes/boxes and make sure you don't have duplicates of information.php. Many times, a shop owner will rename one to information_oig.php when they are installing a change. If you do have such files, just delete them or move them to another location.

 

Jack

 

Thank you very much! That did it, no more duplicates in sitemap. Are duplicate .php files always best keep in a separate backup directory?

Share this post


Link to post
Share on other sites

No, they won't usually hurt anything except for a contribution like this one that reads them or in the payment/shipping modules.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack,

 

I have just installed the sitemap contribution, and it looks great. But many of my links in two of my info boxes are to html pages. How can I make them show on my sitemap so it gets "complete". I noticed that the code is only for php pages, but is there a way for me to make these links show in the sitemap?

 

Thanks:-)

Kjolebutikken


Best regards

Kjolebutikken

Share this post


Link to post
Share on other sites

No, not currently. The code needs to be changed to parse the infoboxes better but I haven't gotten around to it.

 

Jack

Share this post


Link to post
Share on other sites

Also I discovered that one of the links end up at the wrong page. Under "Anbefal" which is the "tell a friend", when I mouse over in the sitemap it shows the correct link which is tell_a_friend.php. But when I click on it, it takes me to another page, it takes me to product_info.php. As far as I can see, this is only happening for this one link. I have checked the language file, as pointed out in this thread, but it seems ok. What can I do to fix this?

 

Thanks:-)

Kjolebutikken


Best regards

Kjolebutikken

Share this post


Link to post
Share on other sites
Also I discovered that one of the links end up at the wrong page. Under "Anbefal" which is the "tell a friend", when I mouse over in the sitemap it shows the correct link which is tell_a_friend.php. But when I click on it, it takes me to another page, it takes me to product_info.php. As far as I can see, this is only happening for this one link. I have checked the language file, as pointed out in this thread, but it seems ok. What can I do to fix this?

 

Thanks:-)

Kjolebutikken

 

No, not currently. The code needs to be changed to parse the infoboxes better but I haven't gotten around to it.

 

OK, but is theer a way for me to add them manually?

Thanks for the fast reply:-)

 

Kjolebutikken


Best regards

Kjolebutikken

Share this post


Link to post
Share on other sites

In the includes/modules/dynamic_sitemap.php file, the links are added to an array. You could add the links to it yourself at the end of that array and it should work.

 

Jack

Edited by Jack_mcs

Share this post


Link to post
Share on other sites
In the includes/modules/dynamic_sitemap.php file, the links are added to an array. You could add the links to it yourself at the end of that array and it should work.

 

Jack

 

 

OK, but I do not know much about php. Do you mean this line?:

 

$str = str_replace("\$info_box_contents[] = array('text' => ", "", $str);

 

Do I put the link http://...... in between the two "" ???

 

Thanks:-)

Kjolebutikken


Best regards

Kjolebutikken

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×