Jump to content
Latest News: (loading..)
Jack_mcs

Dynamic SiteMap

Recommended Posts

I just installed v3.2 with the ssl links 1.0. I am getting the following error:

Parse error: syntax error, unexpected '}' in /mnt/w0207/d18/s05/b02d72b0/www/store/catalog/dynamic_sitemap.php on line 276

 

When I remove the } it causes a t_else error.

Any ideas?


If the only tool you have is a hammer, all your problems look like nails

Share this post


Link to post
Share on other sites
Definitely a path issue. The error is telling you there is no /www/htdocs/primocontatto.com/ OR possibly the permissions are wrong.

 

 

I think its a safe mode issue I am working on a fix for my site now.

 

Note: When safe mode is enabled, PHP checks whether the directory in which the script is operating has the same UID (owner) as the script that is being executed.

 

If you are experiencing problems with reading and writing to files and you're using the server module version of PHP, remember to make sure that the files and directories you're using are accessible to the server process.

Share this post


Link to post
Share on other sites
I think its a safe mode issue I am working on a fix for my site now.

 

 

I have tried to create a new file after deleting, but I don't have permission ! I used the following code:

 

$ourFileName = "sitemapcategories.xml";

$ourFileHandle = fopen($ourFileName, 'w') or die("can't open file");

fclose($ourFileHandle);

 

Looks like fclose() is disabled or restricted on my server.

Edited by WS Evolution

Share this post


Link to post
Share on other sites

Firstly, thank you for this great contribution. Really makes the life easier.

 

Secondly, a quick request to add MS Live service. They do accept sitemaps, check out http://webmaster.live.com/.

 

And finally a question regarding Dynamic SiteMap and Ultimate SEO URLs. Is it possible to have the Dynamic Sitemap generate Search-engine friendly URLs versus the current URL format (i.e. /product_info.php?products_id=29) ?

 

Thanks again!

 

Ivan

Share this post


Link to post
Share on other sites
Hi, just installed this great contribution, tested it and got a few small erros that I don't understand:

 

In the finished map, I get some strange link names, such "Let" for the index.php, "What" for shopping_cart.php, and "I" for password_forgotten.php. All other link names are correct - why does it pick up those names incorrectly? And the entire map is finished with an extra list sign/dot, after the list is finished - is there a layout somewhere for this, or why does it create an extra list line?

 

I testing this on a clean shop, and have the HeaderTags_V_2.6.3 installed, if that can affect this.

 

Thank you.

 

I have this exact same problem, but cannot find a reply to this post I have installed version 3.2. My other problem is I didn't quite understand this instruction:

 

Create a robots.txt file on your web site or add to your existing file a line reading like the following:

 

Sitemap: http://sample.com/catalog/sitemaps.xml

 

Replace the sample.com/catalog with your own web site address and catalog directory. This will help point search engines to the master site map index for your web site.

 

If I add to my "existing file" - which file is that?

 

I have submitted to google - I submitted via webmaster tools - all 6 xml files come back with errors:

 

If I go to the details it says:

 

 

This XML file does not appear to have any style information associated with it. The document tree is shown below.

 

<urlset>

</urlset>

 

Any suggestions?

Share this post


Link to post
Share on other sites

The name of the file is robots.txt - the instructions are telling you, if you already have a robots.txt file in your directory to add the Sitemap:Link to that file.

 

If you do not already have a robots.txt file then you should create one with the Sitemap:Link in it.

 

For more info on robots.txt files see:

http://www.robotstxt.org/

http://en.wikipedia.org/wiki/Robots.txt

 

I have this exact same problem, but cannot find a reply to this post I have installed version 3.2. My other problem is I didn't quite understand this instruction:

 

 

 

If I add to my "existing file" - which file is that?

 

I have submitted to google - I submitted via webmaster tools - all 6 xml files come back with errors:

 

If I go to the details it says:

 

 

This XML file does not appear to have any style information associated with it. The document tree is shown below.

 

<urlset>

</urlset>

 

Any suggestions?


~Tracy
 

Share this post


Link to post
Share on other sites
The name of the file is robots.txt - the instructions are telling you, if you already have a robots.txt file in your directory to add the Sitemap:Link to that file.

 

If you do not already have a robots.txt file then you should create one with the Sitemap:Link in it.

 

For more info on robots.txt files see:

http://www.robotstxt.org/

http://en.wikipedia.org/wiki/Robots.txt

 

Many thanks for this, I've added the robots.txt.

 

Can anyone answer my other problems - why do I get an error for all my sitemap files in google?

 

And the abbreviated link?

 

Thanks

Share this post


Link to post
Share on other sites
Hi, just installed this great contribution, tested it and got a few small erros that I don't understand:

 

In the finished map, I get some strange link names, such "Let" for the index.php, "What" for shopping_cart.php, and "I" for password_forgotten.php. All other link names are correct - why does it pick up those names incorrectly

 

I have this exact same problem, but cannot find a reply to this post I have installed version 3.2.

 

Check define('HEADING_TITLE' ...

for corresponding php file. Sitemap takes name from this line

Edited by leveera

Share this post


Link to post
Share on other sites
Check define('HEADING_TITLE' ...

for corresponding php file. Sitemap takes name from this line

 

Any suggestions which file to look in I checked my english.php but there nothing in there that equates to these values.

 

Thanks

Share this post


Link to post
Share on other sites
Check define('HEADING_TITLE' ...

for corresponding php file. Sitemap takes name from this line

It does not like the escaped apostrophe in eg Let\'s

change the title to somthing that does not have an escaped apostrophe


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

If anyone is interested I have coded some addons for an authors list if you use article manager and for news categories if you use newsdesk. I will post code if anyone wants it.


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites
It does not like the escaped apostrophe in eg Let\'s

change the title to somthing that does not have an escaped apostrophe

 

Thanks that makes sense.

Share this post


Link to post
Share on other sites
Hello. I got the same problem.

I did the changes you said, but I still get the same error

Catchable fatal error: Object of class box could not be converted to string in /home/ercomerc/public_html/admin/includes/functions/html_output.php on line 281

 

Here is my code:

// Output a form pull down menu

function tep_draw_pull_down_menu($name, $values, $default = '', $parameters = '', $required = false) {

$field = '<select name="' . tep_output_string($name) . '"';

 

if (tep_not_null($parameters)) $field .= ' ' . $parameters;

 

$field .= '>';

 

//if (empty($default) && isset($GLOBALS[$name])) $default = stripslashes($GLOBALS[$name]);

 

// For Dymanic Sitemap to work must change this line

if ( ($default == '' && $GLOBALS[$name] == $values[$i]['id']) || ($default == $values[$i]['id']) );

 

for ($i=0, $n=sizeof($values); $i<$n; $i++) {

$field .= '<option value="' . tep_output_string($values[$i]['id']) . '"';

if ($default == $values[$i]['id']) {

$field .= ' SELECTED';

}

 

$field .= '>' . tep_output_string($values[$i]['text'], array('"' => '"', '\'' => ''', '<' => '<', '>' => '>')) . '</option>';

}

$field .= '</select>';

 

if ($required == true) $field .= TEXT_FIELD_REQUIRED;

 

return $field;

}

 

////

 

Can you help?

 

 

BUMPED this guys post, cause I have the same problem, I tried the fix suggested but it made no difference, any1 got any ideas?

Share this post


Link to post
Share on other sites
I think its a safe mode issue I am working on a fix for my site now.

 

Same issue here. I'll be interested in any fix you come up with.

Share this post


Link to post
Share on other sites

Hi

 

Can you please help me

 

I installed all the files and code and ran the query and made sure the table is there but when I go to the admin control panel and click on Site Map Maintenance i get this error

 

1146 - Table 'moodlehealth.TABLE_SITEMAP_EXCLUDE' doesn't exist

 

select exclude_file from TABLE_SITEMAP_EXCLUDE where exclude_type != "0" and is_box="0"

 

I cheked the databse and the table exists

 

thanks

Share this post


Link to post
Share on other sites

Hi

 

Can you please help me

 

I installed all the files and code and ran the query and made sure the table is there but when I go to the admin control panel and click on Site Map Maintenance i get this error

 

1146 - Table 'moodlehealth.TABLE_SITEMAP_EXCLUDE' doesn't exist

 

select exclude_file from TABLE_SITEMAP_EXCLUDE where exclude_type != "0" and is_box="0"

 

I cheked the databse and the table exists

 

thanks

Share this post


Link to post
Share on other sites
This is the support thread for the Dynamic SiteMap contribution. Based on the SiteMap MS2 contribution, it allows the full shop to be automatically listed and updated dynamically.

 

Jack

Hi

 

Can you please help me

 

I installed all the files and code and ran the query and made sure the table is there but when I go to the admin control panel and click on Site Map Maintenance i get this error

 

1146 - Table 'moodlehealth.TABLE_SITEMAP_EXCLUDE' doesn't exist

 

select exclude_file from TABLE_SITEMAP_EXCLUDE where exclude_type != "0" and is_box="0"

 

I cheked the databse and the table exists

 

thanks

Share this post


Link to post
Share on other sites
Hi

 

Can you please help me

 

I installed all the files and code and ran the query and made sure the table is there but when I go to the admin control panel and click on Site Map Maintenance i get this error

 

1146 - Table 'moodlehealth.TABLE_SITEMAP_EXCLUDE' doesn't exist

 

select exclude_file from TABLE_SITEMAP_EXCLUDE where exclude_type != "0" and is_box="0"

 

I cheked the databse and the table exists

 

thanks

You missed adding the definition for TABLE_SITEMAP_EXCLUDE. Read back through the instructions for where that is mentioned.

 

Jack

Share this post


Link to post
Share on other sites

Dynamic Sitemap 3.5

 

Here are changes that I made on my installation to make this work that aren't in the install and some bugs:

 

1. You can remove this line from admin/includes/filenames.php as it is no longer necessary:

 

define('FILENAME_CREATE_XML_SITEMAPS', 'create_xml_sitemaps.php');

 

2. change the file permissions in catalog/dynamic_sitemap.php and in catalog/create_xml_sitemaps.php to 775 or 777

 

3. in catalog/create_xml_sitemaps has the admin directory hardcoded in about LINE 82, so if you've changed the admin directory, you need to change this too

 

4. in catalog/dynamic_sitemap.php

 

find this:

 

					echo '<li>'.$boxHeading[$b]['heading'][$b];
				$nb_elements = count($boxHeading[$b]['filename']);
				if($nb_elements > 0)
				{
					if (tep_not_null($boxHeading[$b]['filename'][0]))
					{
					echo '<ul>';
					for ($f = 0; $f < $nb_elements; ++$f)
						if (tep_not_null($boxHeading[$b]['filename'][$f]))
							echo '<li><a title="'. $boxHeading[$b]['boxtext'][$f] .'" href="' . tep_href_link($boxHeading[$b]['filename'][$f]) . '">' . $boxHeading[$b]['boxtext'][$f] . '</a></li>';
					echo '</ul>';
					}
				}
				echo '</li>';
			}

 

change to this:

 

					echo $boxHeading[$b]['heading'][$b];
				$nb_elements = count($boxHeading[$b]['filename']);
				if($nb_elements > 0)
				{
					if (tep_not_null($boxHeading[$b]['filename'][0]))
					{
					echo '<ul>';
					for ($f = 0; $f < $nb_elements; ++$f)
						if (tep_not_null($boxHeading[$b]['filename'][$f]))
							echo '<li><a title="'. $boxHeading[$b]['boxtext'][$f] .'" href="' . tep_href_link($boxHeading[$b]['filename'][$f]) . '">' . $boxHeading[$b]['boxtext'][$f] . '</a></li>';
					echo '</ul>';
					}
				}
			}

 

 

A few other notes:

 

1. If you re-uploaded your files, make sure you remember to hardcode your webaddress in catalog/sitemaps.xml

2. If you re-uploaded your files, make sure your file permissions in the catalog directory for all .xml files are set to 666

3. If you re-uploaded your files, make sure your file permissions in the catalog directory for catalog/dynamic_sitemap.php and catalog/create_xml_sitemaps.php are set to 775 or 777

 

Bugs:

1. In the admin, there is not a cool integrated popup for the xml sitemap creation with rad icons to submit the sitemap to each of 3 different search engines - ONLY the one popup will work at a time presently in my Firefox browser. Once you've clicked one popup, you can't click the others.

2. The Yahoo submission link always popsup saying

 

		This XML file does not appear to have any style information associated with it. The document tree is shown below.

−
<Success>
<Message>Update notification has successfully submitted.</Message>
</Success>
−
<!--
ws05.search.scd.yahoo.com compressed/chunked Tue Jun 17 17:43:03 PDT 2008 
-->

 

thanks for all your work.

 

Scott

Edited by olsonsp4c

Share this post


Link to post
Share on other sites

Is it odd that version 4 has been uploaded and the install instructions have not been updated? The person who uploaded has not posted about the upload either.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Is it odd that version 4 has been uploaded and the install instructions have not been updated? The person who uploaded has not posted about the upload either.

 

Re: Dynamic Sitemap v4.0

 

I find it very difficult to make heads or tails out of the instructions. I would love to try this contribution but don't want to see my site in pieces. Would be most grateful if anyone can assist.

Share this post


Link to post
Share on other sites
Re: Dynamic Sitemap v4.0

 

I find it very difficult to make heads or tails out of the instructions. I would love to try this contribution but don't want to see my site in pieces. Would be most grateful if anyone can assist.

Yeah, I am not going to touch it. No support from the contributor.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Yeah, I am not going to touch it. No support from the contributor.

Hi MNK!

Sorry for my english.

I install your new version sitemap V4.0 it,is working great.I can acces the google,y..only in browser Mozila_it is ok but i have a small,but for me BIG problem: All it is ok and work ok in Mozzila when i clik on the sitemap link,but in IE the link apear so:

Mon mot de passeInformer une connaissance sur J'ai oublié mon mot de passe !Qu'y-a-t-il dans mon panier ?Creating XML Site MapsLivraison & retourPlan du SiteVoyons ce que nous avons-làInscriptions newslettersRecherche avancéeAchetez-les tant quils sont en promo !Historique de mes commandesCritiquesPanier visiteur/Panier membreTous nos produitsMon carnet d'adresses personnelInformation commandeNotifications de produitsAjouter une entrée du carnet d'adresses

In Mozilla it is ok.

I try changed the cod from: catalog/dynamic_sitemap.php And also i try put the dynamic_sitemap.php from contribution 3 but it is same error.It,s work great in Mozilla ,but in IE are not ok.

Any advice pls?

Th a lots_Octav.

Share this post


Link to post
Share on other sites

Hey guys,

 

I installed Dynamic SiteMap v 4.0 and I cant seem to fix one problem i get. He makes all the sitemap files etc, only I get a error in the dynamic_sitemap.php.

 

Fatal error: Cannot use string offset as an array in /home/***/domains/***.nl/public_html/dynamic_sitemap.php on line 285

 

Anyone have the same problem or knows how to fix it?

 

Kind regards,

Jasper

Share this post


Link to post
Share on other sites

I have followed the instructions given with this contribution. It installs ok but when I try to create a sitemap in admin the following error appears:

 

Creating site map index file dated: 2008-06-29T16:19:28+00:00

Warning: fopen(/home/inkround/public_html/sitemaps.xml) [function.fopen]: failed to open stream: Permission denied in /home/inkround/public_html/create_xml_sitemaps.php on line 137
Unable to create site map index file!

 

It seems a lot of people are having this issue - is there a fix for this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×