Jump to content
Jack_mcs

Dynamic SiteMap

Recommended Posts

It appears to be a typo. Changes like that should be made to the admin/includes/languages.english.php file.

 

Jack

Share this post


Link to post
Share on other sites
Hello,

 

I've just installed Dynamic Sitemap v 2.0 according to the installation instructions. However, when I go to catalog/dynamic_sitemap.php nothing showing up, just empty page. What's wrong? By the way, I have STS installed if it matters.

 

Any help would be appreciated.

Thanks.

I too have this problem. Did you manage to find a solution? I too have STS installed.


Ah, the world wide web. What a wonderful place.

Share this post


Link to post
Share on other sites

I have installed this contribution but whenever I select the sitemap link a blank page where the sitemap should be appears. Any ideas? Admin works fine, just the catalog side not showing up.


Ah, the world wide web. What a wonderful place.

Share this post


Link to post
Share on other sites

I'm guessing by the lack of response from someone who has STS and dynamic sitemap contribution together, that this contribution is not compatible with STS. Anyone? Please! Pretty Please!!


Ah, the world wide web. What a wonderful place.

Share this post


Link to post
Share on other sites

It's compatible. There is nothing in it that would not make it so. But I don't use STS so I can't help you. I would suggest asking in the STS support thread since the problem isn't with this contribution.

 

Jack

Share this post


Link to post
Share on other sites
It's compatible. There is nothing in it that would not make it so. But I don't use STS so I can't help you. I would suggest asking in the STS support thread since the problem isn't with this contribution.

 

Jack

 

Whoa there Jack,

 

I'm not saying it's a problem with this contribution. All I'm saying is that it may not work alongside STS.

 

I have asked in the STS forum and are awaiting a reply. I believe STS is a bit twitchy with some contributions. Appologies if I offended you.

Edited by freakystreak

Ah, the world wide web. What a wonderful place.

Share this post


Link to post
Share on other sites

I am just about to install V1.6 as it sounds to be the most reliable (I am correct in thinking that?)

 

 

Would there be a problem if I renamed the dynamic_sitemap.php to sitemap.php

 

And changed

 

define('FILENAME_DYNAMIC_SITEMAP', 'dynamic_sitemap.php');

 

to

 

define('FILENAME_DYNAMIC_SITEMAP', 'sitemap.php');

Share this post


Link to post
Share on other sites

I have installed 1.6 without any real problems. Just a could of funnies

 

Wherever there is an ' in the title, it cuts the description short. Is there a way around this?

 

Also the Information section appears to be in the wrong place and the title is in Red instead of black. This also caused all the items to appear twice. If I mask out the items eg dynamic_sitemap.php the one in the information section stays, while the one above it gets removed.

 

 

Is there a way to get the title to be black and underneath where it says Sale Items

 

Here is a pic of what I am getting at the moment.

 

sitemapyj6.gif

 

 

Cheers

Share this post


Link to post
Share on other sites

Has anyone figured out how to add/list .html pages to the sitemap?

 

There was a snipet of code suggested earlier in this thread, but it did not do the job.

 

There are important .html pages of my site I want to add into the sitemap.

 

Thanks in advance.


26 contributions installed - - And counting ....

 

Just want to take this time to extend my appreciation to everyone who have patiently answered my questions over the months of working on my site. I hope to be able to "pass it forward" and help new folks.

Share this post


Link to post
Share on other sites
Whoa there Jack,

 

I'm not saying it's a problem with this contribution. All I'm saying is that it may not work alongside STS.

 

I have asked in the STS forum and are awaiting a reply. I believe STS is a bit twitchy with some contributions. Appologies if I offended you.

No, not at all, I'm sorry if you took it that way. There are some contributions that do various things with the code that may not work out of the box with STS. However, this one uses straight code and doesn't do anything different than the index file is doing. That's what I meant that it is compatible. There is not any reason for it not work, from the contributions viewpoint. But STS requires certain things to be changed sometimes for a file to work. So, in that sense, it is an STS problem. Try installing this contribution and turning off STS. If the code works, then it is just an STS problem. Not necessairly a problem with the STS contribuiton, but maybe a problem with the code calling this contribution. If it doesn't work, then it is installed incorrectly.

 

Jack

Share this post


Link to post
Share on other sites
I am just about to install V1.6 as it sounds to be the most reliable (I am correct in thinking that?)

Would there be a problem if I renamed the dynamic_sitemap.php to sitemap.php

 

And changed

 

define('FILENAME_DYNAMIC_SITEMAP', 'dynamic_sitemap.php');

 

to

 

define('FILENAME_DYNAMIC_SITEMAP', 'sitemap.php');

Yes, you can do that but you will also need to change the references to dynamic_sitemap within the dynamic_sitemap files. The only reason it is named that is because there is another contribution that uses sitemap and I didn't want to introduce confusion.

 

Jack

Share this post


Link to post
Share on other sites
Yes, you can do that but you will also need to change the references to dynamic_sitemap within the dynamic_sitemap files. The only reason it is named that is because there is another contribution that uses sitemap and I didn't want to introduce confusion.

 

Jack

 

 

Cheers.

 

 

Will this sitemap work alongside the google sitemap Xml one?

Share this post


Link to post
Share on other sites

Could someone help me with the following error message. I searched this topic but I couldn't find anyone with the same problem. I think it has to do with permissions (I think)

 

I get the errormessage as I try to open in the Admin side the configuration page for sitemap

 

The errormessage is:

 

Warning: opendir(/www/htdocs/gebruike/): failed to open dir: Permission denied in /www/htdocs/gebruike/admin/sitemap.php on line 95

Error! Can't open catalog dir : /www/htdocs/gebruike/

 

Could somebody help me with a solution ?

Share this post


Link to post
Share on other sites
Cheers.

Will this sitemap work alongside the google sitemap Xml one?

Yes, they work fine together and both should be installed for best SEO results.

 

Jack

Share this post


Link to post
Share on other sites
Could someone help me with the following error message. I searched this topic but I couldn't find anyone with the same problem. I think it has to do with permissions (I think)

 

I get the errormessage as I try to open in the Admin side the configuration page for sitemap

 

The errormessage is:

 

Warning: opendir(/www/htdocs/gebruike/): failed to open dir: Permission denied in /www/htdocs/gebruike/admin/sitemap.php on line 95

Error! Can't open catalog dir : /www/htdocs/gebruike/

 

Could somebody help me with a solution ?

It might be a setting on your server. I would ask your host what the problem is.

 

Jack

Share this post


Link to post
Share on other sites
Yes, they work fine together and both should be installed for best SEO results.

 

Jack

 

 

Thanks for the info. Will add the other one soon

Share this post


Link to post
Share on other sites
It might be a setting on your server. I would ask your host what the problem is.

 

Jack

 

Hello Jack,

 

I checked the settings and could the following setting cause the problem: Virtual Directory Support = disabled

 

I think that this setting could be the problem...am I correct ?

Share this post


Link to post
Share on other sites

I would think the opendir setting but since you can access the php.ini file, just try it and see which it is.

 

Jack

Share this post


Link to post
Share on other sites

HI Jack, hopefully your still around, a bit off topic and if its too much fussying around leave it, but how do you access the php.ini file. I have root access to my ftp details and have cpanel, is this what I need or do I need to contact my host support team.

Edited by stu2000

Stuart

Share this post


Link to post
Share on other sites
HI Jack, hopefully your still around, a bit off topic and if its too much fussying around leave it, but how do you access the php.ini file. I have root access to my ftp details and have cpanel, is this what I need or do I need to contact my host support team.

You would need to contact your host support team. You might be able to add your own php.ini file in your root area, some hosts allow that. Worth asking.

Share this post


Link to post
Share on other sites

A php.ini file can be added but not all of the settings can be changed or the server would crash due to eveyone raising their values to the maximum setting. But some can be changed.

 

Jack

Share this post


Link to post
Share on other sites

Is there a way to have this contrib work with the enable/disable catergories as at the moment my site map is showing all my disabled catergories?

 

Thanks

Share this post


Link to post
Share on other sites
Is there a way to have this contrib work with the enable/disable catergories as at the moment my site map is showing all my disabled catergories?

 

Thanks

 

 

Sorted added the

categories_query = tep_db_query("select c.categories_id, cd.categories_name, c.parent_id from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_status = '1' and c.categories_id = cd.categories_id and cd.language_id = '" . (int)$languages_id . "' order by c.parent_id, c.sort_order, cd.categories_name");

in /classes/category_tree.php

 

From version 1.4

Share this post


Link to post
Share on other sites

Hello,

 

I have installed version 2, but get the following;

 

 

1146 - Table 'savageshop.sitemap_exclude' doesn't exist

 

select exclude_file from sitemap_exclude where exclude_type != "0" and is_box="0"

 

[TEP STOP]

 

 

Can someone help me?

Share this post


Link to post
Share on other sites
I have installed version 2, but get the following;

1146 - Table 'savageshop.sitemap_exclude' doesn't exist

 

select exclude_file from sitemap_exclude where exclude_type != "0" and is_box="0"

 

[TEP STOP]

These errors indicate that you have not successfully installed the "install.sql" - which updates your osc database with a needed table and keys. Edited by squeekit

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×