Jump to content
Sign in to follow this  
rinon

Contrib Installer

Recommended Posts

need urgent help here please...

 

1.) when i click on contributions it show below error,

 

1146 - Table 'theshop_php.installed_contributions_type' doesn't exist

 

select type_name from installed_contributions_type order by type_name

 

[TEP STOP]

 

then nothing else accept title of " Installed Contributions - Overview " and help file logo.

 

 

what should i do?

 

2.) how to create contribute files? from other contribution to cis file? i had read the example but still not understand.

 

thanks

 

Hey Rinon...

 

I've finally publishing my automated one-click installer, alongside three other contributions that use it, today.

 

The contribution author documentation is here. Check out the documentation for my other contributions to see screen-shots of it in action.

 

If after looking at it you want to go ahead and work on including its functionality into your module, let me know.

 

 

i cant download anything there....

Share this post


Link to post
Share on other sites
Okay.. I've installed it again. I get the following: [CONTRIB INSTALLER TEP STOP]

 

I ran the following query:

 

CREATE TABLE IF NOT EXISTS contrib_installer (

ID int(4) NOT NULL auto_increment PRIMARY KEY,

line_number int(5) unsigned default NULL,

file varchar(255) default NULL,

contrib_name varchar(255) default NULL

);

 

I get: Your SQL query has been executed successfully

 

The table exists now.

 

I assume I'm good to go now?

 

Hi!

I will change all sql queries if this works on your mashine.

This will be 1.0.4 version.

 

Okay.. I've installed it again. I get the following: [CONTRIB INSTALLER TEP STOP]

 

I ran the following query:

 

CREATE TABLE IF NOT EXISTS contrib_installer (

ID int(4) NOT NULL auto_increment PRIMARY KEY,

line_number int(5) unsigned default NULL,

file varchar(255) default NULL,

contrib_name varchar(255) default NULL

);

 

I get: Your SQL query has been executed successfully

 

The table exists now.

 

I assume I'm good to go now?

 

 

Hi,

folder catalog/admin/contributions/ is only for contribs (CIP).

All files must be placed as they placed in ZIP of Contrib Installer.

So you have now wrong path to files if place all in one folder.


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites
When I try to install All_Products-2.8

 

I get the message:

 

I need write permission for: /home/www/free/mysite.com

 

How do I change permission for my site?

The CHMOD option is disabled!!! it works for the other files/folders...

 

Permissions needed for folder /backup in you contrib (CIP) folder.

There are folder where stored all files changed by this contrib before any changes.

So if you have any problems with install CIP you can restore files from this folder.

 

You must set write-permissions for parent folder too.

Contrib Installer checks all folders for write permission in filepath. And it found that folder:

/home/www/free/mysite.com

is unwritable.

Try to ask you Provider/Hoster about it.

P.S. Web server works with other permissions that you have when using ftp.


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites

when i click on contributions it show below error, ow to fix it please?

 

1146 - Table 'theshop_php.installed_contributions_type' doesn't exist

 

select type_name from installed_contributions_type order by type_name

 

[TEP STOP]

 

only show title of " Installed Contributions - Overview " and help file logo, nothing.

 

 

what about database? anything should add in the mySQL? currenthly i did not touch on the sql, because the readme file did not said need to.

 

thanks

 

INSTALL INFO

 

 

 

##########################################################

# add to your database with phpmyadmin or whatever you like...

== == == == == == == ==

 

add to database.sql

 

 

== ==

 

##########################################################

 

what should i add in my mysQL?

Share this post


Link to post
Share on other sites

Hi,

for me the contrib installer doesn't work. I've tried to install it into a completely new oscommerce-store as well as in an existing oscommerce-store. None of those stores works together with contrib installer (in version 1.0.3). I just get nothing else than http://localhost/oscommerce/admin/contrib_installer.php (and seeing the part of the readme.txt...) Well - thought it would be an permission issue, but it isn't. I've followed the instructions, given in readme.txt and set the rights to g+w... Even with chmod 777 (over admin/contributions/*) it is not willed to work. I can click the "continue"-button, but it doesn't continue, but reloads the contrib-installer.php page... (it also doesn't tell me, that there are permission issues or something - it just reloads...)

 

Anyway: i've translated the language-files into german:

 

installed_contributions.php

<?php
/*
 $Id: installed_contribution.php,v 1.3 2003/04/04 11:10:39 roberthellemans Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce
 Author (Translation into german): Sandra Dismar

 Released under the GNU General Public License

*/

define('HEADING_TITLE','Installierte Contributions');
define('HEADING_TITLE_SELECT_CATEGORY','Alle Kategorien');
define('HEADING_TITLE_SEARCH','Suche');
define('HEADING_SUB_TITLE','?bersicht');
define('HEADING_SUB_TITLE_COPYTO','Kopieren dieser Daten');
define('HEADING_SUB_TITLE_EDIT','Update');
define('HEADING_SUB_TITLE_INSERT','Einf?gen');
define('HEADING_SUB_TITLE_DELETE','L?schen');
define('HEADING_SUB_TITLE_SETFLAG','Status ?ndern');
define('HEADING_SUB_TITLE_READONLY','Vorschau');

define('TABLE_HEADING_AUTHORISE_PROCESS','<font color=blue>Help ?</font>');
define('TABLE_HEADING_HELP','Wie macht man ... ?');

define('TABLE_HEADING_NAME', 'Name');
define('TABLE_HEADING_STATUS', 'Status');
define('TABLE_HEADING_ACTION', 'Aktion');

define('IMAGE_BUTTON_BACK','Zur?ck zur vorherigen Seite');
define('IMAGE_INSERT','Eine neue Contribution hinzuf?gen');
define('IMAGE_BUTTON_UPSORT','Diese Spalte aufsteigend sortieren');
define('IMAGE_BUTTON_DOWNSORT','Diese Spalte absteigend sortieren');
define('IMAGE_ICON_STATUS_YELLOW','Lesezeichen hinzugef?gt');
define('IMAGE_ICON_STATUS_YELLOW_LIGHT','Lesezeichen hinzuf?gen');
define('IMAGE_ICON_INFO', ' Vorschau ');
define('TEXT_SELECT_RELEASE_TARGET','Release-Target ausw?hlen');
define('TEXT_SELECT_CATEGORY','Kategorie ausw?hlen');
define('TEXT_FORUM_REF','Forum Thread');
define('TEXT_CONTR_MODULE','Zus?tzliches Modul');
define('TEXT_CONFIG_COMMENTS','Kommentare zur Konfiguration');
define('TEXT_CONTRIBUTION_REF','Contribution-Nummer');
define('TEXT_NAME_VERSION','Name & Version');
define('TEXT_ID','osC ID');
define('TEXT_CHECK_FORUM','Hier klicken um zum Foren-Beitrag zu gelangen.');
define('TEXT_CHECK_UPDATES','Hier klicken um nach Updates zu suchen.');
define('TEXT_CATEGORY','Kategorie');
define('TEXT_INFO_HEADING_DELETE','Contribution-Info l?schen?');
define('TEXT_INFO_DELETE_INTRO','M?chten Sie wirklich l?schen ');
define('TEXT_INFO_DATE_ADDED','Datum hinzugef?g');
define('TEXT_INFO_LAST_MODIFIED','Letzte ?nderung');
define('TEXT_INFO_STATUS_CHANGE','Status ge?ndert');
define('TEXT_INFO_STATUS','Status');
define('TEXT_INFO_LAST_UPDATE','Letztes Update (von Autor)');
define('TEXT_INFO_OSC_TARGET','Release Target');
define('TEXT_INSERT_URL','Nur nach dieser URL Text einf?gen');
define('TEXT_INSERT_DATE','Datum, an der der Autor diese Version hochladete !');
define('TEXT_INSERT_VERSION','Diese Contribution wurde f?r osC-Version entwickelt ?');
define('TEXT_MORE_INFO','Forum ansehen');
define('TEXT_CONFIG_STATUS', 'Status');
define('TEXT_DISPLAY_NUMBER_OF_RECORDS', ' Eintr?ge ');

define('LABEL_MORE_INFO','Hier klicken um das Forum nach dieser Contribution zu durchsuchen.');

define('TEXT_NO_DATA','Keine passenden Daten gefunden.');
define('TEXT_EMPTY_DATABASE','Die DATENBANK ist leer !');
define('TEXT_EMPTY_CATEGORY','Diese Kategorie enth?lt keine Daten.');
//define('','');
//define('','');
//define('','');
?>

 

 

installed_contributions_help.php

<?php
/*
 $Id: installed_contributions_help.php,v 1.3 2003/04/04 11:10:39 roberthellemans Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License

 Author (Translation into german): Sandra Dismar

 Version Control & Bookmark MODULE for Contributions 0.1
by Robert Hellemans
www.RuddlesMills.com 
This is a LIVE SHOP, so no TEST accounts etc...

*/

define('TITLE','Version Control & Bookmark MODULE for Contributions 0.1.2');
define('AUTHOR','<br>Created by Robert Hellemans, German Translation by Sandra Dismar');
define('TEXT_CLOSE_WINDOW','<br><font color=red><b>Fenster schlie?en.</b></font>');
define('TEXT_IC_ONE','<br><b>Buttons:</b><br>green = Aktiv (installiert)<br>rot = Inaktiv<br>orange = Lesezeichen<br>hell-orange = nicht gesetzt');
define('TEXT_IC_TWO','<br><b>osC ID</b> = Direkt-Link zur Contribution-Seite. Sie k?nnen diese URL unter <br><b>Administration->Konfiguration->Verschiedenes</b> anpassen.');
define('TEXT_IC_THREE','<br><b>Status</b> Hier k?nnen Sie Einstellungen vornhemen, die nicht mit osC verbunden sind.<br>Beispielsweise: gr?n=installiert, rot=hat in der aktuellen, installierten Version Fehler, gelb=Lesezeichen zur Einfachen Suche auf der osC-Website<br>Anmerkung: Sie k?nnen eine Menge Daten in den '\Kommentaren zur Konfiguration\' hinzuf?gen, sodass Sie alle \'Spezial\'-?nderungen ausf?hrlich beschreiben k?nnen, w?hrend die Contribution installiert wird. <br>Anmerkung: Die URLs f?r die osC ID & der Foren-Eintrag werden in <br>Administration->Konfiguration->Verschiedenes->Forum Link<br>Administation->Konfiguration->Verschiedenes->URL zur Contribution gesetzt.');
//define('TEXT_IC_FOUR','');
//define('TEXT_IC_FIVE','');
//define('TEXT_IC_SIX','');
//define('AUTHOR','Robert Hellemans');
?>

 

Greets,

Sandra

Share this post


Link to post
Share on other sites
when i click on contributions it show below error, ow to fix it please?

 

1146 - Table 'theshop_php.installed_contributions_type' doesn't exist

 

select type_name from installed_contributions_type order by type_name

 

[TEP STOP]

 

only show title of " Installed Contributions - Overview " and help file logo, nothing.

 

 

what about database? anything should add in the mySQL? currenthly i did not touch on the sql, because the readme file did not said need to.

 

thanks

 

INSTALL INFO

 

 

 

##########################################################

# add to your database with phpmyadmin or whatever you like...

== == == == == == == ==

 

add to database.sql

 

 

== ==

 

##########################################################

 

what should i add in my mysQL?

 

Please, next time describe your problem with more detailes.

For example:

What version do you use?

What you did

What you get?

 

I'll try to answer now:

Contrib Installer makes changes to database when it's initialize (first time run).

It creates nessesary tables.

This table doesn't exists in your database.

Why? I don't know.

How to fix:

You should remove and install againe Contrib Installer. He will make all nessesary changes.

Just remove and install againe.

 

:thumbsup:


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites
for me the contrib installer doesn't work. I've tried to install it into a completely new oscommerce-store as well as in an existing oscommerce-store. None of those stores works together with contrib installer (in version 1.0.3). I just get nothing else than http://localhost/oscommerce/admin/contrib_installer.php (and seeing the part of the readme.txt...) Well - thought it would be an permission issue, but it isn't. I've followed the instructions, given in readme.txt and set the rights to g+w... Even with chmod 777 (over admin/contributions/*) it is not willed to work. I can click the "continue"-button, but it doesn't continue, but reloads the contrib-installer.php page... (it also doesn't tell me, that there are permission issues or something - it just reloads...)

 

Hi,

Page where contributions folder is chossen loads only once.

This must be a first time when Conmtrib Installer needs to initialize yourself.

If Contrib Installer correctly install yourself you will NOT see this page again.

You could see it by some reasones:

1. Folder for contributions wasn't created.

2. Database tables wasn't created.

 

If one of this 2 checks falls you will see first page again.

 

More detail:

1. SQL check:

SELECT * FROM gonfiguration WHERE configuration_key = 'MODULE_CONTRIB_INSTALLER_DIR_FS_CONTRIBUTIONS'

If this record exists Contrib Installer will work.

 

2. Folder check:

folder for contribs must exists.

+- folder for Contrib Installer (under contribs folder) must exists.

+- file install.xml in Contrib Installer folder must exists

 

That's all. Check this.


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites
You could see it by some reasones:

1. Folder for contributions wasn't created.

2. Database tables wasn't created.

 

2. Folder check:

folder for contribs must exists.

+- folder for Contrib Installer (under contribs folder) must exists.

+- file install.xml in Contrib Installer folder must exists

Hi Vlad,

thx for your help so far. Well, then it must be point 2. Could you please post the SQL-Statements? They're not included in readme.txt or install.txt ;)

Well - i've the folders setup like this:

/opt/lampp/htdocs/oscommerce (as root)

- admin

- admin/contributions

- admin/contributions/backup

- admin/contributions/contrib_install/

- admin/contributions/contrib_install/install.xml

So this config should be ok, shouldn't it? - Means - my only problem is the not-existing DB-structure...

 

Thanks in advance.

 

Greets,

Sandra

Share this post


Link to post
Share on other sites

i got the same problem..

 

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1

);
[CONTRIB INSTALLER TEP STOP]

 

any solution yet?

Share this post


Link to post
Share on other sites

Ahhh~ i`m getting the same problemand it's driving me nuts! haha. =)

 

I wish there was a solution fast =(

 

Initialize Contrib Installer

 

Installing Contribution: Contrib_Installer_1.0.3From install file: /home/consolem/public_html/shop/admin/contributions/Contrib_Installer_1.0.3/install.xmlAuthor: Updated by Rinon for PHP5

Comments: osCommerce Forums: http://forums.oscommerce.com/index.php?showtopic=40010

Checking config file: File install.xml is valid.Checking permissions: Permissions is OK.Checking conflicts:No conflicts.PHP runtime messages: Done.

 

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1

 

);

[CONTRIB INSTALLER TEP STOP]

Share this post


Link to post
Share on other sites

Hi, Sandra!

All SQL statments can be found in

admin/contributions/contrib_install/install.xml

 

There are install-statments and remove-statments.

:)


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites

Hi, everybody!

 

Ahhh~ i`m getting the same problemand it's driving me nuts! haha. =)

 

I wish there was a solution fast =(

 

Initialize Contrib Installer

 

Installing Contribution: Contrib_Installer_1.0.3From install file: /home/consolem/public_html/shop/admin/contributions/Contrib_Installer_1.0.3/install.xmlAuthor: Updated by Rinon for PHP5

Comments: osCommerce Forums: http://forums.oscommerce.com/index.php?showtopic=40010

Checking config file: File install.xml is valid.Checking permissions: Permissions is OK.Checking conflicts:No conflicts.PHP runtime messages: Done.

 

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1

 

);

[CONTRIB INSTALLER TEP STOP]

 

Can you please test your database and run sql-statments that posted above?

I need to know a result because on my mashine it's work and SQL-syntax is OK.

Is it your local mashine or remote?


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites

Hi Vlad,

Hmm. You mean this file: contrib_installer_1.0.3/catalog/admin/includes/functions/install.xml i guess? Might you should point somewhere in the install.txt or so to this file ;) Or making it more user-friendly and providing an .sql-file? ;)

Greets,

Sandra

Share this post


Link to post
Share on other sites
Hi, everybody!

 

 

 

Can you please test your database and run sql-statments that posted above?

I need to know a result because on my mashine it's work and SQL-syntax is OK.

Is it your local mashine or remote?

 

 

Hi, I have the same problems, I tried the SQL statements in the instal.xml file

When I get to:

tep_db_query("INSERT INTO configuration_group VALUES (NULL, 'Contrib Installer', 'Configuration for the Contrib Installer', NULL, 1)");

 

I get:

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'tep_db_query("INSERT INTO configuration_group VALUES (NULL, 'Contrib Installer',' at line 1

 

I did not find a configuration_group table in my db and did not find any statement that creates it.

 

Any ideas? I use contrib_Installer_1.0.3 and osCommerce oscommerce-2.2ms2-051113

PS what's the role of " global $contrib_dir; " (right before the statement i get an error at)? I'm not supposed to run it as a sql statement, right?

 

Thanks, Adrian

 

 

Sandra:

Just open the install.xml file with a text editor or viewer and copy the statements that come after

<sql>

<query><![CDATA[

 

so, the first thing to copy and runt in as a sql statement in the install.xml file is:

 

CREATE TABLE IF NOT EXISTS `contrib_installer` (

`ID` int(4) NOT NULL auto_increment,

`line_number` int(5) unsigned default NULL,

`file` varchar(255) default NULL,

`contrib_name` varchar(255) default NULL,

PRIMARY KEY (`ID`)

);

 

 

I use phpMyAdmin to run the statements.

 

Hope it helps!

Adrian

Share this post


Link to post
Share on other sites
Hi, I have the same problems, I tried the SQL statements in the instal.xml file

When I get to:

tep_db_query("INSERT INTO configuration_group VALUES (NULL, 'Contrib Installer', 'Configuration for the Contrib Installer', NULL, 1)");

 

I get:

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'tep_db_query("INSERT INTO configuration_group VALUES (NULL, 'Contrib Installer',' at line 1

 

I did not find a configuration_group table in my db and did not find any statement that creates it.

 

Any ideas? I use contrib_Installer_1.0.3 and osCommerce oscommerce-2.2ms2-051113

PS what's the role of " global $contrib_dir; " (right before the statement i get an error at)? I'm not supposed to run it as a sql statement, right?

 

Thanks, Adrian

Sandra:

Just open the install.xml file with a text editor or viewer and copy the statements that come after

<sql>

<query><![CDATA[

 

so, the first thing to copy and runt in as a sql statement in the install.xml file is:

 

CREATE TABLE IF NOT EXISTS `contrib_installer` (

`ID` int(4) NOT NULL auto_increment,

`line_number` int(5) unsigned default NULL,

`file` varchar(255) default NULL,

`contrib_name` varchar(255) default NULL,

PRIMARY KEY (`ID`)

);

I use phpMyAdmin to run the statements.

 

Hope it helps!

Adrian

 

 

It seems that there is a statement missing here:

 

<sql>

<query><![CDATA[

INSERT INTO `installed_contributions_type` VALUES (1,'Credit Modules',1),(1,'Features',1), (1,'Images',1),

(1,'InfoBoxes',1),(1,'Languages',1),(1,'Order Total Modules',1),(1,'Payment Modules',1),(1,'Reports',1),

(1,'Shipping Modules',1),(1,'Templates / Themes',1),(1,'Other',1),(1,'Zones',1),(1,'Bookmarks',1);

]]></query>

<remove_query>SELECT * FROM `configuration_group` WHERE 1=0;</remove_query>

</sql>

 

the <query> statement shold cotinue with a <remove_query> for installed_contributions_type and <remove_query> for configuration_group should go atfer some kind of CREATE statement for configuration_group.

 

Am I right?

Adrian

Share this post


Link to post
Share on other sites
Hi,

Page where contributions folder is chossen loads only once.

This must be a first time when Conmtrib Installer needs to initialize yourself.

If Contrib Installer correctly install yourself you will NOT see this page again.

You could see it by some reasones:

1. Folder for contributions wasn't created.

2. Database tables wasn't created.

 

If one of this 2 checks falls you will see first page again.

 

More detail:

1. SQL check:

SELECT * FROM gonfiguration WHERE configuration_key = 'MODULE_CONTRIB_INSTALLER_DIR_FS_CONTRIBUTIONS'

If this record exists Contrib Installer will work.

 

2. Folder check:

folder for contribs must exists.

+- folder for Contrib Installer (under contribs folder) must exists.

+- file install.xml in Contrib Installer folder must exists

 

That's all. Check this.

 

I think there is a mispelling, it's probably configuration not gonfiguration in the SQL statement above.

Anyway, I don't have

configuration_group

configuration

 

I don't see the statements that create these tables. I tried to trace back the statements to " function contrib_tep_db_query($query, $link = 'db_link') { " in /admin/includes/functions/contrib_installer_base.php but I couldn't figure out completely how it works.

 

Can you post the information on the structure of these databases? At least I'll try to create them manually.

Thanks, Adrian

Share this post


Link to post
Share on other sites
Ok Im getting this error. Why? and how can I fix it.

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1

 

);

[CONTRIB INSTALLER TEP STOP]

 

Same problem here too

 

- was there ever a fix posted?

 

I'm trying to install for the first time on a CPANEL/FANTASTICO install of OSCommerce ms2.2 with security patch 051113

 

Server Specs:

PHP version 4.4.0

MySQL version 4.1.13-standard

cPanel Build 10.8.1-RELEASE 30

 

I did do the check

 

More detail:

1. SQL check:

SELECT * FROM gonfiguration WHERE configuration_key = 'MODULE_CONTRIB_INSTALLER_DIR_FS_CONTRIBUTIONS'

If this record exists Contrib Installer will work.

 

and it came up with no table so I'm guessing something fell over in the database installation section of the initial install.

 

I'll keep working on it.

 

Great Contrib by the way guys - really hope I can get it to work!

 

regards,

Harry

Share this post


Link to post
Share on other sites
I did do the check

and it came up with no table so I'm guessing something fell over in the database installation section of the initial install.

 

actually I missed the spelling mistake - when I fixed the spelling mistake it came good and passed the check.

 

 

regards,

Harry

Share this post


Link to post
Share on other sites

I rolled back to version 0.5d and it works - after that point I start getting the SQL error above.

 

Comments on installation of 0.5d:

 

I found I had to change /catalog/admin/contrib_installer.php:

 

	if($addfile[0]) {
	for($loop_index = 0; $loop_index < count($addfile) - 1; $loop_index++) {
		$output .= "<div class=\"section\"><font class=\"section-title\">".COPYING_TO_TEXT."</font>" . DIR_FS_CATALOG . $addfile[$loop_index]['FILE']['@']['NAME'] . "<br>";
		if(!copy(MODULE_CONTRIB_INSTALLER_DIR_FS_CONTRIBUTIONS . $_GET["contrib"] . '/catalog/' . $addfile[$loop_index]['FILE']['@']['NAME'], DIR_FS_CATALOG . $addfile[$loop_index]['FILE']['@']['NAME']))
			error (COULDNT_COPY_TO_TEXT. $addfile[$loop_index]['FILE']['@']['NAME'], $output . '</div>');
		chmod(DIR_FS_CATALOG . $addfile[$loop_index]['FILE']['@']['NAME'], 0755);
		$output .= "</div>";
	}
}

 

Specifically Line 534 to chmod of 0755 (rather than 0644) was needed on my server for the "all products" contrib to work (still working on the admin contrib)

 

The other thing was that the install process suggests the wrong folder location for contributions (had to change it to catalog/admin/contributions rather than catalog/contributions) this gets fixed in latter versions..

 

regards,

 

Harry

Share this post


Link to post
Share on other sites

Is there any resolution to this error yet?

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1

 

);

[CONTRIB INSTALLER TEP STOP]

 

I don't see any answer in any of the posts above. I am seeing this error on a fresh install of oscommerce and this is the first contribution that I have tried to install.

Share this post


Link to post
Share on other sites
Hi, I have the same problems, I tried the SQL statements in the instal.xml file

When I get to:

tep_db_query("INSERT INTO configuration_group VALUES (NULL, 'Contrib Installer', 'Configuration for the Contrib Installer', NULL, 1)");

 

I get:

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'tep_db_query("INSERT INTO configuration_group VALUES (NULL, 'Contrib Installer',' at line 1

 

I did not find a configuration_group table in my db and did not find any statement that creates it.

 

Any ideas? I use contrib_Installer_1.0.3 and osCommerce oscommerce-2.2ms2-051113

PS what's the role of " global $contrib_dir; " (right before the statement i get an error at)? I'm not supposed to run it as a sql statement, right?

 

Thanks, Adrian

Sandra:

Just open the install.xml file with a text editor or viewer and copy the statements that come after

<sql>

<query><![CDATA[

 

so, the first thing to copy and runt in as a sql statement in the install.xml file is:

 

CREATE TABLE IF NOT EXISTS `contrib_installer` (

`ID` int(4) NOT NULL auto_increment,

`line_number` int(5) unsigned default NULL,

`file` varchar(255) default NULL,

`contrib_name` varchar(255) default NULL,

PRIMARY KEY (`ID`)

);

I use phpMyAdmin to run the statements.

 

Hope it helps!

Adrian

Hi Adrian,

 

I was hoping you could help me please, Re: Contrib Installer.

 

I have uploaded everything including phpmysql the contents of the database.sql file, but in my administation panel I've got -

1146 - Table 'xxxxxxx_osc1.TABLE_INSTALLED_CONTRIBUTIONS_TYPE' doesn't exist

 

select type_name from TABLE_INSTALLED_CONTRIBUTIONS_TYPE order by type_name

 

[TEP STOP]

 

Installed Contributions - Overview

1) How do I correct the above?

 

2) How do I uload to phpmysql the install.xml file?

I keep getting errors or do you have a clean copy I can use?

 

Kind Regards,

Michelle

 

Share this post


Link to post
Share on other sites
Hi Adrian,

 

I was hoping you could help me please, Re: Contrib Installer.

 

I have uploaded everything including phpmysql the contents of the database.sql file, but in my administation panel I've got -

1) How do I correct the above?

 

2) How do I uload to phpmysql the install.xml file?

I keep getting errors or do you have a clean copy I can use?

 

Kind Regards,

Michelle

 

 

1). I don't know. Try to do what amhazing suggested above (install the earlier version 0.5d and do the modifications he suggested - I haven't tried that myself).

 

2). You don't. Just open install.xml in a text editor or viewer and copy the required portions and go to phpMyAdmin, go into your db and then go to the tab called "SQL" where you paste what you copied previously and then run the SQL statement. But I tried that and it still didn't work. I still recommend to try what amhazing suggested.

 

Merry Christmas,

Adrian

Share this post


Link to post
Share on other sites

Hi, can somebody give me a full list of the contributions that i can use with the cotrib installer. I need a contrib for a retail price, html area, coupons for discounts and statictics.

 

Thanks

Share this post


Link to post
Share on other sites

I already solve the problem.

 

Simply copy the sql code to a txt file. like database.sql

 

Then remove from the install.xml those code and upload to your domain.

 

add the sql file to your site database and them run contrib_installer.php again.

Edited by clikarte

Share this post


Link to post
Share on other sites
Hi, can somebody give me a full list of the contributions that i can use with the cotrib installer. I need a contrib for a retail price, html area, coupons for discounts and statictics.

 

Thanks

 

Here is a list of packages that have been made for the Contrib Installer:

Contribution Control & Bookmark MOD 0.1.4

Imagecheck v1.2 w/Admin

All Products 2.8

osCommerce PayPal IPN Module v1.1 For 2.2MS2

Attribute Sets version 5.5

Article Manager v1.2b

Header Tags Controller v2.5.4 Complete

Admin Access 2.1 (for MS2)

 

From now on, I have been asked by the osCommerce devel team to put all CIP's on the Contrib Installer download page, which is here: http://www.oscommerce.com/community/contributions,3286.

 

Right now, I'm in the middle of redesigning the Installer, so you may want to hold off until we get this released. I think there will also be some more CIP's being released soon.

 

- Rinon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×