Jump to content
Sign in to follow this  
rinon

Contrib Installer

Recommended Posts

I'am unable to install contribs, i always get messages like this. Anyone know what I need to do to fix??

 

 

step_by_step_orders_v1.8.zip Success: File upload saved successfully.

Could not open XML input from: step_by_step_orders_v1.8/install.xml

step_by_step_orders_v1.8.zip havn't contained well formed XML-file: install.xml

Could not open XML input from: step_by_step_orders_v1.8/install.xml

step_by_step_orders_v1.8.zip havn't contained well formed XML-file: install.xml

 

 

install.xml does not exists!!!

Share this post


Link to post
Share on other sites
I just installed the CI v2.0 on a clean osCommerce, and when I initalize the installation the next screen shows the installed contrib (Contrib Installer) to the left, but it has an orange area to the right of it that says:

File doesn't exist: /home/username/domains/thedomain.com/public_html/admin/includes/column_left.php
<add2end> #1

 

The column_left.php file is in the /includes/ folder.

 

Any suggestions as to what I can do to fix it?

 

Thanks.

 

Kind time of the day.

Wanted to check this contribution, seems like something great :thumbsup: . But I still have same issue with column_left.php and forum at cip.net.ua not available for some reason... :(

 

Does any one know how to fix this?

 

Thanks.

Share this post


Link to post
Share on other sites

Hi!

Sorry, but I did not resieve any email about your problems and I thought that Contrib Installer becaming a non popular.

Try new version. Many bugs was fixed. Many will be fixed in next version which is coming soon.

 

 

Contrib_Installer_2.2 released

Changes since 2.0.6 (2.1 is very buggy):

  • -All strings located in language files.
  • -Removed intefration with phpbb. Removed class phpbb_user and phpbb forum features.
  • -Fixed bug with Contrib Installer removing.
  • -Changed layout and design.
  • -All code was cleaned up.
  • -PHP-tag now is not supported because of security reasons.
  • -All CSS rules moved to separated CSS-file (includes/contrib_installer.css)
  • -Buttons Pack/Unpack and Download is not shown by default. If you want you can turn them on on shop's configuration.
  • -Added russian translation made by Vam (http://vamshop.com/)
  • -Added new parameters in description tag:
  • <post_install>God bless you!</post_install> - message that will be shown after install
  • -Added javascript confirmation for file deleting. Now page will be reloaded only once.
  • -Removed editing, downloading and some unneeded features.
  • -New parameter MAX_UPLOADED_FILESIZE.

Visit to download


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites
I'am unable to install contribs, i always get messages like this. Anyone know what I need to do to fix??

 

Hi!

Your zip file should have s cpecial file structure:

step_by_step_orders_v1.8.zip:

step_by_step_orders_v1.8

step_by_step_orders_v1.8/catalog

step_by_step_orders_v1.8/catalog/*

...

step_by_step_orders_v1.8/install.xml

 

If not Contrib Installer can't find install.xml at regular location.


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites
I just installed the CI v2.0 on a clean osCommerce, and when I initalize the installation the next screen shows the installed contrib (Contrib Installer) to the left, but it has an orange area to the right of it that says:

CODE

File doesn't exist: /home/username/domains/thedomain.com/public_html/admin/includes/column_left.php

<add2end> #1

 

 

The column_left.php file is in the /includes/ folder.

 

Any suggestions as to what I can do to fix it?

 

Thanks.

 

 

Kind time of the day.

Wanted to check this contribution, seems like something great :thumbsup: . But I still have same issue with column_left.php and forum at cip.net.ua not available for some reason... :(

 

Does any one know how to fix this?

 

Thanks.

 

Check permissions of column_left.php. Contrib Installer acts with web-server(apache/apache) rights. So it's posible to web-server to not have a rights to read this file. Also check a path to this file.


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites

.

Edited by Vlad Savitsky

===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites
Check permissions of column_left.php. Contrib Installer acts with web-server(apache/apache) rights. So it's posible to web-server to not have a rights to read this file. Also check a path to this file.

Hello,

 

The problem is another one.

I have the same one. The direcotry /something/catalog/admin/includes/column_left.php is hardcoded so, if you rename or move your admin directory outside of the catalog directory, it won't find the necessary files. But it is allowed to do this, so the contrib installer need to check the directory in which it is and save this for the future.

 

Kevin

Share this post


Link to post
Share on other sites
Hello,

 

The problem is another one.

I have the same one. The direcotry /something/catalog/admin/includes/column_left.php is hardcoded so, if you rename or move your admin directory outside of the catalog directory, it won't find the necessary files. But it is allowed to do this, so the contrib installer need to check the directory in which it is and save this for the future.

 

Kevin

 

 

Ok. In next version I'll try to fix this.

As I understud Contrib Installer should work with admin directory placed anywhere.

Right now Contrib Installer designed for clear installation of osCommerce.

Simple plan:

1. Install osCommrce at loacal mashine

2. Install Contrib Installer

3. Install all CIP you want.

4. Upload to the server files and database.

(if you want - you can NOT upload CI and folder with CIP's, and folder with backups)

 

This means that admin-folder placed always at the same place. But I'll try to fix this.


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites
Simple plan:

1. Install osCommrce at loacal mashine

2. Install Contrib Installer

3. Install all CIP you want.

4. Upload to the server files and database.

(if you want - you can NOT upload CI and folder with CIP's, and folder with backups)

 

This means that admin-folder placed always at the same place. But I'll try to fix this.

 

I understand your concept, but I think for security reasons and for language adaption it is very useful to move it somewhere else. Maybe you can have a directory like /html/yourshop/ and /html/admin/ and a domain yourshop.com pointing to /html/yourshop/ and a subdomain admin.yourshop.com pointing to /html/admin/.

In germany there is the word "Wartung" which means more the word "maintenance" than the word "administration", so I call the directory for the german users to "Wartung".

It is also a fact that many bots are searching for /admin/ directorys in something.com/admin/ and try all password combinations to get access. You can reduce the number of bots, which find you directory if you simple rename it. More different -> better. You can rename it to admin123/ too. All is better than the original name.

BUT please don't misunderstand me: alwas remember that you NEED a password for security! Renaming is only a way to reduce the number of possible attacks.

 

 

I think it should not be such a lot of work to make the directory path more dynamicly. I replaced it with my real path in about 10 files and then it work well.

You can also have a look in the file admin/includes/configure.php: DIR_WS_ADMIN and DIR_FS_ADMIN descripes the admin path. Maybe you can add the admin-path to a configuration file in the contrib installer - so you only need to change one file, if the admin dir is not the default. Or you can make a question in the installer to set the admin path...

 

Best Regards,

 

Kevin

Share this post


Link to post
Share on other sites

I'm getting this error when installing the Contrib.

 

File doesn't exist: /home/wifence/domains/xxxxxxxxxx.com/public_html/admin/includes/column_left.php
<add2end> #1

 

Also, I've installed my store in the root folder, and called my admin folder /iadmin/, but the above error points to /admin/. It also shows another contrib I uploaded into the folder, but that error is still there for the Install Contrib, and there is no left bar navigations or such

 

 

I must admit this too..... this is the 3rd time on 5 different servers, offline, and online I've tried this contrib, and it hasn't worked right out of the box. Too many errors received, and the manual lists files that aren't in the contrib.

 

I've also installed many contribs, and some just didn't pan out, but this is the only contrib thast I've tried to install and just can't.

 

There aught to be more than one person working on this contrib if this contrib is suppose to be the very 1st contrib a person should install on a fresh osCommerce store. All my stores were brand new,, and still, I've tried this version out.... thinking the bugs and kinks were worked out, yet, I'm still challenged with the fact that the Install Contrib isn't cutting the mustard right now.

Edited by kwalker

"What I didn't know yesterday, I know today & will remember tomorrow"

(By Kwalker)

 

What do you see when you open up the tep_database-pr2.2-CVS.pdf file that came with your osCommerce download?

Share this post


Link to post
Share on other sites

OK I have to say, being a noob to osC and php that the concept of an installer is AWESOME !!!

 

I am having the same problem - but it's not my fault - my webhost "supplied" osC and when they installed it they put catalog and admin in the root - so I get the same error - can't find column-left.php. I just ftp'd the osC source files from the latest rev over it (as it wasn't the latest version) and everything seems to be working fine - but it's not what I would call a clean install since the admin folder is not in the catalog folder.

 

Someone earlier said they changed the path is several files and got it to work - I am dreading the idea of manually editing the installer files - but I'd like to see this contrib in action - which files and can you point me to line numbers please (just to make it a little easier) ???

 

THANKS !!!

Share this post


Link to post
Share on other sites

hello this is my error in my host server

 

 

 

Warning: read_from_xml(D:/FruitEngine/store/admin/includes/classes/xml_domit_parser.php) [function.read-from-xml]: failed to create stream: No such file or directory in D:\FruitEngine\store\admin\includes\classes\ci_cip.class.php on line 292

 

Fatal error: read_from_xml() [function.read-from-xml]: Failed opening required 'D:/FruitEngine/store/admin/includes/classes/xml_domit_parser.php' (include_path='.;c:\php4\pear') in D:\FruitEngine\store\admin\includes\classes\ci_cip.class.php on line 292

 

pls help

Share this post


Link to post
Share on other sites

hello this is my error in my localhost server

Fatal error: Call to undefined function: get_real_start() in z:\home\xxxxxxx\www\admin\includes\classes\ci_tag_findreplace.class.php on line 87

 

Help my

Share this post


Link to post
Share on other sites

Hey :)

 

just wondering if there will be an new version for the nye osc rc1??

 

and if any one can make a install pack for the multi-store contrib..

 

BlackCap

Share this post


Link to post
Share on other sites

hey guys am getting this error

Couldn't find :

/* Begin Contrib_Installer_2.2 - installed by Contrib_Installer */

array('title' => TOOLS_FILES, 'link' => tep_href_link(FILENAME_FILE_MANAGER, 'selected_box=tools')))),
array(
'title' =>BOX_HEADING_CONTRIB_INSTALLER,
'image' => 'contrib_installer.png',
'href' => tep_href_link(FILENAME_CIP_MANAGER, 'selected_box=contrib_installer'),
'children' =>
array(
array('title' =>BOX_CONTRIB_INSTALLER_CIP_MANAGER,
'link' => tep_href_link(FILENAME_CIP_MANAGER, 'selected_box=contrib_installer')
),
array('title' =>BOX_CONTRIB_INSTALLER_UPLOAD_CIP,
'link' =>tep_href_link(FILENAME_CIP_MANAGER, 'action=upload&goto='.DIR_FS_CIP)
),
array('title' =>'CIP.NET.UA', 'link' => tep_href_link('http://cip.net.ua/')),
array('title' =>BOX_CONTRIB_INSTALLER_SEARCH_CIP, 'link' => tep_href_link('http://cip.net.ua/catalog/admin/cip_manager.php')),
)
)
);

/* End Contrib_Installer_2.2 - installed by Contrib_Installer */

in the file: /home58c/sub001/sc36895-SEEF/www/test/admin/index.php
<findreplace> #1

 

please help me solve this

and btw wld like to give a suggestion y dont u guys make a preinstalled version

of oscommerce ie contrib installer preinstalled

 

thx

Edited by technoman

Share this post


Link to post
Share on other sites
hey guys am getting this error

Couldn't find :

/* Begin Contrib_Installer_2.2 - installed by Contrib_Installer */

array('title' => TOOLS_FILES, 'link' => tep_href_link(FILENAME_FILE_MANAGER, 'selected_box=tools')))),
array(
'title' =>BOX_HEADING_CONTRIB_INSTALLER,
'image' => 'contrib_installer.png',
'href' => tep_href_link(FILENAME_CIP_MANAGER, 'selected_box=contrib_installer'),
'children' =>
array(
array('title' =>BOX_CONTRIB_INSTALLER_CIP_MANAGER,
'link' => tep_href_link(FILENAME_CIP_MANAGER, 'selected_box=contrib_installer')
),
array('title' =>BOX_CONTRIB_INSTALLER_UPLOAD_CIP,
'link' =>tep_href_link(FILENAME_CIP_MANAGER, 'action=upload&goto='.DIR_FS_CIP)
),
array('title' =>'CIP.NET.UA', 'link' => tep_href_link('http://cip.net.ua/')),
array('title' =>BOX_CONTRIB_INSTALLER_SEARCH_CIP, 'link' => tep_href_link('http://cip.net.ua/catalog/admin/cip_manager.php')),
)
)
);

/* End Contrib_Installer_2.2 - installed by Contrib_Installer */

in the file: /home58c/sub001/sc36895-SEEF/www/test/admin/index.php
<findreplace> #1

 

please help me solve this

and btw wld like to give a suggestion y dont u guys make a preinstalled version

of oscommerce ie contrib installer preinstalled

 

thx

Share this post


Link to post
Share on other sites

i found this contibution installer and as i have a reasonable new install of os, i decided rather than going down the manual route to install all contribs by hand i would make a fresh install and use this contribution, so here is what i did

 

I BACKED EVERYTHINGUP YES EVERYTHING .... site / database complete structure and data / data only

 

 

Now this was a good thing because i got this error.

 

 

COULDNT FIND
/* Begin Contrib_Installer_2.2 - installed by Contrib_Installer */

array('title' => TOOLS_FILES, 'link' => tep_href_link(FILENAME_FILE_MANAGER, 'selected_box=tools')))),
array(
'title' =>BOX_HEADING_CONTRIB_INSTALLER,
'image' => 'contrib_installer.png',
'href' => tep_href_link(FILENAME_CIP_MANAGER, 'selected_box=contrib_installer'),
'children' =>
array(
array('title' =>BOX_CONTRIB_INSTALLER_CIP_MANAGER,
'link' => tep_href_link(FILENAME_CIP_MANAGER, 'selected_box=contrib_installer')
),
array('title' =>BOX_CONTRIB_INSTALLER_UPLOAD_CIP,
'link' =>tep_href_link(FILENAME_CIP_MANAGER, 'action=upload&goto='.DIR_FS_CIP)
),
array('title' =>'CIP.NET.UA', 'link' => tep_href_link('http://cip.net.ua/')),
array('title' =>BOX_CONTRIB_INSTALLER_SEARCH_CIP, 'link' => tep_href_link('http://cip.net.ua/catalog/admin/cip_manager.php')),
)
)
);

/* End Contrib_Installer_2.2 - installed by Contrib_Installer */

in the file: /home/user/public_html/webshop/catalog/admin/index.php
<findreplace> #1

 

seems it doesnt like osc 2.2 rc1 hey?

 

my online shop is installed in root/shop/ so if anybody can tell me what i need to do to tell this how to find the files that i know are there after verification i would be much happier about this contribution, for now il think its pants :s

Edited by Jan Zonjee

Share this post


Link to post
Share on other sites
COULDNT FIND
/* Begin Contrib_Installer_2.2 - installed by Contrib_Installer */

array('title' => TOOLS_FILES, 'link' => tep_href_link(FILENAME_FILE_MANAGER, 'selected_box=tools')))),
array(
'title' =>BOX_HEADING_CONTRIB_INSTALLER,
...

 

seems it doesnt like osc 2.2 rc1 hey?

 

I had the same error on my RC1 installation. It appears that the admin/index.php has changed significantly from MS2 to RC1 and this find/replace is failing.

 

Anyone have an updated index.xml? or suggestions to correct? Thanks. -Craig

Share this post


Link to post
Share on other sites

Is this contribution maintained anymore? e.g., is this dead and have people moved onto another contribution installer package?

I wrote to the author and in the forum and nothing.

 

I think this contribution is a great idea and if it would work with RC1 and get more community support, it has a lot of promise!

 

I have a feeling that many osCommerce coders out there are not interested, since they have their own scripts/methods to modify osCommerce and install contributions and this contrib will take away from that revenue stream, however. Maybe that's why this contrib hasn't caught on as quickly as it could have...?

Share this post


Link to post
Share on other sites

i get this error when tryin to install contrib_installer:

 

Contrib_Installer_2.2.zip

Error Couldn't find :

/* Begin Contrib_Installer_2.2 - installed by Contrib_Installer */

 

array('title' => TOOLS_FILES, 'link' => tep_href_link(FILENAME_FILE_MANAGER, 'selected_box=tools')))),

array(

'title' =>BOX_HEADING_CONTRIB_INSTALLER,

'image' => 'contrib_installer.png',

'href' => tep_href_link(FILENAME_CIP_MANAGER, 'selected_box=contrib_installer'),

'children' =>

array(

array('title' =>BOX_CONTRIB_INSTALLER_CIP_MANAGER,

'link' => tep_href_link(FILENAME_CIP_MANAGER, 'selected_box=contrib_installer')

),

array('title' =>BOX_CONTRIB_INSTALLER_UPLOAD_CIP,

'link' =>tep_href_link(FILENAME_CIP_MANAGER, 'action=upload&goto='.DIR_FS_CIP)

),

array('title' =>'CIP.NET.UA', 'link' => tep_href_link('http://cip.net.ua/')),

array('title' =>BOX_CONTRIB_INSTALLER_SEARCH_CIP, 'link' => tep_href_link('http://cip.net.ua/catalog/admin/cip_manager.php')),

)

)

);

 

/* End Contrib_Installer_2.2 - installed by Contrib_Installer */

 

in the file: /customers/osttyska.de/osttyska.de/httpd.www/blagan/admin/index.php

<findreplace> #1

Share this post


Link to post
Share on other sites

It's a shame this contribution seems to have come to a halt. I was thinking about using it on a new shop (im not using RC1) but, there seems to be little support but even more importantly http://cip.net.ua/ seems to have disappeared, meaning that we can not download contributions to use with this contribution. :(

 

I hope this gets working again soon, it really would be great.. if it works! :)

 

Has anyone heard from Vlad Savitsky in a while? :(

Share this post


Link to post
Share on other sites
It's a shame this contribution seems to have come to a halt. I was thinking about using it on a new shop (im not using RC1) but, there seems to be little support but even more importantly http://cip.net.ua/ seems to have disappeared, meaning that we can not download contributions to use with this contribution. :(

 

I hope this gets working again soon, it really would be great.. if it works! :)

 

Has anyone heard from Vlad Savitsky in a while? :(

 

same errormsg here , as the one listed above...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×