Jump to content
Sign in to follow this  
rinon

Contrib Installer

Recommended Posts

To supersilicon,

When you set a writepermission from /admin to 777

folder /Contrib_Installer_1.0.14a does not exists.

So he can't write to this folder.

May be you should check all folders in path.

(This what I try to check in 1.0.14 but this function has a bug and in 1.0.14a was turned off)


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites

my server did not input the SQL queries into the MySQL. So has anyone got a database written for this contribute installer that i can manually input the necessary enquiries?

Share this post


Link to post
Share on other sites

I got this error after the DB has being installed. Must be something missing there.

 

1064 - You have an error in your SQL syntax near 'add,install,remove,parent_dir_name,dir_name,query,remove_query,code_type from co' at line 1

sElect cip_id,tag_id,tag_name,file_name,start,end,type,find,replace,add,install,remove,
parent_dir_name,dir_name,query,remove_query,code_type from contrib_installer_tags

 

I tried to manually input the SQL data which was quite ok apart from this line i cant figure it out what i need

to change, add or modify. Please help...

 

This are the lines i cant figure it out.

 

INSERT INTO configuration VALUES (NULL, 'Contribution Directory',
		'MODULE_CONTRIB_INSTALLER_DIR_FS_CONTRIBUTIONS', '". $contrib_dir . "', 'Location of contribution files', ".
		$sort_order_query_array['configuration_group_id'] . ", 0, NULL, now(), NULL, NULL)")

My result is this

Error 
SQL-query: 

I 
MySQL said:  

#1064 - You have an error in your SQL syntax near 'I' at line 1

 

UPDATE configuration_group SET sort_order=" .

$sort_order_query_array['configuration_group_id'] . " WHERE configuration_group_id=" . $sort_order_query_array['configuration_group_id'])

 

My result is this

 

Error

SQL-query:

 

U

MySQL said:

 

#1064 - You have an error in your SQL syntax near 'U' at line 1

 

There is some other issues, but this are particular ones.

 

I have read all 14 pages, but i can't get a solution. Vlad, you mention this

 

''. - There is no NULL so we can remove it - but which one do we remove?

 

Hope someone can help

Share this post


Link to post
Share on other sites

When i install i get this error...

Checking config file: File install.xml is valid.Checking permissions: Permissions is OK.Checking conflicts:No conflicts.1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'create,due,agent_id,amount from a_invoices' at line 1

 

sElect id,file,status,create,due,agent_id,amount from a_invoices

 

[TEP STOP]

 

Im running apache 2.0.55, mysql 5.0. under windows on local machine.

Any solutions?

Thank you in advance

Share this post


Link to post
Share on other sites
When i install i get this error...

Checking config file: File install.xml is valid.Checking permissions: Permissions is OK.Checking conflicts:No conflicts.1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'create,due,agent_id,amount from a_invoices' at line 1

 

sElect id,file,status,create,due,agent_id,amount from a_invoices

 

[TEP STOP]

 

Im running apache 2.0.55, mysql 5.0. under windows on local machine.

Any solutions?

Thank you in advance

 

To all:

http://mysql.com/

or

http://google.com/

 

This is NOT a Contrib Installer problems.


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites
Guest
:thumbsup:

Very nice!

I'll add it to Contrib Installer if you agree.

 

Hi Vlad,

 

Got this from the moderators :) regards the fact that I added the CIP to the original tabs project.

 

-------------------------

Hello Harry,

 

On the 13th of February you uploaded a contribution addition for Category Tabs. As this is a CIP addition it is meant to be published with the Contrib Installer contribution itself. I have disabled the CIP addition within the Category Tabs contribution so you should upload it again inside the Contrib Installer contribution. Also please add the GPL license and some installation instructions.

 

Kind regards,

The osCommerce Contribution Moderators Team

---------------------------

 

Which got me thinking...

 

Contrib Installer is almost a project in itself - I say this because I'm about to go through and create my standard baseline using contrib installer and would intend on creating installers for each of my favourite projects and I'd like to share them, but you're not going to want 15 (or a lot more) CIPs cluttering up the CI project area so I don't agree with the moderators perspective on this one :)

 

I'm happy to put up the hosting space for a project site if you like. One of the things to look at is running a seperate forum on the project so that we can unclutter this thread :) we really need topics areas for installation seperated from CIPs seperate from announcements. A FAQ would be handy.

 

Am happy to setup and help moderating the site if you want..

 

if you've got a spare domain name point it at ns1.amhazing.com.au and ns2.amhazing.com.au - let me know the domain name and I'll setup a site. Otherwise I can do it as ci.amhazing.com.au (would prefer neutral name though since it's an open source project..)

 

Source forge is the other option..

 

Comments, suggestions?

 

regards,

 

Harry

Share this post


Link to post
Share on other sites

I've also made a whole lot of CIP files, is it ok to put them on the Contrib Installer page since moderators won't accept them on other contribution pages?

Share this post


Link to post
Share on other sites
I've also made a whole lot of CIP files, is it ok to put them on the Contrib Installer page since moderators won't accept them on other contribution pages?

 

Unfortunately that's only option currently. Yes, please do that. I'm really sorry I haven't had any time to work on this project, everything has been crazy. I'm hoping to get back to working on this soon. Thanks for helping out with questions and bugs, Vlad. I haven't had time to investigate any bugs.

 

- Rinon

Share this post


Link to post
Share on other sites

I installed this mod but do not want it or need it, so I removed it all-except in my ADMIN>CONFIGURATION the Contrib Installer still shows in the list:

My Store

Minimum Values

Maximum Values

Images

Customer Details

Shipping/Packaging

Product Listing

Product Information

Stock

Logging

Cache

E-Mail Options

Download

GZip Compression

Sessions

Misc.

Dynamic MoPics

Featured

Contrib Installer

SEO URLs

 

And when I click on that link in admin, I get a new admin page with the 3 options to change

:URL to the Contributions

:Forum Link

:Contribution Directory

 

How can I get rid of all this?

 

Thanks

Share this post


Link to post
Share on other sites

How to UNINSTALL Contrib Installer

 

You really don't want to use the Contrib Installer anymore?

 

OK, you'll need to

- go to admin/contrib_installer.php (in your web interface),

- choose Contrib Installer from the list,

- click "Remove",

- delete by hand files you've added when install Contrib Installer.

 

 

Contrib Installer installs/removes yourself!!


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites
How to UNINSTALL Contrib Installer

 

You really don't want to use the Contrib Installer anymore?

 

OK, you'll need to

- go to admin/contrib_installer.php (in your web interface),

- choose Contrib Installer from the list,

- click "Remove",

- delete by hand files you've added when install Contrib Installer.

Contrib Installer installs/removes yourself!!

 

Yeah, I read the first time I tried to uninstall....and the line is still in the admin like I said.

 

Thanks

 

Anyone else?

Share this post


Link to post
Share on other sites

Hello all,

 

I have just found this contrib and would very much like to use it and ultimatly build some CIP's for my favorite contribs. However, I've tried to install the new sts CIP and I am having a very hard time. Have any of you installed this CIP? through contrib_installer.php everything works fine and STS is added to the modules Box but when I load my shop I get the following error:

 

Fatal error: Cannot redeclare sts_strip_unwanted_tags() (previously declared in /home/hubbspub/public_html/test/includes/functions/sts.php:17) in /home/hubbspub/public_html/test/includes/functions/sts.php on line 17

 

I installed contrib_installer on a new install of OSC 2.2 and STS is the first CIP I've tried to install. Its hard to have a problem like this so early in the install of my new shop and would appreciate it if any of you knowledgeable folks could help me out on this one.

Share this post


Link to post
Share on other sites
Fatal error: Cannot redeclare sts_strip_unwanted_tags() (previously declared in /home/hubbspub/public_html/test/includes/functions/sts.php:17) in /home/hubbspub/public_html/test/includes/functions/sts.php on line 17

 

I installed contrib_installer on a new install of OSC 2.2 and STS is the first CIP I've tried to install. Its hard to have a problem like this so early in the install of my new shop and would appreciate it if any of you knowledgeable folks could help me out on this one.

 

Please check that it didn't install itself twice for some reason. If that is the whole error it seems like somewhere includes/functions/sts.php is included/required twice. Which template are you using? You might want to remove it through contrib installer and try to install it again. I have this package installed with no problems.

 

Is your store with the latest updates (osCommerce 2.2 Milestone 2 Update 051113)?

 

Could you check application_top.php for duplicate

require (DIR_WS_CLASSES.'sts.php');

lines?

Share this post


Link to post
Share on other sites
I installed this mod but do not want it or need it, so I removed it all-except in my ADMIN>CONFIGURATION the Contrib Installer still shows in the list:

My Store

Minimum Values

Maximum Values

Images

Customer Details

Shipping/Packaging

Product Listing

Product Information

Stock

Logging

Cache

E-Mail Options

Download

GZip Compression

Sessions

Misc.

Dynamic MoPics

Featured

Contrib Installer

SEO URLs

 

And when I click on that link in admin, I get a new admin page with the 3 options to change

:URL to the Contributions

:Forum Link

:Contribution Directory

 

How can I get rid of all this?

 

Thanks

 

Anyone know how to get this out of my admin?

Share this post


Link to post
Share on other sites

To remove by hands:

 

DELETE FROM configuration_group WHERE configuration_group_title = 'Contrib Installer';

DELETE FROM configuration WHERE configuration_title = 'Contribution Directory';

DELETE FROM configuration WHERE configuration_key = 'TEXT_LINK_FORUM';

DELETE FROM configuration WHERE configuration_key = 'TEXT_LINK_CONTR';


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites

Hi everyone,

Thank you for answering my last post, that was the problem, somehow I installed the CIP twice. Anyway, I am now working on my first CIP for ForumV0.9a for OSC2.2 MS2 by Karsten Ley, http://www.oscommerce.com/community/contributions,3219 . My CIP installs with out errors, but I get an internal server error when I try to reach forums.php to actually use this contrib. I believe it?s the SQL that is causing the problem. Here is the code:

<!-- This is a CIP file for osCommerce contribution installer. See contrib_installer.php for more info. -->
<contrib>
<description><!-- Description of the contribution -->
	<details contrib_ref="3219" forum_ref="" contrib_type="Features" status="0" last_update="2005-08-13" />
	<comments>A light weight Forum for OSC2.2 MS2 by Karsten Ley</comments>
	<credits>CIP by Joe Spada</credits>
</description>


<!-- Install new files -->
 <addfile>
	<file name="forum.php" />
</addfile>
<addfile>
	<file name="forums.php" />
</addfile>
<addfile>
	<file name="newthread.php" />
</addfile>
<addfile>
	<file name="reply.php" />
</addfile>
<addfile>
	<file name="showthread.php" />
</addfile>
<addfile>
	<file name="includes/forum_application_top.php" />
</addfile>
<addfile>
	<file name="includes/functions/forum.php" />
</addfile>
<addfile>
	<file name="includes/languages/english/forums.php" />
</addfile>
<!-- Install new image files -->
<addfile>
	<file name="images/design/board.png" />
</addfile>
<!-- emoticons -->
<addfile>
	<file name="images/emoticons/456.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/biggrin.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/bringrin.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/confused.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/cool.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/drunk.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/dunno.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/eek.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/evil.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/finger.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/icon14.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/icon3.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/mad.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/redface.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/rolleyes.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/sad.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/smile.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/tired.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/tounge.gif" />
</addfile>
<addfile>
	<file name="images/emoticons/wink.gif" />
</addfile>


<!-- Add code to files -->
<addcode><!-- Add code to an existing file -->
	<file name="includes/application_top.php" /><!-- name is the name of the file to alter. -->
	<find><![CDATA[define('WARN_DOWNLOAD_DIRECTORY_NOT_READABLE', 'true');]]></find><!-- Text to find... -->
	<!-- Unfortunately I could not make the parser accept whitespace before a string, so please add a comment before any code to be added so that the formatting stays ok (this is a good idea anyways) -->
	<add type="php"><![CDATA[
	  include('includes/forum_application_top.php');
	]]>
	</add><!-- _After_ text in the find section add this -->
	<findlinenumbers start="432" end="433" /><!-- Same as originallinenumbers above. -->
</addcode>

<addcode><!-- Add code to an existing file -->
	<file name="includes/boxes/information.php" /><!-- name is the name of the file to alter. -->
	<find>new infoBoxHeading($info_box_contents, false, false);

 $info_box_contents = array();
 $info_box_contents[] = array('text' =></find><!-- Text to find... -->
	<!-- Unfortunately I could not make the parser accept whitespace before a string, so please add a comment before any code to be added so that the formatting stays ok (this is a good idea anyways) -->
	<add type="php"><![CDATA[
	  '<a href="' . tep_href_link(FILENAME_FORUMS, '', 'NONSSL') . '">' . BOX_INFORMATION_FORUMS . '</a><br>' .
	]]>
	</add><!-- _After_ text in the find section add this -->
	<findlinenumbers start="20" end="23" /><!-- Same as originallinenumbers above. -->
</addcode>

<addcode><!-- Add code to an existing file -->
	<file name="includes/languages/english.php" /><!-- name is the name of the file to alter. -->
	<find>define('BOX_INFORMATION_CONTACT', 'Contact Us');</find><!-- Text to find... -->
	<!-- Unfortunately I could not make the parser accept whitespace before a string, so please add a comment before any code to be added so that the formatting stays ok (this is a good idea anyways) -->
	<add>/* Begin Forum V0.9a */
	  define('BOX_INFORMATION_FORUMS', 'Forum');
	/* End Forum V0.9a */</add><!-- _After_ text in the find section add this -->
	<findlinenumbers start="128" end="128" /><!-- Same as originallinenumbers above. -->
</addcode>

<!-- Add Forum Tables to DB -->
<sql><!-- Run an SQL query -->
	<query>
		CREATE TABLE IF NOT EXISTS forum (
		  forumid smallint(5) unsigned NOT NULL auto_increment,
		  title char(100) NOT NULL default '',
		  description char(250) NOT NULL default '',
		  active smallint(6) NOT NULL default '0',
		  displayorder smallint(6) NOT NULL default '0',
		  replycount int(10) unsigned NOT NULL default '0',
		  lastpost int(11) NOT NULL default '0',
		  threadcount mediumint(8) unsigned NOT NULL default '0',
		  allowposting smallint(6) NOT NULL default '0',
		  PRIMARY KEY  (forumid)
		) TYPE=MyISAM;
	</query><!-- Query to run -->
	<remove_query>
		DROP TABLE IF EXISTS forum;
	</remove_query><!-- Query to run when uninstalling this contribution (should undo query section if necessary). -->
</sql>

<sql><!-- Run an SQL query -->
	<query>
		CREATE TABLE IF NOT EXISTS post (
		  postid int(10) unsigned NOT NULL auto_increment,
		  threadid int(10) unsigned NOT NULL default '0',
		  forumid smallint(5) unsigned NOT NULL default '0',
		  username varchar(50) NOT NULL default '',
		  email varchar(50) NOT NULL default '',
		  title varchar(100) NOT NULL default '',
		  dateline int(11) NOT NULL default '0',
		  pagetext mediumtext,
			public char(1) NOT NULL default '0',
		  PRIMARY KEY  (postid),
		  KEY idxdisp (threadid,dateline)
		) TYPE=MyISAM;			
	</query><!-- Query to run -->
	<remove_query>
		DROP TABLE IF EXISTS post;
	</remove_query><!-- Query to run when uninstalling this contribution (should undo query section if necessary). -->
</sql>

<sql><!-- Run an SQL query -->
	<query>
		CREATE TABLE IF NOT EXISTS thread (
		  threadid int(10) unsigned NOT NULL auto_increment,
		  title char(100) NOT NULL default '',
		  lastpost int(10) unsigned NOT NULL default '0',
		  forumid smallint(5) unsigned NOT NULL default '0',
		  replycount int(10) unsigned NOT NULL default '0',
		  postusername char(50) NOT NULL default '',
		  lastpostuser char(50) NOT NULL default '',
		  dateline int(10) unsigned NOT NULL default '0',
		  allowposting smallint(6) unsigned NOT NULL default '0',
		  PRIMARY KEY  (threadid)
		) TYPE=MyISAM;
	</query><!-- Query to run -->
	<remove_query>
		DROP TABLE IF EXISTS thread;
	</remove_query><!-- Query to run when uninstalling this contribution (should undo query section if necessary). -->
</sql>

</contrib>

I really like this Forum contrib and its suits me well as I believe it would others as well. If I could get some assistance this could be a great addition to the growing list of CIP's for Contrib Installer. Thank you for your help in advance.

Share this post


Link to post
Share on other sites

Hi All

 

After fiddling around a lot with the differnet Contris and losing control over where i installed and changed what - i think this Contribution got it all - thats the only way to go at least for the moment. I will try to move all my Contris I use over to a cib file and release them here. I already tried around with some contris to unterstand the way CIBS work. I also would appriciate, if we coukld move these ro another server until its finished, like one member just recently described as a way to get this straigtehened out ..

 

Now, I just had an error, Trying to install the Admin Acces CIB Package. Tjis is the message I get:

 

--------------------

No remove query necessary for SQL query:

 

INSERT INTO admin_files VALUES (2, 'configuration.php', 1, 0, '1')

-------

 

Wich is quit right since the Table gets droped before, so no nececity to delet Entries into the table.

 

But in reality, the "error Message" Is wrong - it says that, because the the <remove_qeury> is empty! If i write something into those remove_query Tag....

 

So since i had this earlier - what should be inside the remove_query tag if nothing is necessary???

Share this post


Link to post
Share on other sites
Guest

Hi I looked at this contrib and I love it. The contrib itself has installed without event. only 1 prob though. Everything I try to install leads me through all the file permission stuff then I get the error below. Notice the // in red. What am I doing wrong. My basic process is to drop xxx.zip into the contributions directory where it appears contrib_installer picks it up and unzips it. It then appears as available for install.

 

 

Contrib Installer

Installing Contribution: Article_Manager-1.2b

From install file: /home/default/netxonline.co.uk/user/htdocs/catalog/admin/contributions/Article_Manager-1.2b/install.xml

Author:

Rob Anderson

Pawe Robaczewski

Ivan Prieto

Mark Horne

Cormac Bracken

Bedo

Wilhelm Moser

Comments:

To use Article Manager, go to your admin site and select Article Manager from the admin menu (below Catalog).

 

Familiarise yourself with the options, namely:

 

- Topics/Articles - for adding topics and associated articles (like Categories and Products)

 

- Configuration - a wide range of options for controlling how and when Articles appear

 

- Authors - Enter your article authors, including a description and maybe a photo (optional)

 

- Reviews - This is where you approve Article Reviews before they are visible on the site

 

- Cross-Sell Articles - Select from a list of products and associate them with your articles

 

Start adding topics and articles!

 

Hint: you may want to add your Authors first ;-)

Checking config file:

File install.xml is valid.

Checking permissions:

Permissions is OK.

 

File NOT exists (addfile #1): /home/default/netxonline.co.uk/user/htdocs/catalog/admin/contributions//catalog/article_info.php

--

Share this post


Link to post
Share on other sites
Now, I just had an error, Trying to install the Admin Acces CIB Package. Tjis is the message I get:

 

--------------------

No remove query necessary for SQL query:

 

INSERT INTO admin_files VALUES (2, 'configuration.php', 1, 0, '1')

-------

 

Wich is quit right since the Table gets droped before, so no nececity to delet Entries into the table.

 

But in reality, the "error Message" Is wrong - it says that, because the the <remove_qeury> is empty! If i write something into those remove_query Tag....

 

So since i had this earlier - what should be inside the remove_query tag if nothing is necessary???

 

Just put sql-code that do nothing:

<remove_query>SELECT 1;</remove_query>

 

Why?

I don't know. It's a secret technology.

B)


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites
File NOT exists (addfile #1): /home/default/netxonline.co.uk/user/htdocs/catalog/admin/contributions//catalog/article_info.php

 

This means that file not exists.

In path ypu don't have a Contrib name. Must be:

/home/default/netxonline.co.uk/user/htdocs/catalog/admin/contributions/<Contrib name>/catalog/article_info.php

 

What version of Contrib Installer do you use?


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites

To jspada:

 

About your CIP. Can you send me a ZIP to test?

It's hard for me to read just code and without syntacs highlighting.


===============================

Never give up! Never give up! Never give up!

Share this post


Link to post
Share on other sites
Guest
Hi All

 

After fiddling around a lot with the differnet Contris and losing control over where i installed and changed what - i think this Contribution got it all - thats the only way to go at least for the moment. I will try to move all my Contris I use over to a cib file and release them here. I already tried around with some contris to unterstand the way CIBS work. I also would appriciate, if we coukld move these ro another server until its finished, like one member just recently described as a way to get this straigtehened out ..

 

Now, I just had an error, Trying to install the Admin Acces CIB Package. Tjis is the message I get:

 

--------------------

No remove query necessary for SQL query:

 

INSERT INTO admin_files VALUES (2, 'configuration.php', 1, 0, '1')

-------

 

Wich is quit right since the Table gets droped before, so no nececity to delet Entries into the table.

 

But in reality, the "error Message" Is wrong - it says that, because the the <remove_qeury> is empty! If i write something into those remove_query Tag....

 

So since i had this earlier - what should be inside the remove_query tag if nothing is necessary???

 

I am getting exactly the same error (see below) and I can't determine if it succeeded or not. It looks like not as it is not in the admin tools.

 

Contrib Installer

Installing Contribution: Admin_Access-2.1.1-2

From install file: /home/default/domain.co.uk/user/htdocs/catalog/admin/contributions/Admin_Access-2.1.1-2/install.xml

Author:

 

By Robert Hellemans

Updated by MaxiDVD for MS2

Updated by Rinon for PHP5

Comments:

Checking config file:

No remove query necessary for SQL query:

INSERT INTO admin VALUES (1, 1, 'AdminFirstname', 'AdminLastname', 'admin@localhost', '351683ea4e19efe34874b501fdbf9792:9b', now(), '0000-00-00 00:00:00', null, 0)

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (1, 'administrator.php', 1, 0, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (2, 'configuration.php', 1, 0, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (3, 'catalog.php', 1, 0, '1,18')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (4, 'modules.php', 1, 0, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (5, 'customers.php', 1, 0, '1,18')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (6, 'taxes.php', 1, 0, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (7, 'localization.php', 1, 0, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (8, 'reports.php', 1, 0, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (9, 'tools.php', 1, 0, '1,18')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (10, 'admin_members.php', 0, 1, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (11, 'admin_files.php', 0, 1, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (12, 'configuration.php', 0, 2, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (13, 'categories.php', 0, 3, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (14, 'products_attributes.php', 0, 3, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (15, 'manufacturers.php', 0, 3, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (16, 'reviews.php', 0, 3, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (17, 'specials.php', 0, 3, '1,18')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (18, 'products_expected.php', 0, 3, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (19, 'modules.php', 0, 4, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (20, 'customers.php', 0, 5, '1,18')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (21, 'orders.php', 0, 5, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (22, 'countries.php', 0, 6, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (23, 'zones.php', 0, 6, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (24, 'geo_zones.php', 0, 6, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (25, 'tax_classes.php', 0, 6, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (26, 'tax_rates.php', 0, 6, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (27, 'currencies.php', 0, 7, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (28, 'languages.php', 0, 7, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (29, 'orders_status.php', 0, 7, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (30, 'stats_products_viewed.php', 0, 8, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (31, 'stats_products_purchased.php', 0, 8, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (32, 'stats_customers.php', 0, 8, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (33, 'backup.php', 0, 9, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (34, 'banner_manager.php', 0, 9, '1,18')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (35, 'cache.php', 0, 9, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (36, 'define_language.php', 0, 9, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (37, 'file_manager.php', 0, 9, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (38, 'mail.php', 0, 9, '1,18')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (39, 'newsletters.php', 0, 9, '1,18')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (40, 'server_info.php', 0, 9, '1')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (41, 'whos_online.php', 0, 9, '1,18')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (42, 'banner_statistics.php', 0, 9, '1,18')

No remove query necessary for SQL query:

INSERT INTO admin_files VALUES (43, 'contrib_installer.php', 0, 9, '1')

No remove query necessary for SQL query:

INSERT INTO admin_groups VALUES (1, 'Top Administrator')

No remove query necessary for SQL query:

INSERT INTO admin_groups VALUES (2, 'Marketing')

Share this post


Link to post
Share on other sites
Guest
This means that file not exists.

In path ypu don't have a Contrib name. Must be:

/home/default/netxonline.co.uk/user/htdocs/catalog/admin/contributions/<Contrib name>/catalog/article_info.php

 

What version of Contrib Installer do you use?

 

Thanks for quick reply. I am using Contrib_Installer_1.0.14. If contrib does not exist why does it confirm install.xml file ok. The contrib exists as indicated by the error but when installing it seems to include "//"

 

/home/default/netxonline.co.uk/user/htdocs/catalog/admin/contributions/Article_Manager-1.2.b/catalog/article_info.php

 

Directory permission is 755

Share this post


Link to post
Share on other sites
To remove by hands:

 

DELETE FROM configuration_group WHERE configuration_group_title = 'Contrib Installer';

DELETE FROM configuration WHERE configuration_title = 'Contribution Directory';

DELETE FROM configuration WHERE configuration_key = 'TEXT_LINK_FORUM';

DELETE FROM configuration WHERE configuration_key = 'TEXT_LINK_CONTR';

 

And these are all in admin/configuration.php?

Because I am looking there and finding none of these lines....

 

This contribution is like a sickness that will not go away.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×