Jump to content
Sign in to follow this  
empo

PC Pro Creator

Recommended Posts

I've uploaded V2.1

 

Changes:

- Added support for Netscape and Opera

- Bug fix for Euro sign

- Multi language support

- Display box below/above row depending on screen space below row.

 

Todo:

- Check english language file

- Add german and spanish

- Enable quantity box

- Look at/test TAX functionality.

- Dynamic pop-up box size (depending on content with adjustable max lines)

 

Empo: I see that your shop has working amount selection boxes. I haven't looked at the code yet but how did you enable/fix this??

Share this post


Link to post
Share on other sites

Hi, Ғяαпқ,

 

Just to let you know, I just downloaded the PC Pro Creator 2.1.1 & its missing the _english.php file for the english folder.

 

It says in the readme.txt, that you put up with the file, that this file is suppost to be included.

 

Thank you,

Michael

Edited by mrgtec

Michael

Share this post


Link to post
Share on other sites

Hi, Ғяαпқ,

 

Its there, I am sorry, I didn't look under admin, I throught it said catalog, lol.

 

Thank you,

Michael


Michael

Share this post


Link to post
Share on other sites

2->Ғяαпқ This is new version with new fast mechanism of sql queries.

and new dependence machnism.

but this version is not public... and i cant upload it...

Share this post


Link to post
Share on other sites
2->Ғяαпқ This is new version with new fast mechanism of sql queries.

and new dependence machnism.

but this version is not public... and i cant upload it...

 

But the new 'dependence mechanism' isn't automatic like the original one. You need to specifiy which products work with what products. So it isn't an 'intellegent' dependence mechanism unfortunately.

 

Have you sold many copies of your new version?

Maybe it is worth you just putting it on here as open source and then everyone can help to develop it further? :D

 

Cheers,

Chris

Share this post


Link to post
Share on other sites

No I sold only one copy ;)

Why I dont want to distribute this one?

Answer very simple -I asked ppl not to remove copyrights and they arent listen. So after that i saw couple of shops with pcpro without any notice of copyright I decide to stop distirbution of all my new developments...

Share this post


Link to post
Share on other sites

hi! I have important question:

creator is working almost perfect.. almost..

total value isn't updated. :( it is always 0 zł (polish value)

what is wrong?

Share this post


Link to post
Share on other sites

Hi all

I would like to use PC Pro on my oscommerce but i wonder how can i :

 

1 - remove categories i don't use (i don't need the "Mouse" category for instance. I see the lines i can remove in compuild.php (print_field('<?php echo TEXT_MOUSE; ?>',<? echo $c_java;?>) but i want to be sure it's the right way to do.

 

2 - change categories order (i want the case category on the first line before the CPU for instance)

 

3 - how to rename categories in the frontend as well as in the admin section.

 

can anyone help ?

 

Thanks a lot

Guillaume

Share this post


Link to post
Share on other sites

Duch:

There are in some cases some problems with the total value. Could you please give me the settings of the actual currency. And an online shop with the actual problem should also help. Then I can see if I can reproduce the problem and solve it.

 

Guillaume:

1,2: I think you're on the right way. I'll have a look at it and confirm this later.

3: In the front-end you can do this with the language file (includes/languages/[YOUR LANGUAGE]/compbuild.php). The admin section isn't multi language yet....

 

I'll hope to give an update (V2.2) this week. I found some problems and added some (minor) things...

Edited by Ғяαпқ

Share this post


Link to post
Share on other sites
No I sold only one copy ;)

Why I dont want to distribute this one?

Answer very simple -I asked ppl not to remove copyrights and they arent listen. So after that i saw couple of shops with pcpro without any notice of copyright I decide to stop distirbution of all my new developments...

 

 

thats sad to hear! that people are removing copyrights..

 

i mean who cares if its there! it dont bother no body...(dont remove it)

well sorry to hear you got to start selling it!!

i guess from now on everyone is going to need to start buying updates?

its always a few that ruin it for us all!!

:angry:

Edited by pcboy123

Share this post


Link to post
Share on other sites
Duch:

There are in some cases some problems with the total value. Could you please give me the settings of the actual currency. And an online shop with the actual problem should also help. Then I can see if I can reproduce the problem and solve it.

 

Guillaume:

1,2: I think you're on the right way. I'll have a look at it and confirm this later.

3: In the front-end you can do this with the language file (includes/languages/[YOUR LANGUAGE]/compbuild.php). The admin section isn't multi language yet....

 

I'll hope to give an update (V2.2) this week. I found some problems and added some (minor) things...

 

Ғяαпқ: Ok i am gonna try that this week. If i found something valuable i will share the info ! :)

Thanks a lot for your work !!

Share this post


Link to post
Share on other sites
Duch:

There are in some cases some problems with the total value. Could you please give me the settings of the actual currency. And an online shop with the actual problem should also help. Then I can see if I can reproduce the problem and solve it.

 

Guillaume:

1,2: I think you're on the right way. I'll have a look at it and confirm this later.

3: In the front-end you can do this with the language file (includes/languages/[YOUR LANGUAGE]/compbuild.php). The admin section isn't multi language yet....

 

I'll hope to give an update (V2.2) this week. I found some problems and added some (minor) things...

 

 

ok, so link is My Webpage here and value settings are:

currency_left=""

currency_right="zł"

currency="PLN"

Share this post


Link to post
Share on other sites

and under ff and opera i cannot select hardware (list is open but not clickable..)

strange, becouse on my localhost that was ok.

Share this post


Link to post
Share on other sites

duch: I've seen these problems on my system last week, in the new update they should be solved. So please wait. As it looks now I'll upload the new version tomorrow....

Share this post


Link to post
Share on other sites

Hi all !

 

I am facing a little problem. I would like to be abble to build a machine without a motherboard for instance (if the customer select a barebone it's a case with a motherboard so i don't need a motherboard). How to remove the validation form ? ("Please Select a CPU).

 

Thanks a lot

 

Guillaume

Share this post


Link to post
Share on other sites
Has anyone been able to get this contribution to search through layers of categories? For example, in the admin section where you select the categories for CPU's, I have a category called "CPU's" but then there are sub-categories of "Intel" and "AMD". If someone could get that working then it would be excellent.

 

Also, there is another thing that needs to be fixed up in the Admin section. Basically, when you go to match the categories up, it simply displays EVERY category in the drop-down list in alphabetical order. Can this display a category TREE rather than everything in alphabetical order?

For example, it will display something like the following in the drop-down list:

CPU

->AMD

->Intel

Disk Drives

->Floppy Disk

HDD

->IDE

-->PATA

-->SATA

->SCSI

and so on

 

Cheers,

Chris :)

 

Hey,

Has anyone been able to find a way to solve the problems I am experiencing above?

I would imagine everyone would benefit from the above items being solved.

 

Any help is appreciated.

 

Cheers,

Chris :)

Share this post


Link to post
Share on other sites

I have tried to install ppc for the fist time. I have uploaded all files and modified the language file but the module is not showing up in the admin section.

 

Any help appreciated.

Share this post


Link to post
Share on other sites
I have tried to install ppc for the fist time. I have uploaded all files and modified the language file but the module is not showing up in the admin section.

 

Any help appreciated.

 

You must grant an access to this box and file in http://yoursite/admin/admin_files.php and then it will apear

Share this post


Link to post
Share on other sites

@duch. You must set Decimal Point: . Thousands Point: , Decimal Places: 2 in Currencies

setting when total value by ok :thumbsup:

Share this post


Link to post
Share on other sites
@duch. You must set Decimal Point: . Thousands Point: , Decimal Places: 2 in Currencies

setting when total value by ok :thumbsup:

i do what you said but it doesn't work.. :huh: :(

 

when new version of pc pro creator will be available?

Share this post


Link to post
Share on other sites

Hello!

eveyone!

 

i have a question is it possible to ""LOAD"" preset - settings

example:

i have 3 types of computers 1. gaming 2.basic pc 3.server type pc. with preset hardware, and it loads all the pre selected hardware and show price but also able to reconfig, if had to..

 

for example this website has what im talking about~

 

http://www.velocitymicro.com/category.php?cid=12

 

 

thanks for the help

Share this post


Link to post
Share on other sites
I am not currently running the admin access package. I do not have admin_files.php. Does anything need to be put into admin/includes/filenames.php ?

 

I have managed to get the system installed. :D However I have a few problems

Have a look at https://www.tocs.com.au/shop/compbuild.php

 

1. I am not able to change the quantity field.

2. Prices are being displayed ex tax. This is an australian site setup for GST.

3. Deslect item is not being shown in the item selection box.

 

I have looked at the example site that empo setup and can see these items working.

 

Also is it better to have the config read from the config.inc.php for the database ?

 

I have also found an issue that may have come up with other users. Product Names can not contain a " . eg LCD 17"

 

I have installed 2.1.1 version.

 

This is a great contrib. Thanks Empo and Frank :thumbsup:

Share this post


Link to post
Share on other sites
I have managed to get the system installed. :D However I have a few problems

Have a look at https://www.tocs.com.au/shop/compbuild.php

 

1. I am not able to change the quantity field.

2. Prices are being displayed ex tax. This is an australian site setup for GST.

3. Deslect item is not being shown in the item selection box.

 

I have looked at the example site that empo setup and can see these items working.

 

Also is it better to have the config read from the config.inc.php for the database ?

 

I have also found an issue that may have come up with other users. Product Names can not contain a " . eg LCD 17"

 

I have installed 2.1.1 version.

 

This is a great contrib. Thanks Empo and Frank :thumbsup:

 

Hi,

 

THis is for everyone - Please do not get confused with the version that is on Empo's site. It is a different version to the one that is on here. Empo took the Version 1 on OsCommerce (which he did write), and then created a Version 2 which has not been put on this site (version 2 on OsCommerce is not an update done by Empo).

 

Empo's version 2 is one that you have to purchase from him.

 

Cheers,

Chris

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×