Jump to content
Sign in to follow this  
empo

PC Pro Creator

Recommended Posts

It's a pleasure...

 

Do you mean the matrix editor - like I've done filtering by manufacturers, you want the same thing for (oscommerce) categories?

 

 

Yes, so we can choose filtering by manufacturers or categories and subcategories if we can.

Share this post


Link to post
Share on other sites
I am interested in using this contribution, but for a different type of application and was wondering if there was anyone else out there who has done this, or who can atleast let me know that it COULD be done..

 

I have a photography website and i sell prints of the images that are shot. I want the customers to be able to "build" a calander out of 13 images, so essentially they would just add the 13 images to the one product and just pay for that product.. Do you think that this contribution could do that?? I could easily put all the images on one page and just have them click checkboxes under the image.. THat would actually be idea..

 

Any thoughts/suggestions?

 

also, does anyone feel like sharing a link to their site that has this contribution installed so i can take a look??

 

Hi,

 

You could do that with this contrib, although there would be one major drawback. This contrib will allow you to assemble 'a product', but when you click 'add to cart' it would simply dump all the products into the cart - you would have no idea which photo was for Jan, Feb, etc.. The only way around that would be to setup categories in oscommerce representing the months, and then put photos in each month. Your visitors would then be limited to the photos you have made available for each month. Expanding on this idea, instead of separate photos in each month you could have one photos category, and then links to each one from the month categories. It sounds simple but I think that would be a maintenance nightmare for you - every time you add a photo you'll need to create twelve links to it.

 

I have a dream to make this builder build a single product - so you see it in the cart it is one product - each component appearing as an attribute. But that's a dream, I'll need a few more rainy days for that.

 

For links to sites running this contrib have a look at the most recent posts (before yours). You can also visit my demo site and you can go to the admin panel (un:admin pw:admin) to see how that looks (and works). Feel free to rearrange the site - I got backups.


Never underestimate the power of stupid people, especially in groups.

Share this post


Link to post
Share on other sites
Yes, so we can choose filtering by manufacturers or categories and subcategories if we can.

 

ok, sounds good.


Never underestimate the power of stupid people, especially in groups.

Share this post


Link to post
Share on other sites

thanks TENCENTS for the thorough explaination of this contribution.. Sounds liek it is ALMOST where i want it to be.. The ATTRIBUTES idea sounds like the absolute most perfect soltuion on there..

 

if you are interested in having it sponsored by myself so that the idea is expedited, let me know. I have sponsored some contributions before and wouldnt be against doing it again if it was worth it for me..

 

I know that there are some photo store specific codes out there for just this type of thing, but they are not open source, but if you wanted to see something liek that in action, i COULD give you some links..

 

Menalto.com/gallery has something like that and that is opensource, i'm just not so sure how good it is.

 

PM me if your interested.


A great place for newbies to start

Road Map to oscommerce File Structure

DO NOT PM ME FOR HELP. My time is valuable, unless i ask you to PM me, please dont. You will get better help if you post publicly. I am not as good at this as you think anyways!

 

HOWEVER, you can visit my blog (go to my profile to see it) and post a question there, i will find time to get back and answer you

 

Proud Memeber of the CODE BREAKERS CLUB!!

Share this post


Link to post
Share on other sites
This is a problem I know about and I haven't quite figured out how to get around it. There are some html tags in one of your products descriptions. You can either edit them out, or you could try changing these values in /catalog/prduct_list.php.... there are three of them (only one is used for assembly fees)

 

##### FIND: left(products_description,50) ...................

 

##CHANGE THE 50 TO 30, OR SOMETHING UNTIL IT WORKS FOR YOU.

 

The reason why this happens is that java is displaying the shortened descriptions, when it gets to a tag or something in the text that it can't display it bombs the list - so all you'll see is a thin blue line at the top. If you look at the code you'll see I went a bit wild with the stripping and slashing - mainly because I don't know what the heck I'm doing, haha... :lol: - anyways... it works more than it doesn't.

 

It's on my to-do list..... unless someone beats me to it.

 

THX Mike

it works now great i can see listed products and select it

 

hm now i have only 2 errors

first :

contrib works only in 2 currencies USD and EUR

when i change currency to PLN the total price doesnt change and print preview doesnt show anyting "You must have products in order"

is any way to show product list in PLN currency and add products to cart in this currency?

 

second :

minor select query to make list of products need status="1" , default i can see all products in list from shop and select it even when status is 0

but made new hardware compilations add only available products

 

thx

Share this post


Link to post
Share on other sites

Hello Mike

i found and one other small problem

when, in admin panel, one product the status is not availble you can see it in the list of

product and you can choose it. but is ok after because when you add it in the cart is not there

but is better if you can make it not to show it in the list

 

Thanks!

Share this post


Link to post
Share on other sites
thanks TENCENTS for the thorough explaination of this contribution.. Sounds liek it is ALMOST where i want it to be.. The ATTRIBUTES idea sounds like the absolute most perfect soltuion on there..

 

if you are interested in having it sponsored by myself so that the idea is expedited, let me know. I have sponsored some contributions before and wouldnt be against doing it again if it was worth it for me..

 

I know that there are some photo store specific codes out there for just this type of thing, but they are not open source, but if you wanted to see something liek that in action, i COULD give you some links..

 

Menalto.com/gallery has something like that and that is opensource, i'm just not so sure how good it is.

 

PM me if your interested.

 

Thanks for your offer Lindsay, very sporting of you but not necessary. Your need and my dream shall coincide on this one.

 

If you can wait another week (two max) then I should have something we can start running through the mill.

 

;)


Never underestimate the power of stupid people, especially in groups.

Share this post


Link to post
Share on other sites
Hello Mike

i found and one other small problem

when, in admin panel, one product the status is not availble you can see it in the list of

product and you can choose it. but is ok after because when you add it in the cart is not there

but is better if you can make it not to show it in the list

 

Thanks!

 

Ikaros, please get the latest updates (version 2.5.3) which will fix most of the issues you've mentioned so far.


Never underestimate the power of stupid people, especially in groups.

Share this post


Link to post
Share on other sites
THX Mike

it works now great i can see listed products and select it

 

hm now i have only 2 errors

first :

contrib works only in 2 currencies USD and EUR

when i change currency to PLN the total price doesnt change and print preview doesnt show anyting "You must have products in order"

is any way to show product list in PLN currency and add products to cart in this currency?

 

second :

minor select query to make list of products need status="1" , default i can see all products in list from shop and select it even when status is 0

but made new hardware compilations add only available products

 

thx

 

The currency problem (and other) has been fixed - check the downloads for the latest update.

 

PLEASE NOTE: There is an issue with the thousands point which stops the builder working properly - I have made notes about this, included with the updates.


Never underestimate the power of stupid people, especially in groups.

Share this post


Link to post
Share on other sites

Version 2.5.3 (upgrade) has been posted in the downloads.

 

The following changes are made:

1. Support for duplicate builder categories + intelligent 'add-to-cart'

2. Products options popup list honors product status and stock quantity. Now sorted by price (asc)

3. Short descriptions hangup fixed

4. Print preview currency issue fixed + close button for convenience

5. Millions calculation working

6. Builder total currency symbol issue fixed

7. Thousands separator causing builder not to total. How-to-fix details included

 

Enjoy!

B)


Never underestimate the power of stupid people, especially in groups.

Share this post


Link to post
Share on other sites

sounds like a plan.. Let me know when you want to start bouncing things around. PM me if you're interested.


A great place for newbies to start

Road Map to oscommerce File Structure

DO NOT PM ME FOR HELP. My time is valuable, unless i ask you to PM me, please dont. You will get better help if you post publicly. I am not as good at this as you think anyways!

 

HOWEVER, you can visit my blog (go to my profile to see it) and post a question there, i will find time to get back and answer you

 

Proud Memeber of the CODE BREAKERS CLUB!!

Share this post


Link to post
Share on other sites

SMALL PROBLEM AFTER 2.5.3 UPGRADE:

 

I use FCKeditor on my full (cumulative) development site and noticed that the short descriptions are preceeded with a linefeed/carriage return. This

small patch fixes that.

 

##### Edit /catalog/prduct_list.php

 

## FIND (three occurances):

 

// CLEANUP THE DESCRIPTION AND CUT TO SIZE

$temp_description = str_replace("\r", "", $aount['products_description']);

$temp_description = str_replace("\n", "", $temp_description);

if (strlen($temp_description) >= $short_description_length) {

$temp_description = substr($temp_description,0,$short_description_length) . "...";

}

 

## REPLACE (all three) WITH:

 

// CLEANUP THE DESCRIPTION AND CUT TO SIZE

$temp_description = str_replace("\r", "", $aount['products_description']);

$temp_description = str_replace("\n", "", $temp_description);

$temp_description = strip_tags($temp_description);

if (strlen($temp_description) >= $short_description_length) {

$temp_description = substr($temp_description,0,$short_description_length) . "...";

}

 

#### DONE!

 

This instruction will be released with the next (2.5.4?) upgrade.


Never underestimate the power of stupid people, especially in groups.

Share this post


Link to post
Share on other sites
I have done all the upgrades

and everything looks work perfect. :)

 

Cool!

 

Just one thing, I see your popup list is empty on the hardrives.

 

Look at my previous post (just before yours), there's a patch about the description, but modify it slightly as follows:

 

## INSTEAD OF:

 

$temp_description = strip_tags($temp_description);

 

## RATHER USE THIS:

 

$temp_description = strip_tags(addslashes($temp_description));

 

##### REMEMBER TO CHANGE ALL THREE IF YOU HAVE ALREADY APPLIED THE PATCH.

 

Let me know if it still doesn't work


Never underestimate the power of stupid people, especially in groups.

Share this post


Link to post
Share on other sites
Cool!

 

Just one thing, I see your popup list is empty on the hardrives.

 

Look at my previous post (just before yours), there's a patch about the description, but modify it slightly as follows:

 

## INSTEAD OF:

 

$temp_description = strip_tags($temp_description);

 

## RATHER USE THIS:

 

$temp_description = strip_tags(addslashes($temp_description));

 

##### REMEMBER TO CHANGE ALL THREE IF YOU HAVE ALREADY APPLIED THE PATCH.

 

Let me know if it still doesn't work

 

Yes it still doesn't work and the cpu doesn't work with the motherboard only the amd and the q6600 cpu

but when i put the old file back it works ok.

Share this post


Link to post
Share on other sites
Yes it still doesn't work and the cpu doesn't work with the motherboard only the amd and the q6600 cpu

but when i put the old file back it works ok.

SORRY it's working imake one small mistake :(

 

All is ok now :rolleyes:

Share this post


Link to post
Share on other sites

Hoping someone can help me. I have PC Pro Creator 2.5.2 and everything appears to be working except for one small problem.

 

I have about 20 categories listed on my builder for all components and software and assembly. The first 10 categories work perfect but on the 11th category through to 20th - when you add a product it doesn't put the price in the price field. To test it i changed the category order for one of the categories that didn't work and if i put below 10 it will add prices fine but as soon as you go above 10 it puts 0.00

 

If you select the product/quantity and then add to cart it does add the product to the cart and it also has the correct pricing in the cart but the price is different to the price in the builder

 

Any ideas on what this maybe?

 

http://myveryownpcguy.com/systembuilder/compbuild.php

 

regards

 

Peter

Edited by mycomputerguy

Share this post


Link to post
Share on other sites
Hoping someone can help me. I have PC Pro Creator 2.5.2 and everything appears to be working except for one small problem.

 

I have about 20 categories listed on my builder for all components and software and assembly. The first 10 categories work perfect but on the 11th category through to 20th - when you add a product it doesn't put the price in the price field. To test it i changed the category order for one of the categories that didn't work and if i put below 10 it will add prices fine but as soon as you go above 10 it puts 0.00

 

If you select the product/quantity and then add to cart it does add the product to the cart and it also has the correct pricing in the cart but the price is different to the price in the builder

 

Any ideas on what this maybe?

 

http://myveryownpcguy.com/systembuilder/compbuild.php

 

regards

 

Peter

 

Hi Peter,

 

Try this:

 

##### In /catalog/build/builder2.php

 

## FIND:

 

// MAXIMUM BUILDER CATEGORIES

var fields=10;

 

## REPLACE WITH:

 

// MAXIMUM BUILDER CATEGORIES

var fields=20;

 

## You can change the 20 to whatever you foresee fit for your store.

 

Just on a side note. I am busy with version 3 (oh yeah! - I got the single product builds working). Besides that - this little problem you have right now is something that will never bother us again.

 

About the cart / price / qty issues, I'm not sure - try it again after you've changed builder2.php.

 

Regards!!

B)

Edited by TENCENTS

Never underestimate the power of stupid people, especially in groups.

Share this post


Link to post
Share on other sites
Hoping someone can help me. I have PC Pro Creator 2.5.2 and everything appears to be working except for one small problem.

 

I have about 20 categories listed on my builder for all components and software and assembly. The first 10 categories work perfect but on the 11th category through to 20th - when you add a product it doesn't put the price in the price field. To test it i changed the category order for one of the categories that didn't work and if i put below 10 it will add prices fine but as soon as you go above 10 it puts 0.00

 

If you select the product/quantity and then add to cart it does add the product to the cart and it also has the correct pricing in the cart but the price is different to the price in the builder

 

Any ideas on what this maybe?

 

http://myveryownpcguy.com/systembuilder/compbuild.php

 

regards

 

Peter

 

just found the fix for this

 

you need to edit catalog/compbuild.php

 

around line 136 you should see

 

// MAXIMUM BUILDER CATEGORIES

var tlines=27;

 

 

insert the following below // MAXIMUM BUILDER CATEGORIES

 

var fields=X; where x is the maximum categories you want i put var fields=30;

Edited by mycomputerguy

Share this post


Link to post
Share on other sites

Hi Tencents you beat me too it, i hadn't refreshed the forum to check for new posts

 

thanks for you help and great contrib

 

you may also be able to help. is there a way to increase the amount of text inputed into the product description but limit it in the builder description?

Share this post


Link to post
Share on other sites
just found the fix for this

 

you need to edit catalog/compbuild.php

 

around line 136 you should see

 

// MAXIMUM BUILDER CATEGORIES

var tlines=27;

 

 

insert the following below // MAXIMUM BUILDER CATEGORIES

 

var fields=X; where x is the maximum categories you want i put var fields=30;

 

Jinx!

:lol:

 

Same time - different places. I see your print still isn't working - try my patch too!!


Never underestimate the power of stupid people, especially in groups.

Share this post


Link to post
Share on other sites
Jinx!

:lol:

 

Same time - different places. I see your print still isn't working - try my patch too!!

 

what was wrong with print? since updating the max builder categories the price seems fine and all products can be selected now.

 

 

i haven't got around to 2.5.3 yet will update to it shortly.

Share this post


Link to post
Share on other sites
Hi Tencents you beat me too it, i hadn't refreshed the forum to check for new posts

 

thanks for you help and great contrib

 

you may also be able to help. is there a way to increase the amount of text inputed into the product description but limit it in the builder description?

 

Thanks!!, no prob!

 

You should upgrade to version 2.5.3 actually, all the stupid little things are sorted out - and then you will find this bit of code in prduct_list.php:

 

// SHORT DESCRIPTION LENGTH - DISPLAYED IN POPUP LIST AND SELECTED COMPONENTS WHILE BUILDING

$short_description_length = 50;

 

Make sure you apply the upgrade correction too, and then have a look in this forum for the last patch I helped ikaros_60 with - then you should have no problems with the short descriptions - I have yet to see in generate any more errors.

 

Have fun!


Never underestimate the power of stupid people, especially in groups.

Share this post


Link to post
Share on other sites
what was wrong with print? since updating the max builder categories the price seems fine and all products can be selected now.

 

 

i haven't got around to 2.5.3 yet will update to it shortly.

 

If you don't select all components after the 10th category then the unselected ones come though on the print preview with an 'undefined' error.

 

I'm sure it's that 'var fields=10' thing.


Never underestimate the power of stupid people, especially in groups.

Share this post


Link to post
Share on other sites

Hi Tencents

 

i have upgraded to 2.5.3 and done as mentioned in the previous posts but now i have no products in the builder but i still have products in my osc categorys on main page.

 

 

not sure if i have done something wrong or forgot something.

 

i upgraded by just comparing and relplacing files, i didn't manual edit files

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×