Jump to content
Sign in to follow this  
empo

PC Pro Creator

Recommended Posts

Hi all

I am busy right now making the PPC compatible with the VAT incl/excl contribution. i've made some improvements, but it's not working totally yet.

 

For all the other questions, i would like to invite to all those who have improved something of the PPC, to go to the forum i created to work on this project. The URL is http://www.topfreeforum.com/ppc

Hi,

Are you haveing any luck with the inc VAT & Ex VAt contribution?

I am kinda stuck with out this as all seems to be working but cant select any product from the list at all.

 

Here is a link to my compbuild.php

 

Can you help provide what ever you have working as yet?

 

Kunal

Share this post


Link to post
Share on other sites
Just one word of caution with dynamic category menus like dynamenu. Search engines often do not like them and it often stops them from being able to go through your whole site, as they often cannot see the dynamic menu.

Actually, this is not the case with Dynamenu as menus and submenus are rendered along with the page in good ol' HTML as opposed to being dynamically generated from Javascript (which search engines do not see so well) after the page loads...


** Please do not PM with personal support requests (even if offering "payment"). Thank you.

Share this post


Link to post
Share on other sites
Actually, this is not the case with Dynamenu as menus and submenus are rendered along with the page in good ol' HTML as opposed to being dynamically generated from Javascript (which search engines do not see so well) after the page loads...

 

Talking of Dynamenu.. If you use dynamenu horizotal menu then you have to commet out line 305 (window.onload = loadHandler; ) in layersmenu.js to make onload work for custom computer creator


?,???`???,?? God must love stupid people, he made so many ??,???`???,?

Share this post


Link to post
Share on other sites
Talking of Dynamenu.. If you use dynamenu horizotal menu then you have to commet out line 305 (window.onload = loadHandler; ) in layersmenu.js to make onload work for custom computer creator

 

Sorry wrong section :) thought it was for ccc


?,???`???,?? God must love stupid people, he made so many ??,???`???,?

Share this post


Link to post
Share on other sites
Talking of Dynamenu.. If you use dynamenu horizotal menu then you have to commet out line 305 (window.onload = loadHandler; ) in layersmenu.js to make onload work for custom computer creator

Not exactly... More accurately, you should combine any onload functions in the scripts to avoid event handler conflicts...


** Please do not PM with personal support requests (even if offering "payment"). Thank you.

Share this post


Link to post
Share on other sites
Hi,

Are you haveing any luck with the inc VAT & Ex VAt contribution?

I am kinda stuck with out this as all seems to be working but cant select any product from the list at all.

 

Here is a link to my compbuild.php

 

Can you help provide what ever you have working as yet?

 

Kunal

I could make it work... but only on Firefox, and on some categories. Anyway, i invite you and anyone interested on developing PPC, or anyone who just want to give some ideas, to visit the forum http://www.topfreeforum.com/ppc

 

I tried to view your page, but i cannot change the language. And the Spanish gives many errors.

 

Greetings,

Share this post


Link to post
Share on other sites

how to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empt :'( :'( :'( :'( :'( :'( :'( :

Share this post


Link to post
Share on other sites
how to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empthow to make it run? 1065 querywas empt :'( :'( :'( :'( :'( :'( :'( :

 

Next time write something constructive rather than writing crap. It will be looked at more nicely.

Share this post


Link to post
Share on other sites
i m sorry~ but im going mad with taht problem~~~~ please help me

1st. Don't write pm. Your problem might help other people with same problem, so put it always in the forum.

2nd. You told me your site's address on the pm but as i told you, i cannot access it because you don't have the spanish language installed. So, i do not know what the problem is.

Share this post


Link to post
Share on other sites
Sorry - need to ask the dumb question here, but do you have any products in your database, and in the correct categories? Have you also mapped the appropriate categories in the admin for PC Pro Creator config?

 

 

 

im sorry maybe this problem caused by wrong appropriate categories ~~ im trying get it work

Share this post


Link to post
Share on other sites
if you got problem at 1065 th query was empty~ you just need to turn on dependence at admin panel

Thanks you for your prompt respinse.

I am activated the Dependence but still getting an error.

 

Error:

Warning: file_get_contents(): URL file-access is disabled in the server configuration in /var/www/html/compbuild.php on line 95

 

Warning: file_get_contents(http://www.MYSITE.com/build/builder2.php): failed to open stream: no suitable wrapper could be found in /var/www/html/compbuild.php on line 95

 

You can view the page here

 

Would apprecite your help in getting this up and running.

Also just to let you know in Admin. Under the dependence tab it is blank there is nothing listed in it.

 

Hope this helps and look forward to your reply.

Regards,

Kunal

Edited by kunal247

Share this post


Link to post
Share on other sites

Am instalat aici http://www.oscommerce.dublu.ro/compbuild.php si sau aici http://www.oscommerce.dublu.ro/admin/compbuild.php , versiunea ppc-2006-08-15 php5.zip (http://www.oscommerce.com/community/contributions,3282/page,19).

The problem is that after I press for the second time the button UPDATE, everything becomes NULL.

 

Can anybody help me? On http://www.oscommerce.dublu.ro everything is free with password 123456.

 

 

Thank you.

Share this post


Link to post
Share on other sites

Hello meisterbartsch

 

You have make a very nice job in your site

can you give us some help with the the contribution or sent us the files we need?

thank you

have a nice time

Share this post


Link to post
Share on other sites
I could make it work... but only on Firefox, and on some categories. Anyway, i invite you and anyone interested on developing PPC, or anyone who just want to give some ideas, to visit the forum http://www.topfreeforum.com/ppc

 

I tried to view your page, but i cannot change the language. And the Spanish gives many errors.

 

Greetings,

Any fix available for Prices Inc & Excl VAT as yet?

 

Kunal

Share this post


Link to post
Share on other sites
I install Custom PC Creator V2.3.2 in my oscommerce shop... but the Total Price : it is always = 0 ... can help me?

 

thank's

The best way to solve it is downloading version 2.3.4. Try it and if you still got errors, write again!

Share this post


Link to post
Share on other sites
The best way to solve it is downloading version 2.3.4. Try it and if you still got errors, write again!

 

Does anyone have a list of all the database changes that this contrib does? I am interested to see how it all works (at a database level) before installing it.

 

How does the dependancy mechanism work? Is it all fully automatic, or do you have to set up each of the products in the database according to the category you want them in? Hope that makes sense.

 

Cheers,

Chris

Share this post


Link to post
Share on other sites

Hi every body!

 

I have de same problem... kunal247 ... he not post the solution :(

 

Warning: file_get_contents(): URL file-access is disabled in the server configuration in /home/domains/hardpoint.com.ar/web/compbuild.php on line 97

Warning: file_get_contents(http://www.hardpoint.com.ar/build/builder2.php): failed to open stream: no suitable wrapper could be found in /home/domains/hardpoint.com.ar/web/compbuild.php on line 97

 

if anyone can give me a hint / some help to where i went wrong i would be greatfull.

Share this post


Link to post
Share on other sites

Hi all,

 

Installed v2.3.4 and got it working, somehow, on my website. the main problem is that I managed to insert products, get dependancies (which do not work, though), and have no problem whatsoever with decimal points and figures. The thing is that the contribution recalls products which are out of stock, and for some categories, only a product is selectable. When I click on another product, nothing happens.

 

My oscommerce layout has been personally modified, in the layout and structure, but files were kept unchanged (only layout and graphic changes). So I think this is not the problem. But I repeat: I cannot get the dependancies work properly, I have (on the client side) the possibility to choose out of stock products (which I shoulnd't be able to select) and last, but not least in importance, some products are not even selectable.

 

Does anyone know hao to fix these issues?


dunno what to write...

Share this post


Link to post
Share on other sites

Hello,

 

I have installed the latest version of ppc but i cannot get the assembly fees to work. In admin ive gving a assembly fee. Ive made a product i my catalogue root but it will not show up in the assembly option in ppc.

 

Can somebody teel me what i am doing wrong.

 

Thankx

Share this post


Link to post
Share on other sites

Hello, i need help

 

Because space i need product name in other <tr>

 

like: http://www.datario.pt/compbuild.php

 

but i change

 

+"<th onClick=\"oFrame.style.display='none'\" width=120 align=left><font size=2 color=666666><b>"+category+"</b></th><th>"

 

to

 

+"<th onClick=\"oFrame.style.display='none'\" width=120 align=left><font size=2 color=666666><b>"+category+"</b></th></tr><tr><th>"

 

but i recive error....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×