Jump to content
Sign in to follow this  
Expata

Easypopulate

Recommended Posts

Hello Everyone,

 

I was hoping someone could point out my mistake here. I'm trying to use Easypopulate to upload and download my product database. I'm still in the development and test phase here.

 

I got the script downloading the DB to both my hard drive and the catalog/temp dir.

 

Here are the problems:

 

1) When I try to view the file with Excel, some fields line up and others don't. I changed the delimited to ";" then to "|". I can't get it like the sample_output_file.txt

 

2) Uploading.......

 

I tried to upload the sample_output_file.txt untouched

and receive the following message:

=============================

File uploaded.

Temporary filename: /tmp/php8LCyik

User filename: test09.txt

Size: 83261

=============================

When I download the database with easypopulate, then try to reupload it immediately after with easypopulate, I receive the following:

=============================

File uploaded.

Temporary filename: /tmp/php8LCyik

User filename: test09.txt

Size: 83261

| MG200MMS | matrox/mg2 | Matrox G20 | Reinforcin | the first | PCI board | www.matrox | Matrox G20 | Unterst?tz | www.matrox | Matrox G20 | 0 | 0.00 | 0000-00-00 | 0000-00-00 | 320 | 0 | USB Anschl | USB | | 16 | 16 MB | 16 mb | +70.0000 | +4.0000 | 1 | Color | Farbe | Color | 2 | Size | Gr??e | Talla | 0 | Download: | Download: | | +9.0000 | 3 | Model | Modell | Modelo | 5 | Version | Version | Version | +0.0000 | 6 | Premium | Premium Au | Premium | +100.0000 | 7 | Deluxe | Deluxe Aus | Deluxe | | 8 | 8 MB | 8 mb | +50.0000 | | 9 | USB | USB Anschl | USB | | 4 | Memory | Speicher | Memoria | 1 | 4 mb | 4 MB | 4 mb | +0.0000 | 2 | 8 mb | 8 MB | 8 mb | +50.0000 | 3 | Model | Modell | Modelo | +70.0000 | 4 | 4 MB | 4 mb | +0.0000 | | 5 | Version | Version | Version | 10 | Download: | Download: | Download: | | 13 | Box: Windo | Box: Windo | Box: Windo | | 23 | 0000-00-00 | 2005-06-13 | 32 | 32 | 32 MB | 32 mb | | Box: Windo | Hardware | Graphics C | | --none-- | Active Updated

| MG200MMS | matrox/mg2 | Matrox G20 | Reinforcin | the first | PCI board | www.matrox | Matrox G20 | Unterst?tz | www.matrox | Matrox G20 | 0 | 0.00 | 0000-00-00 | 0000-00-00 | 320 | 0 | USB Anschl | USB | | 16 | 16 MB | 16 mb | +70.0000 | +4.0000 | 1 | Color | Farbe | Color | 2 | Size | Gr??e | Talla | 0 | Download: | Download: | | +9.0000 | 3 | Model | Modell | Modelo | 5 | Version | Version | Version | +0.0000 | 6 | Premium | Premium Au | Premium | +100.0000 | 7 | Deluxe | Deluxe Aus | Deluxe | | 8 | 8 MB | 8 mb | +50.0000 | | 9 | USB | USB Anschl | USB | | 4 | Memory | Speicher | Memoria | 1 | 4 mb | 4 MB | 4 mb | +0.0000 | 2 | 8 mb | 8 MB | 8 mb | +50.0000 | 3 | Model | Modell | Modelo | +70.0000 | 4 | 4 MB | 4 mb | +0.0000 | | 5 | Version | Version | Version | 10 | Download: | Download: | Download: | | 13 | Box: Windo | Box: Windo | Box: Windo | | 23 | 0000-00-00 | 2005-06-13 | 32 | 32 | 32 MB | 32 mb | | Box: Windo | Box: Windo | Box: Windo | | --none-- | Active Updated

| MG400-32MB | matrox/mg4 | Matrox G40 | Dramatical | www.matrox | Matrox G40 | Neu! Matro | www.matrox | Matrox G40 | Dramatical | www.matrox | 0 | 0.00 | 0000-00-00 | 0000-00-00 | 534 | 0 | USB Anschl | USB | | 16 | 16 MB | 16 mb | +70.0000 | | 1 | Color | Farbe | Color | 2 | Size | Gr??e | Talla | 0 | Download: | Download: | | | 3 | Model | Modell | Modelo | 5 | Version | Version | Version | | 6 | Premium | Premium Au | Premium | +0.0000 | 7 | Deluxe | Deluxe Aus | Deluxe | +120.0000 | 8 | 8 MB | 8 mb | +50.0000 | | 9 | USB | USB Anschl | USB | | 4 | Memory | Speicher | Memoria | 1 | 4 mb | 4 MB | 4 mb | | 2 | 8 mb | 8 MB | 8 mb | | 3 | Model | Modell | Modelo | -10.0000 | 4 | 4 MB | 4 mb | +0.0000 | +0.0000 | 5 | Version | Version | Version | 10 | Download: | Download: | Download: | | 13 | Box: Windo | Box: Windo | Box: Windo | | 23 | 0000-00-00 | 2005-06-13 | 32 | 32 | 32 MB | 32 mb | | Box: Windo | Hardware | Graphics C | | --none-- | Active Updated

1064 - You have an error in your SQL syntax near 's fastest graphics chip, the Millennium G400 Series takes explosive acceleration' at line 3

 

UPDATE products_description SET products_name='Matrox G400 32MB', products_description='Dramatically Different High Performance Graphics

 

Introducing the Millennium G400 Series - a dramatically different, high performance graphics experience. Armed with the industry's fastest graphics chip, the Millennium G400 Series takes explosive acceleration two steps further by adding unprecedented image quality, along with the most versatile display options for all your 3D, 2D and DVD applications. As the most powerful and innovative tools in your PC's arsenal, the Millennium G400 Series will not only change the way you see graphics, but will revolutionize the way you use your computer.

 

Key features:

 

New Matrox G400 256-bit DualBus graphics chip

Explosive 3D, 2D and DVD performance

DualHead Display

Superior DVD and TV output

3D Environment-Mapped Bump Mapping

Vibrant Color Quality rendering

UltraSharp DAC of up to 360 MHz

3D Rendering Array Processor

Support for 16 or 32 MB of memory

', products_url='www.matrox.com/mga/products/mill_g400/home.htm' WHERE products_id = '2' AND language_id = '1'

 

[TEP STOP]

=============================

 

Any ideas? Am I doing something wrong or is there a setting off somewhere?

 

Thank you inadvance for any help!

 

Regards,

Tim

Share this post


Link to post
Share on other sites

I solved my own problem, incase anyone else runs into this....

 

My entire problem came from

 

'

 

To make use the db file in EXCEL and make the script work I had to insert a black slash:

 

\

 

in front of the:

 

'

 

which became

 

\'

 

To get the sample file to upload:

 

I deleted the space between

 

EOREOR MG200MMS

 

which became

 

EOREORMG200MMS

 

All one word

 

That was it. I only had to do it once. It worked on all the other files I've tested.

 

This may be an isolate situation but maybe it'll help someone else.

 

Cheers!

Tim

Share this post


Link to post
Share on other sites
I solved my own problem, incase anyone else runs into this....

 

My entire problem came from

 

'

 

To make use the db file in EXCEL and make the script work I had to insert a black slash:

 

\

 

in front of the:

 

'

 

which became

 

\'

 

To get the sample file to upload:

 

I deleted the space between

 

EOREOR MG200MMS

 

which became

 

EOREORMG200MMS

 

All one word

 

That was it.  I only had to do it once.  It worked on all the other files I've tested.

 

This may be an isolate situation but maybe it'll help someone else. 

 

Cheers!

Tim

 

 

I just add that the delimited your computer uses should be equal to that of the easypopulate script.....

 

in my case it is the:

 

|

 

Shift + \ not

the lowercase L

:-)

 

 

Go to Control Panel

regional and language setting

Regional OPtion Tab

Customize Button

 

in the list separator enter:

 

|

 

Do the same thing in the easypopulate.php script

 

 

Good Luck

Share this post


Link to post
Share on other sites

Someone please help, I downloaded the tab-delimited txt from the current inventory I had. I just changed one of the products number and tried to upload it and am geting this error. PLEASE HELP!!!!!!

 

 

File uploaded.

Temporary filename: /tmp/phpvP65cB

User filename: EP2005Jun15-1705.txt

Size: 4756

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 's'' at line 8

 

SELECT cat.categories_id FROM categories as cat, categories_description as des WHERE cat.categories_id = des.categories_id AND des.language_id = 1 AND cat.parent_id = 0 AND des.categories_name = 'ATV's'

 

[TEP STOP]

Share this post


Link to post
Share on other sites
Someone please help, I downloaded the tab-delimited txt from the current inventory I had.  I just changed one of the products number and tried to upload it and am geting this error.  PLEASE HELP!!!!!!

File uploaded.

Temporary filename: /tmp/phpvP65cB

User filename: EP2005Jun15-1705.txt

Size: 4756

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 's'' at line 8

 

SELECT cat.categories_id FROM categories as cat, categories_description as des WHERE cat.categories_id = des.categories_id AND des.language_id = 1 AND cat.parent_id = 0 AND des.categories_name = 'ATV's'

 

[TEP STOP]

 

 

Hi Chris,

 

You have the same problem.

 

Use a TEXT EDITOR like NOTEPAD or WORDPAD. You need to add a backslash infront of the '

 

example. Big John's Fish and Tackle would become Big John\'s Fish and Tackle

 

Go to Edit

Select Find/Replace

 

Find: '

Replace: \'

 

Select Replace All

 

Let me know how it goes.

 

Cheers,

Tim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×