Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

For anyone who may be interested I've decided not to offer support for 2-2.2e.

 

I will however support the 2.1d I put up and validation thereof.

Thanks FWR.

I did install the version you posted, however I get the page not loading when I click on a category. This is on OSC 2.2Rc2a installed under wamp (just FYI). I can't risk this happening on my live site.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Thanks FWR.

I did install the version you posted, however I get the page not loading when I click on a category. This is on OSC 2.2Rc2a installed under wamp (just FYI). I can't risk this happening on my live site.

 

 

Sounds like RewriteBase is wrong

 

http://localhost/

RewriteBase /

 

http://localhost/catalog/

RewriteBase /catalog/

 

http://localhost/shop/catalog/

RewriteBase /shop/catalog/

Edited by FWR Media

Share this post


Link to post
Share on other sites
Sounds like RewriteBase is wrong

 

http://localhost/

RewriteBase /

 

http://localhost/catalog/

RewriteBase /catalog/

 

http://localhost/shop/catalog/

RewriteBase /shop/catalog/

Thanks for the post, it suddenly hit me. Mentally I keep thinking that it is installed in the root, but when you posted

http://localhost/

RewriteBase /

it became obvious that it should be

http://localhost/domainname/

RewriteBase /domainname/

 

I use the domainname in wamp to keep the different test sites seperate, and when the files are transferred to the web they are in the root.

 

Will try again tomorrow.

Edited by Coopco

The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Hi FWR Media

 

Is this the one that I should download for the latest version of oscommerce ?

 

>>Ultimate SEO URLs - 2.1d with optional Admin settable Product and Category URLs

 

by yesudo added 25 Nov 2006 ?

 

 

ALSO ... which Header Tags Controller should I download ?

 

 

Adam

 

.

Share this post


Link to post
Share on other sites
Hi FWR Media

 

Is this the one that I should download for the latest version of oscommerce ?

 

>>Ultimate SEO URLs - 2.1d with optional Admin settable Product and Category URLs

 

by yesudo added 25 Nov 2006 ?

ALSO ... which Header Tags Controller should I download ?

Adam

 

.

No, download the one by FWR.

 

How is HTC related?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
No, download the one by FWR.

 

How is HTC related?

 

Thanks I just found it in the downloads :)

 

I'm looking for a Header Tags Controller version that will be compatible with it.

 

I had server problems beforehand with deviation's upload of Ultimate URLs version e, but then mainly had problems after adding the latest cDynamic metatags. Now Im generally looking at which contribution versions are compatible with each other with the latest version of oscommerce. (using php4)

 

Yes I'm new to all this...

Share this post


Link to post
Share on other sites

I just installed Ultimate_SEO_URLSv21d_UPDATED and the urls seem fine for the products and catagories, but when I add anything to the cart it send you back to the index and the url is http://myteststore.info/catalog/index.php?ref=shopping_cart. The same thing occurs when you click any information link i.e: Shipping & Returns as well as when you click My Account, Cart Contents, Checkout, Quick Find, Advanced Search, What's New?, Specials, and Reviews. Does anybody know why this is happening and how to fix it? Your help is greatly appreciated!!! :thumbsup:

Share this post


Link to post
Share on other sites
I just installed Ultimate_SEO_URLSv21d_UPDATED and the urls seem fine for the products and catagories, but when I add anything to the cart it send you back to the index and the url is http://myteststore.info/catalog/index.php?ref=shopping_cart. The same thing occurs when you click any information link i.e: Shipping & Returns as well as when you click My Account, Cart Contents, Checkout, Quick Find, Advanced Search, What's New?, Specials, and Reviews. Does anybody know why this is happening and how to fix it? Your help is greatly appreciated!!! :thumbsup:

 

Yes I can tell you exactly. I'm afraid that I ended up adding to the carnage. The version that I uploaded was one I was working on for a customer. It uses non standard file calling and therefore the seo.class.php will not work with a standard osCommerce.

 

Sorry everyone was a stupid mistake.

 

I have re-uploaded the package with the correct seo.class.php.

 

If you had downloaded my upgraded 2.1d you only need to change the catalog/includes/classes/seo.class.php.

Share this post


Link to post
Share on other sites
Thanks I just found it in the downloads :)

 

I'm looking for a Header Tags Controller version that will be compatible with it.

 

I had server problems beforehand with deviation's upload of Ultimate URLs version e, but then mainly had problems after adding the latest cDynamic metatags. Now Im generally looking at which contribution versions are compatible with each other with the latest version of oscommerce. (using php4)

 

Yes I'm new to all this...

Since I am lazy, I used header tags for novices.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Yes I can tell you exactly. I'm afraid that I ended up adding to the carnage. The version that I uploaded was one I was working on for a customer. It uses non standard file calling and therefore the seo.class.php will not work with a standard osCommerce.

 

Sorry everyone was a stupid mistake.

 

I have re-uploaded the package with the correct seo.class.php.

 

If you had downloaded my upgraded 2.1d you only need to change the catalog/includes/classes/seo.class.php.

Thanks for your efforts Robert.

 

I got the latest seo.class.php. Previously, I had one test site working when clicking on a category, and one not working when clicking on a category. Now I have both test sites not working when clicking on a category. The new page does not load, nor does it seem to time out after a long time.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Thanks for your efforts Robert.

 

I got the latest seo.class.php. Previously, I had one test site working when clicking on a category, and one not working when clicking on a category. Now I have both test sites not working when clicking on a category. The new page does not load, nor does it seem to time out after a long time.

 

Reset SEO Cache

Reset osC categories cache then try again .. make sure RewriteBase is correct on both sites.

Share this post


Link to post
Share on other sites
Reset SEO Cache

Reset osC categories cache then try again .. make sure RewriteBase is correct on both sites.

That did not work, so it got me thinking.

 

I went into phpmyadmin and found that there was a cache table. Ended up dropping the cache table.

 

Still no joy, so I browsed the configuartion table and dropped all seo entries.

 

That seemed to work. The category pages load as they did before, the configuration table shows the seo entries.

 

May have been left over garbage from later versions of ultimate seos and / or the something else.

 

Thanks for your help again.

Edited by Coopco

The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
That did not work, so it got me thinking.

 

I went into phpmyadmin and found that there was a cache table. Ended up dropping the cache table.

 

Still no joy, so I browsed the configuartion table and dropped all seo entries.

 

That seemed to work. The category pages load as they did before, the configuration table shows the seo entries.

 

May have been left over garbage from later versions of ultimate seos and / or the something else.

 

Thanks for your help again.

 

May have been left over garbage from later versions of ultimate seos and / or the something else.

 

Yup

 

I don't like to advise people to drop tables and fields .. some people can do irretrievable damage that way.

Edited by FWR Media

Share this post


Link to post
Share on other sites
Yup

 

I don't like to advise people to drop tables and fields .. some people can do irretrievable damage that way.

 

I did forget to say that I backed up the databases first.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

i recently updated to 2.2.2e jack_mcs edition. i've noticed when i click on the "reviews" button for that product, i'm not send to the review page anymore. it just comes back to the product information page. for example the product page is http://www.advancespeedshop.com/sport-spri...685-p-1549.html .. the reviews link shows http://www.advancespeedshop.com/sport-spri...85-pr-1549.html .. but when i click on it i'm just sent back to the product page.

 

what's wrong?

Edited by jasyn

Share this post


Link to post
Share on other sites
i recently updated to 2.2.2e jack_mcs edition. i've noticed when i click on the "reviews" button for that product, i'm not send to the review page anymore. it just comes back to the product information page. for example the product page is http://www.advancespeedshop.com/sport-spri...685-p-1549.html .. the reviews link shows http://www.advancespeedshop.com/sport-spri...85-pr-1549.html .. but when i click on it i'm just sent back to the product page.

 

what's wrong?

 

2-2.2e doesn't work .. I uploaded a fresh 2.1d .. do that.

Share this post


Link to post
Share on other sites
2-2.2e doesn't work .. I uploaded a fresh 2.1d .. do that.

 

nevermind i used this fix

 

redirects to same Product info page.

In /catalog/includes/classes/seo.class.php
Under function ValidateName

Find:
if ((strpos($parts[count($parts) - 2], $type)) !== FALSE)

Replace with:
if ($parts[count($parts) - 2] == $type)

 

and that fixed it.

Edited by jasyn

Share this post


Link to post
Share on other sites
nevermind i used this fix

 

redirects to same Product info page.

In /catalog/includes/classes/seo.class.php
Under function ValidateName

Find:
if ((strpos($parts[count($parts) - 2], $type)) !== FALSE)

Replace with:
if ($parts[count($parts) - 2] == $type)

 

and that fixed it.

 

It's not a fix it's a hack .. fixes one thing breaks another .. but good luck

Edited by FWR Media

Share this post


Link to post
Share on other sites
Yes I can tell you exactly. I'm afraid that I ended up adding to the carnage. The version that I uploaded was one I was working on for a customer. It uses non standard file calling and therefore the seo.class.php will not work with a standard osCommerce.

 

Sorry everyone was a stupid mistake.

 

I have re-uploaded the package with the correct seo.class.php.

 

If you had downloaded my upgraded 2.1d you only need to change the catalog/includes/classes/seo.class.php.

 

Robert,

 

Thank you for the updated seo.class.php, it worked like a charm :thumbsup: !! I just had a couple of questiond before I install this great contribution on my live shop. What should I set Filter Short Words to? Is there a way for the for the url to display the model # field instead of the title? ie: http://myteststore.info/catalog/DVD-MATR-p-6.html instead of http://myteststore.info/catalog/the-matrix-p-6.html. I have alot of contributions installed and working on my live site that are not on the test site ie: Multi-Vendor Shipping, Header Tags, MVS shipping estimator, request_review_1.0, and more. Do you know of any problems in compatibility with Ultimate SEO URLs and the contributions mentioned above? Thank you again for the previous fix and I would appreciate your help in answering the question above before I install this contribution on my live site.

Share this post


Link to post
Share on other sites
Robert,

 

Thank you for the updated seo.class.php, it worked like a charm :thumbsup: !! I just had a couple of questiond before I install this great contribution on my live shop. What should I set Filter Short Words to? Is there a way for the for the url to display the model # field instead of the title? ie: http://myteststore.info/catalog/DVD-MATR-p-6.html instead of http://myteststore.info/catalog/the-matrix-p-6.html. I have alot of contributions installed and working on my live site that are not on the test site ie: Multi-Vendor Shipping, Header Tags, MVS shipping estimator, request_review_1.0, and more. Do you know of any problems in compatibility with Ultimate SEO URLs and the contributions mentioned above? Thank you again for the previous fix and I would appreciate your help in answering the question above before I install this contribution on my live site.

 

I don't know of any incompatibilities with SEO URLs. I'd leave filter short words as it is as standard. There is no way to use the model number currently.

Share this post


Link to post
Share on other sites
tep_hide_session_id() resides in catalog/admin/includes/functions/html_output.php

 

How you managed to delete it I couldn't guess.

 

Sorry for late reply, connection problems

Ummm tbh not sure either, I just did a straight copy across of all the files in the contribution to a clean oscommerce install, and that was the first thing I had waiting for me.

Share this post


Link to post
Share on other sites
I don't know of any incompatibilities with SEO URLs. I'd leave filter short words as it is as standard. There is no way to use the model number currently.

 

Robert,

 

I was able to add this contribution to my live shop and it seems to be working fine, but it does not seem to create a OscSID at all or very rarely for page requests and not at all for shopping_cart.php, login,ect.. Is this normal? :huh: Also if I am already indexed by the search engines, what is the best way to get the new SEO URL's to replace my old url's indexed? Currently if you click on any of the old url's, you are sent to index.php. Your input is greatly appreciated!!

Share this post


Link to post
Share on other sites
Robert,

 

I was able to add this contribution to my live shop and it seems to be working fine, but it does not seem to create a OscSID at all or very rarely for page requests and not at all for shopping_cart.php, login,ect.. Is this normal? :huh: Also if I am already indexed by the search engines, what is the best way to get the new SEO URL's to replace my old url's indexed? Currently if you click on any of the old url's, you are sent to index.php. Your input is greatly appreciated!!

 

Install my validation script which is specifically for this SEO URLs contibution.

 

http://addons.oscommerce.com/info/5738

Edited by FWR Media

Share this post


Link to post
Share on other sites
Install my validation script which is specifically for this SEO URLs contibution.

 

http://addons.oscommerce.com/info/5738

 

 

Is this the same one included in Ultimate_SEO_URLSv21d_UPDATED_1_2? Also after researching the OSCsid issue it appers that the OSCsid is created on the 2nd click, but any subsequent click after that it is not passed on!! It seems like this could be an issue, do you know why this is happening and how to correct it?

 

Thanks alot for all of you help!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×