Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

Hello

 

This contribution has just be installed on my store and I am now getting the following error in categories.php when I try to edit a product. Has anyone seen this before and know of a fix?

Warning: reset() [function.reset]: Passed variable is not an array or object in

/home/aiwrhhud/public_html/admin/includes/classes/object_info.php on line 18

 

Warning: Variable passed to each() is not an array or object in

/home/aiwrhhud/public_html/admin/includes/classes/object_info.php on line 19

Thieving_Gypsy,

 

No, I haven't seen this.

 

Objectinfo is called to create a new object in five different places within categories.php (line numbers are from the modified categories.php supplied with the contribution):

  1. line 384: $pInfo = new objectInfo($parameters);
  2. line 624: $pInfo = new objectInfo($HTTP_POST_VARS);
  3. line 633: $pInfo = new objectInfo($product);
  4. line 821: $cInfo = new objectInfo($cInfo_array);
  5. line 855: $pInfo = new objectInfo($pInfo_array);

Do you have other contributions installed that affect this file? If so, you must have modified your categories.php file manually to prevent breaking the other contribution(s). In the process, you may have missed one of the changes.

 

As tedious as it is, I recommend you go back to your categories.php file prior to this mod, and try again. Compare the provided categories.php file with an unmodified categories.php to find the changes. If existing mods affect the same snippets of code, you will need to integrate them together.

 

If you don't have an unmodified copy because your store was installed through a script, like Fantastico, you can download an archive from the Downloads page.

 

Aside from the problem in the Admin, does it appear to be working correctly in the catalog? With Ultimate SEO URLs enabled, do the pages redirect properly? And can the customer place products in their cart, and complete the checkout process?

 

-Skittles

Share this post


Link to post
Share on other sites

hello everyone i killed my shop installing another hack so have had to start again and re install this one first but it doesnt seem to be rewriting this time round

 

the url shows as

 

http://woodburner.extreme-mobile.co.uk/index.php?cPath=22

 

not

 

http://woodburner.extreme-mobile.co.uk/Wood-burning-stoves as i wanted it to

 

any ideas?

 

cheers


Visit my website in my profile for prices on woodburning stoves

Share this post


Link to post
Share on other sites

I have searching for an answer with out success so I'll just ask.

 

I have had ultrapics running for a long time with out problems. I have recently added Ultimate SEO URLs. It is working ok but for one thing. The popup image from product info page has stopped working.

 

If anyone would like to take a look here is the site problem example on Deans Cards

 

Any help would be great. Thanks.

Share this post


Link to post
Share on other sites
I have searching for an answer with out success so I'll just ask.

 

I have had ultrapics running for a long time with out problems. I have recently added Ultimate SEO URLs. It is working ok but for one thing. The popup image from product info page has stopped working.

 

If anyone would like to take a look here is the site problem example on Deans Cards

 

Any help would be great. Thanks.

ntd,

 

A mouse-over shows the filename being passed to the javascript is roger-maris-1962_p40894.html. It should be popup_image.php.

 

Here is the unmodified java script:

<script language="javascript"><!--
document.write('<?php echo '<a href="java script:popupWindow(\\\'' . tep_href_link(FILENAME_POPUP_IMAGE, 'pID=' . $product_info['products_id']) . '\\\')">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], addslashes($product_info['products_name']), SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>'; ?>');
//--></script>

Notice tep_href_link is passed the constant for popup_image.php, FILENAME_POPUP_IMAGE.

 

Did Ultrapics change this?

 

-Skittles

Share this post


Link to post
Share on other sites

Hi,

 

I see lot of people have been successful in installing this contirbution but i have some problems.

 

I have installed the contribution but after installation my site doesn't work and it give Internal Server Error.

 

this is the only contribution that i'm installing to oscommerce shop. i have tried to install it on my local server and the live server.

 

i'll tell you what steps i followed.

 

instead of changing code i replaced the files provided in the contribution as it said all the changes are already made in provided files. Yeah, i have the backup.

 

the installation was simple but not working for me so, any idea what the problem may be?

Share this post


Link to post
Share on other sites

did you change the /catelog/ bit i htacess? whats the url to your shop


Visit my website in my profile for prices on woodburning stoves

Share this post


Link to post
Share on other sites
Hi,

 

I see lot of people have been successful in installing this contirbution but i have some problems.

 

I have installed the contribution but after installation my site doesn't work and it give Internal Server Error.

 

this is the only contribution that i'm installing to oscommerce shop. i have tried to install it on my local server and the live server.

 

i'll tell you what steps i followed.

 

instead of changing code i replaced the files provided in the contribution as it said all the changes are already made in provided files. Yeah, i have the backup.

 

the installation was simple but not working for me so, any idea what the problem may be?

raslam,

 

Assuming you're on a linux/apache server, check with your host to see if "mod_rewrite" is enabled. You may also need to have "AllowOverride" enabled. (See this post).

If you need to do the changes yourself, the file is httpd.conf in the apache/conf directory of your server. Look for:

#LoadModule rewrite_module modules/mod_rewrite.so

and remove the "#":

LoadModule rewrite_module modules/mod_rewrite.so

Then look for something like this:

# First, we configure the "default" to be a very restrictive set of

# features.

#

<Directory />

(It may vary between versions of apache, so just search for "<Directory />").

Enable AllowOveride in this location. (It shows up in several places in the file).

AllowOveride All

Don't assume it won't work on your site if you can't get it working locally. I use XAMPP for my local install, but I've not been able to get this working locally. (It may have something to do with the fact my operating system is Windows XP.) It works as it should online. Anyway, locally I simply keep the contrib disabled. It's annoying but not a real issue.

 

Another possibility might be your .htaccess file. As long as you copied the changes into an existing .htaccess file, this shouldn't be the problem. However, if you replaced the existing .htaccess file, you may have removed some things necessary for osCommerce to work.

 

Let us know whether or not these suggestions help you find the problem.

 

-Skittles

Share this post


Link to post
Share on other sites

Hi there

 

I have used this contrib for some time now. I am grateful to the writer - thanks

 

As the url is made up of the product name, and some of my product names are very long I am concerened this may be causing an issue with my page rank and search engine positions.

 

I do not know if this is correct so I am really looking for advice? And If it could harm my position is there a way to reduce the size of the url?

 

Thanks in advance

Share this post


Link to post
Share on other sites

Just on a similar topic. I am trying to find out why my pagerank is still 0. In my quest I have found that google may not like this:

 

URL=http://www.jbosolutions.co.uk/xyzxyzxyzxyz-p-362.html

 

this url is not of any product. But if you visit the link it takes you to the product. I'm guessing on the number.

 

I have been told that - to quote

 

"It is a requirement of Google that requests for non-existent pages

should return a suitable code such as 301 Permanently Moved or 404 Page

Not Found.

 

To return code 200 is "misleading" to Google. In fact, up with it they

will not put! They periodically deliberately send requests for random

filenames to test that they do indeed get a 404 back.

 

To effectively map an almost infinite number of page names to a single

page (or limited number of pages) is not going to help your indexing."

 

Has anyone else had this and got around it or am I worrying unneccesarily?

 

 

Thanks a lot

Share this post


Link to post
Share on other sites
Hi there

 

I have used this contrib for some time now. I am grateful to the writer - thanks

 

As the url is made up of the product name, and some of my product names are very long I am concerened this may be causing an issue with my page rank and search engine positions.

 

I do not know if this is correct so I am really looking for advice? And If it could harm my position is there a way to reduce the size of the url?

 

Thanks in advance

ollyno1uk2,

 

This contribution adds special fields to the database to hold alternate filenames, and category names too. After installing the contribution, you can enter whatever you want to be used from the admin.

 

For example, if the product name is "Joe Schmoe's Hot and Cold Folding Doors in Blue", you could use "Blue Hot Cold Folding Doors" or just "Hot Cold Folding Doors". (Product name compliments of my ex-husband... :P ).

 

The information is stored as is in the database, then processed when used. Hyphens are removed along with other non-alpha characters, then spaces are replaced with hyphens, and the whole thing is converted to lowercase. So "Alpha-Male" becomes "alphamale".

 

Hope this helps,

-Skittles

Share this post


Link to post
Share on other sites
Just on a similar topic. I am trying to find out why my pagerank is still 0. In my quest I have found that google may not like this:

 

URL=http://www.jbosolutions.co.uk/xyzxyzxyzxyz-p-362.html

 

this url is not of any product. But if you visit the link it takes you to the product. I'm guessing on the number.

 

I have been told that - to quote

 

"It is a requirement of Google that requests for non-existent pages

should return a suitable code such as 301 Permanently Moved or 404 Page

Not Found.

 

To return code 200 is "misleading" to Google. In fact, up with it they

will not put! They periodically deliberately send requests for random

filenames to test that they do indeed get a 404 back.

 

To effectively map an almost infinite number of page names to a single

page (or limited number of pages) is not going to help your indexing."

 

Has anyone else had this and got around it or am I worrying unneccesarily?

Thanks a lot

ollyno1uk2,

 

Page Rank is one of over a hundred factors used by Google in determining your position in search results for any given query. That said, Page Rank is not about on page factors. It is solely about incoming links, and the quality of those links.

 

Google also has an aging delay built into their algorithm. Depending on the number of incoming links, how long those links have been in place, and how old the site is that's linking to you, it can take anywhere from 6 to 18 months for your site to start showing up in search results for important keywords. This has commonly been called the Google Sandbox.

 

For some of the best SEO information, bar none, checkout the High Rankings Forum. Most of the industry's best known names hang out there. People who get invited to make presentations at the Search Engine Strategies conferences held around the world, not some Johnny-Come-Lately whose real goal is to make a fast buck off of unsuspecting newbies.

 

I know it isn't what anyone wants to hear, but the first year of your new site most likely will not get a lot of traffic from Google's organic search results. Yahoo and MSN aren't as strict about the aging delay, though that could change. Your best bet is to use a combination of PPC, Google Base (formerly Froogle) and "sitemaps" (the xml variety, started by Google, not a site map page). (Go easy on the PPC, though, and keep track of your conversions.)

 

And for the record, the search engine friendly URLs won't hurt your efforts. And they are people friendly too: So much easier to remember matrox-video-card-200mx-p-15.html than product_info.php?product_id=15. :)

 

-Skittles

Share this post


Link to post
Share on other sites

I installed SEO URL, but when i try to long in to website/admin it gives me "Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory." MY php.ini has registrar globals set to on, and i dont know the problem. I know this may sound noobish and what not.

help would be appreciated.

thanks,

shadi

Share this post


Link to post
Share on other sites
I installed SEO URL, but when i try to long in to website/admin it gives me "Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory." MY php.ini has registrar globals set to on, and i dont know the problem. I know this may sound noobish and what not.

help would be appreciated.

thanks,

shadi

okay i fixed tht problem but now i get this whenever i tyr to loginto admin

Fatal error: Call to undefined function: tep_catalog_href_link() in /home/bleubayc/public_html/osc/admin/index.php on line 101

Share this post


Link to post
Share on other sites

Just some additional comments about pagerank and online marketing of your site.

 

SEO consists of on-page factors and off-page factors. Having your keyword in the url of your site is one of the on-page factors - just one of the 100 factors that Google takes into account.

 

Link exchanges are dead and the most important factor is backlinks / inbound link. The way to get these links relates more to online marketing than SEO - i.e. you will have to do press releases when you launch new products, add content about your products for example articles and then distribute these press releases and articles.

 

An influx of links are also considered suspicious activity so you have to build it up over a period of time. Add a blog to your site and blog about your business or the field of business you are in. For topics, check the latest industry news and discuss it on your blog.

 

Once again just adding this module or the header tags module is not going to be the begin and end of all solutions. Also do not expect miracles - it will take up to 3 months before you start seeing a difference. SEO whether it is on-page of off-page factors that you work on is part of a whole and if you do not have your marketing strategy right, i.e. which target markets you want to reach, then these tools will only have a 0.01% chance of making a difference to your site.

Share this post


Link to post
Share on other sites
Once again just adding this module or the header tags module is not going to be the begin and end of all solutions. Also do not expect miracles - it will take up to 3 months before you start seeing a difference. SEO whether it is on-page of off-page factors that you work on is part of a whole and if you do not have your marketing strategy right, i.e. which target markets you want to reach, then these tools will only have a 0.01% chance of making a difference to your site.

espectations,

 

I so agree with you!

 

-Skittles

Edited by Skittles

Share this post


Link to post
Share on other sites

Skittles - thanks a lot for taking the time to answer. I have a database of 7500 products. I apprecaite I can change the name to what I want but to manually reduce all namess will take a lot of time and I do not know if it would even be neccesary. Its purely the longer names I was concerned about but hopefuly this will not be a problem

 

With reference to the second query, it was more about the fact that if the product was called /monitor-316.htm you could type in as a url /anything-316.htm and still reach the same product. This was the concern that google would not like an unlimieted amount of urls pointing to one product?

 

Thanks for your input. Its helpful.

Share this post


Link to post
Share on other sites

I want to redirect for example

chocolate_scented.html?oscsid=ee1bfaad296af98940af4448b5fa6b7f

to

chocolate_scented.html

 

but chocolate_scented.html could be any page name, in other words get rid of oscsid

 

So

*.html?oscsid=*

redirects to

*.html

 

Can anyone tell me the RewriteRule?

 

Any help would be appreciated.

 

Thanks.

Edited by ChocolateTeapot

Share this post


Link to post
Share on other sites
I want to redirect for example

chocolate_scented.html?oscsid=ee1bfaad296af98940af4448b5fa6b7f

to

chocolate_scented.html

 

but chocolate_scented.html could be any page name, in other words get rid of oscsid

 

So

*.html?oscsid=*

redirects to

*.html

 

Can anyone tell me the RewriteRule?

 

Any help would be appreciated.

 

Thanks.

 

This has been discussed a lot on here.

 

You do not do any rewrites to remove the oscsid, as that needs to be there for the first click or two, and then should automatically be removed as it is then stored in a cookie.

 

If it doesn't disappear, then there is something wrong with your website, or with your web browser not accepting cookies.

 

There are solutions on the past couple of pages (applying some updates from the OSC Update releases).

 

Cheers,

Chris

Share this post


Link to post
Share on other sites
Hi,

 

do you know whether the add cPath to product links work? Any workarounds? Thanks in advance.

jashnu,

 

The option to add cPath to the products link does work. It adds "?cpath=" and the numeric value for the product directory and parent following the .html. For example: dvd-movies-action-lethal-weapon-p-13.html?cPath=3_10.

 

These categories are included in the url by name, whether or not you enable "Add cPath to product URLs" if you enable "Add category parent to beginning of URLs".

 

If you do not enable "Add category parent to begining of URLs", the current category name will still be included in the product URL.

 

What is it you want to do? I'm not sure what you mean by "any workarounds".

 

-Skittles

Edited by Skittles

Share this post


Link to post
Share on other sites
These categories are included in the url by name, whether or not you enable "Add cPath to product URLs" if you enable "Add category parent to beginning of URLs".

 

For some reason enabling that setting did not help. My site is done in xhtml so I wonder if it has to do something with using "&" instead of & in urls?

Share this post


Link to post
Share on other sites

Not sure if this is a problem but my address are kind of funny when using the manufacturer filter.

 

For instanace, myitem-c-23.html?filter_id=1&sort=3a shows up is this normal?

 

Shouldn't it be myitem-c-23.html?filter_id=1&sort=3a

 

 

basically the "&" is showing as "&"

 

 

Help :(

Share this post


Link to post
Share on other sites
Hi,

 

I see lot of people have been successful in installing this contirbution but i have some problems.

 

I have installed the contribution but after installation my site doesn't work and it give Internal Server Error.

 

this is the only contribution that i'm installing to oscommerce shop. i have tried to install it on my local server and the live server.

 

i'll tell you what steps i followed.

 

instead of changing code i replaced the files provided in the contribution as it said all the changes are already made in provided files. Yeah, i have the backup.

 

the installation was simple but not working for me so, any idea what the problem may be?

 

Assuming you're on a linux/apache server, check with your host to see if "mod_rewrite" is enabled. You may also need to have "AllowOverride" enabled. (See this post).

If you need to do the changes yourself, the file is httpd.conf in the apache/conf directory of your server. Look for:

#LoadModule rewrite_module modules/mod_rewrite.so

and remove the "#":

LoadModule rewrite_module modules/mod_rewrite.so

Then look for something like this:

# First, we configure the "default" to be a very restrictive set of

# features.

#

<Directory />

(It may vary between versions of apache, so just search for "<Directory />").

Enable AllowOveride in this location. (It shows up in several places in the file).

AllowOveride All

Don't assume it won't work on your site if you can't get it working locally. I use XAMPP for my local install, but I've not been able to get this working locally. (It may have something to do with the fact my operating system is Windows XP.) It works as it should online. Anyway, locally I simply keep the contrib disabled. It's annoying but not a real issue.

 

Another possibility might be your .htaccess file. As long as you copied the changes into an existing .htaccess file, this shouldn't be the problem. However, if you replaced the existing .htaccess file, you may have removed some things necessary for osCommerce to work.

 

Let us know whether or not these suggestions help you find the problem.

 

-Skittles

it didn't work. any suggestions? :(

Share this post


Link to post
Share on other sites
ntd,

 

A mouse-over shows the filename being passed to the javascript is roger-maris-1962_p40894.html. It should be popup_image.php.

 

Here is the unmodified java script:

<script language="javascript"><!--
document.write('<?php echo '<a href="java script:popupWindow(\\\'' . tep_href_link(FILENAME_POPUP_IMAGE, 'pID=' . $product_info['products_id']) . '\\\')">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], addslashes($product_info['products_name']), SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>'; ?>');
//--></script>

Notice tep_href_link is passed the constant for popup_image.php, FILENAME_POPUP_IMAGE.

 

Did Ultrapics change this?

 

-Skittles

 

Skittles

 

This mod did that renaming. If I shut down Ult SEO URL I get the popups url. I've tried to comment out the popups line from the .htaccess file but that didn't change anything.

 

I found an issue where Ult SEO URL had problems with another multi image mod and some one had a solution for at one but it didn't adapt over.

 

Thanks

 

ntd

Share this post


Link to post
Share on other sites

solved the problem. I removed the line in the .htaccess and edited out the code for popup file in the seo class file.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×