Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

K so I installed Ultimate SEO on a site that I am developing. Wondering if any of you could help me figure out why I am not getting any product catagory or product name in my URL? I am sure that the contrubution is working but it is not doing this one thing. Some help on this would be great!

 

All my urls look like this http://yourdomain.com/-c-41.html

 

 

Development site address is http://thevacuumcenter.com/catalog

 

thanks,

 

Matthew

Share this post


Link to post
Share on other sites

One thing to look at is the .htaccess file, the line regarding whether it'd be / or /catalog/ , ie, the RewriteBase.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
yes, give that a go first and if it doesn't work then you can move on to a new avenue. Hopefully it will work

 

Chooch,

 

A postscript to say the problem went away after I restored back to an earlier copy. On examination of the offending dataset there were some orphan entries in TABLE configuration referring to SEO

 

Thanks to you, Yesudo et al - Respect

 

 

Cheers

 

Nossum

Share this post


Link to post
Share on other sites

Hello All,

 

Been Reading through all the pages of fun and I saw where a few people said that this contib HURt them in the rankings...

 

I installed it on a smaller site (which I always tend to do before trying something on my main site) to a) see if it's easy to install and B) see if I like it. If it's neither a or b I don't put it on the main site I run..

 

My question is...

 

Is this really going to help me out in the rankings?

 

I've been in business on line for 13 years, and had OSC going for a little over 3 now, I have 10,200 listings on google and 128,381 on Yahoo! with about 2,600 total products in my catalog.

 

With what I have achieved should I screw with trying to make it better or leave things as they are and just "Keep on Truckin"

 

I'd really value your input here, and if anyone talks to Chemo, Tell him THANKS for the GREAT work as always! I for one hope he one day comes back around.

Share this post


Link to post
Share on other sites

I think people do not understand the importance of SEO combined with SEM.

 

SEO consist of on-page and off-page factors. SEO urls are part of the on-page factors as it is important for your keywords used in your url to also appear on your page.

 

A recent report indicated that 2007 is going to be the year where SEO is going to change as more and more clients are expecting additional services for example public relations, marketing etc.

 

It is like the use of a marketing mix in offline marketing where the whole package consist of several elements.

 

SEO urls should just be one part of your web site promotion mix. Content is still king and if you do not add updates, decent content etc. to your site you will not see much of a difference.

 

So to answer your question - there is no "quick fix" as far as online marketing, search engine optimization and positioning is concerned and SEO urls is not going to provide you with a miracle solution.

 

You still need to do all the rest that goes with it for ultimate results.

Share this post


Link to post
Share on other sites
I'd really value your input here, and if anyone talks to Chemo, Tell him THANKS for the GREAT work as always! I for one hope he one day comes back around.

Ok, sorry for the double post but kindly disregard my statement above for this:

 

In post #1351 mentioned above, Yesudo's update wasn't mentioned, an older deleted 2.2.2 version was mentioned and that was causing the problem not Yesudo's 29 Nov 2006 version...

 

.... i actually use the 29 Nov 2006 version myself and for my clients and we have not encountered problems at all

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
The latest download does allow that

chooch,

 

I downloaded and installed the latest version of Ultimate SEO (filename: Ultimate_SEO_URLsv21da_1_2.zip), and have only one issue that I couldn't find the answer to. Like pieter333, I want my category names in the url to look like directories, not be part of the filename.

 

You say this version allows that. Could you be a bit more specific? How do we set it up this way? Or where do we find the directions to set it up this way?

 

Let me say in advance, your time and expertise are greatly appreciated.

 

-Skittles

Share this post


Link to post
Share on other sites

Everything is perfect on my installation. The only thing is that I don't see a link in my admin for the configuration of it. And yes I did go through step 4 and have completd it. I have horizontal admin installed. I think this might have something to do with it. Any suggestions to get that link to show up somewhere?

Share this post


Link to post
Share on other sites
-Skittles

 

Ok, the first part of Pieters post can't be done, the part where you want seperate directories but the second part can be done, that was what i was refering to. In short products can but categories can't.

 

http://www.domain/catalog/movies/matrix-p-15.html

do become

http://www.domain/catalog/the-movie-matrix...reeve-p-15.html

 

but

 

http://www.domain/catalog/movies-action-c-3_10.html

can not become

http://www.domain/catalog/action-c-3_10.html

 

not unless someone updates the contribution - is that what you are asking?

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

or maybe this is better:

 

catalog/movies/matrix-p-15.html

do become

catalog/the-movie-matrix-keanu-reeve-p-15.html

 

but

 

catalog/movies-action-c-3_10.html

can not become

catalog/movies/action-c-3_10.html

 

not unless someone updates the contribution

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
Ok, the first part of Pieters post can't be done, the part where you want seperate directories but the second part can be done, that was what i was refering to. In short products can but categories can't.

 

http://www.domain/catalog/movies/matrix-p-15.html

can become

http://www.domain/catalog/the-movie-matrix...reeve-p-15.html

 

but

 

http://www.domain/catalog/movies-action-c-3_10.html

can not become

http://www.domain/catalog/action-c-3_10.html

 

not unless someone updates the contribution

or maybe this is better:

 

catalog/movies/matrix-p-15.html

do become

catalog/the-movie-matrix-keanu-reeve-p-15.html

 

but

 

catalog/movies-action-c-3_10.html

can not become

catalog/movies/action-c-3_10.html

 

not unless someone updates the contribution

Thanks chooch.

 

I've looked at the php files and it looks like it's possible. But it also looks like a lot of work for a non-programmer like me!

 

Darn!

 

Guess I'll just have to dig in, and see what I can do...

 

I'm converting my static site over to osCommerce, and have an existing file structure that I want to emulate as much as possible. If I'm successful, I'll post the changes here.

 

Thanks to all who've been supporting this contribution and this thread. I think Chemo is sorely missed, but at least we still have a dedicated group of community members to fill in the gap, to some extent.

 

Happy New Year. May it be extremely prosperous for us all! :thumbsup:

-Skittles

Share this post


Link to post
Share on other sites
Any suggestions to get that link to show up somewhere?

you could always try removing your header navigation menu contribution and seeing if it part of the problem but i doubt that.... trying removing the seo class file and re-adding it (via ftp)

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
... I've looked at the php files and it looks like it's possible. But it also looks like a lot of work for a non-programmer like me!

It is possible but to the majority of people who don't have your file structure, it isn't necessary either because SEO is at the root of this contribution and there are many ways in which the fact the directory name stays as part of the URL can help with listing and rankings.

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
Hello All,

 

Been Reading through all the pages of fun and I saw where a few people said that this contib HURt them in the rankings...

 

I installed it on a smaller site (which I always tend to do before trying something on my main site) to a) see if it's easy to install and B) see if I like it. If it's neither a or b I don't put it on the main site I run..

 

My question is...

 

Is this really going to help me out in the rankings?

 

I've been in business on line for 13 years, and had OSC going for a little over 3 now, I have 10,200 listings on google and 128,381 on Yahoo! with about 2,600 total products in my catalog.

 

With what I have achieved should I screw with trying to make it better or leave things as they are and just "Keep on Truckin"

 

I'd really value your input here, and if anyone talks to Chemo, Tell him THANKS for the GREAT work as always! I for one hope he one day comes back around.

 

 

 

Interesting question! - I installed this contrib about 1 month ago and although the URL's look clean I'm starting to find google indexing problems. I use google webmaster tools to analyse my web site and I now have redirect errors showing on google crawls.

 

It might be worth reading the articles here before installing:

 

http://www.google.com/support/webmasters/b...35156&hl=en

 

Good luck! - I'm going to leave the contrib live on one of my sites for a few more weeks to see how things progress. I'll report back when I have more info.

 

Si.

p.s. happy new year to all. I hope all of your e-commerce sites do well next year.... :)


Best regs,

Simon.

Share this post


Link to post
Share on other sites

Hello Si,

 

Which of the redirect error messages Google mentions are you seeing ?


Your online success is Paramount.

Share this post


Link to post
Share on other sites

Also what do you have in your htaccess file ?


Your online success is Paramount.

Share this post


Link to post
Share on other sites

I have just added this contribution to very good customers templated site and get this error:

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

 

 

--------------------------------------------------------------------------------

 

Apache/1.3.33 Server at www.domain.com Port 80

 

 

Also, when i remove the .htaccess file it actually opens the index page and all the category clicks all show .html correctly but the pages open up blank and the products urls rollover are still product_info.php?xxxxx instead of .html --- could it be something to do with it being a mac server as i have had problems on this site before?

 

Can anyone help please because i've been working non-stop on it for 2 and half hours - thanks

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
Also what do you have in your htaccess file ?

 

 

My .htaccess file is as follows:

 

Options +FollowSymLinks

RewriteEngine On

RewriteBase /buy-car-accessories/

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ default.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-([0-9]+).html$ default.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}


Best regs,

Simon.

Share this post


Link to post
Share on other sites
Hello Si,

 

Which of the redirect error messages Google mentions are you seeing ?

 

My stats show:

 

Code 200 - OK 1842761

Code 206 - Partial Content 497

Code 301 - Moved Permanently 54251

Code 302 - Found 5026

Code 304 - Not Modified 132749

Code 400 - Bad Request 45

Code 403 - Forbidden 22

Code 404 - Not Found 50624

Code 405 - Method Not Allowed 3


Best regs,

Simon.

Share this post


Link to post
Share on other sites

Hi Guys,

 

I am running the latest verion of the SEO implement, i have just noticed that when i click buy now, nothing happens, i can go in to the product information and everything see to work ok from there when i click add to basket.

 

Any help you be greatful.

 

Thanks, Tim.

Share this post


Link to post
Share on other sites
My stats show:

 

Code 200 - OK 1842761

Code 206 - Partial Content 497

Code 301 - Moved Permanently 54251

Code 302 - Found 5026

Code 304 - Not Modified 132749

Code 400 - Bad Request 45

Code 403 - Forbidden 22

Code 404 - Not Found 50624

Code 405 - Method Not Allowed 3

 

Have you got some example Not Found urls ?


Your online success is Paramount.

Share this post


Link to post
Share on other sites

yesudo, if you are refering to me (tim.ford) then know, this is why i have only just found this issue. site has been running this for the last couple of days.

 

Any idea??

 

Thanks, Tim.

Share this post


Link to post
Share on other sites
yesudo, if you are refering to me (tim.ford) then know, this is why i have only just found this issue. site has been running this for the last couple of days.

 

Any idea??

 

Thanks, Tim.

Tim,

 

FYI: yesudo is helping simondj figure out why Google crawls are producing redirect errors.

 

There is a switch in includes/application_top.php which handles Buy Now

switch ($HTTP_GET_VARS['action']) {

Here's the specific code:

	  case 'buy_now' :		if (isset($HTTP_GET_VARS['products_id'])) {
							if (tep_has_product_attributes($HTTP_GET_VARS['products_id'])) {
							  tep_redirect(tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $HTTP_GET_VARS['products_id']));
							} else {
							  $cart->add_cart($HTTP_GET_VARS['products_id'], $cart->get_quantity($HTTP_GET_VARS['products_id'])+1);
							}
						  }
						  tep_redirect(tep_href_link($goto, tep_get_all_get_params($parameters)));
						  break;

The first if statement is looking for 'products_id' from the url ($HTTP_GET_VARS['products_id']). If the url doesn't have it, the code skips all the way down to the last redirect, which uses $goto for the filename. $goto is initialized just before the switch:

	if (DISPLAY_CART == 'true') {
  $goto =  FILENAME_SHOPPING_CART;
  $parameters = array('action', 'cPath', 'products_id', 'pid');
} else {
  $goto = basename($PHP_SELF);
  if ($HTTP_GET_VARS['action'] == 'buy_now') {
	$parameters = array('action', 'pid', 'products_id');
  } else {
	$parameters = array('action', 'pid');
  }
}

 

I haven't tested this, but it appears this code will always send the visitor to the product because the url does not contain "products_id=nnn" (where nnn is the product id.)

 

Assuming your url contains "-p-nnn", this code could be modified to look for the "-p-" and then do effectively the same thing as the existing code, with changes necessary to accommodate the new format.

 

I'd recommend adding it using "else if", rather than replacing the current code, like this:

//pseudo-code:
  case 'buy_now' :		if (isset($HTTP_GET_VARS['products_id'])) {
									[existing code here]
						  } else if ([test for -p- here]) {
									[new code here]
						  }
						  tep_redirect(tep_href_link($goto, tep_get_all_get_params($parameters)));
						  break;

 

I'm sorry this isn't a complete solution to your problem. But I think it is a good starting point to finding your solution. Perhaps someone who is a "real" programmer can step in and help. Good luck.

 

-Skittles

Share this post


Link to post
Share on other sites
Have you got some example Not Found urls ?

 

Here are some of the Googlebase reported error URL's:

 

http://www.directcarparts.co.uk/buy-car-ac...49eb15ba0db247d 404 (Not found)

 

http://www.directcarparts.co.uk/buy-car-ac...roducts_id=6129 301 (Moved permanently)

 

http://www.directcarparts.co.uk/buy-car-ac...55ebc7b6fd17cf7 Redirect error

 

http://www.directcarparts.co.uk/buy-car-ac...ers-p-1802.html Network unreachable

 

I'd like to see the back of the '&osCid' in the URL link - Google has indexed the session id a few times and as you can imagine that has caused issues,

 

Thanks, Si.


Best regs,

Simon.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×