Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

Hi,

 

I recently applied the contribution Ultimate URLS. I then submitted my sitemap to google and all my sub pages that ranked around 20 to 30 either disappeared from google or ranked around the 90s. It's been just over two months since then and no change. Any ideas why this happened? Is it worth turning this feature off? Thought this would benefit my ranking as name appear on the page and url. Does google detect these as duplicates?

 

Any experience shared would help.

 

Thanks,

 

James

 

Dang, that sucks. Sorry to hear that.

 

Anybody else have the same problems? If so, please let us know.

 

Peace.


JHouse

Share this post


Link to post
Share on other sites

Hi,

 

Well looking at the google tools it's clear that the non-seo urls are indexed 2 months on, maybe why I'm ranking so low. I've just tried switching the button "Enable SEO URLs?" to false. Unfortunately now when I try and click on a product I get the following message in FireFox:

 

Redirection limit for this URL exceeded. Unable to load the requested page.

 

I've tried the same in explorer and it just hangs, it's like it's stuck in a loop. I've removed the cient side cache but think somethings wrong here! Can anyone help!

 

P.S I've had to switch it back on to keep my site running!

 

Thanks,

 

James

Share this post


Link to post
Share on other sites

Hello James,

 

Either uninstall the contribution or apply the modification by Randelia.

 

Cheers,

Emmett


Your online success is Paramount.

Share this post


Link to post
Share on other sites

I've tried removing Ultimate Urls now and the site just doesn't work anymore, so i restored a backup. Site is running now but not the manufacturer dropdown box.

My site is: http://www.coolchip.co.uk/catalog/

What parts of the code change effect the manufacturer dropdown? I've been working on this problem for about 4 days now and i cannot find a solution.

 

one thing i have noticed is that when the manufacturer dropdown is used the url changes to:

www.coolchip.co.uk/catalog/index.php?catalog=index.php

and the page is refreshed.

 

Please help!

 

Many thanks

 

Rob

Edited by coolchip

Share this post


Link to post
Share on other sites

Yes I think both of you are right (yesudo & coolchip), it's probably best to uninstall the contribution from a backup. I've been through google web tools and the google browser and not a single one of my products with the new SEO URLS are listed (2 months on). They vanished overnight after the contribution. I use to have many product_ID=xx URLS in google, but now they have gone (hoping they'd be replaced with higher SEO URLs).

 

I think it would be fair to say that this contribution harms your Search Engine Rankings - Maybe this is because I submitted my site to google directory and then after applied the Ultimate SEO URLs. Had I applied the contribution the other way round.....who knows!

 

*** The only plus is on the MSN.co.uk search engine, which to be honest doesn't really count for anything as in my experience google is used by 90% of internet users. There has been a lot of hard work put into this contribution and it's a real shame.

Share this post


Link to post
Share on other sites

I nstall Ultimate SEO URLs it work perfect in English but I have problem in Bulgarian

 

Warning: Cannot modify header information - headers already sent by (output started at ....../catalog/includes/languages/bulgarian.php:2) in ...../catalog/includes/classes/seo.class.php on line 1951

Warning: Cannot modify header information - headers already sent by (output started at ....../catalog/includes/languages/bulgarian.php:2) in ......../catalog/includes/classes/seo.class.php on line 1952

and address in Bulgarian is:

.....catalog/e%C3%A4%C3%AD%C3%AE%C.....D-e%C3%AB%C3%B5%C3%AE%C3%A2%C3%AE-p-222.html

may I make translation from Cyrillic alphabet to Roman alphabet on .htaccess and how?

 

Please help me

Share this post


Link to post
Share on other sites
Yes I think both of you are right (yesudo & coolchip), it's probably best to uninstall the contribution from a backup. I've been through google web tools and the google browser and not a single one of my products with the new SEO URLS are listed (2 months on). They vanished overnight after the contribution. I use to have many product_ID=xx URLS in google, but now they have gone (hoping they'd be replaced with higher SEO URLs).

 

I think it would be fair to say that this contribution harms your Search Engine Rankings - Maybe this is because I submitted my site to google directory and then after applied the Ultimate SEO URLs. Had I applied the contribution the other way round.....who knows!

 

*** The only plus is on the MSN.co.uk search engine, which to be honest doesn't really count for anything as in my experience google is used by 90% of internet users. There has been a lot of hard work put into this contribution and it's a real shame.

 

If anybody else had the same problem, please speak up. My client's site has been ranking well too and I obviously don't want to jeapordize that.

 

James, let me ask you this, was there anything else that did to your site that could have possibly affected your rankings? Even if it's a relatively small change/addition, it can make a huge difference ranking wise. Some of the smallest revisions I've made in the past had a collosal impact; both good and bad.

 

Thanks.


JHouse

Share this post


Link to post
Share on other sites
If anybody else had the same problem, please speak up. My client's site has been ranking well too and I obviously don't want to jeapordize that.

 

James, let me ask you this, was there anything else that did to your site that could have possibly affected your rankings? Even if it's a relatively small change/addition, it can make a huge difference ranking wise. Some of the smallest revisions I've made in the past had a collosal impact; both good and bad.

 

Thanks.

I doubt it, there are many people having problems with this contribution and the negative side of it when it comes to search engine rankings.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

This sounds like a pretty nice mod, but I have had a lot of trouble with installation. I've tried multiple versions and have not had success yet. My latest installation has been from the nov. 29, 2.1d release.

 

I have verified with my host that the Linux server does support mod rewrite capabilities.

I have checked that my PhP version is >= PHP 4.3.0.

I get all the information in the Admin panel as I am supposed too.

 

The problem is if I enable Ultimate SEO URL's I get the following:

 

The URL in the window is correct:

http://www.nationalmerchandiseoutlet.com/s...ner-p-2264.html

 

Instead of loading the product information I just get a 404 error:

 

Not Found
The requested URL /nationalmerchandiseoutlet.com/product_info.php was not found on this server.

--------------------------------------------------------------------------------
Apache/1.3.31 Server at nationalmerchandiseoutlet.com Port 80

 

At first I figured I probably copied/pasted something wrong or otherwise messed up... but I have done this about 5 times now and always get the same result. Any ideas on what causes this, or how to fix it? Any help is greatly appreciated.

Share this post


Link to post
Share on other sites

I used the category/products SEO URL's and have changed the cat/prod name yet if I add the old SEO URL in the browser that page still opens.

 

catalog.com/online/hardware-graphic-sfdsfsdfsdfsdfsdfsdfsdfsdfsdfsdf-c-1_4.html

catalog.com/online/hardware-graphic-cardy-wardy-c-1_4.html

catalog.com/online/hardware-graphic-c-1_4.html

 

all the above open up in the same product info page yet the URL's are different... what will this do the search engine rankings?

 

as the above problem applies to category, product does anyone know stop this happening because at the moment you can simply go the browser and type in any mambo-jambo and as long as the c-1_4.html , p-1.html etc etc is in the URL the product info will open with that product showing....

 

.... also, when SEO URL's are set to false (off) the product info pages still open with SEO URL's if the URL is overrided.

 

Anyone have any advice?

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
I used the category/products SEO URL's and have changed the cat/prod name yet if I add the old SEO URL in the browser that page still opens.

 

catalog.com/online/hardware-graphic-sfdsfsdfsdfsdfsdfsdfsdfsdfsdfsdf-c-1_4.html

catalog.com/online/hardware-graphic-cardy-wardy-c-1_4.html

catalog.com/online/hardware-graphic-c-1_4.html

 

all the above open up in the same product info page yet the URL's are different... what will this do the search engine rankings?

 

as the above problem applies to category, product does anyone know stop this happening because at the moment you can simply go the browser and type in any mambo-jambo and as long as the c-1_4.html , p-1.html etc etc is in the URL the product info will open with that product showing....

 

.... also, when SEO URL's are set to false (off) the product info pages still open with SEO URL's if the URL is overrided.

 

Anyone have any advice?

 

seo url's work solely on those indicators so you can add any mumbojumbo but the rewrites will always translate -c-1_4.html to the same category (cPath).


Treasurer MFC

Share this post


Link to post
Share on other sites

I have installed and un-installed this serveral times.

 

Not once have I had any settings appear in my admin, I followed the steps precisely and repeated step 4 as advised in the install html file, and carried out the additional install instructions.

 

Also this contrib is screwing up my 'buy now' function and I did a test purchase yesterday. I completed the purchase, click continue at checkout_success.php and was automatically logged out and taken to login.php

 

I don't understand how so many people are raving about this. Twelve times I tried, i've read every post in this thread and it just doesn't work.

 

I have seen people posting 'are you sure you installed 2.1d by chemo' etc but chemo is not listed obviously as the uploader, so if you wish to suggest a particular version then please post a link.

 

What's going on with the admin configuration not appearing? Anyone help.

Share this post


Link to post
Share on other sites
Hello,

 

I have installed Ultimate SEO URLs v2.1c by Chemo and I really do not know what SID killer contribution from http://www.oscommerce.com/community/contri...arch,sid+killer

should I install. Is there anyone who have experience in using SEO URLs v2.1c and

SID killer and can recommend me what contribution shoul I choose. Thank you.

 

you should not install sid killer.


Treasurer MFC

Share this post


Link to post
Share on other sites
you should not install sid killer.

 

Can you tell me why I should not install sid killer, and what do you propose me instead of sid killer to get rid of osCsid.

Share this post


Link to post
Share on other sites

I nstall Ultimate SEO URLs it work perfect in English but I have problem in Bulgarian

 

Warning: Cannot modify header information - headers already sent by (output started at ....../catalog/includes/languages/bulgarian.php:2) in ...../catalog/includes/classes/seo.class.php on line 1951

Warning: Cannot modify header information - headers already sent by (output started at ....../catalog/includes/languages/bulgarian.php:2) in ......../catalog/includes/classes/seo.class.php on line 1952

and address in Bulgarian is:

.....catalog/e%C3%A4%C3%AD%C3%AE%C.....D-e%C3%AB%C3%B5%C3%AE%C3%A2%C3%AE-p-222.html

may I make translation from Cyrillic alphabet to Roman alphabet on .htaccess and how?

 

Please help me

Share this post


Link to post
Share on other sites
.... also, when SEO URL's are set to false (off) the product info pages still open with SEO URL's if the URL is

can anyone answer this part of the question please?


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
I have installed and un-installed this serveral times.

 

Not once have I had any settings appear in my admin, I followed the steps precisely and repeated step 4 as advised in the install html file, and carried out the additional install instructions.

 

Also this contrib is screwing up my 'buy now' function and I did a test purchase yesterday. I completed the purchase, click continue at checkout_success.php and was automatically logged out and taken to login.php

 

I don't understand how so many people are raving about this. Twelve times I tried, i've read every post in this thread and it just doesn't work.

 

I have seen people posting 'are you sure you installed 2.1d by chemo' etc but chemo is not listed obviously as the uploader, so if you wish to suggest a particular version then please post a link.

 

What's going on with the admin configuration not appearing? Anyone help.

 

I installed the latest upload (Nov 30, 2006 contribution I think) and it's working fine. I did, however, have some initial problems (i.e. buy now feature not working properly), but I've since got it all sorted. You can read my posts about the prob and the solution here:

 

http://forums.oscommerce.com/index.php?sho...166&st=1220

 

Peace.


JHouse

Share this post


Link to post
Share on other sites
can anyone answer this part of the question please?

 

yes as your rewrites are server based in your htaccess files and separate from your php controls


Treasurer MFC

Share this post


Link to post
Share on other sites

Hi all.

 

Before I installed the Ult SEO URLs on my site, I created a subfolder and installed a second (test) version of oscommerce on the same domain to make sure I get the (if any) bugs out before I install it on my live shop. I installed it then only on the test version. (I installed version: Ultimate SEO URLs - 2.1d with optional Admin settable Product and Category URLs posted by yesudo on 29 Nov 2006)

 

 

I can't seem to get outta the gate though because (it seems like) I am stuck trying figure out how to config the htaccess file. The directory is /TEST/catalog/ I have put it in the file like that as well as any and all of the following ways:

/test//catalog/

/my domain name/test//catalog/

/my domain name/test/catalog/

/catalog/

 

No matter what I get the page (in mozilla)

 

Bad Request

Your browser sent a request that this server could not understand.

 

WHAT am I doing wrong here? I looked at the url when this error page shows and the url looks great! No ? marks....nice. This error page shows when I click on a product.

 

THANK YOU SO MUCH in advance!!!!

Share this post


Link to post
Share on other sites

Hello,

 

I am using Ultimate SEO URLs - 2.1d with optional Admin settable Product and Category URLs.

 

I am trying to use the custom product URL yesudo added and while it works, it removes the dashes I put in the name.

 

For example, if I put in "bob-is-your-uncle" in the Products SEO URL you get something like bobisyouruncle-p-31.html for the output.

 

I have tried underscores and equal signs, all of these extended characters are removed. I am using pretty much the default settings (except I have turned off the case for testing),

 

I verified that in the admin that "Remove all non-alphanumeric characters?" is set to false, but even the function strip (in seo_class.php) it looks like the default replacement character is "-".

 

****

 

As I was writing researching this point I found a work-around to get it to work. Ok. maybe this is how it is designed, I do not know, but I thought I would share in case anyone else had the problem.

 

Use a space character instead of the dash.

 

For example:

 

bob-is-your-uncle => bobisyouruncle-p-31.html

bob is your uncle => bob-is-your-uncle-p-31.html

 

- Roger

Share this post


Link to post
Share on other sites
yes as your rewrites are server based in your htaccess files and separate from your php controls

thanks for the reply.

 

in that case if the URL is set up as:catalog/hardware-111-c.html and then later changed to catalog/hardware-222-c.html and then to catalog/hardware-111-c.html so on and so forth... basically search engines will pick up all variations that lead to the same product info page. is my assumption correct? and what happens to search engine rankings here?

 

can anyone please advise.

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
thanks for the reply.

 

in that case if the URL is set up as:catalog/hardware-111-c.html and then later changed to catalog/hardware-222-c.html and then to catalog/hardware-111-c.html so on and so forth... basically search engines will pick up all variations that lead to the same product info page. is my assumption correct? and what happens to search engine rankings here?

 

can anyone please advise.

 

not exactly.

 

the unique identifier that the rewrite uses to determine the "real" page is in the -c-xxx.html part.

 

hardware-C-21.html would result in index.php?cPath=21

hardware-C-22.html would result in index.php?cPath=22

 

The part before the -c is totally irrelevant for the rewrite to determine the actual page.

 

hardware-C-22.html would result in index.php?cPath=22

software-C-22.html would result in index.php?cPath=22

mumbojumbo-C-22.html would result in index.php?cPath=22

 

all the same page.

 

So the question is, why do you keep changing your category names.


Treasurer MFC

Share this post


Link to post
Share on other sites
So the question is, why do you keep changing your category names.

I don't, it was an example and basically to test the functions out.... but going back to my earlier post - will all previous (for example) item URL's that lead back to the same product info page be cached by search engines? if so, what does this do to rankings?

 

The question may sound trivial and pointless but I would appreciate an answer as I need to know what it does to search engine rankings if all search engine cached pages lead back to the same page.

 

If my matrox graphic card is called matrox-g200-one-p-1.html and few days later it is called matrox-g200-two-p-1.html and every so often the name is changed - does this have a negative effect on search engines? if a search engine page opened would it list all or some the names that lead back to the same product page?

 

many thanks

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×