Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

New version uploaded - incorporating updated install instructions.

Will test it out tomorrow - thanks for the contribution modification!


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

After installing it for the first time i got this error when editting a product.

 

TEXT_PRODUCTS_SEO_URL

Fatal error: Call to undefined function: tep_get_products_seo_url() in /var/***/shop/admin/categories.php on line 562

 

The code of line 562 of shop/admin/categories.php

<td class="main"><?php echo tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name']) . ' ' . tep_draw_input_field('products_seo_url[' . $languages[$i]['id'] . ']', (isset($products_seo_url[$languages[$i]['id']]) ? $products_seo_url[$languages[$i]['id']] : tep_get_products_seo_url($pInfo->products_id, $languages[$i]['id']))); ?></td>

 

Someone gots some pointers?

Edited by esstilo

Share this post


Link to post
Share on other sites

Did you add the code from the additional instructions file - as it sounds like you dont have that function added within your code.


Your online success is Paramount.

Share this post


Link to post
Share on other sites

Yes that was the problem didnt add the additional instructions code to the site. My bad.

 

It works like a charm now, thx...

Share this post


Link to post
Share on other sites

Why was Chemo banned? Seems he was a great addition around here and now who do we ask about instaltion problems????

 

I have 2 different problems? First when i go to the catalog folder in admin i get

define('TEXT_PRODUCTS_SEO_URL', 'Products SEO URL:'); define('TEXT_EDIT_CATEGORIES_SEO_URL', 'Category SEO URL:'); define('TEXT_CATEGORIES_SEO_URL', 'Category SEO URL:')

 

AND when i try to add a product i get this

define('TEXT_PRODUCTS_SEO_URL', 'Products SEO URL:'); define('TEXT_EDIT_CATEGORIES_SEO_URL', 'Category SEO URL:'); define('TEXT_CATEGORIES_SEO_URL', 'Category SEO URL:')
Warning: Cannot modify header information - headers already sent by (output started at /home/leather/public_html/catalog/admin/includes/languages/english/categories.php:103) in /home/leather/public_html/catalog/admin/includes/functions/general.php on line 22

 

Please HELP as my site is not working now! I followed all the instructions as described..

 

 

Thank you

 

Tom

Share this post


Link to post
Share on other sites

Hello Tom,

 

I'd re-check your install as it looks like you may have put those defines in the wrong place in the file.

 

Cheers,

Edited by yesudo

Your online success is Paramount.

Share this post


Link to post
Share on other sites

Hi,

 

I have version 2 of this mod installed. My problem is that i have around 600 pages of my site in Google supplemental results. I changed the design of the site about 3 times in last one year. and moved to a new server.. Google supplemental has lot of my old urls....which either dont exist anymore or whose urls have changed.

 

WOuld the latest release of this contribution help redirectt my urls( old urls are also mod rewrite generated)?

 

If I have to manually to do this through htaccess ..how do i do that?

 

How do I redirect 301...index.php to www.sitename.com with this contribution installed?

 

thank you

Share this post


Link to post
Share on other sites

Thank you. Got it.. Stuck on stpe 6:

Run the following sql on your store database:

 

ALTER TABLE `categories_description` ADD `categories_seo_url` VARCHAR( 100 ) NOT NULL ;

ALTER TABLE `products_description` ADD `products_seo_url` VARCHAR( 100 ) NOT NULL ;

 

I know its in phpMyAdmin but cant see to find out how? Or do i just run the catalog.diff file to update?

 

 

Thanks for the quick response.

Share this post


Link to post
Share on other sites

I have no idea why i couldn't get this last update to work when I tried upgrading.

 

Anyway, tested it on a new install and found does work but whenever a category or product SEO URL is added, the image is lost and whenever an image URL is typed the page gets stuck because the 'save' button stops working but the cancel button still does work?

 

Another idea would be to have the obvious... an 'item' SEO URL field where you can add your own URL's for items... this would be better because your standard SEO URL 'matrix.html' would look better like 'matrix-the-movie-keanu-reeves.html'

 

Great work by Emmett and of-course Chemo!

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

1) Anyway, tested it on a new install and found does work but whenever a category or product SEO URL is added, the image is lost and whenever an image URL is typed the page gets stuck because the 'save' button stops working but the cancel button still does work?

 

2) Another idea would be to have the obvious... an 'item' SEO URL field where you can add your own URL's for items... this would be better because your standard SEO URL 'matrix.html' would look better like 'matrix-the-movie-keanu-reeves.html'

 

 

If you pm me your ftp details i'll take a look at 1.

 

Not sure what you mean on 2 ?


Your online success is Paramount.

Share this post


Link to post
Share on other sites
1) Anyway, tested it on a new install and found does work but whenever a category or product SEO URL is added, the image is lost and whenever an image URL is typed the page gets stuck because the 'save' button stops working but the cancel button still does work?

 

2) Another idea would be to have the obvious... an 'item' SEO URL field where you can add your own URL's for items... this would be better because your standard SEO URL 'matrix.html' would look better like 'matrix-the-movie-keanu-reeves.html'

If you pm me your ftp details i'll take a look at 1.

 

Not sure what you mean on 2 ?

What i mean is the SEO URL is dynamically created so if the matrix is selected the url will be something like:

domain.com/catalog/matrix-p-23.html

 

if your modifications for category/procducts were applied to items having their own SEO URL field then the admin could make it even more search engine friendly by making the SEO URL something like: domain.com/catalog/matrix-movie-keanu-reeves.html

 

I'll set up a fresh install of osC for you and message you the FTP details later today - thanks Emmett


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Do you mean concatenating the product name with the admin input seo url ?

 

The modification I added allows the user to put whatever they want, some examples being:

 

domain.com/catalog/matrix-movie-keanu-reeves.html

 

domain.com/catalog/matrix-keanu-reeves.html

 

domain.com/catalog/keanu-reeves-movie.html

 

domain.com/catalog/keanu-reeves-matrix-movie.html

 

domain.com/catalog/keanu-reeves-matrix.html

 

Which is a lot more flexible than concatenating the fields.


Your online success is Paramount.

Share this post


Link to post
Share on other sites

Yup it's official - this contribution is absolute dynamite.... thanks to all those who contributed.

 

I have PM'd you Emmett, thanks.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Can someone PLEASE help me regarding the problem w/ the amp; appearing in the url, which makes it impossible to click on any products because they ALL GET HUNG UP due to the amp in the url. i ve tried EVERY FIX i could find on the internet; uploading the fix on the contribution page does nothing, ive tried anything i could find and not one thing makes the amp; go away, im ready to cry!!! Can anyone help?

thanks!

Jennifer

Share this post


Link to post
Share on other sites
Can someone PLEASE help me regarding the problem w/ the amp; appearing in the url, which makes it impossible to click on any products because they ALL GET HUNG UP due to the amp in the url. i ve tried EVERY FIX i could find on the internet; uploading the fix on the contribution page does nothing, ive tried anything i could find and not one thing makes the amp; go away, im ready to cry!!! Can anyone help?

thanks!

Jennifer

 

Did you try setting the:

 

"Remove all non-alphanumeric characters?" to "true"

 

in your admin - configuration - SEO urls ?

Share this post


Link to post
Share on other sites

No need to cry but in need of trying this:

 

This problem is caused by a php function 'htmlspecialchars', which, among other things, converts '&' into '&'.

 

Open seo.class.php for edit (make a copy first!). Search for (between 700 and 750) the line that contains the following:

 

htmlspecialchars(utf8_encode($return)

 

and replace the whole line with:

 

return str_replace('&', '&', htmlspecialchars(utf8_encode($return))); // give me back the '&'!

 

Good luck!

 

Ken

 

Can someone PLEASE help me regarding the problem w/ the amp; appearing in the url, which makes it impossible to click on any products because they ALL GET HUNG UP due to the amp in the url. i ve tried EVERY FIX i could find on the internet; uploading the fix on the contribution page does nothing, ive tried anything i could find and not one thing makes the amp; go away, im ready to cry!!! Can anyone help?

thanks!

Jennifer


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Just to let everyone know about the fix in relation to the image upload problem. Thanks to Emmett the problem is fixed using the code below:

 

Try adding:

 

$this = null;

 

before line 30 ( which says: return false;) in admin/includes/classes/upload.php.

 

I need to make it clear that Chemo's original contribution (and this update from Emmett) did not cause the image upload problem. In fact the same problem occured on a fresh install of osC with no modifications made whatsoever, however Emmett found a fix.

 

Hope that helps :D


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Hi,

 

I was wondering whether it would be possible to exclude the checkout pages (checkout_*.php) from this SEO urls contribution ?

 

I mean the contribution is really great (my ranking improved a lot) but have problems with a payment module that requires the dynamic pages as it sends a string in the url to the bank.

When using the SEO contribution it doesn't work anymore.

 

So I would like to keep the contribution working for 95% of all my pages, except for the pages used during checkout.

 

Is there any solution or workaround already known or would anybody have any suggestions?

I do hope I'm not asking for something that is impossible ! :)

 

I was thinking if some pages could be harcoded to be excluded or alternatively once you are logged in the SEO contribution is disabled. Your ideas are very welcome!

 

many thanks

Share this post


Link to post
Share on other sites

Ok..I installed the update ( to 2.2.2)...I noticed that old urls get redirected to correct new urls but 301 is not generated when I ran the old url through a header check tool.

 

Is this how the mod is designed to work or is there an error in installtion?

Share this post


Link to post
Share on other sites
Hi,

 

I was wondering whether it would be possible to exclude the checkout pages (checkout_*.php) from this SEO urls contribution ?

 

I mean the contribution is really great (my ranking improved a lot) but have problems with a payment module that requires the dynamic pages as it sends a string in the url to the bank.

When using the SEO contribution it doesn't work anymore.

 

So I would like to keep the contribution working for 95% of all my pages, except for the pages used during checkout.

 

Is there any solution or workaround already known or would anybody have any suggestions?

I do hope I'm not asking for something that is impossible ! :)

 

I was thinking if some pages could be harcoded to be excluded or alternatively once you are logged in the SEO contribution is disabled. Your ideas are very welcome!

 

many thanks

 

SEO urls does not affect the checkout pages URLs: it only affects the pages that are defined in your htaccess file:

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

 

If some strings are added to your URL during teh checkout, they are less likely put by this contrib.

Could you give us an example of what is added?

Share this post


Link to post
Share on other sites

I was wondering if someone could help me out with the rewrite rule:

 

I am having trouble with the subtopics rewriting correctly and can't seem to find the right rule for it.

 

http://www.naturalsupplementwarehouse.com/...php/tPath/16_19

 

There are already rules in the htaccess file that allow for it to rewrite,

 

I added this rule

 

RewriteRule ^(.*)-t-([0-9]+)_([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

 

 

trying to compensate for the 19 but right now what its doing is just

stopping and displaying 16 and basically ignorning the _19

 

Now before i added _19 it gave me a 404 errror.

 

This would be the finished url should someone need it: http://www.naturalsupplementwarehouse.com/...ls-t-16_19.html

 

Thank you for any help anyone might be able to lend.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×