Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

Hi Jack

 

I have installed Ultimate SEO v2.2 and it is fabulous. I'm not a coder/developer so apologies in advance for what might be a stupid question.

I seem to have everything working except when you type in the homepage address www.jomaysgifthampers.com.au I receive an 404 error ... /shop/shop/ page not found on this server

When I changed the .htaccess file I put in to RewriteBase / shop/ because that is where my catalog etc is in the directory, so if you type in www.jomaysgifthampers.com.au/shop everything is fine.

How do I change/fix the link to "Top" [which is www.jomaysgifthampers.com.au" on the homepage]

 

Hope that makes sense

Any help very greatly appreciated

Jo

Edited by onlinegourmetfood

Share this post


Link to post
Share on other sites

My guess is that you changed the .htaccess file in the root directory instead of the one in the shop directory. Since your root directory just points to the shop anyway, or so it seems, I suggest replacing the Top->Catalog pair with Home, which makes more sense to most visitors, I think. There are many posts here on the forum on how to do that.

Share this post


Link to post
Share on other sites

Thanks for your reply Jack ... ok I think that is what I did, however, I do not seem to have a .htaccess file in the "shop" directory. I have the following .htaccess files

 

 

/public_html/.htaccess

/public_html/shop/pub/.htaccess

/public_html/shop/errors/.htaccess

/public_html/shop/includes/.htaccess

/public_html/shop/includes/work/.htaccess

/public_html/shop/images/.htaccess

/public_html/shop/download/.htaccess

/public_html/shop/admin/.htaccess

/public_html/shop/admin/includes/.htaccess

/public_html/shop/admin/images/.htaccess

/public_html/shop/admin/backups/.htaccess

 

does this make sense?

cheers

Jo

Edited by onlinegourmetfood

Share this post


Link to post
Share on other sites

Create a file, name it .htaccess, add the changes required for this addon and upload it to the shop directory. You should remove the changes you made to the root directory.

Share this post


Link to post
Share on other sites

Thanks again Jack

I'm obviously doing something wrong...

 

If I change the .htaccess file in the root directory & it looks like this

RewriteEngine on

RewriteCond %{HTTP_HOST} ^jomaysgifthampers\.com\.au$

RewriteRule (.*) http://www.jomaysgifthampers.com.au/shop/$1 [R=301,L]

RewriteRule ^$ shop [L]

 

 

and the .htaccess file in the shop directory to look like this

 

# Begin Ultimate SEO V2.2d

Options +FollowSymLinks

RewriteEngine on

 

 

 

RewriteCond %{HTTP_HOST} ^jomaysgifthampers\.com\.au$

RewriteRule (.*) http://www.jomaysgifthampers.com.au/shop/$1 [R=301,L]

RewriteRule ^$ shop [L]

 

 

RewriteBase /shop/

 

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}

# End Ultimate SEO V2.2d

 

I get 404 Not Found errors for both the www.jomaysgifthampers.com.au and www.jomaysgifthampers.com.au/shop

 

any ideas?

thank you!

Jo

Share this post


Link to post
Share on other sites

For the root file, remove this line

RewriteRule ^$ shop [L]

For the shop file, remove these lines

RewriteCond %{HTTP_HOST} ^jomaysgifthampers\.com\.au$
RewriteRule (.*) http://www.jomaysgifthampers.com.au/shop/$1 [R=301,L]
RewriteRule ^$ shop [L]

Share this post


Link to post
Share on other sites

Hi

I have succesfully installed this contribution and am working my way through the functionality.

I have tried to read through most of the forum and have gone through all the documentation that has been supplied but had a question:

 

Is there any way to change the format from:

 

www mydomain com/product-pr-100.html to www mydomain com/product.html

 

Not major just wondered if this was standard and if so what purpose does it serve?

 

Cheers

Share this post


Link to post
Share on other sites

No, you can't do that. The pr in your example stands for page review and refers to that page in the shop. The 100 is the ID of the product being reviewed. A url like the one you want won't work in a dynamic shop since it would only point to one specific page. The pr-100 doesn't have any affect on SEO so it is not anything to worry about.

Share this post


Link to post
Share on other sites

No, you can't do that. The pr in your example stands for page review and refers to that page in the shop. The 100 is the ID of the product being reviewed. A url like the one you want won't work in a dynamic shop since it would only point to one specific page. The pr-100 doesn't have any affect on SEO so it is not anything to worry about.

 

That is exaclty what I was looking for. Thanks for responding.

Share this post


Link to post
Share on other sites

Hi Guys

 

I have scrolled through numerous pages and read lots of questions but somehow cannot find an answer to my question. Currently the URL of a product catagory of mine is

http://outdoorgeek.co.za/catalog/camping-tables-c-51.html

but I would like the URL to only look like this

http://outdoorgeek.co.za/catalog/camping-tables

 

And to a specific product it is

http://outdoorgeek.co.za/catalog/oztrail-classic-table-p-112.html?osCsid=72ljj9vsf7pocm1u2t6ac8vbp7

but I would like it to read

http://outdoorgeek.co.za/catalog/oztrail-classic-table-p-112.html

 

Could somebody please tell me how or which settings to change.

 

Thanks

George

Share this post


Link to post
Share on other sites

For the first one, you can't do that. For the second, it is due to an incorrectly setup configure file. See this thread for that.

Share this post


Link to post
Share on other sites

Hi

 

Since installing this add-on [which is great] I've now realised that when you type in our url www.jomaysgifthampers.com.au it lands on a page with

 

Index of /

instead of going to the index page.

what have I done wrong? again thank you for any help

Jo

Share this post


Link to post
Share on other sites

Your shop is located in the shop directory, not the root directory. You either changed the wrong .htaccess file (see above posts) or didn't set it up correctly (see the instructions in the changes for that file).

Share this post


Link to post
Share on other sites

Hi Jack

Thank you for your reply

 

the .htaccess file in the root directory reads ...

 

RewriteEngine on

RewriteCond %{HTTP_HOST} ^jomaysgifthampers\.com\.au$

RewriteRule (.*) http://www.jomaysgifthampers.com.au/shop/$1 [R=301,L]

 

 

the .htaccess file in the shop directory reads...

 

# Begin Ultimate SEO V2.2d

Options +FollowSymLinks

RewriteEngine on

 

 

RewriteBase /shop/

 

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}

# End Ultimate SEO V2.2d

 

???

thanks Jo

Share this post


Link to post
Share on other sites

It because the redirect in the root only considers the url without the url. If you go to jomaysgifthampers.com.au, you will see it works. Try changing this

RewriteCond %{HTTP_HOST} ^jomaysgifthampers\.com\.au$
RewriteRule (.*) http://www.jomaysgifthampers.com.au/shop/$1 [R=301,L]

to this

RewriteCond %{HTTP_HOST} ^jomaysgifthampers\.com\.au$ [OR]
RewriteCond %{HTTP_HOST} ^www\.jomaysgifthampers\.com\.au$
RewriteRule (.*) http://www.jomaysgifthampers.com.au/shop/$1 [R=301,L]

Share this post


Link to post
Share on other sites

hi

 

i am using latest osc.I got no other contrib installed in my site..

 

I am using the Ultimate_SEO_URLSv22d_11.I am getting url in this format -p-291376.html.Web page laods very slow.

 

I have made changes as discribed in instruction.I got an old 2.2 site that works fine with this addon

 

When i try to remove i get an error of cache table is missing.I installed this table via php my admin.But the table never gets populated.

 

IF I remove the table and try again.Same error.I reinstall the table .Go to front end try to load a page.It takes time and then the same error on backend when i try to uninstall it.

 

 

 

With the addon the site loads fast.I dont know what the probelm is.Just cant get this addon to work

 

I am using php 5.3.27 and mysql 5.5.

 

Cant figure out what i am doing wrong,I have been using this addon on other site for a while.I have instaelled and reintalled this addon to make sure i am making right code changes.

 

Any clue whats wrongs..

Share this post


Link to post
Share on other sites

That's not one of my versions so I can't help with it. You're probably on your own as far as getting support for it. But I'm confused as to why you are continually trying to uninstall it. Is there a problem on the shop side? You give a partial url which is not useful for this addon. I suggest you post the correct url and the parts of the .htaccess file that have to do with this addon. You may also want to try replacing the seo.class.php file with the one from my version to see if that makes a difference.

Share this post


Link to post
Share on other sites

That's not one of my versions so I can't help with it. You're probably on your own as far as getting support for it. But I'm confused as to why you are continually trying to uninstall it. Is there a problem on the shop side? You give a partial url which is not useful for this addon. I suggest you post the correct url and the parts of the .htaccess file that have to do with this addon. You may also want to try replacing the seo.class.php file with the one from my version to see if that makes a difference.

 

Hi

 

I copied the name from the uncompresssed folder.it is listed on contrib side as Ultimate SEO 2-2.2d-11.When you incompress it into a folder it shows up as Ultimate_SEO_URLSv22d_11.

 

Full url is in this format... www.sitename.com/-p-291376.html .Category pages are in this format www.sitename.com/-c-13_1551.html

As you can see i am missing the product name/category name from the url.Once i have this contrib installed it takes along time for page to load..If i remove it completely including the code it only takes a second for page to load.i have replaced seo.class.php quitte a few times in case it was damaged vis ftp.

 

I got over 100K products.Do u think it might be becuase of this.My other sites have smaller product range and they work okay..

 

htaccess only has these entries...

 

Options +FollowSymLinks
RewriteEngine On
# RewriteBase instructions
# Change RewriteBase dependent on how your shop is accessed as below.
# http://www.mysite.com = RewriteBase /
# http://www.mysite.com/catalog/ = RewriteBase /catalog/
# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/
# Change the following line using the instructions above

RewriteBase /
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}
# End Ultimate SEO V2.2d

Edited by nafri

Share this post


Link to post
Share on other sites

You didn't provide the url so I can only guess that the .htaccess file is correct. Assuming it is, you can try removing this line

Options +FollowSymLinks

Other than that, I would have to see the code to determine the problem. If you have a very large number of products, you shouldn't use the cache settings in this addon.

Share this post


Link to post
Share on other sites

You didn't provide the url so I can only guess that the .htaccess file is correct. Assuming it is, you can try removing this line

Options +FollowSymLinks

Other than that, I would have to see the code to determine the problem. If you have a very large number of products, you shouldn't use the cache settings in this addon.

 

i sent u pm with site url. i have tried it without

Options +FollowSymLinks

 

one of the other sites is based on 2.2 and has over 100 k and that works fine with this addon..

Edited by nafri

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×