Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

I suggest using the last one by me, Ultimate SEO 2-2.2d-11. Others have used -12 and have had problems.

Share this post


Link to post
Share on other sites

I suggest using the last one by me, Ultimate SEO 2-2.2d-11. Others have used -12 and have had problems.

 

Thank you for your answer.I tried to install today but I've got the following errors:

"Warning: include_once(includes/classes/seo.class.php) [function.include-once]: failed to open stream: No such file or directory in /home/.../public_html/includes/functions/html_output.php on line 20

 

Warning: include_once() [function.include]: Failed opening 'includes/classes/seo.class.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/.../public_html/includes/functions/html_output.php on line 20

 

Fatal error: Class 'SEO_URL' not found in /home/.../public_html/includes/functions/html_output.php on line 23"

 

In html_outptup.php I replaced only the code below, because that I didn't find more there:

////

// The HTML href link wrapper function

function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL') {

$page = tep_output_string($page);

 

if ($page == '') {

die('</td></tr></table></td></tr></table><br /><br /><font color="#ff0000"><strong>Error!</strong></font><br /><br /><strong>Unable to determine the page link!<br /><br />Function used:<br /><br />tep_href_link(\'' . $page . '\', \'' . $parameters . '\', \'' . $connection . '\')</strong>');

}

if ($connection == 'NONSSL') {

$link = HTTP_SERVER . DIR_WS_ADMIN;

} elseif ($connection == 'SSL') {

if (ENABLE_SSL_CATALOG == 'true') {

$link = HTTPS_SERVER . DIR_WS_ADMIN;

} else {

$link = HTTP_SERVER . DIR_WS_ADMIN;

}

} else {

die('</td></tr></table></td></tr></table><br /><br /><font color="#ff0000"><strong>Error!</strong></font><br /><br /><strong>Unable to determine connection method on a link!<br /><br />Known methods: NONSSL SSL<br /><br />Function used:<br /><br />tep_href_link(\'' . $page . '\', \'' . $parameters . '\', \'' . $connection . '\')</strong>');

}

if ($parameters == '') {

$link = $link . $page . '?' . SID;

} else {

$link = $link . $page . '?' . tep_output_string($parameters) . '&' . SID;

}

 

while ( (substr($link, -1) == '&') || (substr($link, -1) == '?') ) $link = substr($link, 0, -1);

 

return $link;

}

 

Can be these the reason of errors?

Thanks in advance

Edited by alexman

Share this post


Link to post
Share on other sites

Try uploading the included files.

 

There were uploaded and I repeat the operations,but the results are the same. I forgot to tell you that the errors appear only when I want to access my admininstration tool.

Edited by alexman

Share this post


Link to post
Share on other sites

Then you've made a mistake in the installation because this addon is for the shop side only.

Share this post


Link to post
Share on other sites

Then you've made a mistake in the installation because this addon is for the shop side only.

I restore backup over what I already have and in administration tool I found added SEO URL but with the information that in general.php is a problem at line 1281. I reinstalled there and SEO work perfectly.It seems is a good way to guide by the error messeges directly in administration tool.

Edited by alexman

Share this post


Link to post
Share on other sites

Noticed this thread now.........

 

 

I'm working on oscommerce 2.3.3

 

and I've got some login issue.

 

I installed this addon (SEO URL).

 

http://addons.oscommerce.com/info/6768

 

But after I enable it through the admin panel. I'm not able to login. In fact any member can't login.

 

If i disable it, customer login works fine.

 

Did anyone encountered any similar issues?


A man is great by Deeds, not by Birth....

Share this post


Link to post
Share on other sites

Its not throwing any error..... only the page refreshes.... Another weird thing is that... this issue is only on server.... I'm able to login in localhost.... :wacko:


A man is great by Deeds, not by Birth....

Share this post


Link to post
Share on other sites

Fixed.......

 

 

Went to admin panel.... Configuration---> Sessions

 

and did these changes...

 

 

 

Session Directory ------------ /tmp

Force Cookie Use -------------False

Check SSL Session ID -------------False (was on True)

Check User Agent -------------False (was on True)

Check IP Address -------------False (was on True)

Prevent Spider Sessions -------------True

Recreate Session -------------False

 

This worked for me......

Edited by yogeshnaik

A man is great by Deeds, not by Birth....

Share this post


Link to post
Share on other sites

 

I installed this addon (SEO URL).

 

http://addons.oscommerce.com/info/6768

 

You're in the wrong support thread. This is for Ultimate SEO, not SEO 5.

Share this post


Link to post
Share on other sites

Hi, please help in URL issue.

I have installed Ultimate SEO URLs

i need slash has a separator in the URL instead of dash, unable to do it please help me.

what should i change and where should i change to get slash has the separator.

 

Present URL:

http://localhost/catalog/catgegory-sub-category-manufacturer-product-p-29.html

 

Required URL:

http://localhost/catalog/catgegory/sub-category/manufacturer/product-p-29.html

 

please help

Thanks in advance

Share this post


Link to post
Share on other sites

The code isn't meant to use a slash. I seem to recall that someone posted how to change it for that so you may want to go back through the thread.

Share this post


Link to post
Share on other sites

I installed this contribution today. It works on my online shop, but I like to edit via a wamp windows server and I keep getting a 500 internal server error. I have figured out that it is the htaccess file causing the problem. When I delete the file, I can access the index page (localhost/essential-oils-catalog/), but none of the product pages. I get a 404 not found page errors with them.

 

I really would like to get this working on the windows server if at all possible. Thank you.

 

Here is my htaccess

 

# $Id$
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# 
# AllowOverride Options
# 
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

#
# 
# SetEnvIf User-Agent ".*MSIE.*" \
# nokeepalive ssl-unclean-shutdown \
# downgrade-1.0 force-response-1.0
# 
#

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter

# AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)

# php_value session.use_trans_sid 0
# php_value register_globals 1

# Begin Ultimate SEO V2.2d
Options +FollowSymLinks
RewriteEngine On

# RewriteBase instructions
# Change RewriteBase dependent on how your shop is accessed as below.
# http://www.mysite.com = RewriteBase /
# http://www.mysite.com/catalog/ = RewriteBase /catalog/
# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

# Change the following line using the instructions above

RewriteBase /essential-oils-catalog/

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}
# End Ultimate SEO V2.2d


Diana

Share this post


Link to post
Share on other sites

Is your Windows box running the Apache web server? IIS does not support .htaccess files.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I don't know... I had the htaccess file there before the contribution and everything worked fine, but when I added the seo code it quit.

 

What I'm running is wamp installed on my Windows 7 laptop. I just checked... Apache 2.4.2 is being used. Is there a specific module that needs to be on?


Diana

Share this post


Link to post
Share on other sites

I've been playing around with various settings and found that a dll file needed to be replaced. I am now able to access some pages and the admin with the htacess in place; however, I am still getting a 404 errors for category, product, and information pages. Frustrating.


Diana

Share this post


Link to post
Share on other sites

Be sure that you have mod rewrite enabled in the settings for wamp. You can look at the server info in admin->tools to see if it is on. You may also need to comment out this line

Options +FollowSymLinks

And if your shop is in a sub-directory, then you have to change the rewrite path to use it.

Share this post


Link to post
Share on other sites

Wow, there is a lot of information listed there!

 

Here are the enabled Apache mods (rewrite is near the bottom):

 

core mod_win32

mpm_winnt

http_core

mod_so

mod_access_compat

mod_actions

mod_alias

mod_allowmethods

mod_asis

mod_auth_basic

mod_authn_core

mod_authn_file

mod_authz_core

mod_authz_groupfile

mod_authz_host

mod_authz_user

mod_autoindex

mod_cgi

mod_dir

mod_env

mod_include

mod_isapi

mod_log_config

mod_mime

mod_negotiation

mod_rewrite

mod_setenvif

mod_php5

 

Is there another mod that should be enabled? I started to enable them all, but got an error message stating that it wouldn't work with the wamp server.

 

When using the wamp server, I visit my store by pointing the browser to (this takes me to the front/index page): localhost/essential-oils-catalog/

 

So, in the htacess I have: RewriteBase /essential-oils-catalog/

 

When I comment out the line you suggested (# Options +FollowSymLinks), I still get 404 errors for categories, products, and information pages.

Edited by dhooper

Diana

Share this post


Link to post
Share on other sites

It sounds like everything is setup correctly. To ensure mod rewrite is working, try this:

 

- Create a sub directory in the shop. The name doesn't matter but I'll use abc

- Create an .htaccess file with the following in it and place it in the new directory

Options +FollowSymLinks
RewriteEngine On

 

Now visit that location localhost/essential-oils-catalog/abc

 

If you don't get any errors,mod rewrite is working.

If you do get an error, like an Internal Server Error, then mod rewrite is not workng correctly.

 

If it is working, then the problem is in your code or wamp setup. You said this was working on the live shop but I would still double check the files to be sure they are the same. Also turn off all settings in the SEO settings except for the enable one to be sure one of those isn't causing a problem. I'm assuming, of course, that if you turn off the enable setting the url's will work but you should test those too.

Share this post


Link to post
Share on other sites

I disabled all of the seo settings and now I can see my pages. The urls do not work, but at least I can see my edits. I'll just have to be sure to double check all of my links when I move it online, but this will work for now. Thanks! :)


Diana

Share this post


Link to post
Share on other sites

There isn't anything in the code to prevent it from working with 5.4, as far as I know. I suggest looking at the obvious: that mode rewrite is enabled and that the .htaccess file matches the directory it is in.

Share this post


Link to post
Share on other sites

Thanks. That is kind of what I expected. Already went there. rewrite engine is working, .htaccess looks okay, I had backed out URLS5, probably missed something. I think I will scrap that and just work on a copy already running on PHP 5.3.x with register-everything turned off.

 

 

George


GEOTEX from Houston, TX

 

(George)

Share this post


Link to post
Share on other sites

Thanks to all of you for your posts, support and for this excellent contribution thread.

I have installed the Ultimate SEO URLs (2.2) contribution and the iOSC contribution on my dev site (OSC2.3.3). Everything seems to work except on the mobile side I keep getting an error of too many redirects when I go to view my product on my not-so-smartphone. Is there something I am missing?

Thanks in advance!

Edited by videod

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×