Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

Hi.

V2.2d version already installed and I check my files multiple times.

This is my .htaccess

But now whenI click onany product,it returns the index.

http://medirsei.co/

[

That's a different problem than previously stated. Look back on this page or the previous one to see the same problem and the link I posted for the fix.

Share this post


Link to post
Share on other sites

 

Could you give me the direct link download?

 

 

I'm sorry, but I Get stuck. I've tried everything, but does not work...

Please help.

Edited by CORENERED

Share this post


Link to post
Share on other sites

Ready...

 

I had to look very carefully in the header.php, and edit line by line, until I found the problem.

 

Thanks.

Share this post


Link to post
Share on other sites

Hello!

First of all thanks for this contrib!

I'm having 404 error sad.png please, someone can help me out?

This is my .htaccess:

# Begin Ultimate SEO V2.2d
Options +FollowSymLinks
RewriteEngine On
 # RewriteBase instructions
 # Change RewriteBase dependent on how your shop is accessed as below.
 # http://www.mysite.com = RewriteBase /
 # http://www.mysite.com/catalog/ = RewriteBase /catalog/
 # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/
 # Change the following line using the instructions above

RewriteBase /
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}
# End Ultimate SEO V2.2d

 

and this is my configure file (only without db access data):

 define('HTTP_SERVER', 'http://testsite01.hopto.org');
 define('HTTP_CATALOG_SERVER', 'http://testsite01.hopto.org');
 define('HTTPS_CATALOG_SERVER', 'http://testsite01.hopto.org');
 define('ENABLE_SSL_CATALOG', 'false');
 define('DIR_FS_DOCUMENT_ROOT', '/var/www/html/oscommerce-3/catalog/');
 define('DIR_WS_ADMIN', '/admin/');
 define('DIR_FS_ADMIN', '/var/www/html/oscommerce-3/catalog/admin/');
 define('DIR_WS_CATALOG', '/');
 define('DIR_FS_CATALOG', '/var/www/html/oscommerce-3/catalog/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

maybe there is something wrong in the configure file but I can't solve it.

I placed the .htaccess in the catalog folder...

 

hope someone can help me, thanks!

Edited by franz85e

Share this post


Link to post
Share on other sites

Hello!

First of all thanks for this contrib!

I'm having 404 error sad.png please, someone can help me out?

This is my .htaccess:

# Begin Ultimate SEO V2.2d

Options +FollowSymLinks

RewriteEngine On

# RewriteBase instructions

# Change RewriteBase dependent on how your shop is accessed as below.

# http://www.mysite.com = RewriteBase /

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

Per the instructions.

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

your .htaccess file is incorrect.

Share this post


Link to post
Share on other sites

when I downloaded the file the only thing I got was a readme.txt nothing else is there something wrong with the link??

 

I have os commerce 2.3.2 so idk if I can use the other ultimate seo.

 

Any help is appreciated

 

Thanks

Share this post


Link to post
Share on other sites

when I downloaded the file the only thing I got was a readme.txt nothing else is there something wrong with the link??

 

I have os commerce 2.3.2 so idk if I can use the other ultimate seo.

 

Any help is appreciated

 

Thanks

I only upload full packages so you must be downloading some other version, which I can't help you with. Try download my last version and you shouldn't have a problem.

Share this post


Link to post
Share on other sites

I only upload full packages so you must be downloading some other version, which I can't help you with. Try download my last version and you shouldn't have a problem.

 

 

Could you send me a link to your latest version?

 

thanks

Share this post


Link to post
Share on other sites

Hello, somebody can help me? I have installed the Ultimate_SEO_URLSv22d_11, I have oscommerce version 2.3

 

but my web do not load, it show me the next error:

 

Internal Server Error

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@storecomercial.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

 

 

This is my .htaccess

 

# Begin Ultimate SEO V2.2d
Options +FollowSymLinks
RewriteEngine On
 # RewriteBase instructions
 # Change RewriteBase dependent on how your shop is accessed as below.
 # http://www.mysite.com = RewriteBase /
 # http://www.mysite.com/catalog/ = RewriteBase /catalog/ 
 # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/
 # Change the following line using the instructions above 

RewriteBase /YOU HAVE TO CHANGE ME/
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}
# End Ultimate SEO V2.2d

 

thank you.

Share this post


Link to post
Share on other sites

This is my .htaccess

 

# Begin Ultimate SEO V2.2d

Options +FollowSymLinks

RewriteEngine On

# RewriteBase instructions

# Change RewriteBase dependent on how your shop is accessed as below.

# http://www.mysite.com = RewriteBase /

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

# Change the following line using the instructions above

 

RewriteBase /YOU HAVE TO CHANGE ME/

These lines in that file may give you an idea of where to look

 # Change the following line using the instructions above

RewriteBase /YOU HAVE TO CHANGE ME/

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

These lines in that file may give you an idea of where to look

 # Change the following line using the instructions above

RewriteBase /YOU HAVE TO CHANGE ME/

 

Jack_msc, thank you for your help, jejeje it works.

Share this post


Link to post
Share on other sites

Hello,

 

First of all: THANKS for the contribution!!!

I used it on other webshops and it always worked Good.

 

Now I'm making a new webshop.

 

I use osc 2.2 rc2

and ultimate seo 2.2d

 

Installed every thing and it seems to work everywhere

 

BUT

 

When i come for the first time on the webshop, and i make the first click on a product detail

 

I get redirected to

 

mydomain.com/product_info.php?products_id=42?osCsid=f8158909efc0d971649117c00f250838

 

following with a 404 error,

 

instead of a nice .html page

 

When i click back and select the same product it rewrites fine, and every page after that also.

 

When i go to:

mydomain.com/product_info.php?products_id=42

 

i works and i get a nice redirect to a .html page

 

Its only the first click

 

Does somebody know how to resolve this problem?

 

Thanks in advanced,

 

Gijs

Share this post


Link to post
Share on other sites

Its only the first click

 

Does somebody know how to resolve this problem?

If it's only on products from the home page, then there is probably something wrong with how the links are coded (a common problem with purchased templates). If it fails on categories too, then it is probably your confiugre file at fault, though that could be your code too.

Share this post


Link to post
Share on other sites

If it's only on products from the home page, then there is probably something wrong with how the links are coded (a common problem with purchased templates). If it fails on categories too, then it is probably your confiugre file at fault, though that could be your code too.

 

I think its not in the code.. not sure.

When i turn ultimate seo off->

the product link on the home page stays the same, but will direct me to the correct product, instead of giving me a 404 error.

 

so still generate the link:

mydomain.com/product_info.php?products_id=42?osCsid=f8158909efc0d971649117c00f250838

Share this post


Link to post
Share on other sites

OK, found the problem, or better i don'n get the error anymore.

 

In the admin section i had to set the option:

Enable automatic redirects? to "false"

 

Now i only remain with the question: why and what does this setting has to do for me?

Share this post


Link to post
Share on other sites

Ok back to problem 1

 

Turning off the automatic redirects doesnt work for me. no errors but also no nice url's, perhaps it is a broken code but dont know how to fix this'.

Share this post


Link to post
Share on other sites

I'm trying the su_autoinstaller and it won't work.

 

when I hit the install button it give me this error

 

"Cannot read file 'includes/boxes/currencies.php' . Try to change file permissions and click the "Retry" button. "

 

I look in my files and I don't even see that file there to set the permissions for?

 

What did I do wrong?

 

Thank you

 

Adamanto75

Share this post


Link to post
Share on other sites

I'm trying the su_autoinstaller and it won't work.

I don't what the su_autoinstaller is but it doesn't have anything to do with this contribution so it seems you've posted in the wrong thread.

Share this post


Link to post
Share on other sites

Hello there. Thank you for ur contribution.

I have one huge problem after installing it to my osCommerce.

I can not add or edit product in admin panel. The same with categories.

Please help me here.

I have osCommerce Online Merchant v2.3.1.

 

It doesn't give me any error messages. No errors in error log file..

Here what I do:

1. I ho to admin/categories.php

2. for example I want to add new category... so I press new category: admin/categories.php?cPath=&action=new_category

3. page loads up: categories.php?cPath=&action=new_categor, but nothing.. I mean.. I am on the same page...

the same with products... or if I want to edit product

 

Please some help there... all this happened after I installed contribution. :'(

Edited by dasani

Share this post


Link to post
Share on other sites

Ok....

I figure it out.. I acedently deleted line in admin/categories.php:

 $action = (isset($HTTP_GET_VARS['action']) ? $HTTP_GET_VARS['action'] : '');

paste it back and it is working fine now!!!

Share this post


Link to post
Share on other sites

having issues with getting all my links to rewrite.

could i get some assistance?

 

i have it partially working on my main live site, but the catagories are not rewriting: https://www.irepairworks.com/products.php?cPath=25_29

 

products are working : https://www.irepairworks.com/iphone-3gs-diagnostic-service-p-94.html

 

here is following .httaccess:

 

 

--------------------------------------------------

 

Options +FollowSymLinks

 

<IfModule mod_rewrite.c>

 

 

 

RewriteEngine on

 

 

 

RewriteCond %{HTTP_HOST} ^irepairworks\.com [NC]

 

RewriteRule ^(.*)$ http://www.irepairworks.com/$1 [R=301,L]

 

 

 

RewriteCond %{HTTPS} off

 

RewriteRule ^(.*)$ https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]

 

 

 

 

 

# RewriteBase instructions

 

# Change RewriteBase dependent on how your shop is accessed as below.

 

# http://www.mysite.com = RewriteBase /

 

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

 

# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

 

 

 

# Change RewriteBase using the instructions above

 

RewriteBase /

 

RewriteRule ^([a-z0-9/-]+)-p-([0-9]+).html$ product_info.php [NC,L,QSA]

 

RewriteRule ^iPhone-3g-Repair\.html$ /products.php?cPath=25_28 [L]

RewriteRule ^([a-z0-9/-]+)-c-([0-9_]+).html$ index.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-m-([0-9]+).html$ index.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-pi-([0-9]+).html$ popup_image.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-pr-([0-9]+).html$ product_reviews.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-pri-([0-9]+).html$ product_reviews_info.php [NC,L,QSA]

 

# Articles contribution

 

RewriteRule ^([a-z0-9/-]+)-t-([0-9_]+).html$ articles.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-au-([0-9]+).html$ articles.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-a-([0-9]+).html$ article_info.php [NC,L,QSA]

 

# Information pages

 

RewriteRule ^([a-z0-9/-]+)-i-([0-9]+).html$ information.php [NC,L,QSA]

 

# Links contribution

 

RewriteRule ^([a-z0-9/-]+)-links-([0-9_]+).html$ links.php [NC,L,QSA]

 

# Newsdesk contribution

 

RewriteRule ^([a-z0-9/-]+)-n-([0-9]+).html$ newsdesk_info.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-nc-([0-9]+).html$ newsdesk_index.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-nri-([0-9]+).html$ newsdesk_reviews_info.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-nra-([0-9]+).html$ newsdesk_reviews_article.php [NC,L,QSA]

 

</IfModule>

 

Share this post


Link to post
Share on other sites

 

having issues with getting all my links to rewrite.

could i get some assistance?

 

i have it partially working on my main live site, but the catagories are not rewriting: https://www.irepairworks.com/products.php?cPath=25_29

That's not a valid url, or, at least, not one this contribution can understand. You'll need to change it so it uses the standard oscommerce format and then it should redirect correctly.

Share this post


Link to post
Share on other sites

hi

when im running the osc from a localhost how do i change my htaccess file

i have changed like this

RewriteBase http://localhost/osc/ = RewriteBase /osc/

 

but i'm getting server error , anyone got any idea ?

RewriteBase /osc/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×