Latest News: (loading..)
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

7,334 posts in this topic

I have a question when editing .htaccess file. Do I replace all the code with the code in the install instructions or add. It looks to me like replace but the instructions are not clear on this. There is more above this dealing with SSL.

Thank you in advance.

 

Existing Code:

 

 

RewriteEngine On

RewriteCond %{HTTPS} off

RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

 

<Files ~ "\.inc$">

Order allow,deny

Deny from all

</Files>

<Files ~ "\.inf$">

Order allow,deny

Deny from all

</Files>

<Files ~ "\.ini$">

Order allow,deny

Deny from all

</Files>

<Files ~ "\.hta$">

Order allow,deny

Deny from all

</Files>

Edited by Papadish

Share this post


Link to post
Share on other sites

I have a question when editing .htaccess file. Do I replace all the code with the code in the install instructions or add. It looks to me like replace but the instructions are not clear on this. There is more above this dealing with SSL.

Hmm, interesting. No one's ever mentioned that oversight before and I've never noticed it. You are correct, the instructions are not clear for that part. You can generally place that code anywhere in the .htaccess file but if you already have the RewriteEngine On statement, you don't need another. You can copy from the line RewriteBase /YOU HAVE TO CHANGE ME/ to the bottom in the instructions and place that at the bottom of your .htaccess file and you should be all set (be sure to change it as directed though).

Share this post


Link to post
Share on other sites

Hmm, interesting. No one's ever mentioned that oversight before and I've never noticed it. You are correct, the instructions are not clear for that part. You can generally place that code anywhere in the .htaccess file but if you already have the RewriteEngine On statement, you don't need another. You can copy from the line RewriteBase /YOU HAVE TO CHANGE ME/ to the bottom in the instructions and place that at the bottom of your .htaccess file and you should be all set (be sure to change it as directed though).

Thank you for such a rapid response. I am working with this on a dedicated testing server with the site under /catalog/. The live site is in the root, so I will have to change the Rewritebase again when it goes to the live site. Do you reccomend this approach? I have backed up the backups.

Share this post


Link to post
Share on other sites

Thank you for such a rapid response. I am working with this on a dedicated testing server with the site under /catalog/. The live site is in the root, so I will have to change the Rewritebase again when it goes to the live site. Do you reccomend this approach? I have backed up the backups.

Yes, that's fine.

Share this post


Link to post
Share on other sites

I installed this contribution on my osc 2.3.1. Everything is good, all the links are good, only 1 thing dont want to work.

ENLARGE PRODUCT IMAGE. Its not working if U-seo is active.

This product image enlarge dont work if i turn on in the admin the search-engine safe URLs. If i turn it off, images are good, but i dont have SEO URLs then.

 

Somebody knows what should i do?

 

Please help me!

Share this post


Link to post
Share on other sites

I installed this contribution on my osc 2.3.1. Everything is good, all the links are good, only 1 thing dont want to work.

ENLARGE PRODUCT IMAGE. Its not working if U-seo is active.

This product image enlarge dont work if i turn on in the admin the search-engine safe URLs. If i turn it off, images are good, but i dont have SEO URLs then.

 

Somebody knows what should i do?

 

Please help me!

Search Engine safe url's won't work with this contribution. The code in it will just turn that option off. As for the enalrge not working, it all other links in your shop work correctly, then there is something wrong with the code for that popup since this contribuiton doesn't affect it directly.

Share this post


Link to post
Share on other sites

Search engine safe urls are turned off. And when i turn them off, the enlarge image works correctly. When i turn it on, dont works. I said this problem because with the ultimate seo the problem is the same. The search engine safe urls are off, and ultimate seo is installed, and image enlarge dont work. What could be the problem? It is a 2.3.1 version, not 2.2.

Share this post


Link to post
Share on other sites

Search engine safe urls are turned off. And when i turn them off, the enlarge image works correctly. When i turn it on, dont works. I said this problem because with the ultimate seo the problem is the same. The search engine safe urls are off, and ultimate seo is installed, and image enlarge dont work. What could be the problem? It is a 2.3.1 version, not 2.2.

Something is wrong with your code. As mentioned, this contribuiton doesn't distinguish between parts of the shop.

Share this post


Link to post
Share on other sites

Hello,

 

in order to be able to index my site separately for each language, I wonder if the Ultimate SEO Url contribution might be modified to allow the ?language=xx parameter to be included in the url to obtain a virtual language directory....I mean - for example for the product id=16 - something like:

 

www.example.com/it/italian-product-name-p-16.html

www.example.com/en/english-product-name-p-16.html

etc....

 

Has anyone faced this problem before ?

 

Thanks in advance for any help or suggestion.

Share this post


Link to post
Share on other sites

Hello,

 

in order to be able to index my site separately for each language, I wonder if the Ultimate SEO Url contribution might be modified to allow the ?language=xx parameter to be included in the url to obtain a virtual language directory....I mean - for example for the product id=16 - something like:

 

www.example.com/it/italian-product-name-p-16.html

www.example.com/en/english-product-name-p-16.html

etc....

 

Has anyone faced this problem before ?

 

Thanks in advance for any help or suggestion.

That wouldn't work, assuming you are using one of the canonical contributions, which you should be, since they look for the language at the end of the url. The language is already included in the url anyway so such a change shouldn't be necessary.

Share this post


Link to post
Share on other sites

That wouldn't work, assuming you are using one of the canonical contributions, which you should be, since they look for the language at the end of the url. The language is already included in the url anyway so such a change shouldn't be necessary.

 

Hello Jack,

 

thanks for your reply. I'm not sure if I properly understood your answer.

I'm already using the Ultimate SEO URL's 2.2d11.

In my post previous post I meant that to have "language urls" like those I posted (for example with a virtual directory www.example.com/it/.. , /en/.., /de/.. etc would be very useful to effectively index the site in different countries and languages.

If the contribution allowed this possibility one would be able to set a different virtual site for each language in Google Webmaster tools (see for example: http://www.google.com/support/webmasters/bin/answer.py?answer=182192 ).

 

Kind rgds.

Share this post


Link to post
Share on other sites

 

 

Hello Jack,

 

thanks for your reply. I'm not sure if I properly understood your answer.

I'm already using the Ultimate SEO URL's 2.2d11.

In my post previous post I meant that to have "language urls" like those I posted (for example with a virtual directory www.example.com/it/.. , /en/.., /de/.. etc would be very useful to effectively index the site in different countries and languages.

If the contribution allowed this possibility one would be able to set a different virtual site for each language in Google Webmaster tools (see for example: http://www.google.com/support/webmasters/bin/answer.py?answer=182192 ).

This contribution won't allow that. You can try using SEO 5. I think it allows that. Of course, you will have to deal with its incompatibility issues.

Share this post


Link to post
Share on other sites

This contribution won't allow that. You can try using SEO 5. I think it allows that. Of course, you will have to deal with its incompatibility issues.

 

Thanks Jack. I had a look to other contributions and found out that Ultimate SEO Urls 5 PRO offers exactly what I need: it is called multi language functionality. There's also an upgrade path from Ultimate SEU Urls 2 contributions to SEO 5 PRO.

 

I'll try in my test site this kind of upgrade, because even the assistance forum of google confirmed that to be effectively indexed in different countries it's necessary to separate language sections of the site.

 

A last question: what do you mean with "incompatibility issues" ?

Share this post


Link to post
Share on other sites

A last question: what do you mean with "incompatibility issues" ?

It has a number of problems with various addons, or at least it did last time I looked at it. Maybe they have all been address now.

Share this post


Link to post
Share on other sites

Hi,

ive installed this contribution and it works perfectly as i wanted..

there is one problem thou...

 

my homepage is a custom url.. and when i enable the mod, it says 404 error for the homepage.

 

url: http://breatheapparel.com

 

ive disabled the mod for now.. please if someone can provide a solution for such url or a way to exclude this specific url to rewrite?

thanks

Share this post


Link to post
Share on other sites

Hi, there was a separate thread about "Fatal error: allowed memory size .... seo.class.php....." I thought I'd post my experience with this here. First post included below:

 

"Hi guys, I run a successful website on osCommerce and we're moving over to a new server. Copied all the files and database across. I've done all the configuration changes I think I need but I am stuck with one error I cannot fathom that's stopping me running any page.

 

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 31457280 bytes) in /home/jandb/public_html/includes/classes/seo.class.php(1657) : eval()'d code on line 21846

 

If I use the PHP command to up the memory limit it just does the same exhausting what I increase it to.

 

I don't understand the line 21846 either since it doesn't even have that many lines.

 

Anyone help please?"

 

 

----------

 

I had same issue after moving client website to new server. There are 20,000 producst in this shop. I did end up re-installing SEO v2.2d, as verson I had was a slightly earlier version. However I stiil ended up with same error. Resetting SEO Url Cache would allow me see the homepage etc, but I would get an error if I tried any links.

 

Then in admin, I turned off (made false) all the settings for caching, and website now works. However, I do think that this could have an effect on website speed,

but at least am not receiving errors for the moment. I will play around with this some more, and post any other updates.

Share this post


Link to post
Share on other sites

my homepage is a custom url.. and when i enable the mod, it says 404 error for the homepage.

 

url: http://breatheapparel.com

 

ive disabled the mod for now.. please if someone can provide a solution for such url or a way to exclude this specific url to rewrite?

thanks

You've got the home page going directly to a category page. My guess is that you didn't code that url using the link function in oscommerce. The rewrite will only work correctly if that function is used. See other links in your shop, like in includes/modules/product_listing.php, to see how to code it correctly.

Share this post


Link to post
Share on other sites

You've got the home page going directly to a category page. My guess is that you didn't code that url using the link function in oscommerce. The rewrite will only work correctly if that function is used. See other links in your shop, like in includes/modules/product_listing.php, to see how to code it correctly.

 

Hi,

im not that good with php so im not sure where to look at for that change to make. can you please guide me on how to fix it? sad.png

ive attached my index.html and index.php so you know what exactly is happening here

index.html

index.php

Share this post


Link to post
Share on other sites

You've got the home page going directly to a category page. My guess is that you didn't code that url using the link function in oscommerce. The rewrite will only work correctly if that function is used. See other links in your shop, like in includes/modules/product_listing.php, to see how to code it correctly.

 

Hi,

im not that good with php so im not sure where to look at for that change to make. can you please guide me on how to fix it? sad.png

ive attached my index.html and index.php so you know what exactly is happening here

index.php

index.html

Share this post


Link to post
Share on other sites

Hi, there was a separate thread about "Fatal error: allowed memory size .... seo.class.php....." I thought I'd post my experience with this here. First post included below:

 

 

 

 

----------

 

I had same issue after moving client website to new server. There are 20,000 producst in this shop. I did end up re-installing SEO v2.2d, as verson I had was a slightly earlier version. However I stiil ended up with same error. Resetting SEO Url Cache would allow me see the homepage etc, but I would get an error if I tried any links.

 

Then in admin, I turned off (made false) all the settings for caching, and website now works. However, I do think that this could have an effect on website speed,

but at least am not receiving errors for the moment. I will play around with this some more, and post any other updates.

 

Upping the PHP memory limit from 32 to 64MB enabled me to turn cache back on!

Share this post


Link to post
Share on other sites

 

Hi,

im not that good with php so im not sure where to look at for that change to make. can you please guide me on how to fix it? sad.png

ive attached my index.html and index.php so you know what exactly is happening here

 

hi.. any update??? :( im still waiting for the fix :(

Share this post


Link to post
Share on other sites

 

hi.. any update??? sad.png im still waiting for the fix sad.png

This is a forum where help is provided freely and at the whim of the person supplying it. If you need something fixed on your shop and can't find an answer here, then you either need to fix it yourself or pay someone to fix it for you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now