Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

Thanks for your reply

 

Sorry, I mean the root of the shop:

/home/usr/public_html/shop/includes/classes/seo.class.php

 

 

I'm using PHP 5.2.17. It's still working at all (product page, category page, etc... in rewritten url) exclude the homepage sad.png

If the file is there and teh code is saying it isn't, then there is either something wrong in your configure files or with the server. For the latter, you will need to ask your host to look at it.

Share this post


Link to post
Share on other sites

Question, is this thread in any way associated with ultimate seo url 5 pro? I upgraded to this and now am having a huge issue, one I am sure can be fixed fairly simply with the right touch.. can you help?

Share this post


Link to post
Share on other sites

Ultimate Seo Urls 2.1d STABLE FINAL r172 FWR Media 12 Jan 2010 16x16_report.png

Minor changes only to this stable version.

Upgrading just overwrite the seo.class.php

When setting cron jobs with this (google base etc) ensure to use wget.

"If you have PHP5 I would recommend Ultimate Seo Urls 5 instead."

http://addons.oscommerce.com/info/6768

Unless you specifically require header tags code then this is the version I would recommend if you have to stay with series 2.

Share this post


Link to post
Share on other sites

This is why I upgraded and now no support?

Oh my - that's terrible - and you had to wait a whole 10 minutes for an answer! You may want to file a complaint with the team members.

 

In answer to your question though, this contribution is totally different than the others you mentioned. You need to decide on which you want to use and totally remove the other one to avoid conflicts.

Share this post


Link to post
Share on other sites

I cannot get a hold of anyone that coded it, and it looks like there thread has been ignored for weeks if not months.. can you try to help or you know nothing about how this fella built this? I will pay for this expertise I just need it resolved timely.

Share this post


Link to post
Share on other sites

10 min, I have been trying for 3 days. thanks,

Not according to the time on your posts. Besides, support is not guaranteed, for any contribution.

Share this post


Link to post
Share on other sites

I would suggest taking that comment from your contrib, it could cause some issues later.

What comment would that be?

Share this post


Link to post
Share on other sites

I cannot get a hold of anyone that coded it, and it looks like there thread has been ignored for weeks if not months.. can you try to help or you know nothing about how this fella built this? I will pay for this expertise I just need it resolved timely.

Did you bother to compare the signature on the contribution with mine? If you do take the time to do that, you would see they are the same.

Share this post


Link to post
Share on other sites

Sorry, and thank you for getting back to me, even thought I ave been a pain in the keester..

Would you or have you found my issue on the other board?

And yes that is why I came to this board? It seems to be the same person. And that is you?

 

Can you explain why the osc sites that are using this or similar contributions are experiencing this?

 

when you change the url of a deeper directory, it keeps you on the same page

IE: www.site.com/category-category2-category3-c-01_02_03.html

changed to:

www.site.com/category-category2-category3-c-32563452345234372401_2346523623713713702_03.html

 

Same page?? a few minor things change, but for the most part it is indexing as multiple pages?

 

Can you shed some light.

Share this post


Link to post
Share on other sites

Sorry, and thank you for getting back to me, even thought I ave been a pain in the keester..

Would you or have you found my issue on the other board?

This is the support thread for Ultimate SEO. And, specifically, I only offer support for V2.2d. If you are using any other version of Ultimate SEO and it is one of the versions for this contribution, it is doubtfull you will get support for it. If you are using one of the SEO 5 contribuitons, they have their own support thread. I don't look at those threads since I don't offer support for them. So, as already mentioned, you need to decide which contribution you are going to use and ask in the appropriate place.

Share this post


Link to post
Share on other sites

Hi everyone!

 

I successfully installed the contrib, and by successfully, I mean that the store still works with no errors! However, the urls are still in the old product id = 34 form. I wonder what I've done? Thanks for reading, and I look forward to your help! :]

 

-Jennifer J., The*BroomCloset

Share this post


Link to post
Share on other sites

Hi everyone!

 

I successfully installed the contrib, and by successfully, I mean that the store still works with no errors! However, the urls are still in the old product id = 34 form. I wonder what I've done? Thanks for reading, and I look forward to your help! :]

 

-Jennifer J., The*BroomCloset

It could be that your urls are coded incorrectly. Please post the url to your shop and your .htaccess file and I will take a look to see if it is anything obvious.

Share this post


Link to post
Share on other sites

It could be that your urls are coded incorrectly. Please post the url to your shop and your .htaccess file and I will take a look to see if it is anything obvious.

 

Wonderful! Thanks :]

 

http://www.the-broomcloset.com/

 

DirectoryIndex /catalog/index.php

# Begin Ultimate SEO V2.2d
Options +FollowSymLinks
RewriteEngine On
 # RewriteBase instructions
 # Change RewriteBase dependent on how your shop is accessed as below.
 # http://www.mysite.com = RewriteBase /
 # http://www.mysite.com/catalog/ = RewriteBase /catalog/
 # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/
 # Change the following line using the instructions above

RewriteBase /catalog/
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}
# End Ultimate SEO V2.2d

Edited by JenniferJordan

Share this post


Link to post
Share on other sites

 

Wonderful! Thanks :]

 

The .htacces is correct and the rewriter is working, though not correctly, since it will load a page if you go to a url likehttp://www.the-broomcloset.com/catalog/sds-c-65.html. Normally, links will fail if the contribution is installed but something is setup incorrectly so it seems that the links in your shop are coded incorrectly. That seems unlikely, though, because the category box looks like a standard one and so it would be coded correctly. Are you sure you made the .htaccess changes to the one in catalog and not the root of your shop?

Share this post


Link to post
Share on other sites

The .htacces is correct and the rewriter is working, though not correctly, since it will load a page if you go to a url likehttp://www.the-broom...g/sds-c-65.html. Normally, links will fail if the contribution is installed but something is setup incorrectly so it seems that the links in your shop are coded incorrectly. That seems unlikely, though, because the category box looks like a standard one and so it would be coded correctly. Are you sure you made the .htaccess changes to the one in catalog and not the root of your shop?

 

Okay! I DID have it in my root .htaccess, but I've just moved it to the one in my catalog, and still the links are the same. Hmm, now what should I try? Thanks for your help so far! :]

 

OH! Could it have something to do with having Header Tags SEO installed?

Edited by JenniferJordan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×