Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

This contribution doesn't make any changes to the checkout pages so it is only reacting to something in your shop. My guess is that the return url is incorrect for your payment module. You might want to check in its support thread or its documentation.

Share this post


Link to post
Share on other sites

I realize I'm lax sometimes using correct tep functions, you are correct, but that really wasn't the question.

Let me try to clarify the question please,

 

As part of a server move I've changed from seoClass Chemos 2.1original to 2.2d_11. Everything is working great and fantastic with one minor tweak I would like to sort. There is nothing broken, and this just might not be possible with the newer version IPU (in the way it builds the link) or newer seoclass (in the way it processes).

 

For example, on the old server/seoclass, within Admin, when creating a new Information Page, I'd put this in the Title line:

 

  <img src="/images/icons/video_sm.gif" border="0" /> How To: Video 

 

Which not technically tep_ correct, worked fine (see example here)

Both the icon and link worked fine for my purposes, the OLD seoclass ignored what was between < and >, the visual on the page worked, and the http link showed perfectly as

  http://www.example.com/how-to-video-i-1.html  

 

With the new server/seoclass, if I do the same, it works visually on the page and the navbar, but the http link shows as

  http://www.example.com/img-srcimagesiconsvideosmgif-border0-how-to-video-i-1.html  

 

The problem being the seo class (or IPU??) allowing the text between < and > into the url... "img-srcimagesiconsvideosmgif-border0"

 

Any suggestions appreciated


-Dave

Share this post


Link to post
Share on other sites

As part of a server move I've changed from seoClass Chemos 2.1original to 2.2d_11. Everything is working great and fantastic with one minor tweak I would like to sort. There is nothing broken, and this just might not be possible with the newer version IPU (in the way it builds the link) or newer seoclass (in the way it processes).

 

For example, on the old server/seoclass, within Admin, when creating a new Information Page, I'd put this in the Title line:

 

  <img src="/images/icons/video_sm.gif" border="0" /> How To: Video 

 

Which not technically tep_ correct, worked fine (see example here)

Both the icon and link worked fine for my purposes, the OLD seoclass ignored what was between < and >, the visual on the page worked, and the http link showed perfectly as

  http://www.example.com/how-to-video-i-1.html  

 

With the new server/seoclass, if I do the same, it works visually on the page and the navbar, but the http link shows as

  http://www.example.com/img-srcimagesiconsvideosmgif-border0-how-to-video-i-1.html  

 

The problem being the seo class (or IPU??) allowing the text between < and > into the url... "img-srcimagesiconsvideosmgif-border0"

First, you can't just replace the seo.class file to upgrade. Next, <img ...> is not a link so it could not possibly work as a link under any circumstances. Nothing is accomplished by posting partial code so I can't help you. But I suggest looking at the code you are using.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

I'm sorry but I don't understand the question. What is the real url you are wanting to display?

 

I want to display www.domain.com/product-name-product-model.html

 

Product Name (Mouse Microsoft) + Product Model (MSE174) = www.domain.com/mouse-microsoft-mse174.html

 

Thank you

Sergio B.

Share this post


Link to post
Share on other sites

First, you can't just replace the seo.class file to upgrade. Next, <img ...> is not a link so it could not possibly work as a link under any circumstances. Nothing is accomplished by posting partial code so I can't help you. But I suggest looking at the code you are using.

 

Why would you think I would just replace a seoclass file without performing the proper steps? I might not be a php guru, but I know osc well enough to get by most of the time.

Jack it does (did) work in this circumstance. I've failed in my question by wrongly assuming you know how IPU works with the Title entry... I'll take this to the IPU support thread, even though I am pretty sure the solution for me is in the seo class. I could be wrong.

 

If you know an easy way to make the (IPU or) the seoclass ignore anyhthing between < and > when generating rewrite links please let me know.

 

Thanks for the efforts,

Dave


-Dave

Share this post


Link to post
Share on other sites

Hello,

I just added this contribution to my site but I have one problem. The links have cyrilic letters and they cannot be displayed in the URL. I have function that can transform the cyrilic letters to latin. My question is where should I put the function and get it working?

Share this post


Link to post
Share on other sites

I want to display www.domain.com/product-name-product-model.html

 

Product Name (Mouse Microsoft) + Product Model (MSE174) = www.domain.com/mouse-microsoft-mse174.html

 

Thank you

Sergio B.

This contribution won't create such because nothing like that exists naturally in oscommerce. If you want all of your products to display the model instead of the name, the best thing to do would be to replace the name with model number in the database. If you don't want to do that, you could edit the seo.class.php file and replace the name with the model. That involves a number of changes though and will cause you problems with new updates.

Share this post


Link to post
Share on other sites

Hello,

I just added this contribution to my site but I have one problem. The links have cyrilic letters and they cannot be displayed in the URL. I have function that can transform the cyrilic letters to latin. My question is where should I put the function and get it working?

That option is already built-in. Look in the settings for the option to convert characters.

Share this post


Link to post
Share on other sites

ok I found it and it is working but i cannot type all the characters I want to convert there. so is there other solution? maybe I should write them in some file by hand ?

Share this post


Link to post
Share on other sites

ok I found it and it is working but i cannot type all the characters I want to convert there. so is there other solution? maybe I should write them in some file by hand ?

If the field isn't large enough to old all of the characters, then you can increase the field size in the database. Otherwise, the code would have to be edited to create an array of all of the characters, maybe using the script you mentioned, and have them checked that way.

Share this post


Link to post
Share on other sites

sorry for the dumb question but how can I increase the field size? I have no idea of database.

Edited by genata93

Share this post


Link to post
Share on other sites

sorry for the dumb question but how can I increase the field size? I have no idea of database.

You would have to increase the configuration value size in the configuration table using a program like phpmyadmin, which your host probably has installed. There are many examples of how to use that program on the web. You need to be sure you make a backup first though since a mistake could cause problems. If you aren't familiar with making such changes, you would probably be better off hiring someone to do it for you, or maybe your host will make the change, since the database is the most important part of the shop.

Share this post


Link to post
Share on other sites

Hi there, I've installed the contribution and it works just fine. But I've been reading about it a bit and it seems as if it's better for google if you links look like this

http://yourshop.com/category/product_name.html

rather then

http://yourshop.com/manufacturer_products_name.html

So what's better???

The examples are for two different urls and two different forms as well as not having the ide so I don't understand which part(s) you are asking about.

Share this post


Link to post
Share on other sites

The examples are for two different urls and two different forms as well as not having the ide so I don't understand which part(s) you are asking about.

 

Sorry, what I mean is

 

The verson of contribution I have only allows me to have a manufacturer and product name in the link which i would love to change for category,subcategory and products name.

So if I do - is it better to use slashes rather then long links?

 

Now they http://www.w3.org/Provider/Style/URI#remove also suggest to remove the file extensions ??

Share this post


Link to post
Share on other sites

Sorry, what I mean is

 

The verson of contribution I have only allows me to have a manufacturer and product name in the link which i would love to change for category,subcategory and products name.

So if I do - is it better to use slashes rather then long links?

 

Now they http://www.w3.org/Provider/Style/URI#remove also suggest to remove the file extensions ??

There is an option in the settings to add the path to the url. It does it with a hyphen instead of a slash. As I recall, someone posted a way to use the slash in this thread, if you would prefer that way.

Share this post


Link to post
Share on other sites

Hi,

 

I've just installed Ultimate SEO on my OSC 2.3.1 and I really like it! A great add-on. However, I'm having the error message appear now when I alter products in admin;

 

 

Warning: include_once(includes/reset_seo_cache.php) [function.include-once]: failed to open stream: No such file or directory in /mounted-storage/home15a/sub003/sc17799-IEOR/root/categories.php on line 21

 

Warning: include_once() [function.include]: Failed opening 'includes/reset_seo_cache.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/home15a/sub003/sc17799-IEOR/root/categories.php on line 21

 

Warning: Cannot modify header information - headers already sent by (output started at /mounted-storage/home15a/sub003/sc17799-IEOR/root/categories.php:21) in /mounted-storage/home15a/sub003/sc17799-IEOR/root/includes/functions/general.php on line 34

 

 

I always have to back page out of it, but the product alterations are still done. Would anyone be kind enough to show me the error of my ways?!

 

Many thanks

Edited by tomrowley

Share this post


Link to post
Share on other sites

Hi,

 

I've just installed Ultimate SEO on my OSC 2.3.1 and I really like it! A great add-on. However, I'm having the error message appear now when I alter products in admin;

 

 

Warning: include_once(includes/reset_seo_cache.php) [function.include-once]: failed to open stream: No such file or directory in /mounted-storage/home15a/sub003/sc17799-IEOR/root/categories.php on line 21

That usually means a mistake was made in the installation. Be sure you have uploaded the include file to admin and have changed the two files there.

Share this post


Link to post
Share on other sites

There is an option in the settings to add the path to the url. It does it with a hyphen instead of a slash. As I recall, someone posted a way to use the slash in this thread, if you would prefer that way.

 

Thanks Jack_mcs

 

I've upgraded to new version, changed the options and changed the hyphen to slash, and it all works great!

But I'm a bit worried about the extensions

 

Now the link to the category page would look like this

h ttp://shop.com/category-c-31.html

 

and to the product in this category

h ttp://shop.com/category/product-p-349.html

 

Wouldn't it be better for google if it was

h ttp://shop.com/category/

and

h ttp://shop.com/category/product/

??

 

What would be the best way to get rid of the extensions ?

Share this post


Link to post
Share on other sites

Thanks Jack_mcs

 

I've upgraded to new version, changed the options and changed the hyphen to slash, and it all works great!

But I'm a bit worried about the extensions

 

Now the link to the category page would look like this

h ttp://shop.com/category-c-31.html

 

and to the product in this category

h ttp://shop.com/category/product-p-349.html

 

Wouldn't it be better for google if it was

h ttp://shop.com/category/

and

h ttp://shop.com/category/product/

??

 

What would be the best way to get rid of the extensions ?

No, they don't make any difference with the search engines.

Share this post


Link to post
Share on other sites

Hi there, I have a problem with some category pages, when I try to sort by price or by name or go to the next result page for example

www.myshop.com/category/subcategory_c-29_44.html?page=2&sort=3a

I get the error:

 

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

Of course it's all ok when I disable "Enable automatic redirects"

Share this post


Link to post
Share on other sites

Hi there, I have a problem with some category pages, when I try to sort by price or by name or go to the next result page for example

www.myshop.com/category/subcategory_c-29_44.html?page=2&sort=3a

I get the error:

 

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

Of course it's all ok when I disable "Enable automatic redirects"

What version of this contribution are you using?

Share this post


Link to post
Share on other sites

What version of this contribution are you using?

 

Ultimate_SEO_URLSv22d_10-1.zip

in Chrome it says: This webpage has a redirect loop

Share this post


Link to post
Share on other sites

Ultimate_SEO_URLSv22d_10-1.zip

in Chrome it says: This webpage has a redirect loop

My guess is that there is something wrong with how the url is formatted, which is a very common thing in templates. If you are not using a template and it is common, oscommerce, code creating the url, then it is probably something to do with the server php/mysql versions. I've never had a site that had such a problem so I can't think of anything else that would cause it. If your site has been indexed already, you can turn the redirect option off without causing any problems.

Share this post


Link to post
Share on other sites

I have a multilanguage shop, with 8 languages and from Google I understood that the URL's should something like:

 

www.url.nl/nl/product

www.url.nl/de/product

www.url.nl/en/product

etc

 

Now all pages come in 8 versions, each in their own language, but they are all represented by just one URL. Probable not very SEO efficient.

 

I use Header Tags SEO V3.0 and Ultimate_SEO_URLSv22d_10

 

Is it possible with Ultimate_SEO_URLSv22d_10 to get the URL's like I want?

 

Or must I install ULTIMATE Seo Urls 5 Pro? Will that work with Header Tags SEO V3.0??

 

I have to fix this because in Google my site is almost invisible. So I appreciate all feedback

 

thanks, Bouke

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×