Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

i recently installed Ultimate_SEO_URLSv22d_11 and found that the created html pages for the products keep returning a 404 page warning. i cannot work out why this is as i have double checked the code additions and the .htaccess file. I have even went so far as to ask my server provider is the mod-rewrite function enabled and they have said that it is. Can some one help? I have also checked the config files and everything appears to be correct in these files also. im quite frankly lost! i do have to say that if the contribution is switched off the urls revert back to normal and the pages display

 

my url is bluetoothit.co.uk - and to let you know the contribution is switched off

Share this post


Link to post
Share on other sites

i recently installed Ultimate_SEO_URLSv22d_11 and found that the created html pages for the products keep returning a 404 page warning. i cannot work out why this is as i have double checked the code additions and the .htaccess file. I have even went so far as to ask my server provider is the mod-rewrite function enabled and they have said that it is. Can some one help? I have also checked the config files and everything appears to be correct in these files also. im quite frankly lost! i do have to say that if the contribution is switched off the urls revert back to normal and the pages display

 

my url is bluetoothit.co.uk - and to let you know the contribution is switched off

If the category links work, which your message implies, then the problem has to be in your shop. Template designers almost always code some of the links incorrectly. They will work but not the way they should and not with a rewwriter that expects them to be coded in an oscommmerce-friendly way.

Share this post


Link to post
Share on other sites

Hi,

 

I have checked the category links and these are not working either but i have noticed that again these are .html urls. i just seem to be lost with this. can anyone advise what i need to check

Share this post


Link to post
Share on other sites

Hi, this contri was easy to install and im very happy with it.

Im only have one problem. If I put Filter Short Words on 3 everything works well but the product names are not totally in the url. Xbox 360 XBLA Game Support becomes Xbox support.

So I put the filter on 4 (and higher). After that, i start having a lot of trouble with many products. When i click on them it says:

 

(translated with google to english)

The page is not redirecting properly

Firefox has detected that the server's request for this address redirects in a way that will never end.

* This problem can sometimes be caused by disabling or refusing cookies.

 

Internet explorer gives the same kind of error.

When I put the filter on 10, 20, or 40 it gaves the same error. Tried on 3 PC's.

 

Does anyone know how to handle this issue because I really want to see the full product name in the url.

Edited by ericattack

Share this post


Link to post
Share on other sites

Hi,

 

I have checked the category links and these are not working either but i have noticed that again these are .html urls. i just seem to be lost with this. can anyone advise what i need to check

Please post your utl and .htaccess file.

Share this post


Link to post
Share on other sites

Hi, this contri was easy to install and im very happy with it.

Im only have one problem. If I put Filter Short Words on 3 everything works well but the product names are not totally in the url. Xbox 360 XBLA Game Support becomes Xbox support.

So I put the filter on 4 (and higher). After that, i start having a lot of trouble with many products. When i click on them it says:

 

(translated with google to english)

The page is not redirecting properly

Firefox has detected that the server's request for this address redirects in a way that will never end.

* This problem can sometimes be caused by disabling or refusing cookies.

 

Internet explorer gives the same kind of error.

When I put the filter on 10, 20, or 40 it gaves the same error. Tried on 3 PC's.

 

Does anyone know how to handle this issue because I really want to see the full product name in the url.

You're going the wrong way with the filter. Try setting it to 2.

Share this post


Link to post
Share on other sites

Hi,

 

My URL is www.bluetoothit.co.uk - please be advised that I have the contribution off. If you wish me to turn it on so you can see what is happening feel free to email me using sales@bluetoothit.co.uk. Please also find a copy of my htaccess file below

 

# Begin Ultimate SEO V2.2d

Options +FollowSymLinks

RewriteEngine On

 

# RewriteBase instructions

# Change RewriteBase dependent on how your shop is accessed as below.

# http://www.mysite.com = RewriteBase /

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

 

# Change the following line using the instructions above

 

RewriteBase /

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}

# End Ultimate SEO V2.2d

Share this post


Link to post
Share on other sites

My URL is www.bluetoothit.co.uk - please be advised that I have the contribution off. If you wish me to turn it on so you can see what is happening feel free to email me using sales@bluetoothit.co.uk. Please also find a copy of my htaccess file below

You have it setup correctly. The problem is in your template. See here.

Share this post


Link to post
Share on other sites

Hi, this contri was easy to install and im very happy with it.

Im only have one problem. If I put Filter Short Words on 3 everything works well but the product names are not totally in the url. Xbox 360 XBLA Game Support becomes Xbox support.

So I put the filter on 4 (and higher). After that, i start having a lot of trouble with many products. When i click on them it says:

 

(translated with google to english)

The page is not redirecting properly

Firefox has detected that the server's request for this address redirects in a way that will never end.

* This problem can sometimes be caused by disabling or refusing cookies.

 

Internet explorer gives the same kind of error.

When I put the filter on 10, 20, or 40 it gaves the same error. Tried on 3 PC's.

 

Does anyone know how to handle this issue because I really want to see the full product name in the url.

 

You're going the wrong way with the filter. Try setting it to 2.

 

Thanks for the advise but that gives the same problem. Only on 3 it seems to work fine.

Anybody else a clue how to solve my problem? It is only giving this problem in some catagories. One is empty and one has some products in it. Cant think of a reason why the maps are making problems.

Edited by ericattack

Share this post


Link to post
Share on other sites

Hi guys,

 

I have installed Ultimate SEO V22d_1

 

Everything works fine but for some reason all of my products are displaying osCsid=4cf2c173d6c3809b697890b9ca0a7d0a on the end of links..

 

I have set add cpath to product url to false..

 

Any idea what could be going wrong?

 

Many thanks

Share this post


Link to post
Share on other sites

Hi guys,

 

I have installed Ultimate SEO V22d_1

 

Everything works fine but for some reason all of my products are displaying osCsid=4cf2c173d6c3809b697890b9ca0a7d0a on the end of links..

 

I have set add cpath to product url to false..

 

Any idea what could be going wrong?

 

Many thanks

 

I have managed to fix it. I have found

define('HTTP_COOKIE_DOMAIN', 'www.domain.co.uk');
 define('HTTPS_COOKIE_DOMAIN', 'www.domain.co.uk');

And changed it to:

define('HTTP_COOKIE_DOMAIN', '.domain.co.uk');
 define('HTTPS_COOKIE_DOMAIN', '.domain.co.uk');

Share this post


Link to post
Share on other sites

Hi, i recently posted an issue i have had with an oscommerce template. I had been pointed towards possible bad code but have been unable to find it anywhere. The problem that I continue to have is that the rewrite of the url is successful but the page does not display. a 404 page error displays instead. can anyone help?

Share this post


Link to post
Share on other sites

Hi, i recently posted an issue i have had with an oscommerce template. I had been pointed towards possible bad code but have been unable to find it anywhere. The problem that I continue to have is that the rewrite of the url is successful but the page does not display. a 404 page error displays instead. can anyone help?

You need to post the url of your shop, its .htaccess file and the version of Ultimate SEO you are using.

Share this post


Link to post
Share on other sites

I'm considering installing this contribution but am a bit wary as to how smooth it will go since my shop is live. Anyway, I'm wondering which version is the most stable. Although the shop is heavily modified, no template has been used, so the main code should be virgin.

Share this post


Link to post
Share on other sites

I'm considering installing this contribution but am a bit wary as to how smooth it will go since my shop is live. Anyway, I'm wondering which version is the most stable. Although the shop is heavily modified, no template has been used, so the main code should be virgin.

Use my latest version of 2.2d. If it doesn't work for some reason, you can turn it off in admin until the problem is resolved.

Share this post


Link to post
Share on other sites

Hi there

 

Google duplicate content is obviously a issue that cannot be ignored, in my webmaster google account i have dupicates with

 

.html

.html?language=en

.html?language=fr

and others (my sitemaps was putting on a different extention which has now been fixed)

 

now in my sitemap it now uses .html, and the site is quite happy to use it, when i click on freench language it has .html?language=fr but only for 1 click then its happy just to have .html (with different french title)

 

I was thinking about using a Mod Rewrite in HTaccess to strip out all the other strings after .html and send a 301.

 

Does anyone know if this is going to cause other problems as it seems like the logical thing to do?

 

Also struggling with the actual rewrite itself, have tried various ways as one is below (done lots of googleing but not easy)

 

# Ultimate SEO URLs BEGIN

Options +FollowSymLinks

RewriteEngine On

RewriteBase /

RewriteRule ^(.*)\.html(.*)$ $1.html [R=301,L]

 

 

Thank you

 

David


David

Share this post


Link to post
Share on other sites

Just as a update and it might help someone else

 

one of the issues i had was misformed links in google causeing duplicates, they had language=URL_LANGUAGE on the end of them, in htaccess i have put

 

# Ultimate SEO URLs BEGIN

Options +FollowSymLinks

RewriteEngine On

RewriteBase /

RewriteCond %{QUERY_STRING} language=URL_LANGUAGE

RewriteRule ^(.*)-p-(.*).html$ /$1-p-$2.html? [R=301,NC]

 

which appears to be sending 301's and rewriting the URL's to omit the last bit

 

Have to do the same with Categories now, i thought it would be as simple as replaceing the "p" with a "c" but unfortunalty its not.

 

PS it took me all night and half a day to get this far so it maybe completly bad way of doing it, but as far as i can see its working, if someone can improve on this please post.

 

David


David

Share this post


Link to post
Share on other sites

Just as a update and it might help someone else

 

PS it took me all night and half a day to get this far so it maybe completly bad way of doing it, but as far as i can see its working, if someone can improve on this please post.

The correct way to do is to install a contribution that handles duplicate content. I recommend installing Header Tags SEO since it offers many other benefits but there is also a contribution that just handles duplicate pages. Short of that, you can place the following in your robots.txt file, though it won't cover of duplciate content problems, like sort and SID arguments.

Disallow: /*language=*

Disallow: /*language=*

Share this post


Link to post
Share on other sites

Is it possible to specify terms that should be disregarded when creating URLs? For instance, I do need two-letter words in some cases and don't in others.

Share this post


Link to post
Share on other sites

Is it possible to specify terms that should be disregarded when creating URLs? For instance, I do need two-letter words in some cases and don't in others.

No. There's nothing in the code for that.

Share this post


Link to post
Share on other sites

The correct way to do is to install a contribution that handles duplicate content. I recommend installing Header Tags SEO since it offers many other benefits but there is also a contribution that just handles duplicate pages. Short of that, you can place the following in your robots.txt file, though it won't cover of duplciate content problems, like sort and SID arguments.

Disallow: /*language=*

Disallow: /*language=*

 

In the short term i need to clear up the duplicates etc and then i will look at which direction to go in, currently have 2.1d and a header tags contrib but this is not enough as name changes etc create duplicates.

 

I quite like the idea of using the robots.txt to stop future listing of products and categories with language=, and mabe even currency= but i already have loads of links with them, not sure how google would veiw these older links being put in the restricted section, do you think it would be better to run a rewrite for a fe weeks to convert the ones alrewady in the index, something like

 

RewriteCond %{QUERY_STRING} language=(.+)

RewriteRule ^(.*)-p-(.*).html$ /$1-p-$2.html [R=301,NC,L] not tested yet

 

Regards

 

david


David

Share this post


Link to post
Share on other sites

In the short term i need to clear up the duplicates etc and then i will look at which direction to go in, currently have 2.1d and a header tags contrib but this is not enough as name changes etc create duplicates.

 

I quite like the idea of using the robots.txt to stop future listing of products and categories with language=, and mabe even currency= but i already have loads of links with them, not sure how google would veiw these older links being put in the restricted section, do you think it would be better to run a rewrite for a fe weeks to convert the ones alrewady in the index, something like

 

RewriteCond %{QUERY_STRING} language=(.+)

RewriteRule ^(.*)-p-(.*).html$ /$1-p-$2.html [R=301,NC,L] not tested yet

If you are only concerned about google, they have an option in your webmaster toools account to handle urls with arguments so that is an easy way to take care of it. If you've placed them in the robots file, the search engines will clean up their links when they get to them. It won't be any faster to put them in the .htaccess file since, in either case, you have to wait for the search engines to visit. You shouldn't brush off the installation of a contribution so quickly since there are other arguments that you don't want to list in the .htaccess or robots file but will still cause duplicate pages issues. And "a header tags" contribution isn't the same as "the Header Tags SEO" contribution. There is a tremendous difference between it and all other meta tags contributions. The handling of duplicate content one of them.

 

This is all off-topic for this thread though so please continue it in the general forum, if need be.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×