Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

however, i have a problem... I cant add products to the shopping cart!

been searching the web for the past 2 hours for a solution with no luck..

read something about the php.ini file to look for arg_separator.output and input, and both are set to "&".

im all out of ideas, i tried everything i came up with.

if "use SEO urls" is set to off everything works just fine..

There are a few problems with the oscommerce code that caaues problems like this. They aren't caused by the contribution but are shown by it. You can read back through this thread to find such posts and the fixes for them to see if that helps. You could also try setting the w3c setting to false.

Share this post


Link to post
Share on other sites

hi again,

I fixed the problems that I had and now all is running as it should except that the URLs remained the same (localhost/eden/results.php?cPath=69&cID=69&osCsid=detluvmpa0o0ut2fa3mtchfov3)... :(

I changed the RewriteBase to \eden\ in .htaccess amd made all the changes required in the installation guide and have no idea where to search the problem...

Did you remember to turn the conribution on? What happens if you change it to RewriteBase /eden/ as the instructions state?

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

hi,

In admin control panel > configuration> SEO URLs > Enable SEO URLs is set to TRUE

Yes, on windows tests I tried both /eden/ & \eden\ but there's no change.

I will keep searching and if something odd occurs I will post it here.

(I apologize for my bad English)

Thanks

Share this post


Link to post
Share on other sites

There are a few problems with the oscommerce code that caaues problems like this. They aren't caused by the contribution but are shown by it. You can read back through this thread to find such posts and the fixes for them to see if that helps. You could also try setting the w3c setting to false.

 

 

Ive looked through a s*it load of pages, didnt find anything useful :(

 

Is this what "add product" should look lite in applications_top?

 

      case 'add_product' :    if (isset($HTTP_POST_VARS['products_id']) && is_numeric($HTTP_POST_VARS['products_id'])) {
                               $cart->add_cart($HTTP_POST_VARS['products_id'], $cart->get_quantity(tep_get_uprid($HTTP_POST_VARS['products_id'], $HTTP_POST_VARS['id']))+1, $HTTP_POST_VARS['id']);
                             }

Share this post


Link to post
Share on other sites

First of all, Great contrib!

Its easy to edit, and easy to use.

however, i have a problem... I cant add products to the shopping cart!

been searching the web for the past 2 hours for a solution with no luck..

read something about the php.ini file to look for arg_separator.output and input, and both are set to "&".

im all out of ideas, i tried everything i came up with.

if "use SEO urls" is set to off everything works just fine..

 

someone please help me! :)

cheers

 

I would need a link to the site .. if you can't give it publicly then PM me a link.

Share this post


Link to post
Share on other sites

There are very few install instructions for this simple contribution and essentially it is the same as the original install wise.

 

You don't need to "uninstall" stuff you just need to follow the instructions and where the ultimate_seo_urls code already exists simple replace it with the new version.

 

Once it is all installed upload to your root directory the file located in the package extras/Remove Database entries/usu2_removal.php

 

Browse to www.mysite.com/[some possible directory]/usu2_removal.php which will remove the database entries ( remove after use )

 

Then browse to the front of your site and it will load itself.

 

I recommend the use of USU5 however if your server runs PHP 5.2+ ( which it should be ). USU5 has complete upgrade instructions .. see my sig for a link.

 

Thanks for the reply. I will give it a go.

Share this post


Link to post
Share on other sites

I would need a link to the site .. if you can't give it publicly then PM me a link.

 

My site arnt online yet.

still cant add products to the cart from product_info.php

but the buy now button works on the product listing if the product dont have any attributes linked to it. thats wierd.

Share this post


Link to post
Share on other sites

hi,

In admin control panel > configuration> SEO URLs > Enable SEO URLs is set to TRUE

Yes, on windows tests I tried both /eden/ & \eden\ but there's no change.

I will keep searching and if something odd occurs I will post it here.

(I apologize for my bad English)

Thanks

 

I can't find where is the problem :(

any suggestions?

Share this post


Link to post
Share on other sites

Hi,

 

I'm having an issue for some reason where when I click the Friendly URLS links, it will just redirect back to the index.php page. I've been able to successfully installed the mod without problems before, but this time I had originally created the store in a different site and moved to a new hosting server with different domain.

 

Your help will be much appreciated, thank you.

Share this post


Link to post
Share on other sites

Hi,

 

I'm having an issue for some reason where when I click the Friendly URLS links, it will just redirect back to the index.php page. I've been able to successfully installed the mod without problems before, but this time I had originally created the store in a different site and moved to a new hosting server with different domain.

 

Your help will be much appreciated, thank you.

You don't provide any of the needed information (version, domain .htacces) as mentioned here many times so it comes down to just guessing. If you are using atemplate, you probably have the redirect problem mentioned here about every other page.

Share this post


Link to post
Share on other sites

Hi All,

 

I am in urgent need of some help.

 

I have been asked by lawyers to disable certain urls containing some copyrighted words.

 

I have changed the product name so the copyright name does not appear in the url anymore. However, if you copy and paste the old url (with the copyrighted word) into a browser, it gets redirected to the new name, which I believe is a standard behaviour for this contribution.

 

Since I have been asked by the lawyers I cannot do this, I have to get rid of this redirection all together and if someone cuts & pastes the copyrighted url, basically it needs to either show a 404.

 

How can I do this?

 

Regards

Share this post


Link to post
Share on other sites

I recommend the use of USU5 however if your server runs PHP 5.2+ ( which it should be ). USU5 has complete upgrade instructions .. see my sig for a link.

 

Just wanted to say thanks for your help - I am now running USU5 as per your recommendation and all is working well.

Share this post


Link to post
Share on other sites

Just wanted to say thanks for your help - I am now running USU5 as per your recommendation and all is working well.

 

Just add some code to the top of application_top.php if the request uri matches this particular url then show the 404 page and exit.

Share this post


Link to post
Share on other sites

hi chemo

i´d like to know if you can help me

 

i have a shop in my localhost and other in a public server. they are the same

In my localhost i have it in localhost/tienda/ and in the server public in a folder named xxxxxx in my root path. the domain goes to that folder so writting www.xxxxx.com, the shop appear.

 

the problem is in my localhost. when i want to see a product or categories appear error 404. in the server public everything works.

i´ve compared configure´s files and htaccess and i think everythins is ok

--------------------------------------------------

configure.php of the public server

 

<?php

define('HTTP_SERVER', 'http://www.mydomain.es');

define('HTTPS_SERVER', 'http://www.mydomain.es');

define('ENABLE_SSL', false);

define('HTTP_COOKIE_DOMAIN', 'www.mydomain.es');

define('HTTPS_COOKIE_DOMAIN', 'www.mydomain.es');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/content/38/4798538/html/oneFolder/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

define('DB_SERVER', 'database.db.4798538.domain.com');

define('DB_SERVER_USERNAME', 'userdatabase');

define('DB_SERVER_PASSWORD', 'mypassword');

define('DB_DATABASE', 'database');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');

?>

----------------------------------------

configure.php of the localhost

 

<?php

define('HTTP_SERVER', 'http://127.0.0.1');

define('HTTPS_SERVER', 'http://127.0.0.1');

define('ENABLE_SSL', false);

define('HTTP_COOKIE_DOMAIN', '127.0.0.1');

define('HTTPS_COOKIE_DOMAIN', '127.0.0.1');

define('HTTP_COOKIE_PATH', '/tienda/');

define('HTTPS_COOKIE_PATH', '/tienda/');

define('DIR_WS_HTTP_CATALOG', '/tienda/');

define('DIR_WS_HTTPS_CATALOG', '/tienda/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', 'C:/Archivos de programa/EasyPHP-5.3.2/www/tienda/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

define('DB_SERVER', '127.0.0.1');

define('DB_SERVER_USERNAME', 'userdatabase');

define('DB_SERVER_PASSWORD', 'mypassword');

define('DB_DATABASE', 'database');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');

?>

-----------------------------------------------

htaccess in public server

 

# RewriteBase instructions

# Change RewriteBase dependent on how your shop is accessed as below.

# http://www.mysite.com = RewriteBase /

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

 

# Change the following line using the instructions above

 

RewriteBase /

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}

# End Ultimate SEO V2.2d

---------------------------------

And htaccess in localhost

 

# RewriteBase instructions

# Change RewriteBase dependent on how your shop is accessed as below.

# http://www.mysite.com = RewriteBase /

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

 

# Change the following line using the instructions above

 

RewriteBase /tienda/

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}

# End Ultimate SEO V2.2d

-------------------------

when i write en firefox -> localhost, i can see all my folders and in 'tienda' is my shop. i dont know why doesn´t work.

do you know why???. it´s important for me to work from my localhost. everything is quicker.

thanks for all

Share this post


Link to post
Share on other sites

hi again,

I fixed the problems that I had and now all is running as it should except that the URLs remained the same (localhost/eden/results.php?cPath=69&cID=69&osCsid=detluvmpa0o0ut2fa3mtchfov3)... :(

I changed the RewriteBase to \eden\ in .htaccess amd made all the changes required in the installation guide and have no idea where to search the problem...

my .htaccess looks like this:

php_flag register_globals On
php_value register_long_arrays On

# Begin Ultimate SEO V2.2d 
Options +FollowSymLinks
RewriteEngine On 

 # RewriteBase instructions 
 # Change RewriteBase dependent on how your shop is accessed as below. 
 # http://www.mysite.com = RewriteBase / 
 # http://www.mysite.com/catalog/ = RewriteBase /catalog/  
 # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/ 

 # Change the following line using the instructions above  

RewriteBase \eden\

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}
# End Ultimate SEO V2.2d

 

Thanks in advance for any kind of help

can it be the problem that the catalog is other language than EN? - language_id=14

site is estatesbulgaria.com

Share this post


Link to post
Share on other sites

I am having some issues with "the most common problem". I have ultimate SEO working on my localhost (except for the fact that the OsIds are staying between pages, but that is why i need to test online) but I am trying to get it working on my online test site. you can see the test site here:

 

http://www.sackling.com/catalog/cat_coveralls_all.php (dont go to sackling.com/catalog directly because there is a redirect there still i was lazy to remove)

 

I passworded the test site

 

login: sackling

password: testsite

 

the second I add the .htaccess file to the catalog directory all of my pages inside the catalog directory go 500 internet error. if you go to the site root www.sackling.com the catalog folder completely disappears when adding the .htaccess file.

 

I have tried reviewing/ comparing my two configure.php files to no avail. I can't for the life of my figure out why this is working on my localhost but not online! any help is greatly appreciated!

 

here are my files with the database login info changed up.

 

catalog/includes/configure.php:

 

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.sackling.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://www.sackling.com/catalog/'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', false); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'www.sackling.com');
 define('HTTPS_COOKIE_DOMAIN', 'https://www.sackling.com');
 define('HTTP_COOKIE_PATH', '/www.sackling.com/catalog/');
 define('HTTPS_COOKIE_PATH', '/catalog/');
 define('DIR_WS_HTTP_CATALOG', '/catalog/');
 define('DIR_WS_HTTPS_CATALOG', '');

 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_IMAGES_CAT', 'images/product_mid/');
 define('LARGE_IMAGES', 'images/product_big/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_WS_CATALOG', '/catalog/');
 define('DIR_FS_CATALOG', '/www.sackling.com/catalog/');
 define('DIR_FS_DOWNLOAD', DIR_FS_catalog . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_catalog . 'pub/');

// define our database connection
 define('DB_SERVER', 'server'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'user');
 define('DB_SERVER_PASSWORD', 'password');
 define('DB_DATABASE', 'database_name');
 define('USE_PCONNECT', 'false'); // use persistent connections?
 define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'
?>

 

admin/includes/configure.php:

 

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.sackling.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTP_CATALOG_SERVER', 'http://www.sackling.com/catalog/');
 define('HTTPS_CATALOG_SERVER', 'https://www.sackling.com/catalog/');
 define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', '/www.sackling.com/catalog/'); // where the pages are located on the server
 define('DIR_WS_ADMIN', '/catalog/admin/'); // absolute path required
 define('DIR_FS_ADMIN', '/www.sackling.com/catalog/admin'); // absolute pate required
 define('DIR_WS_CATALOG', '/catalog/'); // absolute path required
 define('DIR_FS_CATALOG', '/www.sackling.com/catalog/'); // absolute path required
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . '/images/');

 /* not sure why I ever added these two 
 define('DIR_WS_IMAGES_CAT', 'images/product_mid/');
 define('', 'images/product_mid/'); */

 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'admin/backups/');

// define our database connection
 define('DB_SERVER', 'database'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'user');
 define('DB_SERVER_PASSWORD', 'pass');
 define('DB_DATABASE', 'database_name');
 define('USE_PCONNECT', 'false'); // use persisstent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

 

.htaccess file:

 

# Begin Ultimate SEO V2.2d 
Options +FollowSymLinks
RewriteEngine On 

 # RewriteBase instructions 
 # Change RewriteBase dependent on how your shop is accessed as below. 
 # http://www.mysite.com = RewriteBase / 
 # http://www.mysite.com/catalog/ = RewriteBase /catalog/  
 # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/ 

 # Change the following line using the instructions above  

RewriteBase /catalog/

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}
# End Ultimate SEO V2.2d

Share this post


Link to post
Share on other sites

I am having some issues with "the most common problem". I have ultimate SEO working on my localhost (except for the fact that the OsIds are staying between pages, but that is why i need to test online) but I am trying to get it working on my online test site. you can see the test site here:

 

the second I add the .htaccess file to the catalog directory all of my pages inside the catalog directory go 500 internet error. if you go to the site root www.sackling.com the catalog folder completely disappears when adding the .htaccess file.

 

I have tried reviewing/ comparing my two configure.php files to no avail. I can't for the life of my figure out why this is working on my localhost but not online! any help is greatly appreciated!

Your configure file for the shop side is not setup correctly. Actually, neither is the admin one but that won't affect this contribution. This thread explain how to set it up. If you can't figure it out, you should post in that thread for help.

Share this post


Link to post
Share on other sites

Your configure file for the shop side is not setup correctly. Actually, neither is the admin one but that won't affect this contribution. This thread explain how to set it up. If you can't figure it out, you should post in that thread for help.

 

Thanks for the reply. I have been to that thread for a large portion of the day. I will post there now. Is there anywhere in particular that you see my config file is not setup correctly? I feel like I'm taking crazy pills it all looks good to me!

Share this post


Link to post
Share on other sites

jack, can you see something strange in my code. i wrote properly in htaccess file, didn´t it??

I can't follow the problem. It sounds like you are talking about two different shops and you also have this line

define('DIR_FS_CATALOG', '/home/content/38/4798538/html/oneFolder/');

pointing to a third. You need to focus on one problem at a time and be more clear about what the problem is.

Share this post


Link to post
Share on other sites

Your configure file for the shop side is not setup correctly. Actually, neither is the admin one but that won't affect this contribution. This thread explain how to set it up. If you can't figure it out, you should post in that thread for help.

 

So I've got some help from someone on that thread and my configure file is now changed like so:

 

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.sackling.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://www.sackling.com'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', false); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'www.sackling.com');
 define('HTTPS_COOKIE_DOMAIN', 'www.sackling.com');
 define('HTTP_COOKIE_PATH', '.sackling.com');
 define('HTTPS_COOKIE_PATH', '.sackling.com');
 define('DIR_WS_HTTP_CATALOG', '/catalog/');
 define('DIR_WS_HTTPS_CATALOG', '/catalog/');

 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_IMAGES_CAT', 'images/product_mid/');
 define('LARGE_IMAGES', 'images/product_big/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_WS_CATALOG', '/catalog/');
 define('DIR_FS_CATALOG', '/home/gostwear/www.sackling.com/catalog/');
 define('DIR_FS_DOWNLOAD', DIR_FS_catalog . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_catalog . 'pub/');

// define our database connection
 define('DB_SERVER', 'mysql.site.com'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'user');
 define('DB_SERVER_PASSWORD', 'pass');
 define('DB_DATABASE', 'database');
 define('USE_PCONNECT', 'false'); // use persistent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

 

everything seems to be fine in here. except when I add the htaccess file the directory still "dissapears" from the index of files you see if you go to sackling.com

 

right now the htaccess is deleted so you can go to the catalog here for instance: http://www.sackling.com/catalog/cat_coveralls_pollycotton.php

 

and there are no issues. is there anything you can suggest I look at? my htaccess is still the same as before:

 

# Begin Ultimate SEO V2.2d 
Options +FollowSymLinks
RewriteEngine On 

 # RewriteBase instructions 
 # Change RewriteBase dependent on how your shop is accessed as below. 
 # http://www.mysite.com = RewriteBase / 
 # http://www.mysite.com/catalog/ = RewriteBase /catalog/  
 # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/ 

 # Change the following line using the instructions above  

RewriteBase /catalog/

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}
# End Ultimate SEO V2.2d

Share this post


Link to post
Share on other sites

ok. i gonna try to explain it better

 

i have a shop. i usually work with the shop in my computer because i have a web server (localhost). also i hired with a company, a server where i put my shop to the public (public server). when i finish of setting up a contribution and it works well, i upload to my public server.

 

in the last contribution i´ve installed (SEO URL), it´s appeared a mistake BUT just in my localhost. in the public server runs perfectly. i think it has to be a problem with the htaccess but i´m not sure. i write down the mistake i meant

---------------------

¡Objeto no encontrado! ----> Objet not found

 

El enlace requerido no ha sido localizado en este servidor. El enlace en la página referente parece tener algun error o ha expirado. Por favor comunique al autor de la página el error.

 

the link requeried hasn´t been found in the server. the link in the reference page look to have a mistake o has expired. please, contact with de administrator

 

Por favor contacte con el webmaster en caso de que usted crea que existe un error en el servidor.

Error 404

127.0.0.1

11/24/10 17:10:07

Apache/2.2.14 (Win32) PHP/5.3.2

 

-------------------------

i cant work because of this error and i dont find the mistake. my code is above. any idea????

thanks

Share this post


Link to post
Share on other sites

everything seems to be fine in here. except when I add the htaccess file the directory still "dissapears" from the index of files you see if you go to sackling.com

I don't understand what "still "dissapears" from the index of files" means. But your configure and .htaccess files look correct so there would seem to be a problem with your installation or server. You may need to ask your host to look at the problem.

Share this post


Link to post
Share on other sites

ok. i gonna try to explain it better

 

i cant work because of this error and i dont find the mistake. my code is above. any idea????

thanks

As mentioned, there is a mistake in your configure file. You need to fix that. Other than that, if you are doing some kind of redirect wiht the localhost, this contribution may not work with it. Create a blank shop and install it into it. It should work and will give you something to compare against. Also, since you know it works on the live shop, there is no reaon it has to be enabled on the local shop so just turn it off in the local shop.

Share this post


Link to post
Share on other sites

Hi

 

Just have a question - I would like to know how does this contribution remembers the old urls and redirects them to the new one?

 

Is there a cache, a file or database table where it keep the old urls and does a transalation?

 

I have renamed some old products but I can still access the new products by using the old url.

 

Thanks

 

Sam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×