Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

That's a server setting. You'll need to contact your host and ask them to do that.

 

 

Need you help Jack,

 

 

 

I dind't undestand this properly.

 

 

Enable mod_rewrite

Find the httpd.conf file (usually you will find it in a folder called conf, config or something along those lines)

Inside the httpd.conf file uncomment the line LoadModule rewrite_module modules/mod_rewrite.so (remove the pound '#' sign from in front of the line)

Also find the line ClearModuleList is uncommented then find and make sure that the line AddModule mod_rewrite.c is not commented out.

 

********************** AND ********************************

 

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

***********************************

 

How should i use parameter 'Options' to do what this does =>> "uncomment the line LoadModule rewrite_module modules/mod_rewrite" in my .htaccess so i can Enable mod_rewrite :(

 

Sincerely,

Ashin

Share this post


Link to post
Share on other sites

How should i use parameter 'Options' to do what this does =>> "uncomment the line LoadModule rewrite_module modules/mod_rewrite" in my .htaccess so i can Enable mod_rewrite :(

I'm sorry but this isn't a question for this thread, or even this forum really. If you have a host, then you need to ask them. If it is your own server, then you need to ask in the apache forums.

Share this post


Link to post
Share on other sites

Hello,

 

my catalog is based on the root folder. the installation goes fine (with 404) until I get to the .htaccess file. the changes I make there cause an Internal Server Error.

 

i'm assuming the 404 isn't a problem since the .htaccess sets it right.

 

# Begin Ultimate SEO V2.2d 
Options +FollowSymLinks
RewriteEngine On

RewriteBase /

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}
# End Ultimate SEO V2.2d



# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

#<IfModule mod_setenvif.c>
#  <IfDefine SSL>
#    SetEnvIf User-Agent ".*MSIE.*" \
#             nokeepalive ssl-unclean-shutdown \
#             downgrade-1.0 force-response-1.0
#  </IfDefine>
#</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter

# AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)

# php_value session.use_trans_sid 0
# php_value register_globals 1

any help, please?

Share this post


Link to post
Share on other sites

my catalog is based on the root folder. the installation goes fine (with 404) until I get to the .htaccess file. the changes I make there cause an Internal Server Error.

 

i'm assuming the 404 isn't a problem since the .htaccess sets it right.

There's no way to tell without the url to your shop. It could also be that your host doesn't have mod_rewrite enabled.

Share this post


Link to post
Share on other sites

There's no way to tell without the url to your shop. It could also be that your host doesn't have mod_rewrite enabled.

 

http://www.monsbike.co.cc

 

i believe mod_rewrite is enabled

 

currently the program is installed, but turned off. if turned on it 404s (the links). the problem only occurs when i edit .htaccess

Share this post


Link to post
Share on other sites

Hi Guy's

 

Need help..., I have done a clean install of OSCommerce & PHP is the latest and all works well. I have installed the Ultimate SEO URL Module. I just get one error..., My site is www.wizbits.biz (My SEO URL is switched to false). If you click on the product search and select a manufacturer - you will see my list of manufacturers. Now if I switch the SEO URL module to true, then this page disappears and I go back to the front page. Why?

 

-----------------------

 

My .htaccess file

 

# Begin Ultimate SEO V2.2d

Options +FollowSymLinks

RewriteEngine On

 

# RewriteBase instructions

# Change RewriteBase dependent on how your shop is accessed as below.

# http://www.mysite.com = RewriteBase /

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

 

# Change the following line using the instructions above

 

RewriteBase /catalog/

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}

# End Ultimate SEO V2.2d

 

SetEnvIfNoCase Request_URI IP_Trapped\.txt ban

<Files ~ "^.*$">

order allow,deny

allow from all

deny from env=ban

</Files>

 

----------------------

 

My configure.php (non admin side)

 

<?php

define('HTTP_SERVER', 'http://wizbits.biz');

define('HTTPS_SERVER', 'https://wizbits.biz');

define('ENABLE_SSL', true);

define('HTTP_COOKIE_DOMAIN', 'wizbits.biz');

define('HTTPS_COOKIE_DOMAIN', 'wizbits.biz');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_IMAGES_CAT', DIR_WS_IMAGES . 'categories/');

define('DIR_WS_IMAGES_MFG', DIR_WS_IMAGES . 'manufacturers/');

define('DIR_WS_IMAGES_PROD', DIR_WS_IMAGES . 'products/');

define('DIR_WS_IMAGES_THUMBS', DIR_WS_IMAGES . 'product_thumbnails/');

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/content/w/i/z/wizbitsb/html/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

define('DB_SERVER', 'REMOVED');

define('DB_SERVER_USERNAME', 'REMOVED');

define('DB_SERVER_PASSWORD', 'REMOVED');

define('DB_DATABASE', 'REMOVED');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');

?>

 

-----------------------

 

I rechecked the files for installation and I believe I have them 100% as instructed.

 

Please can someone assist me..,

 

Andy

Share this post


Link to post
Share on other sites

i believe mod_rewrite is enabled

 

currently the program is installed, but turned off. if turned on it 404s (the links). the problem only occurs when i edit .htaccess

Does it fail on products and categories? You don't have any categories correctly setup so that could be the problem. If you click on the item in the What's New box though it will go directly to a product so that could point out the problem. Also, you should turn off all options in the Ultimate SEO settings except for the top one to see if any of those are causing the problem.

Share this post


Link to post
Share on other sites

Need help..., I have done a clean install of OSCommerce & PHP is the latest and all works well. I have installed the Ultimate SEO URL Module. I just get one error..., My site is www.wizbits.biz (My SEO URL is switched to false). If you click on the product search and select a manufacturer - you will see my list of manufacturers. Now if I switch the SEO URL module to true, then this page disappears and I go back to the front page. Why?

It could be that your manufacturer tables are not setup correctly. They can get setup incorrectly by earlier versions, and maybe later versions, of easy populate and other contributions. You will need to look at the two manufacturer tables in the database to be sure they both have entries for a given manufacturer. If that isn't it, I can only think it is something in your code or with the version of php on the server.

Share this post


Link to post
Share on other sites

1.) Does it fail on products and categories? You don't have any categories correctly setup so that could be the problem. If you click on the item in the What's New box though it will go directly to a product so that could point out the problem.

 

2.) Also, you should turn off all options in the Ultimate SEO settings except for the top one to see if any of those are causing the problem.

 

1.) Added category, still 500 error when I add the .htaccess info

 

2.) tried, no success.

 

The 500 error occurs on all pages on the website, including the admin in osc. if I add the text to the .htaccess my site is inaccessible.

 

if i add only the line "Options +FollowSymLinks" my website already 500's

 

many thanks in advance,

-isaac

 

help me out please.

 

-edit-

 

removing

Options +FollowSymLinks

removes the problem from the website, even with the rest of the .htaccess file there. still doesn't work without this command. halp?

 

-edit2-

removing Options +FollowSymLinks from the .htaccess file but keeping the rest leaves me with a fully functional website with ultimate seo working.

Edited by tsachi

Share this post


Link to post
Share on other sites

1.) Added category, still 500 error when I add the .htaccess info

 

2.) tried, no success.

 

The 500 error occurs on all pages on the website, including the admin in osc. if I add the text to the .htaccess my site is inaccessible.

The problem is with the server then since this contribution doesn't change the admin enough to cause such a problem. The commands in the .htaccess file are affecting the admin , which is why it is failing. You will need to ask your host to look at the failure. It is most likely that they don't have an option enabled but be sure you have not inserted any extra spacce in the lines of code added to the .htaccess file.

Share this post


Link to post
Share on other sites

The problem is with the server then since this contribution doesn't change the admin enough to cause such a problem. The commands in the .htaccess file are affecting the admin , which is why it is failing. You will need to ask your host to look at the failure. It is most likely that they don't have an option enabled but be sure you have not inserted any extra spacce in the lines of code added to the .htaccess file.

like I said, it's working now and all I had to do was remove one line.

Share this post


Link to post
Share on other sites

hello,

 

thinking about the last thing i did was mod to seo urls,

i changed the categories.php from this:

 

 

$action = (isset($HTTP_GET_VARS['action']) ? $HTTP_GET_VARS['action'] : '');

 

to this:

 

 

// Ultimate SEO URLs v2.2d// If the action will affect the cache entries   if ( preg_match("/(insert|update|setflag)/i", $action) ) include_once('includes/reset_seo_cache.php');

 

therre are no errors just refreshes the page.

does anyone see anything wrong with this??

 

 

craig

Share this post


Link to post
Share on other sites

therre are no errors just refreshes the page.

does anyone see anything wrong with this??

If you have the cache options set in this contributions settings, they may not be updated correctly.

Share this post


Link to post
Share on other sites

If you have the cache options set in this contributions settings, they may not be updated correctly.

 

i tried setting the products,categories, and manufactures cache to false updating it from true.

no help.

 

i tried setting enable seo cache to save queries to false.

no help.

 

and lastly i tried setting seo urls to false.

and that did not help.

 

am i missing your point about updating?

i mean do i have to install an update for 2.2.10 because i didnot see one.

 

craig

Share this post


Link to post
Share on other sites

am i missing your point about updating?

i mean do i have to install an update for 2.2.10 because i didnot see one.

You asked if commenting out that line of code would cause any problems. I answered that question.

Share this post


Link to post
Share on other sites

If clicking a product or Mfr takes you back to the index.php page, read this!

 

I'd love to take credit for this fix, but I am not THAT good of a PHP developer (yet). However, if you look here http://addons.oscommerce.com/info/2823/v,22, Sunrise99 found a fix for your problem on February 6. I was having the same problem. The Ultimate SEO contribution (wonderful, by the way) automatically sets the new pages to .HTML pages. Your /includes/header.php file contains the following line ...

 

if(strpos($path_parts['basename'], "php") == false)
	{
		 print("<script type='text/javascript'>window.location='index.php';</script>");  
	}  

 

that basically says "If 'php' is not included in the basename URL, redirect to index.php! THAT'S WHAT'S CAUSING YOUR PROBLEM.

 

I simply added "//" before print("... and it works GREAT! My code in header.php now looks like this...

 

if(strpos($path_parts['basename'], "php") == false)
	{
		 //print("<script type='text/javascript'>window.location='index.php';</script>");  
	}

 

Sunrise99, you saved me a HELLUVA lot of troubleshooting! Thanks a million!

 

Jim Evans

unpaid help for Aunt Denise's Children's Used Clothing and More

Share this post


Link to post
Share on other sites

I want to do something and I can't really find a way to do that :(. Maybe someone could help me.

I need to shange the links for articles from this : http://domain.com/article-title-a-11.html

to:

http://domain.com/articles/article-title-a-11.html or even better, http://domain.com/article-title.html

 

How hard is that to do? :) Thank you!

I don't recommend doing that and you can't do it with my version. You can try SEO 5 though. I'm pretty sure it does both of those.

Share this post


Link to post
Share on other sites

I have Installed Ultimate SEO URLs and everything has seemed to work. The main pages such as index.php contactus.php exc work fine.

 

But when trying to view the product either by category or manufacturer im represented with a 404 error.

 

""The requested URL /catalog/alpha-spares-c-1.html was not found on this server.

Apache/2.0.63 (Unix) PHP/5.3.2 DAV/2 Server at localhost Port 80""

 

I have tried to work out how to access or adjust the HTaccess file but to no avail.

 

can anyone please give me some advice ?

 

Jereth

Share this post


Link to post
Share on other sites

I have Installed Ultimate SEO URLs and everything has seemed to work. The main pages such as index.php contactus.php exc work fine.

 

But when trying to view the product either by category or manufacturer im represented with a 404 error.

 

""The requested URL /catalog/alpha-spares-c-1.html was not found on this server.

Apache/2.0.63 (Unix) PHP/5.3.2 DAV/2 Server at localhost Port 80""

See the install file for requirements for asking for help.

Share this post


Link to post
Share on other sites

See the install file for requirements for asking for help.

 

Hi Guys,

 

My first post here, I have installed the latest ultimate SEO URLS on my site whatmower.com they work really well.

 

Th eoproblem I am having is that in the admin backend everything is been redirected too 401.shtml I need to fix this immediately if you have any suggestions I would be very grateful.

 

Thanks

Share this post


Link to post
Share on other sites

Installed v22d_10 and it works very well but just one very small problem.

 

For some reason the Reviews button on a couple of products was returning a 404.

 

If I turn off SEO URLs the Reviews button worked fine.

 

The products affected do have small words in the title (by and a) and I have Filter Short Words set to 0. I changed this to 1 and still had the same problem, changed to 2, worked fine.

 

Is this something which can be fixed?

Share this post


Link to post
Share on other sites

For some reason the Reviews button on a couple of products was returning a 404.

 

If I turn off SEO URLs the Reviews button worked fine.

 

The products affected do have small words in the title (by and a) and I have Filter Short Words set to 0. I changed this to 1 and still had the same problem, changed to 2, worked fine.

 

Is this something which can be fixed?

What url is the button creating? Does the code for the button use oscommerce link code. Some template makers use non-oscommerce link code in various parts of the code and those won't work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×