Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

I've reloaded includes/classes/seo.class.php but I still see Polish????????

If that version has an uninstall option in the settings in admin, use it to remove that version from the database. If that doesn't work, you will need to go through the complete installation process of the correct version, possibly removing the changes from the one you have first.

Share this post


Link to post
Share on other sites

If that version has an uninstall option in the settings in admin, use it to remove that version from the database. If that doesn't work, you will need to go through the complete installation process of the correct version, possibly removing the changes from the one you have first.

Yes. It's all in Polish but I realized the uninstall is the bottom one. Now to try to install your English version. Thanks.

Share this post


Link to post
Share on other sites

I installed the Polish version to all 5 of my sites. I've managed to change back one (My plants shop) after some anxious moments. My site disappeared but I did a save then an old reinstall then the new reinstall and not only did my site come back but the admin section was English too. Bonus! I guess I'll just do the same with my other 4 sites tomorrow. Thanks heaps Jack.

Share this post


Link to post
Share on other sites

I installed the Polish version to all 5 of my sites. I've managed to change back one (My plants shop) after some anxious moments. My site disappeared but I did a save then an old reinstall then the new reinstall and not only did my site come back but the admin section was English too. Bonus! I guess I'll just do the same with my other 4 sites tomorrow. Thanks heaps Jack.

You're welcome. I'm pleased you were able to get it working. It's a shame you had to go through that but such are the joys of open contributions.

Share this post


Link to post
Share on other sites

Hi Jack

 

I'm new to this contribution and i must admit i haven't read all 124 pages :)

 

Is there a way we can remove those -p-1842.html from the URL?

 

Thank you very much!

Share this post


Link to post
Share on other sites

Hi Jack

 

I'm new to this contribution and i must admit i haven't read all 124 pages :)

 

Is there a way we can remove those -p-1842.html from the URL?

 

Thank you very much!

 

I don't think that's possible, that indicates wich product you are viewing.

Without it, the shop doesn't know what to do :)

 

 

I have an other problem:

When i'm viewing a subcategory, and redirecting of this contribution is set to true, it keeps redirecting to the same page...

Products in top level categories and top level categories itself are no problem.

 

The urls are like this: shop.com/category-name/subcategory-name/productname-p-number.html

But this particulary one ends up in an infinite redirect loop.

 

What could be the problem, where do i have to start searching?

 

Best regards,

Leo

Share this post


Link to post
Share on other sites

I'm new to this contribution and i must admit i haven't read all 124 pages :)

Slacker. :)

Is there a way we can remove those -p-1842.html from the URL?

As Leo mentioned, it is not currently possible.

Share this post


Link to post
Share on other sites

thanx :)

 

i had to google for word slacker, cause my english is not that good :) now i know :)

Share this post


Link to post
Share on other sites

I have an other problem:

When i'm viewing a subcategory, and redirecting of this contribution is set to true, it keeps redirecting to the same page...

Products in top level categories and top level categories itself are no problem.

 

The urls are like this: shop.com/category-name/subcategory-name/productname-p-number.html

But this particulary one ends up in an infinite redirect loop.

 

What could be the problem, where do i have to start searching?

Problems like that always turn out to be a coding problem or a product naming problem. I would look at the latter first if it is only product related. A product with a number in the name can sometimes cause that. Otherwise, it may be something in the code. Unfortunately, the problem is specific to your shop and then for only certain situations so I can't help much. You will need to play detective and see what is different about the pages that fail versus the ones that don't. You can try adding a new product with a plain name, like abc, and see if that works. Then proceed from there.

Share this post


Link to post
Share on other sites

@CutieCute2

 

You need to visit the "Security" part of the forum and read the pinned thread "How to Secure Your Site".

 

It looks OK to me now, but if I were a hacker you'd be a victim by now.

:blush:


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

Well Jack_mcs,

 

the problem lies somewhere in the fact the contribution isn't created to work with my separator ("/" instead of "-"), at least, that's what i'm thinking.

 

When I visit an old url, one like this: examplewebshop.com/productname-p-number.html, it keeps redirecting to the same, new url, wich looks likes:

examplewebshop.com/categoryname/productname-p-number.html.

So it ends up in a loop :S

Also when i directly visit a url in the new format.

 

I've been debugging and debugging, but can't find the reason.

 

Then I thought, well if i can't find the cause, i'll make an workaround...

In the function do_redirect() I've put an if-statement around the following switch:

switch(true){
                           case (defined('USE_SEO_REDIRECT_DEBUG') && USE_SEO_REDIRECT_DEBUG == 'true'):
                                   $this->attributes['SEO_REDIRECT']['REDIRECT_URL'] = $url;
                                   break;
                           case ($this->attributes['USE_SEO_REDIRECT'] == 'true'):
                                   header("HTTP/1.0 301 Moved Permanently");
                                   $url = str_replace('&', '&', $url);
                                   header("Location: $url"); // redirect...bye bye                
                                   break;
                           default:
                                   $this->attributes['SEO_REDIRECT']['REDIRECT_URL'] = $url;
                                   break;
                   }

 

And now it looks like this:

if($this->base_url.$this->uri != $url)
			{
                switch(true){
                        case (defined('USE_SEO_REDIRECT_DEBUG') && USE_SEO_REDIRECT_DEBUG == 'true'):
                                $this->attributes['SEO_REDIRECT']['REDIRECT_URL'] = $url;
                                break;
                        case ($this->attributes['USE_SEO_REDIRECT'] == 'true'):
                                header("HTTP/1.0 301 Moved Permanently");
                                $url = str_replace('&', '&', $url);
                                header("Location: $url"); // redirect...bye bye                
                                break;
                        default:
                                $this->attributes['SEO_REDIRECT']['REDIRECT_URL'] = $url;
                                break;
				}# end switch
               }

 

Wich basicly just prevents a redirect loop.

 

 

Best regards,

 

Leo

Share this post


Link to post
Share on other sites

the problem lies somewhere in the fact the contribution isn't created to work with my separator ("/" instead of "-"), at least, that's what i'm thinking.

 

When I visit an old url, one like this: examplewebshop.com/productname-p-number.html, it keeps redirecting to the same, new url, wich looks likes:

examplewebshop.com/categoryname/productname-p-number.html.

So it ends up in a loop :S

I don't understand what you mean by "my separator" but if you are adding a / somewhere in the name then that won't work. The script only adds the category name if that option is set in the settings so if you have that enabled, you may want to turn it off, though it should work. It sounds like you are trying to adjust the urls to display in some different way than the code was designed for and that, probably, won't work.

Share this post


Link to post
Share on other sites

I don't understand what you mean by "my separator" but if you are adding a / somewhere in the name then that won't work. The script only adds the category name if that option is set in the settings so if you have that enabled, you may want to turn it off, though it should work. It sounds like you are trying to adjust the urls to display in some different way than the code was designed for and that, probably, won't work.

 

Well the contribution works with the hyphen as seperator between the categorynames and the productnames. So the urls are as follows:

www.exampleshop.com/category-subcategory-product-p-1234.html

 

I've rewritten it so it uses the forward slash as separator between the categorynames and the productnames. The url in my shop is now like this:

www.exampleshop.com/category/subcategory/product-p-1234.html

Share this post


Link to post
Share on other sites

Well the contribution works with the hyphen as seperator between the categorynames and the productnames. So the urls are as follows:

www.exampleshop.com/category-subcategory-product-p-1234.html

 

I've rewritten it so it uses the forward slash as separator between the categorynames and the productnames. The url in my shop is now like this:

www.exampleshop.com/category/subcategory/product-p-1234.html

I can't help you with code you've edited. Although I do have to ask why you would want to do that? It is not good for SEO.

Share this post


Link to post
Share on other sites

i have finally install the Ultimate SEO URLs Documentation - originally by Chemo

 

everythings work fine, but under "Configuration" => "SEO URLs"

 

everything is not in english, how do i change it to english version.. below are the screen

 

by the way, i'm new to osCommerce and let me intro myself..

my name is kenny from singapore

Edited by the man

Share this post


Link to post
Share on other sites

i have finally install the Ultimate SEO URLs Documentation - originally by Chemo

 

everythings work fine, but under "Configuration" => "SEO URLs"

 

everything is not in english, how do i change it to english version.. below are the screen

 

by the way, i'm new to osCommerce and let me intro myself..

my name is kenny from singapore

While I understand you are new to the forums but you'll find better support if you put in a little effort before posting. This question has been addressed several times just within the last page or so.

Share this post


Link to post
Share on other sites

I just installed this contribution and I made sure to follow everything precisley but apparently an error slipped through.

 

The main page of my site comes up fine, but when I click on any of the categories I get an error "Page Not Found"

 

The only thing I was not 100% sure about was the phrasing of the ReWriteBase line in the htaccess file. So here is what I have and what I *think* is right.

 

It said:

# RewriteBase instructions

# Change RewriteBase dependent on how your shop is accessed as below.

# http://www.mysite.com = RewriteBase /

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

 

# Change the following line using the instructions above

 

RewriteBase /YOU HAVE TO CHANGE ME/

 

Now my site does not use a catalog subfolder, it is directly in the root of the site (www.mysite.com, not www.mysite.com/catalog)

 

So I changed "RewriteBase /YOU HAVE TO CHANGE ME/" to "RewriteBase /" (without the quotes) - is that right? Because now when I go to my home page everything is fine, but when I click on a product or category I get a File Not Found error, but it shows the product name in the url with an additional "c-29.html" (or other letter-number combination, then .html)

 

Any ideas on what to look for?

Share this post


Link to post
Share on other sites

I just installed this contribution and I made sure to follow everything precisley but apparently an error slipped through.

What version did you install?

Share this post


Link to post
Share on other sites

What version did you install?

 

The only place I was able to find anything related to a version # is in the code that I placed into my files, which is "Ultimate SEO URLs v2.2d"

Share this post


Link to post
Share on other sites

The only place I was able to find anything related to a version # is in the code that I placed into my files, which is "Ultimate SEO URLs v2.2d"

You know which version you have by remembering which archive you used from the contributions section.

 

Your .htaccess file looks correct though you didn't show it all so I can't say for sure. The problem might be that your host doesn't have mod_rewrite enabled.

Share this post


Link to post
Share on other sites

You know which version you have by remembering which archive you used from the contributions section.

 

Your .htaccess file looks correct though you didn't show it all so I can't say for sure. The problem might be that your host doesn't have mod_rewrite enabled.

 

I have no idea which one I used, my eyes go blurry every time I go to look at various contributions because I am overwhelmed by the different versions and updates and partial packages and full packages, then by the time I figure which one would be good for me, I have to dig through everything again to figure out which one the "good" one was.

 

Should I post the entire htaccess file or should I contact my host (Go Daddy) to see if they have mod_rewrite enabled?

Share this post


Link to post
Share on other sites

I have no idea which one I used, my eyes go blurry every time I go to look at various contributions because I am overwhelmed by the different versions and updates and partial packages and full packages, then by the time I figure which one would be good for me, I have to dig through everything again to figure out which one the "good" one was.

 

Should I post the entire htaccess file or should I contact my host (Go Daddy) to see if they have mod_rewrite enabled?

 

Okay mod_rewrite is installed & enabled by default @ GoDaddy

Share this post


Link to post
Share on other sites

Alright since this was not working and shutting my site down, I decided to just uninstall it.

 

Now I have an issue because of this.

 

I undid all modification's to the code (on all pages) that were in place.

 

I got an error on the /includes/functions/html_output.php page. So since I just did a backup yesterday before attempting this contribution I went to my backup copied the contents of the includes/functions/html_output.php file and replaced the entire file with the backed up content.

 

Now I am getting the following error.

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/f/l/a/mysite/html/includes/functions/html_output.php:330) in /home/content/f/l/a/mysite/html/includes/functions/sessions.php on line 102

 

Now I have not touched the includes/functions/sessions.php page so I don't see any reason for line 102 to be messed up. And I used the backed up contents for my html_output.php page so there should be nothing wrong there either.

 

Can anyone tell me what this message is trying to tell me?

Share this post


Link to post
Share on other sites

i have finally install the Ultimate SEO URLs Documentation - originally by Chemo

 

everythings work fine, but under "Configuration" => "SEO URLs"

 

everything is not in english, how do i change it to english version.. below are the screen

 

by the way, i'm new to osCommerce and let me intro myself..

my name is kenny from singapore

 

I usually (always?) go for the most recent version of an add-on because I assume it's the most advanced. In this case, it was a Polish version of Ultimate URLs. Since my site appeared to work well, I applied the add-on to a number of my other osc shops. After I found the admin section was in Polish, I started the process of trying to uninstall the Polish language and install the English version. Initially, I removed the two maiin files and selected uninstal in the admin panel but the Polish was still there and the site was still using Ultimate URLs so I assumed it had something to with the cache or the language being in the database. Anyway, after deleting and uploading the English version of the two files, selecting uninstall in the admin and checking the front end of my site a number of times eventually the Polish disappeared. After installing the English files once again, the English suddenly appeared in the admin. I couldn't work it out step-by-step because what worked one time, didn't work the next. All I can say is keep trying and you CAN get rid of the Polish and get English. Sorry, I can't be more help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×