Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

Yep all issues were removed - no file

That type of hack is typical of one where the hacker changes many files so you may want to check your other files.

Share this post


Link to post
Share on other sites

That type of hack is typical of one where the hacker changes many files so you may want to check your other files.

 

I have looked and removed the 64 base from 30 files - all the same and still redirecting to login

Share this post


Link to post
Share on other sites

What could make www.mydomain.com/category-cat-c27?osCsid.html not work?

 

P.S: WAIT!!!

 

I think I know why the link along with the two others of its type might not work, but I'll need your assistance.

 

 

The original link does not link directly to a category, but redirects/points to a category in my store: www.domain.com/index.php?cPath=27.

Edited by quicker

Share this post


Link to post
Share on other sites

A new version has been uploaded with these changes:

 

- Added code to redirect category child so it uses the full path, i.e., parent ID = 3, child ID = 4, url -c-4.html changes to -c-3_4.html

- Added code to redirect category id = 0 to home page and issue a 404 error

- Fixed problem that caused code to fail with oscommerce SEO urls ( /cPath/ID )

- Fixed on/off switch in admin. The first setting now turns off the whole module

- Removed unused variable

- Updated instructions regarding .htaccess file

- Updated instructions regarding upgrading from a previous version

Share this post


Link to post
Share on other sites

A new version has been uploaded with these changes:

 

- Added code to redirect category child so it uses the full path, i.e., parent ID = 3, child ID = 4, url -c-4.html changes to -c-3_4.html

- Added code to redirect category id = 0 to home page and issue a 404 error

- Fixed problem that caused code to fail with oscommerce SEO urls ( /cPath/ID )

- Fixed on/off switch in admin. The first setting now turns off the whole module

- Removed unused variable

- Updated instructions regarding .htaccess file

- Updated instructions regarding upgrading from a previous version

 

Do you know if this has fixed the problem I was having with credit card redirect?

Share this post


Link to post
Share on other sites

Do you know if this has fixed the problem I was having with credit card redirect?

I'm sorry, but I don't remember what problem you are having. But trying it involves uploading one file. Seems like it would be easier to just try it.

Share this post


Link to post
Share on other sites

I just upgraded to the new version and this is what my homepage says:

 

Fatal error: Call to a member function href_link() on a non-object in /home/user/public_html/website/includes/functions/html_output.php on line 17

 

I followed instructions exactly as to how to upgrade.

Edited by quicker

Share this post


Link to post
Share on other sites

I just upgraded to the new version and this is what my homepage says:

 

Fatal error: Call to a member function href_link() on a non-object in /home/directfa/public_html/superreadingglasses/includes/functions/html_output.php on line 17

 

I followed instructions exactly as to how to upgrade.

 

 

Whats line 17?

Share this post


Link to post
Share on other sites

What will i have to do to upgrade from prev version 2.2.9

Replace the includes/classes/seo.class.php file.

Share this post


Link to post
Share on other sites

Hi Jack,

 

first, sorry for my bad english...

 

i install your SEO contrib and i have on big problem...

 

i have in .htaccess this line:

ErrorDocument 404 /catalog/404.php

 

but there ist no redirect to the page 404.php if not found a product or category :(

 

what must i change???

 

thank you,

 

best regards

Paul

Share this post


Link to post
Share on other sites

i have in .htaccess this line:

ErrorDocument 404 /catalog/404.php

 

but there ist no redirect to the page 404.php if not found a product or category :(

 

what must i change???

There's nothing in the code to send a 404, except for what I just added in the last revision.

Share this post


Link to post
Share on other sites

There's nothing in the code to send a 404, except for what I just added in the last revision.

ok, please, can you say what must i change in the classes/seo_class.php for send a 404 if a product, categorie or manufacturer is not found?

 

thank you very much,

 

best regards,

Paul

Share this post


Link to post
Share on other sites

ok, please, can you say what must i change in the classes/seo_class.php for send a 404 if a product, categorie or manufacturer is not found?

No, it's not a simple change.

Share this post


Link to post
Share on other sites

I just installed this and am getting a 500 Internal Server Error. Here's what it displays:

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator, webmaster@nationalsportsequipment.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

 

 

--------------------------------------------------------------------------------

 

Apache mod_fcgid/2.3.5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at www.nationalsportsequipment.com Port 80

Share this post


Link to post
Share on other sites

Here are a few additional comments to my post above:

 

  1. I changed the name of the admin folder. I don't think this would cause such an error though on the front end.
  2. I wasn't sure if we were supposed to append the htaccess file or replace it.

 

Thanks for any help.

Share this post


Link to post
Share on other sites

I just installed this and am getting a 500 Internal Server Error. Here's what it displays:

 

Internal Server Error

What does the install file you are using say under testing the installation?

Share this post


Link to post
Share on other sites

A new version has been uploaded with these changes:

 

- Added code to redirect category child so it uses the full path, i.e., parent ID = 3, child ID = 4, url -c-4.html changes to -c-3_4.html

- Added code to redirect category id = 0 to home page and issue a 404 error

- Fixed problem that caused code to fail with oscommerce SEO urls ( /cPath/ID )

- Fixed on/off switch in admin. The first setting now turns off the whole module

- Removed unused variable

- Updated instructions regarding .htaccess file

- Updated instructions regarding upgrading from a previous version

 

Jack, thanks for the update. I just tested this with some duplicate meta descriptions and duplicate title tags that were flagged in my google webmaster tools. Such as.....

 

/-c-0_136.html

/-c-0_182.html

/-c-0_32_62.html

/-c-0_43_179.html

/-c-0_43_53.html

/-c-0_43_55.html

/-c-0_43_56.html

 

After the update these are all now redirected to the index page, which should take care of those duplicate situations if I understand the concept correctly.

 

Thanks


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

What does the install file you are using say under testing the installation?

 

It says this:

 

Call your store in your favorite browser! The contribution should be functional out of the box and all database settings will be installed automatically on first page request. The contribution has an intelligent database installer that detects whether the proper settings are present and if not will install them.

 

You may need to clear your cache files to ensure that all URLs generated are fresh.

 

Click a few links and verify everything is functional. Test the add to cart and buy now buttons if you use them. Once you verify everything is working it's time to configure the contribution.

Share this post


Link to post
Share on other sites

Jack, thanks for the update. I just tested this with some duplicate meta descriptions and duplicate title tags that were flagged in my google webmaster tools. Such as.....

 

/-c-0_136.html

/-c-0_182.html

/-c-0_32_62.html

/-c-0_43_179.html

/-c-0_43_53.html

/-c-0_43_55.html

/-c-0_43_56.html

 

After the update these are all now redirected to the index page, which should take care of those duplicate situations if I understand the concept correctly.

Yes, that's correct. The code issues a 404 for those pages so the search engines will remove them whenever they get around to scanning them again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×