Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

The erroneous page is like this:

http://www.toolsup.co.uk/

grafters-tone-trousers-

p-1534?

osCsid.html

My guess is that your configure and/or .htaccess file is not setup correctly or the link to your site is invalid. You didn't mention what version you are using (please always do that), but I don't think any of them will correct for such a url.

Share this post


Link to post
Share on other sites

My guess is that your configure and/or .htaccess file is not setup correctly or the link to your site is invalid. You didn't mention what version you are using (please always do that), but I don't think any of them will correct for such a url.

 

Sorry I'm using osCommerce Online Merchant v2.2 RC1 with the latest Ultimate SEO, well, from a couple of weeks ago.

 

Configure file? Where can I find a 'good' configure file or .htaccess file?

 

Here's my htaccess:

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

 

Here's what happens (from previous thread):

"AFAICS, when I first clicked one of the products off the front page, I was sent to this: http://www.toolsup.c...534?osCsid.html

Not sure if this forum is breaking that up, it's:

http://www.toolsup.co.uk/

grafters-tone-trousers-

p-1534?

osCsid.html

 

which gave a 404.

 

When I returned to the home page and rolled over the link, it showed it going to:

http://www.toolsup.co.uk/

product_info.php?

products_id=1534

 

When I clicked it (the same link as before) it worked."

 

So am I right in thinking that USEO takes http://www.toolsup.co.uk/

product_info.php?

products_id=1534

 

and uses the rules in .htaccess to rewrite the URL?

 

OK, so which rule is the culprit? I don't know enough about those to know :-)

 

Cheers

J


----------------------------

John Allsopp

http://www.johnallsopp.co.uk/

Share this post


Link to post
Share on other sites

Sorry I'm using osCommerce Online Merchant v2.2 RC1 with the latest Ultimate SEO, well, from a couple of weeks ago.

 

Here's my htaccess:

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

I'm sorry but I only support my version (2.2d), which isn't what you are using based on the .htacces file contents.

Share this post


Link to post
Share on other sites

As mentioned previously, if everything else is working, it is something in your shop causing the problem. There isn't a default.php file in a standard oscommerce shop and since that would work as your home page and you are redirecting it, I suspect that is where the problem lies.

 

How would one go about fixing this problem? Is there a minor change I could make somewhere and keep the htaccess the way it is... redirecting default.php to the main site. and have this contribution work?

Share this post


Link to post
Share on other sites

I'm sorry but I only support my version (2.2d), which isn't what you are using based on the .htacces file contents.

 

Well maybe that's the problem.

 

I 'upgraded' by following the instructions and I'm sure all I had to copy across was the seo class. I'll check for .htaccess file differences tomorrow.


----------------------------

John Allsopp

http://www.johnallsopp.co.uk/

Share this post


Link to post
Share on other sites

Well maybe that's the problem.

 

I 'upgraded' by following the instructions and I'm sure all I had to copy across was the seo class. I'll check for .htaccess file differences tomorrow.

 

I just checked for a .htaccess file in my Ultimate SEO download (from a couple of weeks ago), I don't see one. What should my .htaccess file contain? Where do I find what it should be?

 

Cheers

J


----------------------------

John Allsopp

http://www.johnallsopp.co.uk/

Share this post


Link to post
Share on other sites

I just checked for a .htaccess file in my Ultimate SEO download (from a couple of weeks ago), I don't see one. What should my .htaccess file contain? Where do I find what it should be?

 

Cheers

J

 

Hello John, If you downloaded Jack_mcs Ultimate SEO 2-2.2d-9 from here http://addons.oscommerce.com/info/2823

The .htaccess file is in the "Docs" folder.

Open the instructions in Docs / upgrade.html

Step # 6 in the instructions will give you the .htaccess file

Share this post


Link to post
Share on other sites

How would one go about fixing this problem? Is there a minor change I could make somewhere and keep the htaccess the way it is... redirecting default.php to the main site. and have this contribution work?

Support threads like this only offer support for basic shops, unless it is something obvious. When the shop has been altered,as your apparently has been, your own your own.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Hello John, If you downloaded Jack_mcs Ultimate SEO 2-2.2d-9 from here http://addons.oscommerce.com/info/2823

The .htaccess file is in the "Docs" folder.

Open the instructions in Docs / upgrade.html

Step # 6 in the instructions will give you the .htaccess file

 

Thanks Larry

 

I downloaded originally from here: http://www.oscommerce.com/community/contributions,2823

 

OK, yes, there was at least a line missing in that .htaccess file, so I changed that. I remember running through those instructions a couple of weeks ago and I only needed to do the first part. However, having checked through the second part, I don't think includes/functions/html_output.php had been updated so I did that.

 

With .htaccess and includes/functions/html_output.php amended I had high hopes, but no. I've cleared the SEO cache, and no, the problem still remains.

 

You can try it yourself if you like, go to http://www.toolsup.co.uk , click any of the products and you get a 404. Hit the back button, click the product again and it works.

 

To get it to go wrong again, you have to clear the toolsup cookies.

 

OK, so am I right in thinking that the rollover address, for instance for Fibreglass Shaft Flexo Leaf Rake ( http://www.toolsup.co.uk/product_info.php?products_id=1587 (I've typed that so E&OE)) is the OSC 'original' address, which gets re-written by Ultimate SEO. Is the engine of that process in the .htaccess file?

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

 

Oh, no. That's the bit that rewrites what USEO creates so that OSC can understand it, in other words it undoes what USEO creates in the background so that OSC still works. Right?

 

So .. any ideas where I should be looking to work out where this OSCSID problem is happening?

 

All help appreciated :-)

 

Cheers

J


----------------------------

John Allsopp

http://www.johnallsopp.co.uk/

Share this post


Link to post
Share on other sites

Hello John, If you downloaded Jack_mcs Ultimate SEO 2-2.2d-9 from here http://addons.oscommerce.com/info/2823

The .htaccess file is in the "Docs" folder.

Open the instructions in Docs / upgrade.html

Step # 6 in the instructions will give you the .htaccess file

 

Oh, one other thing. The comments in my installation refer to 2.2d, the code in the upgrade instructions from the address you gave refer to SEO URLs v2.1, I don't know if that's significant, but I mention it to say that my installation *should* be 2.2d, if it was ever done properly.

 

Cheers

J


----------------------------

John Allsopp

http://www.johnallsopp.co.uk/

Share this post


Link to post
Share on other sites

Oh, one other thing. The comments in my installation refer to 2.2d, the code in the upgrade instructions from the address you gave refer to SEO URLs v2.1, I don't know if that's significant, but I mention it to say that my installation *should* be 2.2d, if it was ever done properly.

 

Cheers

J

 

I guess I could work through a full installation, check everything's been done


----------------------------

John Allsopp

http://www.johnallsopp.co.uk/

Share this post


Link to post
Share on other sites

All working 100% except for the normal pages of OSC.

 

I created various pages duplicating contact_us.php and modifing them.

 

page1.php

page2.php

 

The problem is the url doesnt translate to page1.html or page2.html

 

I use mod_rewrite in .htaccess

RewriteCond %{QUERY_STRING} ^options\=(.*)$

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2%1

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

# Added polls and newsdesk

#RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}

RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

# BOF: Faqdesk support added by faaliyet

RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}

# EOF: Faqdesk support added by faaliyet

# Ultimate SEO URLs END

 

any suggestion?

Edited by bhbilbao

Share this post


Link to post
Share on other sites

All working 100% except for the normal pages of OSC.

 

I created various pages duplicating contact_us.php and modifing them.

 

page1.php

page2.php

 

The problem is the url doesnt translate to page1.html or page2.html

It doesn't do that since there is no purpose in doing so. You can add entries to the .htaccess file but since it is just a waste of time, it isn't included in the contribution. There are probably examples on the web though if you want to do it.

Share this post


Link to post
Share on other sites

This is a fantastic add on along with headers tags seo.

 

I have a question on somthing that I am not sure whay it is not working all the way.

 

I have a catagory name called Clock Dials and under it a sub called 451, 461 and 1151 and 1161 and others.

What happens is the path looks like this.. http://domain.com/OS/clock-dials-c4_8.html when you click on the sub 451 but when you click on 1161 it works correctly and I get http://domain.com/OS/clock-dials-1161-c4_11.html

 

Anytime I click on a sub catagory that only has 3 numbers in it, like 451 or 461 or others the numbers do not show up in the URL. Anytime I click on a sub catagory that has 4 numbers those number show up.

 

I have added the manufactures name in from of those numbers and it works the same way only 4 numbers show up. I have also added a dash in bewteen the manufacturers name and the 3 digit number with nothing changing. I am using headers tag seo to change my tags and trying all kinds of things.

 

Is there a coding that I can change to get this to work?

Is there something in the forum that had this and I missed it could someone point me to it?

 

Thanks for your help

Share this post


Link to post
Share on other sites

Anytime I click on a sub catagory that only has 3 numbers in it, like 451 or 461 or others the numbers do not show up in the URL. Anytime I click on a sub catagory that has 4 numbers those number show up.

Change the short word setting in admin->Configuration->SEO URLs.

Share this post


Link to post
Share on other sites

Awesome thanks. I knew I read that but forgot. Sorry Again great contribution

Share this post


Link to post
Share on other sites

Thanks Jack_mcs,

 

in includes/aplication_top.php

// set the HTTP GET parameters manually if search_engine_friendly_urls is enabled
//  if (SEARCH_ENGINE_FRIENDLY_URLS == 'true') {
// ADDED FOR DINAMIC SITEMAP That way if the setting for "Use Search-Engine Safe URLs" gets changed in admin from true to false and a new XML sitemap is not generated osCommerce will still be able to understand the search engine safe URLs that may get used after the change
// If you are certain PHP version 5 or higher will be used you can simplify the "strpos(strtolower($PHP_SELF)," to " stripos($PHP_SELF, "
            if ((SEARCH_ENGINE_FRIENDLY_URLS == 'true') || (strpos(strtolower($PHP_SELF), '.php/') > 0)) {
//  PHP V5.0 if ((SEARCH_ENGINE_FRIENDLY_URLS == 'true') || stripos($PHP_SELF, '.php/') > 0)) {
//  PHP V5.0 if ((SEARCH_ENGINE_FRIENDLY_URLS == 'true') || (stripos($PHP_SELF, '.php/') > 0) {

I activated "Enable Search-Engine Safe URLs" in admin>configuration.

I dont know if I must change the commented lines in aplication_top.

 

it is just a waste of time

Why did you said that?.

I use Seo-Doctor addon of Firefox , and all flags are green except for the Seo Friendly Url pages with xxx.php

 

I need to convert 5 pages that ends with .php (because as i readed Google penalizes them).

 

services.php

consulting.php

rma.hph

security.php

new.php

 

I don´t know how to modify the .htaccess file to include them, or if I need to use other contribution.

Share this post


Link to post
Share on other sites

in includes/aplication_top.php

// set the HTTP GET parameters manually if search_engine_friendly_urls is enabled
//  if (SEARCH_ENGINE_FRIENDLY_URLS == 'true') {
// ADDED FOR DINAMIC SITEMAP That way if the setting for "Use Search-Engine Safe URLs" gets changed in admin from true to false and a new XML sitemap is not generated osCommerce will still be able to understand the search engine safe URLs that may get used after the change
// If you are certain PHP version 5 or higher will be used you can simplify the "strpos(strtolower($PHP_SELF)," to " stripos($PHP_SELF, "
            if ((SEARCH_ENGINE_FRIENDLY_URLS == 'true') || (strpos(strtolower($PHP_SELF), '.php/') > 0)) {
//  PHP V5.0 if ((SEARCH_ENGINE_FRIENDLY_URLS == 'true') || stripos($PHP_SELF, '.php/') > 0)) {
//  PHP V5.0 if ((SEARCH_ENGINE_FRIENDLY_URLS == 'true') || (stripos($PHP_SELF, '.php/') > 0) {

This is the support thread for Ultimate SEO 2. You need to post your questions for SEO 5 support thread.

 

Why did you said that?.

I use Seo-Doctor addon of Firefox , and all flags are green except for the Seo Friendly Url pages with xxx.php

 

I need to convert 5 pages that ends with .php (because as i readed Google penalizes them).

Then their test routine is incorrect or you are misreading it. The search engines don't care about the type of page being viewed.

Share this post


Link to post
Share on other sites

Hello

 

Have installed Ultimate SEO 2-2.2d-9

 

It is a great adddon. Thanks for your good work. Most of the things seems to be fine apart from 2 issues, URL & breadcrumb trail.

 

I run ink cartridge shop which I have link the same products in multiple category.

 

For example I am in Home » Brother Ink Cartridges » By Cartridge Model Number » Brother LC900 Ink Cartridges. The URL & breadcrumb trail show as:

 

Home » Brother Ink Cartridges » By Cartridge Model Number » Brother LC900 Ink Cartridges

 

http://www.xxxx.com/brother-lc900-ink-cartridges-c-21_325_326.html

 

Upto this part is all fine. The problem which happen if I click on a product listed here.

 

The URL & breadcrumb trail will change to:

 

Home » Brother Ink Cartridges » Brother Fax Printers Ink Cartridges » Brother FAX-1835C Ink Cartridges

 

http://www.xxxx.com/brother-ink-cartridges-brother-fax-printers-ink-cartridges-brother-fax-1835c-ink-cartridges-1-set-of-brother-lc900-compatible-multipack-ink-cartridges-p-37.html

 

It did not follow the current cpath. It The SEO module looks at to first category ID in database assigned to that product creates the URL & the breadcrumb trail use that too.

 

If I click a product It suppose to show:

 

Home » Brother Ink Cartridges » By Cartridge Model Number » Brother LC900 Ink Cartridges

 

http://www.xxxx.com/brother-ink-cartridges-by-cartridge-model-number-brother-lc900-ink-cartridges-1-set-of-brother-lc900-compatible-multipack-ink-cartridges-p-37.html

 

If I disable the SEO.

 

The breadcrumb trail will work as normal as it suppose to be as mention.

 

How Can I make this SEO work in my suitation. So both the URL & breadcrumb trail will be as I wanted as above.

 

Need help. Many Thanks in advance.

 

Kevin

Share this post


Link to post
Share on other sites

If I click a product It suppose to show:

 

Home » Brother Ink Cartridges » By Cartridge Model Number » Brother LC900 Ink Cartridges

 

http://www.xxxx.com/brother-ink-cartridges-by-cartridge-model-number-brother-lc900-ink-cartridges-1-set-of-brother-lc900-compatible-multipack-ink-cartridges-p-37.html

I can't follow your description but you say above that it is supposed to be a certain path and that is the path shown so it seems to be donig what you want.

Share this post


Link to post
Share on other sites

Hi jack,

 

First off, a great Thank You for both the contrib and also for the great support to this thread. (btw I have your ht seo contrib as well)

 

I installed your contrib without problems, works perfectly Ok on my windows machine.

 

One general question:

I recently moved to osCommerce, so I put a 301 redirect on my old path to the new osCommerce path eg cPath=1_2 etc., so far so good.

I have around 1000 URLs indexed by Google (with both old path eg. categoriesID=1 as well as new path URLs eg. cPath=1) and everything's cool.

 

My questions is, after installing your contrib, all URLs now are abc.html instead of products_id=1

 

1) Will this affect my Google and other SE rankings? I read earlier in this thread one guy lost his client's Google rankings, I wouldnt wanna be in his shoes!

 

2) Also, will it be a problem now that I already have a 301 redirect from old path to new osc path, and then now after your contrib it is going to abc.html (which is a rewrite, so it will send a 301 again)!

 

3) is there a way i can redirect the old path eg. categoriesID=1 directly to the seo friendly URLs instead of sending 301 to osc Path and then again doing the url rewrite.

 

Thanks!!

Share this post


Link to post
Share on other sites

I can't follow your description but you say above that it is supposed to be a certain path and that is the path shown so it seems to be donig what you want.

 

Hi Jack thanks for your quick reply.

 

Have installed Ultimate SEO 2-2.2d-9

 

Most of the things seems to be fine apart from 1 issues, URL with Add category parent to product URLs set to true.

 

I run ink cartridge shop, I have link the same products in multiple category.

 

For example I have this product LC900 Brother Compatible Black Ink Cartridge in the following categories

 

Home » Brother Ink Cartridges » By Cartridge Model Number » Brother LC900 Ink Cartridges cPath=21_325_326

Home » Brother Ink Cartridges » Brother DCP Printers Ink Cartridges » Brother DCP-110C Ink Cartridges cPath=21_24_67

Home » Brother Ink Cartridges » Brother MFC Printers Ink Cartridges » Brother MFC-210C Ink Cartridges cPath=21_25_76

Home » Brother Ink Cartridges » Brother Fax Printers Ink Cartridges » Brother FAX-1835C Ink Cartridges cPath=21_61_62

 

If i am in the category as below:

 

Home » Brother Ink Cartridges » By Cartridge Model Number » Brother LC900 Ink Cartridges

 

with SEO URL disable, when I click on the product the breadcrumb trail & URL show as:

 

Home » Brother Ink Cartridges » By Cartridge Model Number » Brother LC900 Ink Cartridges

 

www.xxx.com/product_info.php?cPath=21_25_76&products_id=32

 

When I turn on the SEO URL in the same category

with Add category parent to product URLs set to true

with Add cPath to product URLs set to true

 

Home » Brother Ink Cartridges » By Cartridge Model Number » Brother LC900 Ink Cartridges

 

when I click on the product the breadcrumb trail & URL show as:

 

Home » Brother Ink Cartridges » By Cartridge Model Number » Brother LC900 Ink Cartridges (This is fine and as I wanted)

 

www.xxx.com/brother-ink-cartridges-brother-fax-printers-ink-cartridges-brother-fax-1835c-ink-cartridges-brother-lc900-compatible-black-ink-cartridge-p-32.html?cPath=21_325_326 (This is the issue)

 

The SEO URL did not follow the current cPath & breadcrumb trail. It looks at the first category ID in database assigned to that product and use that ID to creates the URL.

 

If I click a product in that category I wanted the URL to show:

 

www.xxx.com/brother-ink-cartridges-by-cartridge-model-number-brother-lc900-ink-cartridges-1-set-of-brother-lc900-compatible-multipack-ink-cartridges-p-37.html?cPath=21_325_326 which it follow the breadcrumb trail. But at the moment it does not do that.

 

How Can I make this SEO URL work in my suitation. So the URL will be follow the breadcrumb trail as I wanted as above.

 

Need help. Many Thanks in advance.

 

Kevin

Share this post


Link to post
Share on other sites

How Can I make this SEO URL work in my suitation. So the URL will be follow the breadcrumb trail as I wanted as above.

With Ultimate SEO, the breadcrumb is built by the actual catagory name read at the time of the click. With it turned on, the name is loaded based on an internal path to the product. Since linked products are not separate products, the path ends up being the parent path. The code would have to be altered in this contribution to look at the current cPath and compare it to the calculated one and apply the appropriate one. I'll add it to the list of things to look at for a future version.

Share this post


Link to post
Share on other sites

Hi Jack, I have a finished shop that you can see at.. http://bifanoclockworks.com. Have a few more things to add to it but it is up there. I love your additions and all the others I used. This is a great product.

 

Was wondering about this. I am building another store for another website that has been indexed, on some pages, that are using html static pages. I know this has been covered in some ways before but I do not want to loose the pages I do have that are up in the top rankings. The htaccess file you use for the products, can that be used to redirect the pages I am building in the store to be able to switch from php to html? It is not the store products I am thinking about it is mostly information pages that are in my navigation header or information box.

 

What is the best way to do this? And where can I get more information on it.

 

I use header tags seo for those pages.

 

I know this is not maybe one of your add-ons that you are working on, but what page editor add-on works best with all of your addons? I have tried a few but never got them to work real good. I will use fckeditor but the add-on's I have tried are not real good. I want to use them for the extra pages I am doing that I am referring to in this topic.

 

Thanks again

Share this post


Link to post
Share on other sites

Hi jack,

 

First off, a great Thank You for both the contrib and also for the great support to this thread. (btw I have your ht seo contrib as well)

 

I installed your contrib without problems, works perfectly Ok on my windows machine.

 

One general question:

I recently moved to osCommerce, so I put a 301 redirect on my old path to the new osCommerce path eg cPath=1_2 etc., so far so good.

I have around 1000 URLs indexed by Google (with both old path eg. categoriesID=1 as well as new path URLs eg. cPath=1) and everything's cool.

 

My questions is, after installing your contrib, all URLs now are abc.html instead of products_id=1

 

1) Will this affect my Google and other SE rankings? I read earlier in this thread one guy lost his client's Google rankings, I wouldnt wanna be in his shoes!

 

2) Also, will it be a problem now that I already have a 301 redirect from old path to new osc path, and then now after your contrib it is going to abc.html (which is a rewrite, so it will send a 301 again)!

 

3) is there a way i can redirect the old path eg. categoriesID=1 directly to the seo friendly URLs instead of sending 301 to osc Path and then again doing the url rewrite.

 

Thanks!!

 

I think 2 & 3 points can be solved with the .htaccess rewrite. I need to learn that now!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×