Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

I just remembered there was a problem like that in an earlier version of the google feeder that I support. I had to add an instance of the function. You can see that file to get what you need, I think.

Thank you Jack for the hint - after including the tep_not_null function in the file, all works fine!


Absinthe Original Liquor Store

Share this post


Link to post
Share on other sites

I was hoping someone could help with this...

 

Installed the ultimate URL contribute. Works fine, but have fatal error message when i try to access the admin section:

 

Fatal error: Call to undefined function tep_get_languages() in /home/content/s/t/r/streamuk/html/XXXXX/login.php on line 79

 

The person who made my website had problems early on with a hacker and so changed 'admin' to a different name.

(Hence the 'XXXXX' part)

 

I was wondering if the name change itself might be causing the error?

 

I'm using version 2.2 rc2 of oscommerce.

 

Thanks in advance.

 

Rachel

x

Share this post


Link to post
Share on other sites

Installed the ultimate URL contribute. Works fine, but have fatal error message when i try to access the admin section:

 

Fatal error: Call to undefined function tep_get_languages() in /home/content/s/t/r/streamuk/html/XXXXX/login.php on line 79

 

The person who made my website had problems early on with a hacker and so changed 'admin' to a different name.

(Hence the 'XXXXX' part)

 

I was wondering if the name change itself might be causing the error?

No, the name change wouldn't cause this problem, nor will this contribution. You either made a mistake in the installation or the problem was there before. You need to restore the admin files that you changed and see if the problem goes away. If it does, re-install the admin changes one step at a time.

Share this post


Link to post
Share on other sites

Bonjour,

First sorry for my english and thank you very much for this wonderfull contribution.

 

I want to modify the seo.class.php for display products_model field after products_name of the url but i don't find the case on the seo.class.php.

 

Can you help me please ?

 

Thank you.

Share this post


Link to post
Share on other sites

Hi,

 

I have installed ultimate SEO URL but the thing is that I am getting a 404 Error. If you look at My webpage You can see that the links are SEF but when you click on the them you get a 404 error. The store is in root so I think there is no need to define a different path in .htaccess. Here is what my .htaccess has

 

Options +FollowSymLinks
RewriteEngine On 
RewriteBase /catalog/

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

 

I am using a windows server. Kindly let me know where and what is wrong so that it can be fixed.

 

Looking forward to some help

Share this post


Link to post
Share on other sites

The store is in root so I think there is no need to define a different path in .htaccess. Here is what my .htaccess has

 

RewriteBase /catalog/

 

I am using a windows server. Kindly let me know where and what is wrong so that it can be fixed.

You say the store is in the root but have the .htaccess file set to a sub-directory. Plus, this contribution doesn't work on a Windows server.

Share this post


Link to post
Share on other sites

 

I am using a windows server. Kindly let me know where and what is wrong so that it can be fixed.

 

Looking forward to some help

 

Ultimate Seo Urls 5 ( see my signature ) works just as well with Windows servers as Linux.

Share this post


Link to post
Share on other sites

Hello Jack

 

I am having trouble with my product review pages. When you click the link in the product review info box it takes the user to a page that list all the product categories.

 

The link in the reviews box is something like this:

mydomain.com/category-product-pri-151.html?reviews_id=1

 

However after you click the link, it redirects to this

mydomain.com/-product-pri-151.html?reviews_id=1

 

but it is not the correct page. I noticed the the seo url start with a "-" and it seems like the category name is missing there.

 

I am using Ultimate_SE_ Urls_V 2-2.2d-8 and HeaderTags_SEO_V_3.2.2

Edited by larryjam

Share this post


Link to post
Share on other sites

Hello Jack

 

I am having trouble with my product review pages. When you click the link in the product review info box it takes the user to a page that list all the product categories.

 

The link in the reviews box is something like this:

mydomain.com/category-product-pri-151.html?reviews_id=1

 

However after you click the link, it redirects to this

mydomain.com/-product-pri-151.html?reviews_id=1

 

but it is not the correct page. I noticed the the seo url start with a "-" and it seems like the category name is missing there.

 

I am using Ultimate_SE_ Urls_V 2-2.2d-8 and HeaderTags_SEO_V_3.2.2

 

 

Ok I have it working now, however I had to disable the option to "Add category parent to product URLs" in the configuration settings.

Share this post


Link to post
Share on other sites

Ok I have it working now, however I had to disable the option to "Add category parent to product URLs" in the configuration settings.

You may want to upgrade to V 2-2.2d-9. I know some changes were made with redirects though I don't recall if that was one. But even if it doesn't fix that problem, it will fix others so an upgrade would be a good idea.

Share this post


Link to post
Share on other sites

Hey thanks for that great contribution, it works wonderful :D

 

I use: Ultimate SEO 2-2.2d-9

 

But just one question: I use ,ä ,ö ,ü and it just leaves them out instead of writing ae, oe, ue. So is there some way in the seo admin section to set these up or do I need to change or add some code?

 

Thanks in advance

Edited by strub

Share this post


Link to post
Share on other sites

I use: Ultimate SEO 2-2.2d-9

 

But just one question: I use ,ä ,ö ,ü and it just leaves them out instead of writing ae, oe, ue. So is there some way in the seo admin section to set these up or do I need to change or add some code?

You need to enter them in the special character settings in admin.

Share this post


Link to post
Share on other sites

You need to enter them in the special character settings in admin.

 

Hey Jack_mcs thanks so much for that hint, I just didn't see that. It works wonderful. :D

Share this post


Link to post
Share on other sites

Ok I got everything working correctly except one thing. Now whenever I go to a category that has 2+ pages of results when I click the 2nd page result it just brings me right back to the same page. So for example http://www.qstix.com/index.php?cPath=21_247&sort=2a&page=2 just comes back to the same page 1. Any help?

Are you sure you are using 2.2d-9? Older versions of the contribution had that problem but it has been a while. It seems to me someone mentioned this not too long ago. It will take a while but if you read back through this thread, you should be able to find it.

Share this post


Link to post
Share on other sites

Hiya and thanks for great contribution, I am trying to install ver 2.2d-9, after following the info I keep getting the following error soon as I try to access any of the pages

 

Fatal error: Call to undefined function mb_convert_case() in /home/xxxxxxx/public_html/catalog/includes/classes/seo.class.php on line 1828

 

tried searching anything on this but cant see anyone else having teh same problem, have tried this a few times and am stuck atm.

 

Any help would be appreciated. :rolleyes:

Edited by kolakubes

Share this post


Link to post
Share on other sites

Fatal error: Call to undefined function mb_convert_case() in /home/xxxxxxx/public_html/catalog/includes/classes/seo.class.php on line 1828

 

tried searching anything on this but cant see anyone else having teh same problem, have tried this a few times and am stuck atm.

 

Any help would be appreciated. :rolleyes:

In includes/classes/seo.class.php, change this line

           		 $anchor = preg_replace($pattern, '', mb_convert_case($string, MB_CASE_LOWER, "utf-8"));

to

                $anchor = preg_replace($pattern, '', strtolower($string));

Share this post


Link to post
Share on other sites

Thanks so much for the quick reply and sorry for my slow response, as I had initially turn everything upside down trying to figure it out and took time to revert everything back. your solution was perfect and I can see it now working, just have to figure out how to use it properly.

 

:thumbsup: your a star !!

Share this post


Link to post
Share on other sites

Are you sure you are using 2.2d-9? Older versions of the contribution had that problem but it has been a while. It seems to me someone mentioned this not too long ago. It will take a while but if you read back through this thread, you should be able to find it.

 

Yeah using 2.2d-9 and looked through all these posts and found people talking about the same problem but nobody ever posts an answer to fix it. Alot of speculation and ideas on how to fix it in old versions.

Share this post


Link to post
Share on other sites

Yeah using 2.2d-9 and looked through all these posts and found people talking about the same problem but nobody ever posts an answer to fix it. Alot of speculation and ideas on how to fix it in old versions.

I don't have a fix for you then. It must be something in your shop that is confusing the code but there's no way to tell from here.

Share this post


Link to post
Share on other sites

In includes/classes/seo.class.php, change this line

           		 $anchor = preg_replace($pattern, '', mb_convert_case($string, MB_CASE_LOWER, "utf-8"));

to

                $anchor = preg_replace($pattern, '', strtolower($string));

 

Am sorry about this, but when I try it on my live shop i get the following error

 

Warning: ereg_replace() [function.ereg-replace]: REG_ERANGE in /home/xxxxxxx/public_html/catalog/includes/classes/seo.class.php on line 1829

 

I did everything the same on my test site

Share this post


Link to post
Share on other sites

Am sorry about this, but when I try it on my live shop i get the following error

 

Warning: ereg_replace() [function.ereg-replace]: REG_ERANGE in /home/xxxxxxx/public_html/catalog/includes/classes/seo.class.php on line 1829

 

I did everything the same on my test site

Double check that the changed file got uploaded. The code is telling it to use the function preg_replace but the error is saying the ereg_replace function is failing.

Share this post


Link to post
Share on other sites

Yeah using 2.2d-9 and looked through all these posts and found people talking about the same problem but nobody ever posts an answer to fix it. Alot of speculation and ideas on how to fix it in old versions.

 

Hav you tried to clear the cache?

Share this post


Link to post
Share on other sites

Hello to everybody

 

I have a problems installing Ultimate SEO 2.7, but I have try to install another versions with the same error. My web is ww.espirituracing.com

 

My Ultiamte SEO admin zone goes perfect! If I put the variable "Enable SEO URLs?" to "false" the public web goes perfect. If I put in On mode my web is white page.

 

When the Enable SEO url is off, if you browse this adress for example: http://www.espirituracing.com/example-product-p-1.html the .htacces translate the url and oscommerce say you that the prodcut ID is incorrect(not and 404 error like with erroneus .htacces)

 

I have view with PHPmyAdmin the tables of cache and all of them are empty

 

This is my .Htacces:

 

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

#<IfModule mod_setenvif.c>

# <IfDefine SSL>

# SetEnvIf User-Agent ".*MSIE.*" \

# nokeepalive ssl-unclean-shutdown \

# downgrade-1.0 force-response-1.0

# </IfDefine>

#</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

 

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

 

# php_value session.use_trans_sid 0

# php_value register_globals 1

 

# BOF Ultimate SEO URLs EDITABLE

Options +FollowSymLinks

RewriteEngine On

RewriteBase /

 

RewriteCond %{QUERY_STRING} ^options\=(.*)$

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2%1

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

# BOF: "Extra pages-info box w/ admin" support added by faaliyet

RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}

# EOF: "Extra pages-info box w/ admin" support added by faaliyet

RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}

# Added polls and newsdesk

#RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}

RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

# BOF: Faqdesk support added by faaliyet

RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}

# EOF: Faqdesk support added by faaliyet

 

# Block Bad Bots

RewriteCond %{HTTP_USER_AGENT} ^BlackWidow [OR]

RewriteCond %{HTTP_USER_AGENT} ^Bot\ mailto:craftbot@yahoo.com [OR]

RewriteCond %{HTTP_USER_AGENT} ^ChinaClaw [OR]

RewriteCond %{HTTP_USER_AGENT} ^Custo [OR]

RewriteCond %{HTTP_USER_AGENT} ^DISCo [OR]

RewriteCond %{HTTP_USER_AGENT} ^Download\ Demon [OR]

RewriteCond %{HTTP_USER_AGENT} ^eCatch [OR]

RewriteCond %{HTTP_USER_AGENT} ^EirGrabber [OR]

RewriteCond %{HTTP_USER_AGENT} ^EmailSiphon [OR]

RewriteCond %{HTTP_USER_AGENT} ^EmailWolf [OR]

RewriteCond %{HTTP_USER_AGENT} ^Express\ WebPictures [OR]

RewriteCond %{HTTP_USER_AGENT} ^ExtractorPro [OR]

RewriteCond %{HTTP_USER_AGENT} ^EyeNetIE [OR]

RewriteCond %{HTTP_USER_AGENT} ^FlashGet [OR]

RewriteCond %{HTTP_USER_AGENT} ^GetRight [OR]

RewriteCond %{HTTP_USER_AGENT} ^GetWeb! [OR]

RewriteCond %{HTTP_USER_AGENT} ^Go!Zilla [OR]

RewriteCond %{HTTP_USER_AGENT} ^Go-Ahead-Got-It [OR]

RewriteCond %{HTTP_USER_AGENT} ^GrabNet [OR]

RewriteCond %{HTTP_USER_AGENT} ^Grafula [OR]

RewriteCond %{HTTP_USER_AGENT} ^HMView [OR]

RewriteCond %{HTTP_USER_AGENT} HTTrack [NC,OR]

RewriteCond %{HTTP_USER_AGENT} ^Image\ Stripper [OR]

RewriteCond %{HTTP_USER_AGENT} ^Image\ Sucker [OR]

RewriteCond %{HTTP_USER_AGENT} Indy\ Library [NC,OR]

RewriteCond %{HTTP_USER_AGENT} ^InterGET [OR]

RewriteCond %{HTTP_USER_AGENT} ^Internet\ Ninja [OR]

RewriteCond %{HTTP_USER_AGENT} ^JetCar [OR]

RewriteCond %{HTTP_USER_AGENT} ^JOC\ Web\ Spider [OR]

RewriteCond %{HTTP_USER_AGENT} ^larbin [OR]

RewriteCond %{HTTP_USER_AGENT} ^LeechFTP [OR]

RewriteCond %{HTTP_USER_AGENT} ^Mass\ Downloader [OR]

RewriteCond %{HTTP_USER_AGENT} ^MIDown\ tool [OR]

RewriteCond %{HTTP_USER_AGENT} ^Mister\ PiX [OR]

RewriteCond %{HTTP_USER_AGENT} ^Navroad [OR]

RewriteCond %{HTTP_USER_AGENT} ^NearSite [OR]

RewriteCond %{HTTP_USER_AGENT} ^NetAnts [OR]

RewriteCond %{HTTP_USER_AGENT} ^NetSpider [OR]

RewriteCond %{HTTP_USER_AGENT} ^Net\ Vampire [OR]

RewriteCond %{HTTP_USER_AGENT} ^NetZIP [OR]

RewriteCond %{HTTP_USER_AGENT} ^Octopus [OR]

RewriteCond %{HTTP_USER_AGENT} ^Offline\ Explorer [OR]

RewriteCond %{HTTP_USER_AGENT} ^Offline\ Navigator [OR]

RewriteCond %{HTTP_USER_AGENT} ^PageGrabber [OR]

RewriteCond %{HTTP_USER_AGENT} ^Papa\ Foto [OR]

RewriteCond %{HTTP_USER_AGENT} ^pavuk [OR]

RewriteCond %{HTTP_USER_AGENT} ^pcBrowser [OR]

RewriteCond %{HTTP_USER_AGENT} ^RealDownload [OR]

RewriteCond %{HTTP_USER_AGENT} ^ReGet [OR]

RewriteCond %{HTTP_USER_AGENT} ^SiteSnagger [OR]

RewriteCond %{HTTP_USER_AGENT} ^SmartDownload [OR]

RewriteCond %{HTTP_USER_AGENT} ^SuperBot [OR]

RewriteCond %{HTTP_USER_AGENT} ^SuperHTTP [OR]

RewriteCond %{HTTP_USER_AGENT} ^Surfbot [OR]

RewriteCond %{HTTP_USER_AGENT} ^tAkeOut [OR]

RewriteCond %{HTTP_USER_AGENT} ^Teleport\ Pro [OR]

RewriteCond %{HTTP_USER_AGENT} ^VoidEYE [OR]

RewriteCond %{HTTP_USER_AGENT} ^Web\ Image\ Collector [OR]

RewriteCond %{HTTP_USER_AGENT} ^Web\ Sucker [OR]

RewriteCond %{HTTP_USER_AGENT} ^WebAuto [OR]

RewriteCond %{HTTP_USER_AGENT} ^WebCopier [OR]

RewriteCond %{HTTP_USER_AGENT} ^WebFetch [OR]

RewriteCond %{HTTP_USER_AGENT} ^WebGo\ IS [OR]

RewriteCond %{HTTP_USER_AGENT} ^WebLeacher [OR]

RewriteCond %{HTTP_USER_AGENT} ^WebReaper [OR]

RewriteCond %{HTTP_USER_AGENT} ^WebSauger [OR]

RewriteCond %{HTTP_USER_AGENT} ^Website\ eXtractor [OR]

RewriteCond %{HTTP_USER_AGENT} ^Website\ Quester [OR]

RewriteCond %{HTTP_USER_AGENT} ^WebStripper [OR]

RewriteCond %{HTTP_USER_AGENT} ^WebWhacker [OR]

RewriteCond %{HTTP_USER_AGENT} ^WebZIP [OR]

RewriteCond %{HTTP_USER_AGENT} ^Wget [OR]

RewriteCond %{HTTP_USER_AGENT} ^Widow [OR]

RewriteCond %{HTTP_USER_AGENT} ^WWWOFFLE [OR]

RewriteCond %{HTTP_USER_AGENT} ^Xaldon\ WebSpider [OR]

RewriteCond %{HTTP_USER_AGENT} ^Zeus

RewriteRule .* - [F]

# EOF Ultimate SEO URLs EDITABLE

 

Do you now what is my problem? Any idea?

 

Thank you and sorry for my bad english

 

Please! Help Me!

Share this post


Link to post
Share on other sites

Please! Help Me!

 

That version is unsupported.

 

I support and recommend: -

 

Ultimate Seo Urls 5 ( seperate new contribution for PHP5 )

Ultimate Seo Urls 2.1d STABLE FINAL r172

 

jack_mcs supports his own modifications to ultimate seo urls which are all named 2-2.2d

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×