Jump to content
Latest News: (loading..)
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

I've just installed this and it's working very well, except that the "Add Category Parent To Beginning of URLS" config doesn't appear to be working correctly.

 

With it turned off, I get a URL like this -

 

etcetc.com/electric-c-198.html

 

With it turned on, I get this -

 

etcetc.com/thrusters-bow-thrusters-c-22_30_198.html

 

I lose the last child category off the URL. What I actually want is this -

 

etcetc.com/thrusters-bow-thrusters-electric-c-22_30_198.html

 

Is this how it's meant to work? Any ideas how I can modify it to put the full category path into the URL? Apologies if this has already been answered, a forum search didn't turn anything up.

Edited by Code Red

Share this post


Link to post
Share on other sites

I've just installed this and it's working very well, except that the "Add Category Parent To Beginning of URLS" config doesn't appear to be working correctly.

It should include all categories in the path. Be sure you clear the case settings in admin->Configuration->URL SEOs when making such a change.

Share this post


Link to post
Share on other sites

The only things I can think of that might be causing that is that your .htaccess file is not setup correctly (no rewrite for products) or your products are missing names.

 

Hi,

I don't thing so, becouse I copy the changes from the intstalinstructions into the .htaccess, an set RewriteEngine On

and RewriteBase to: RewriteBase/testshop3/

Share this post


Link to post
Share on other sites

No, mb_convert_case nor the other suggested changes should be made to ultimate seo urls, whatever version.

 

1) mb_convert case is not on as standard in php.ini so this should not be included as standard.

 

2) uri link text should be latin characters only .. that is how the web works, therefore there is no need for it to be UTF-8 as no special language characters are allowed. Perhaps the web works differently in china or Japan, I don't know, if it did then there would need to be an admin selectable option to change the functionality to accomodate it.

 

Just want to share this piece of news about non-Latin characters domain is taking off : http://news.xinhuanet.com/english/2009-11/09/content_12416886.htm

Share this post


Link to post
Share on other sites

 

I've just installed this and it's working very well, except that the "Add Category Parent To Beginning of URLS" config doesn't appear to be working correctly.

 

It should include all categories in the path. Be sure you clear the case settings in admin->Configuration->URL SEOs when making such a change.

 

Do you mean the "Reset SEO URLs Cache" setting? I've tried that and it makes no difference, it's still dropping the child category.

Share this post


Link to post
Share on other sites

Hi, i'ive got a question,

the url show me this: testshop3/dachwandfassade-flechtzaunbeschlag-stck-flechtzaunbeschlag-form-gelb-verz-28x38x30x25-p-5425.html

Is it possible to remove this part here: -p-5425?

Edited by gimmin

Share this post


Link to post
Share on other sites

Do you mean the "Reset SEO URLs Cache" setting? I've tried that and it makes no difference, it's still dropping the child category.

Yes, that's what I meant. Are you sure you are on 2.2-7? When you installed that version, did you make the change to the admin/includes/functions/general.php file? If yes, to both of those, try using the uninstall option and then go o your site and click on a link to re-install it. Then go back and change the path setting in admin.

Share this post


Link to post
Share on other sites

Hi, i'ive got a question,

the url show me this: testshop3/dachwandfassade-flechtzaunbeschlag-stck-flechtzaunbeschlag-form-gelb-verz-28x38x30x25-p-5425.html

Is it possible to remove this part here: -p-5425?

No, it isn't. This has been addressed many times. Please check the thread if you would like more details.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Hi,

 

PAYMENT MODULE NOT WORKING DUE TO CHANGE IN tep_href_link

 

I would require some help here.... stuck since morning...

 

I have installed authorize.net AIM through the Built-in Payment Module, as well as also tried a contribution. It was successful. But when a user hits CONFIRM ORDER, the user gets logged off and user is redirected to login.php, and then if the user tries to login, it does not logs him in, it again and again shows login.php page and asks to login.

 

Why don't it processes the card and makes the transaction successful???

 

Same case is with paypal...

 

If I remove Authorize.net and install Cash on delivery, it works perfectly...

 

Please help me...

 

Here is the url when it gets redirected to login.php and not lets user to login : MY WEBSITE/login.php?osCsid=s8ohftjnn9o0j4igl6aqv8qo22

 

My Oscommerce version is : oscommerce-2.2rc2a

 

I will be glad to hear from you.

 

Here is something I figured out.. as I have Ultimate SEO enabled, and according to the instructions i had changed the html_output.php as stated below. But if i revert tep_href_link, it works fine... Can anyone HELP???

 

function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true) {
  global $seo_urls;                
  if ( !is_object($seo_urls) ){
   if ( !class_exists('SEO_URL') ){
    include_once(DIR_WS_CLASSES . 'seo.class.php');
   }
   global $languages_id;
   $seo_urls = new SEO_URL($languages_id);
  }
       //echo $seo_urls->href_link($page, $parameters, $connection, $add_session_id)."<br/>";
  return $seo_urls->href_link($page, $parameters, $connection, $add_session_id);  
}

 

Regards

Share this post


Link to post
Share on other sites

PAYMENT MODULE NOT WORKING DUE TO CHANGE IN tep_href_link

It's unlikely that is the reason. More likely is that your configure file is not setup correctly and it's causing the session ID to be lost. You should compare your configure settings to those mentioned in this thread to make sure that is not the problem.

Share this post


Link to post
Share on other sites

Hi,

 

PAYMENT MODULE NOT WORKING DUE TO CHANGE IN tep_href_link

 

 

Yes this happens quite often. Usually it is do to the W3c option converting the url and therefore creating & which is fine for displaying as the source of an html page but is not fine for redirects and direct links.

 

Try turning off the W3C option that will probably work.

 

If it works you can then open up the payment module and find where it is using tep_href_link(), if it looks like you are passing the url to the payment process or you can then replace the & with a str_replace().

Share this post


Link to post
Share on other sites

Hello!

I have a little problem and I can't solve it by myself.

I installed this great contrib and almost everything is working. The only part that is not working is when I am trying to access the second page from a category.

So, for ecample, when I press the "AMOI" category (in my store) the link is http://magazindeinchiriat.ro/demo/amoi-c-1.html . But if I try to go to page 2 the link is: http://magazindeinchiriat.ro/demo/index.php?cPath=1&sort=6a&page=2 .

I can't get this to work. How can I solve it?

 

My .htaccess file looks like this:

 

# Ultimate SEO URLs BEGIN
Options +FollowSymLinks
RewriteEngine On
RewriteBase /

RewriteCond %{QUERY_STRING} ^options\=(.*)$
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2%1
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

 

Do I need to add something to it?

Regards,

Laurentiu

Share this post


Link to post
Share on other sites

I have a little problem and I can't solve it by myself.

Please mention your your version when asking for help.

Share this post


Link to post
Share on other sites

The version I have installed is 2.7.

Thank you!

 

I don't believe that version is supported.

 

I support

 

Ultimate Seo Urls 5 ( PHP5.2+ and different support thread )

 

And ..

 

Ultimate Seo Urls 2.1d STABLE FINAL

 

Jack supports 2.2-2d

Share this post


Link to post
Share on other sites

Ok, I can understand that but could you just give me a guideline about what should I do? Where should I look to solve this thing? I looked everywhere and I can't find the problem.

Strange thing is that when I go to the second page of a category and I try to get back to first page (by clicking on the "previous page" button I gev the link "/index.php?cPath=1&sort=6a&page=1" so it isn't rewrite back

Please, if you can and have any idea why this is happening, please help me.

 

Thank you!

Share this post


Link to post
Share on other sites

Ok, I can understand that but could you just give me a guideline about what should I do? Where should I look to solve this thing? I looked everywhere and I can't find the problem.

Strange thing is that when I go to the second page of a category and I try to get back to first page (by clicking on the "previous page" button I gev the link "/index.php?cPath=1&sort=6a&page=1" so it isn't rewrite back

Please, if you can and have any idea why this is happening, please help me.

 

Thank you!

 

Yes .. I believe the problem will go if you install either of the contributions I support.

Share this post


Link to post
Share on other sites

Please, if you can and have any idea why this is happening, please help me.

As Robert mentioned, it is due to the version you are using. I vaguely recall that problem and it was fixed in an update but I don't recall which one. You should replace yours with one of the ones he mentioned since your version has other problems besides that one.

Share this post


Link to post
Share on other sites

Hi there,

 

I think i did something wrong installing SEO...

 

When I do a search when I am in a category, the URL advanced_search_result.php is not showing, but the URL of the category with the search variables:

 

http://www.domain.nl/wastafel-c-1964.html?y=0&x=0&inc_subcat=1&search_in_description=1&keywords=test&sort=products_sort_order

 

I should be:

 

http://www.domain.nl/advanced_search_result.php?y=0&x=0&inc_subcat=1&search_in_description=1&keywords=test&sort=products_sort_order

 

Can someone please help?

 

Steve

Share this post


Link to post
Share on other sites

Hi there,

 

I think i did something wrong installing SEO...

 

When I do a search when I am in a category, the URL advanced_search_result.php is not showing, but the URL of the category with the search variables:

 

http://www.domain.nl/wastafel-c-1964.html?y=0&x=0&inc_subcat=1&search_in_description=1&keywords=test&sort=products_sort_order

 

I should be:

 

http://www.domain.nl/advanced_search_result.php?y=0&x=0&inc_subcat=1&search_in_description=1&keywords=test&sort=products_sort_order

 

Can someone please help?

 

Steve

 

I'm not aware of any versions that cause that .. which version are you running?

 

Perhaps a modified search box?

Share this post


Link to post
Share on other sites

I don't know if SEO is causing this and the search box is the original one... The contrib is Ultimate-SEO-URLs.

But it is strange that the file advanced_search_result.php isn't rewriting the url....

 

Has it something to do with the .htaccess ? or application_top.php??

Share this post


Link to post
Share on other sites

I just found out it is only in the categories, not in product_info or all the other pages.

When doing a search while being in product_listing.php, the url doesn't change in advanced_search_result.php

 

Here is my product_listing.php code:

<?php
/*
 $Id: product_listing.php,v 1.44 2003/06/09 22:49:59 hpdl Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/
 $listing_split = new splitPageResults($listing_sql, MAX_DISPLAY_SEARCH_RESULTS, 'p.products_id');

 if ( ($listing_split->number_of_rows > 0) && ( (PREV_NEXT_BAR_LOCATION == '1') || (PREV_NEXT_BAR_LOCATION == '3') ) ) {
?>
<table border="0" width="100%" cellspacing="0" cellpadding="2">
 <tr>
   <td class="smallText"><?php //echo $listing_split->display_count(TEXT_DISPLAY_NUMBER_OF_PRODUCTS); ?></td>
   <td class="main" align="right"><?php echo '<span class=main>' . TEXT_RESULT_PAGE . ' ' . $listing_split->display_links(MAX_DISPLAY_PAGE_LINKS, tep_get_all_get_params(array('page', 'info', 'x', 'y'))) . '</span>' ; ?></td>
 </tr>
</table><?php
 }

 $list_box_contents = array();

 for ($col=0, $n=sizeof($column_list); $col<$n; $col++) {
   switch ($column_list[$col]) {
     case 'PRODUCT_LIST_MODEL':
       $lc_text = TABLE_HEADING_MODEL;
       $lc_align = '';
       break;
     case 'PRODUCT_LIST_NAME':
       $lc_text = TABLE_HEADING_PRODUCTS;
       $lc_align = '';
       break;
     case 'PRODUCT_LIST_MANUFACTURER':
       $lc_text = TABLE_HEADING_MANUFACTURER;
       $lc_align = '';
       break;
     case 'PRODUCT_LIST_PRICE':
       $lc_text = TABLE_HEADING_PRICE;
       $lc_align = 'right';
       break;
     case 'PRODUCT_LIST_QUANTITY':
       $lc_text = TABLE_HEADING_QUANTITY;
       $lc_align = 'right';
       break;
     case 'PRODUCT_LIST_WEIGHT':
       $lc_text = TABLE_HEADING_WEIGHT;
       $lc_align = 'right';
       break;
     case 'PRODUCT_LIST_IMAGE':
       $lc_text = TABLE_HEADING_IMAGE;
       $lc_align = 'center';
       break;
     case 'PRODUCT_LIST_BUY_NOW':
       $lc_text = TABLE_HEADING_BUY_NOW;
       $lc_align = 'center';
       break;
      case 'PRODUCT_SORT_ORDER':
$lc_text = TABLE_HEADING_PRODUCT_SORT;
$lc_align = 'center';
break;
   }

   if ( ($column_list[$col] != 'PRODUCT_LIST_BUY_NOW') && ($column_list[$col] != 'PRODUCT_LIST_IMAGE') ) {
     $lc_text = tep_create_sort_heading($HTTP_GET_VARS['sort'], $col+1, $lc_text);
   }

   $list_box_contents[0][] = array('align' => $lc_align,
                                   'params' => 'class="productListing-heading"',
                                   'text' => ' ' . $lc_text . ' ');
 }

 if ($listing_split->number_of_rows > 0) {
   $rows = 0;
   $column = 0;
   echo ' 

             <table cellspacing=0 cellpadding=0>
              <tr><td width="100%" height=10></td></tr>
              <tr><td>
                   <table cellspacing=0 cellpadding=0 width="100%" align=center>
                    <tr>


        ';

   $listing_query = tep_db_query($listing_split->sql_query);
   while ($listing = tep_db_fetch_array($listing_query)) {
     $product_contents = array();
     $rows++;
     if (($rows/2) == floor($rows/2)) {
       $list_box_contents[] = array('params' => 'class="productListing-even"');
     } else {
       $list_box_contents[] = array('params' => 'class="productListing-odd"');
     }

     $cur_row = sizeof($list_box_contents) - 1;

     for ($col=0, $n=sizeof($column_list); $col<$n; $col++) {
       $lc_align = '';

       switch ($column_list[$col]) {
         case 'PRODUCT_LIST_MODEL':
           $lc_align = '';
           $lc_text = ' ' . $listing['products_model'] . ' ';
           break;
case 'PRODUCT_LIST_NAME':
           // begin extra product fields
           $extra = '';
           foreach ($epf as $e) {
             if ($e['listing']) {
               $mt = ($e['uses_list'] ? ($listing[$e['field']] == 0) : !tep_not_null($listing[$e['field']]));
               if (!$mt) { // only list fields that aren't empty
                 $extra .= '<br><b>' . $e['label'] . ': </b>';
                 if ($e['uses_list']) {
                   $extra .= tep_get_extra_field_list_value($listing[$e['field']],$e['show_chain'] == 1);
                 } else {
                   $extra .= $listing[$e['field']];
                 }
               }
             }
           }
           // end extra product fields
           $lc_align = '';
           if (isset($HTTP_GET_VARS['manufacturers_id'])) {
             $lc_text = '<span class=main><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'manufacturers_id=' . $HTTP_GET_VARS['manufacturers_id'] . '&products_id=' . $listing['products_id']) . '">' . $listing['products_name'] /*begin epf*/ . $extra /*end epf*/ . '</a></span>';
           } else {
             $lc_text = '<span class=main><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, ($cPath ? 'cPath=' . $cPath . '&' : '') . 'products_id=' . $listing['products_id']) . '">' . $listing['products_name'] /*begin epf*/ . $extra /*end epf*/ . '</a></span> ';
           }
           break;
         case 'PRODUCT_LIST_MANUFACTURER':
           $lc_align = '';
           $lc_text = ' <a href="' . tep_href_link(FILENAME_DEFAULT, 'manufacturers_id=' . $listing['manufacturers_id']) . '">' . $listing['manufacturers_name'] . '</a> ';
           break;
         case 'PRODUCT_LIST_PRICE':
           $lc_align = 'right';
           if (tep_not_null($listing['specials_new_products_price'])) {
             $lc_text = '<s>' .  $currencies->display_price($listing['products_price'], tep_get_tax_rate($listing['products_tax_class_id'])) . '</s><br><span class="special">  ' . $currencies->display_price($listing['specials_new_products_price'], tep_get_tax_rate($listing['products_tax_class_id'])) . '</span>';
           } else {
             $lc_text = '' . $currencies->display_price($listing['products_price'], tep_get_tax_rate($listing['products_tax_class_id'])) . '';
           }
           break;
         case 'PRODUCT_LIST_QUANTITY':
           $lc_align = 'right';
           $lc_text = ' ' . $listing['products_quantity'] . ' ';
           break;
         case 'PRODUCT_LIST_WEIGHT':
           $lc_align = 'right';
           $lc_text = ' ' . $listing['products_weight'] . ' ';
           break;
         case 'PRODUCT_LIST_IMAGE':
           $lc_align = 'center';
           if (isset($HTTP_GET_VARS['manufacturers_id'])) {
             $lc_text = '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'manufacturers_id=' . $HTTP_GET_VARS['manufacturers_id'] . '&products_id=' . $listing['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $listing['products_image'], $listing['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'class=imagedecoration') . '</a>';
           } else {
             $lc_text = '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, ($cPath ? 'cPath=' . $cPath . '&' : '') . 'products_id=' . $listing['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $listing['products_image'], $listing['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'class=imagedecoration') . '</a>';
           }
           break;
         case 'PRODUCT_LIST_BUY_NOW':
           $lc_align = 'center';
           $lc_text = '<a href="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $listing['products_id']) . '">' . tep_image_button('button_buy_now.gif', IMAGE_BUTTON_BUY_NOW) . '</a> ';
           break;
          case 'PRODUCT_SORT_ORDER';
           $lc_align = 'center';
           $lc_text = ' ' . $listing['products_sort_order'] . ' ';
           break;
       }

       $list_box_contents[$cur_row][] = array('align' => $lc_align,
                                              'params' => 'class="productListing-data"',
                                              'text'  => $lc_text);
       $product_contents[] = $lc_text;       
     }


     $product_query = tep_db_query("select products_description  from " . TABLE_PRODUCTS_DESCRIPTION . " where products_id = '" . (int)$listing['products_id'] . "' and language_id = '" . (int)$languages_id . "'");
     $product = tep_db_fetch_array($product_query);
     $new_products['products_description'] = $product['products_description'];

     echo '


                         <td width=200 valign=top>
                                 <table cellspacing=0 cellpadding=0 width=190 align=center>
                                  <tr>
                                    <td height height="190" valign=top align="center">'.$product_contents[0].'</td>

                                  </tr>

                                  <tr><td colspan=2 style="border-left:1px dotted #cccccc;">

							   <table width="100%" cellspacing=0 cellpadding=0>
                                    <tr>
								   <td width="10"> </td>	
                                      <td align="left" valign="top" height="70" style="font-weight:normal; border-bottom:1px dotted #cccccc;"><b>'.$product_contents[1].'</b></td>
                                    </tr>
                                    <tr>
                                      <td align="left" class=ps3 colspan="2"><span class=ps2>   Prijs: </span>'.$product_contents[2].'<span class=ps2> (incl. BTW)</span></td>
                                    </tr>
								 <tr><td colspan=2 height=5></td></tr>
                                    <tr><td align="left" colspan="2">  <a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $listing['products_id']) . '">' . tep_image_button('small_view.gif') . '</a>   <a href="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $listing['products_id']) . '">' . tep_image_button('button_in_cart.gif') . '</a></td></tr></table></td></tr>
                                  <tr><td colspan=2 height=6></td></tr>
                                 </table>
                                </td>



     ';
     $column ++;
     if ($column >= 3) {
       $rows ++;
       $column = 0;
       echo '


                   		 </tr>
						 <tr height=5><td colspan=5 align=center height=5></td> </tr>
                            <tr height=5><td colspan=5 align=center height=5 style="border-bottom:1px dotted #cccccc;"> </td></tr>
						 <tr height=5><td colspan=5 align=center height=5> </td></tr>
                            <tr>


            ';
     } else echo '<td><width=1></td>';



   }

   echo '


                       </tr>
                   </table>
              </td></tr>
              <tr><td></td></tr>
             </table>



        ';

   //new productListingBox($list_box_contents);
 } else {
   $list_box_contents = array();

   $list_box_contents[0] = array('params' => 'class="productListing-odd"');
   $list_box_contents[0][] = array('params' => 'class="productListing-data"',
                                  'text' => TEXT_NO_PRODUCTS);

   echo '<div class=PageHeading>Categories</div>';
   new productListingBox($list_box_contents);
 }

 if ( ($listing_split->number_of_rows > 0) && ((PREV_NEXT_BAR_LOCATION == '2') || (PREV_NEXT_BAR_LOCATION == '3')) ) {
?>

<table border="0" width="100%" cellspacing="0" cellpadding="2">
 <tr><td height=2></td></tr>
 <tr>
   <td class="smallText"><?php //echo $listing_split->display_count(TEXT_DISPLAY_NUMBER_OF_PRODUCTS); ?></td>
   <td class="main" align="right"><?php echo TEXT_RESULT_PAGE . ' ' . $listing_split->display_links(MAX_DISPLAY_PAGE_LINKS, tep_get_all_get_params(array('page', 'info', 'x', 'y'))); ?></td>
 </tr>
</table>
<?php
 }
?>

 

I am using STS by the way....

Share this post


Link to post
Share on other sites

I don't know if SEO is causing this and the search box is the original one... The contrib is Ultimate-SEO-URLs.

But it is strange that the file advanced_search_result.php isn't rewriting the url....

 

Has it something to do with the .htaccess ? or application_top.php??

 

I know the contribution is Ultimate Seo Urls, this is its support thread, what I don't know is the version.

 

I don't understand your second question at all.

 

Could you clarify the actual problem please.

Edited by FWR Media

Share this post


Link to post
Share on other sites

I don't know the right version, where can i check this?

 

The exact problem is as follows; when the page is in product_listing.php (on index.php) the SEO URL is like /categoryname-c-111.html

When I do a search via the search box, the result page gives: ../categoryname-c-111.html?y=0&x=0&inc_subcat=1&search_in_description=1&keywords=test&sort=products_sort_order

 

But that is not correct. The correct url must be: ../advanced_search_result.php?y=0&x=0&inc_subcat=1&search_in_description=1&keywords=test&sort=products_sort_order

 

When the url is not changing in advanced_search_result.php, the results of the search doesn't show up.

 

I don't know why the URL doesn't give the advanced search result, but just puts the ?y=0&x=0&inc_subcat=1&search_in_description=1&keywords=test&sort=products_sort_order behind the SEO URL of the category.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×