Jump to content
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

The option to add the actual cPath number was changed to use the directory name since numbers have almost no meaning compared to text with regards to SEO. But others have asked for that option back so I will add it back in with the next version.

 

Thx for that.

 

The problems with the names ist - that they are not unique. The cPath variable is very important if you have the same products stored as links in many categories.

Share this post


Link to post
Share on other sites

I'm not seeing that problem here. If you turn it off (turn off all settings in admin->Configuration->SEO URLs) does the problem go away?

Yes, it does.

 

When i'm clicking "add to cart" the page url becomes like .../shopping_cart.php?osCsid=94a443bb4284dc834d0e87f17767756d

But when i'm clicking "buy now" the page url becomes like .../shopping_cart.php?sort=2a&osCsid=94a443bb4284dc834d0e87f17767756d

I think problem in "amp;" :) How can i fix it?


Sorry for my english...

Share this post


Link to post
Share on other sites

Yes, it does.

 

When i'm clicking "add to cart" the page url becomes like .../shopping_cart.php?osCsid=94a443bb4284dc834d0e87f17767756d

But when i'm clicking "buy now" the page url becomes like .../shopping_cart.php?sort=2a&osCsid=94a443bb4284dc834d0e87f17767756d

I think problem in "amp;" :) How can i fix it?

 

Unless you specifically need the header tags code I'd suggest installing Ultimate Seo Urls 5 (if you are on php5.2+) or if not Ultimate Seo Urls 2.1d STABLE FINAL r164.

Share this post


Link to post
Share on other sites

Yes, it does.

 

When i'm clicking "add to cart" the page url becomes like .../shopping_cart.php?osCsid=94a443bb4284dc834d0e87f17767756d

But when i'm clicking "buy now" the page url becomes like .../shopping_cart.php?sort=2a&osCsid=94a443bb4284dc834d0e87f17767756d

I think problem in "amp;" :) How can i fix it?

It may not be the cause of the problem but the session ID shouldn't be in the link. That is usually due to the configure file not being setup correctly. Obvious problems like that should be fixed before looking further. See other posts in this thread on how fix that.

Share this post


Link to post
Share on other sites

Men, thanks for your help! I've installed Ultimate Seo Urls 2.1d STABLE FINAL r164 and it's resolved my problem!

 

But..... I have one more problem.. :)

 

I have cyrilic symbols in my category and products names, so i set "Remove all non-alphanumeric characters" to true.

And now when i click the category or product with the name consist of only cyrilic symbols the page url becomes like .../--c-30_23.html and "Page not found" :(

 

Please help me again!!


Sorry for my english...

Share this post


Link to post
Share on other sites

Men, thanks for your help! I've installed Ultimate Seo Urls 2.1d STABLE FINAL r164 and it's resolved my problem!

 

But..... I have one more problem.. :)

 

I have cyrilic symbols in my category and products names, so i set "Remove all non-alphanumeric characters" to true.

And now when i click the category or product with the name consist of only cyrilic symbols the page url becomes like .../--c-30_23.html and "Page not found" :(

 

Please help me again!!

 

You are supposed to put character conversions in the admin panel "Enter special character conversions." to convert your language special characters to LATIN

Share this post


Link to post
Share on other sites

You are supposed to put character conversions in the admin panel "Enter special character conversions." to convert your language special characters to LATIN

 

Thanks!

Here is all cyrillic symbols conversions (all i need):

а=>a,б=>b,в=>v,г=>g,д=>d,е=>e,ё=>e,ж=>zh,з=>z,и=>i,й=>i,к=>k,л=>l,м=>m,н=>n,о=>o,п=>p,р=>r,с=>s,т=>t,у=>u,ф=>f,х=>h,ц=>c,ч=>ch,ш=>sh,щ=>sh,ъ=>j,ы=>y,ь=>j,э=>e,ю=>u,я=>ja,А=>a,Б=>b,В=>v,Г=>g,Д=>d,Е=>e,Ё=>e,Ж=>zh,З=>z,И=>i,Й=>i,К=>k,Л=>l,М=>m,Н=>n,О=>o,П=>p,Р=>r,С=>s,Т=>t,У=>u,Ф=>f,Х=>h,Ц=>c,Ч=>ch,Ш=>sh,Щ=>sh,Ъ=>j,Ы=>y,Ь=>j,Э=>e,Ю=>u,Я=>ja

 

This field is too long and is cut when i try to save it. Can you prompt me what field needs to be longer in database (or where?)?

Edited by alexflasher

Sorry for my english...

Share this post


Link to post
Share on other sites

Thanks!

Here is all cyrillic symbols conversions (all i need):

а=>a,б=>b,в=>v,г=>g,д=>d,е=>e,ё=>e,ж=>zh,з=>z,и=>i,й=>i,к=>k,л=>l,м=>m,н=>n,о=>o,п=>p,р=>r,с=>s,т=>t,у=>u,ф=>f,х=>h,ц=>c,ч=>ch,ш=>sh,щ=>sh,ъ=>j,ы=>y,ь=>j,э=>e,ю=>u,я=>ja,А=>a,Б=>b,В=>v,Г=>g,Д=>d,Е=>e,Ё=>e,Ж=>zh,З=>z,И=>i,Й=>i,К=>k,Л=>l,М=>m,Н=>n,О=>o,П=>p,Р=>r,С=>s,Т=>t,У=>u,Ф=>f,Х=>h,Ц=>c,Ч=>ch,Ш=>sh,Щ=>sh,Ъ=>j,Ы=>y,Ь=>j,Э=>e,Ю=>u,Я=>ja

 

This field is too long and is cut when i try to save it. Can you prompt me what field needs to be longer in database (or where?)?

 

SEO_CHAR_CONVERT_SET is a configuration value and is set at VARCHAR 255 .. are you on PHP5.2+ because if you are you'd have been better off with the character conversion system of Ultimate Seo Urls 5.

Share this post


Link to post
Share on other sites

Thanks again, now it's ok!

 

I tryied USU5 some time ago, but had serious problems with product/category page display (it was blank with only some part of text)....


Sorry for my english...

Share this post


Link to post
Share on other sites

Thanks again, now it's ok!

 

I tryied USU5 some time ago, but had serious problems with product/category page display (it was blank with only some part of text)....

 

My pleasure.

 

Re: USU5 .. never heard that one before! obviously from when it was brand new to the current totally stable version there have been improvements, but never anything like that.

Share this post


Link to post
Share on other sites

Hi guys,

I have installed: V 2.2d-5 by Jack_mcs.

When I'm buying, I can add products to cart correctly. But if I select a category/subcategory with some products, the shop shows me the possibilty to "buy now" (for all the products - It isn't necesary to view the product detail). If I buy clicking this item, THE CART IS CLEAR, all the products in the cart has been deleted.

THanks for your attention, regards

Daniel

Share this post


Link to post
Share on other sites

for all those who get the Call to undefined function: mb_convert_case error in seo.class.php because you run the php4 version add this in your htaccess file

 

AddHandler x-httpd-php5 .php

AddType application/x-httpd-php5 .php

 

at least it worked for me

 

 

This worked like a charm for me. Seems to be running great now! Thanks :)

Share this post


Link to post
Share on other sites

Hi guys,

I have installed: V 2.2d-5 by Jack_mcs.

When I'm buying, I can add products to cart correctly. But if I select a category/subcategory with some products, the shop shows me the possibilty to "buy now" (for all the products - It isn't necesary to view the product detail). If I buy clicking this item, THE CART IS CLEAR, all the products in the cart has been deleted.

THanks for your attention, regards

Daniel

Please upgrade to the 2.2d-7 and see if the problem still occurs. If it does, be sure to test it with Ultimate SEO turned off to be sure where the problem is coming from. To upgrade, just replace the seo.class.php file and add replace the .htaccess entries with the ones listed in the install file.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Please upgrade to the 2.2d-7 and see if the problem still occurs. If it does, be sure to test it with Ultimate SEO turned off to be sure where the problem is coming from. To upgrade, just replace the seo.class.php file and add replace the .htaccess entries with the ones listed in the install file.

 

Thanks for your answer Jack.

When Ultimate SEO is turned off, there are no problem at the shop.

I'll install the 2.2d-t and test it.

Daniel

Share this post


Link to post
Share on other sites

Please upgrade to the 2.2d-7 and see if the problem still occurs. If it does, be sure to test it with Ultimate SEO turned off to be sure where the problem is coming from. To upgrade, just replace the seo.class.php file and add replace the .htaccess entries with the ones listed in the install file.

 

Hi Jack,

I have installed the SEo 2.2d-7, and the problem persist.

IF Seo is turned off, the url is something like this: http://localhost/catalog/index.php?cPath=1_9&osCsid=b4md3skumbebju19ocuehsgq41

 

But, If Seo is turned on: http://localhost/catalog/ratones-c-1_9.html?osCsid=dpdf0bsdrig627pehk7qdns4s1

 

And your shopping cart, if you click on "buy now" will be deleted.

 

:(

Share this post


Link to post
Share on other sites

Hi Jack,

I have installed the SEo 2.2d-7, and the problem persist.

Did you clear cache in admin->Configuration->SEO URLs? What happens if you turn all of the options off in that section except for the top one?

Share this post


Link to post
Share on other sites

Did you clear cache in admin->Configuration->SEO URLs? What happens if you turn all of the options off in that section except for the top one?

 

Jacks, it's the same. Problem Persist.

Al the optios are turned off

Thanks, Daniel

Share this post


Link to post
Share on other sites

Jacks, it's the same. Problem Persist.

Al the optios are turned off

Thanks, Daniel

From the url's you provided, you are trying this on a local setup. If I do that, it fails for me the same way. But when I try it on a live shop, it works fine. Have you tried it on a live shop?

Share this post


Link to post
Share on other sites

From the url's you provided, you are trying this on a local setup. If I do that, it fails for me the same way. But when I try it on a live shop, it works fine. Have you tried it on a live shop?

 

 

Hi Jacks,

I have tried only on local. I haven´t tried on a live shop.

 

Tomorrow, I'll make a production backup, and then i'll modify it. ;)

I'll say you the test result.

 

Thanks for your attention

Daniel

Share this post


Link to post
Share on other sites

Hi guys,

I have installed: V 2.2d-5 by Jack_mcs.

When I'm buying, I can add products to cart correctly. But if I select a category/subcategory with some products, the shop shows me the possibilty to "buy now" (for all the products - It isn't necesary to view the product detail). If I buy clicking this item, THE CART IS CLEAR, all the products in the cart has been deleted.

THanks for your attention, regards

Daniel

This is just an idea for you to try...

 

Presume you've got the latest version (2-2.2d-7) of Ultimate SEO installed. Go to admin and set Output W3C valid URLs (parameter string)? to "false". Reset SEO URLs cache (update, reset), clear your browser cache and try again. Does it work fine now or not?


Absinthe Original Liquor Store

Share this post


Link to post
Share on other sites

This is just an idea for you to try...

 

Presume you've got the latest version (2-2.2d-7) of Ultimate SEO installed. Go to admin and set Output W3C valid URLs (parameter string)? to "false". Reset SEO URLs cache (update, reset), clear your browser cache and try again. Does it work fine now or not?

 

Hi MR,

I have tryed this, and the problem persist.

Share this post


Link to post
Share on other sites

From the url's you provided, you are trying this on a local setup. If I do that, it fails for me the same way. But when I try it on a live shop, it works fine. Have you tried it on a live shop?

 

Hi Jacks,

I have installed the SEO 2.2d-7 on the server. At first call, it works fine.

But, I have a 404 error now.

My url is http://www.devicesandcomponents.com/catalog/index.php

 

And my .htaccess is:

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

#<IfModule mod_setenvif.c>
#  <IfDefine SSL>
#    SetEnvIf User-Agent ".*MSIE.*" \
#             nokeepalive ssl-unclean-shutdown \
#             downgrade-1.0 force-response-1.0
#  </IfDefine>
#</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter

# AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)

# php_value session.use_trans_sid 0
# php_value register_globals 1

Options +FollowSymLinks
RewriteEngine On 
RewriteBase /catalog/

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}

Share this post


Link to post
Share on other sites

Hi Jacks,

I have installed the SEO 2.2d-7 on the server. At first call, it works fine.

But, I have a 404 error now.

Your .htaccess file is correct. I don't see the problem on your site since Ultimate SEO is not enabled but I don't see anything obvious that would stop it from working. Please check with your host to verify mod rewrite is enabled.

Share this post


Link to post
Share on other sites

See the instructions for testing the installation. You've most likely made a mistake with the .htaccess file.

 

Hi,

 

My htaccess is fine.

 

Htaccess file is as below :

 

Options +FollowSymLinks

RewriteEngine On

RewriteBase /

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}

 

I did uninstall and re install few times and always get the same problem.

 

Some month ago I did the same job for another of my site and it was working correctly so for this reason I don't understand where is the problem...

Share this post


Link to post
Share on other sites

My htaccess is fine.

There's no way to tell if the .htaccess file is fine without the url to the shop.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×