Jump to content
Latest News: (loading..)
spidometrs

[CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

Recommended Posts

Thx you are great , im wondering if it possible to do

 

my old adress are : www. homepage.com/tillbehoer/sadelstol-112/ is it possible to remove this "p" on the url thats generated on all procucts and categorys on the new seo urls

With new seo urls its like this without / at the end : http:// www.homepage.com/sadelstol-p-112

 

I need to get this old url : www. homepage.com/tillbehoer/sadelstol-112/

 

With the redirect script i must redirect all products on my shop :(

 

/Best Regards Marcus

Edited by swekidz

Share this post


Link to post
Share on other sites

my old adress are : www. homepage.com/tillbehoer/sadelstol-112/ is it possible to remove this "p" on the url thats generated on all procucts and categorys on the new seo urls

 

No the script needs the -p- marker.

Share this post


Link to post
Share on other sites

No the script needs the -p- marker.

 

Hi

 

Do you have a proposal how i can fix this problem ? i have 1500 index pages on google , and when they search and find something they come to 404 page

becouse its new urls. Is it possible to change in the script sow it dont need "p" marker

 

/Best Regards SweKidz - Marcus

Share this post


Link to post
Share on other sites

Hi

 

Do you have a proposal how i can fix this problem ? i have 1500 index pages on google , and when they search and find something they come to 404 page

becouse its new urls. Is it possible to change in the script sow it dont need "p" marker

 

/Best Regards SweKidz - Marcus

 

As I said, the script needs the -p- marker.

 

The one "light at the end of the tunnel" seems to be that there is some link consistency ..

 

http:// www.homepage.com/tillbehoer/sadelstol-112/

 

Becomes ..

 

http:// www.homepage.com/sadelstol-p-112

 

If links really are that consistent (which I doubt) a redirect script could be written to handle redirection dynamically.

Share this post


Link to post
Share on other sites

Hi

 

Thx for fast answer , I've been thinking about making a 404 redirect in part to the home page ?

Is that possible ?

 

When i try something the 404 thats in seo urls 5 dont works , do you now how i get your 404 to work ?

 

/Best Regard Marcus

 

 

 

 

 

 

 

 

 

 

 

 

As I said, the script needs the -p- marker.

 

The one "light at the end of the tunnel" seems to be that there is some link consistency ..

 

http:// www.homepage.com/tillbehoer/sadelstol-112/

 

Becomes ..

 

http:// www.homepage.com/sadelstol-p-112

 

If links really are that consistent (which I doubt) a redirect script could be written to handle redirection dynamically.

Edited by swekidz

Share this post


Link to post
Share on other sites

Hi

 

Thx for fast answer , I've been thinking about making a 404 redirect in part to the home page ?

Is that possible ?

 

When i try something the 404 thats in seo urls 5 dont works , do you now how i get your 404 to work ?

 

/Best Regard Marcus

 

the 404 in USU5 works fine, I think what you are saying is that your modification to it didn't work.

 

This is the support thread for the 2005 series 2 seo urls. Support for USU5 is here

Edited by FWR Media

Share this post


Link to post
Share on other sites

Thanks for a great contrib!

 

Earlier I used an old version of 2.1, I think it was from 2006, anyway I upgraded this version to Ultimate SEO 2-2.2d-7.

It works great except that it won't take the names I've written in categories_seo_url and products_seo_url column in the database.

Is this version not using these columns anymore?

Share this post


Link to post
Share on other sites

Thanks for a great contrib!

 

Earlier I used an old version of 2.1, I think it was from 2006, anyway I upgraded this version to Ultimate SEO 2-2.2d-7.

It works great except that it won't take the names I've written in categories_seo_url and products_seo_url column in the database.

Is this version not using these columns anymore?

What are the categories_seo_url and products_seo_url columns? There's no such database fields for that this contribution uses so I don't understand what you are talking about.

Share this post


Link to post
Share on other sites

What are the categories_seo_url and products_seo_url columns? There's no such database fields for that this contribution uses so I don't understand what you are talking about.

 

You could set your own SEO Url's in admin for each category and product that it used, if it was blank it used the title.

At least it was like that in an earlier version <=2.1.

Share this post


Link to post
Share on other sites

You could set your own SEO Url's in admin for each category and product that it used, if it was blank it used the title.

At least it was like that in an earlier version <=2.1.

Oh, I remember now. There was one version that allowed you to do that but it was never carried through to the updates and got lost along the way. If you have Header Tags installed, you can control the titles that way. Otherwise, the regular titles are used. In any case, those titles you have setup will no longer work. You could edit the current seo.class.php file and substitute the name of those fields for where Header Tags titles are used. That should allow it to work. But you would have to do that with each and every update since that file always gets changed.

Share this post


Link to post
Share on other sites

Hello

My categories and product names are on Cyrillic (I'm using utf-8)

How can I get categories on cyrellic in URL, I saw some on has achieved this, but with older version

I have installed Header Tags SEO, but it don't help, non latin characters are cut

Remove all non-alphanumeric characters? is set to false

Share this post


Link to post
Share on other sites

Hello

My categories and product names are on Cyrillic (I'm using utf-8)

How can I get categories on cyrellic in URL, I saw some on has achieved this, but with older version

I have installed Header Tags SEO, but it don't help, non latin characters are cut

Remove all non-alphanumeric characters? is set to false

If your shop handles Cyrillic anyway (with this contribution turned off), it should handle the characters with it on. But there's no special code in it to handle those characters specifially. You could probably use the special character conversion option but that would just translate it, which I don't think is what you want.

Share this post


Link to post
Share on other sites

Oh, I remember now. There was one version that allowed you to do that but it was never carried through to the updates and got lost along the way. If you have Header Tags installed, you can control the titles that way. Otherwise, the regular titles are used. In any case, those titles you have setup will no longer work. You could edit the current seo.class.php file and substitute the name of those fields for where Header Tags titles are used. That should allow it to work. But you would have to do that with each and every update since that file always gets changed.

 

Hey, I noticed the Header Tag option and is using that one instead. Thanks!

Share this post


Link to post
Share on other sites

Hi,

 

I activated SEO_ADD_CPATH_TO_PRODUCT_URLS (Add category parent to product URLs?) in the admin.

 

Is this the same parameter as the following?

 

(copied from the install page)

Add cPath to product URLs? *NEW*

Default Setting: false

This setting enables/disables the option of adding the cPath parameter to the end of product pages.

Example: some-product-p-1.html?cPath=xx

 

 

Because I never see the cPath parameter - instead I see the name of the category.

 

Ciao Anathema

Share this post


Link to post
Share on other sites

Hi,

 

I activated SEO_ADD_CPATH_TO_PRODUCT_URLS (Add category parent to product URLs?) in the admin.

 

Is this the same parameter as the following?

 

(copied from the install page)

Add cPath to product URLs? *NEW*

Default Setting: false

This setting enables/disables the option of adding the cPath parameter to the end of product pages.

Example: some-product-p-1.html?cPath=xx

 

 

Because I never see the cPath parameter - instead I see the name of the category.

 

Ciao Anathema

 

Now I found a solution for the problem.

 

I had the cPath parameter already in my link and wondered why it was not in my seo link.

 

I debugged the seo code and found an error in the function is_product_string (in my version line 1744.

 

original function is:

 

function is_product_string($params){

if ( is_numeric(strpos('products_id',$params )) ){

return true;

} else {

return false;

}

} # end function

 

 

corrected function is (in strpos twist the parameters!)

 

function is_product_string($params){

if ( is_numeric(strpos($params,'products_id' )) ){

return true;

} else {

return false;

}

} # end function

 

@Jack_mcs: perhaps you can change this in the official contribution.

 

 

 

My problem was the following:

 

I choosed a category with the menu. And then if I changed from product listing to the product page, the category changed to the first category of the product (in the menu, in the breadcrumb and in the link to the next/prev product) - so cPath had the wrong value.

 

 

And it is solved now! Yippieh.

 

Anathema

Share this post


Link to post
Share on other sites

Now I found a solution for the problem.

 

I had the cPath parameter already in my link and wondered why it was not in my seo link.

 

I debugged the seo code and found an error in the function is_product_string (in my version line 1744.

@Jack_mcs: perhaps you can change this in the official contribution.

 

My problem was the following:

 

I choosed a category with the menu. And then if I changed from product listing to the product page, the category changed to the first category of the product (in the menu, in the breadcrumb and in the link to the next/prev product) - so cPath had the wrong value.

 

And it is solved now! Yippieh.

The option to add the actual cPath number was changed to use the directory name since numbers have almost no meaning compared to text with regards to SEO. But others have asked for that option back so I will add it back in with the next version.

Share this post


Link to post
Share on other sites

Just a quick note to thank everyone here (Jack_mcs and FWR Media, I'm lookin' at you guys) for helping me get my implementation of Ultimate SEO up and running. This is an impressively active forum filled with really good information and members. Thanks much!

Share this post


Link to post
Share on other sites

Hi everybody,

I just installed the contrib and I think everything is installed correctly...

 

But the problem is that once I click to any link (category or products pages) the page load and then come back to index.php

 

Anybody know what's the solution for this ?

Share this post


Link to post
Share on other sites

Can't find the problem - done all three times...

 

On the index page:

"Fatal error: Call to undefined function: mb_convert_case() in /.../.../shop22a/includes/classes/seo.class.php on line 1809"

 

Admin area works...

 

any idea???

sorry for that - can't find anything with the search...

Edited by wauziweb.de

Share this post


Link to post
Share on other sites

Can't find the problem - done all three times...

 

On the index page:

"Fatal error: Call to undefined function: mb_convert_case() in /.../.../shop22a/includes/classes/seo.class.php on line 1809"

 

Admin area works...

 

any idea???

sorry for that - can't find anything with the search...

 

mb_convert_case() has no business being in seo urls, it is not portable as it is not compiled as standard with PHP.

 

includes/classes/seo.class.php

 

Find ..

 

$anchor = preg_replace($pattern, '', mb_convert_case($string, MB_CASE_LOWER, "utf-8"));

 

Change to ..

 

$anchor = preg_replace( $pattern, '', strtolower( $string ) );

Share this post


Link to post
Share on other sites

THX for fast answer!!!

 

...direkt into next trap:

 

Warning: Compilation failed: unknown POSIX class name at offset ...

 

This error normally occurs when a defined character class is used but does not exist,

or delimiters are not set.

 

I can't imagine where this error came from.

Share this post


Link to post
Share on other sites

But the problem is that once I click to any link (category or products pages) the page load and then come back to index.php

See the instructions for testing the installation. You've most likely made a mistake with the .htaccess file.

Share this post


Link to post
Share on other sites

Hello.

I've installed "Ultimate SEO 2-2.2d-7"

 

When I clicking "buy now" in product listing my shopping cart is clearing. But it's ok when I clicking "add to cart" in product info..

 

How can I fix this problem?

I'm not seeing that problem here. If you turn it off (turn off all settings in admin->Configuration->SEO URLs) does the problem go away?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×